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1 Quick-start

1 Quick-start
This introduction will quickly familiarize you with important functions of the
measurement system based on an FFT measurement. For this purpose, first
of all run a scan and then evaluate it using some of the software functions.
Use an object with simple geometry for the scan. If you have a function
generator, use it to excite the object and then use this signal as a reference
signal for the measurement. If you do not have a function generator, you can
also excite it by other means.

)

Although you can also make a measurement without a reference signal, if
you do, you will not be able to animate the vibration during evaluation.

Preparation
1. Connect up the measurement system and start it as described in the
hardware manual.
2. If available, connect the reference signal to the jack REF 1 on the front of
the junction box.
3. Start the software. To do so, double-click the icon
You will find more information on this in SECTION 2.4.

on the desktop.

4. If the software has not been started in Acquisition mode, go into
acquisition. To do so, in the toolbar of the application window, click
.
You will find more information on this in SECTION 2.5. You will now see the
video window at the top and an analyzer at the bottom. On the left you will
see the project browser (refer also to SECTION 2.6.4 and on the right the
scanning head control (refer also to SECTION 2.6.1).
5. Select Setup > Preferences. The dialog Preferences appears.
6. Display the page Devices.
7. From the list Junction Box, select the junction box which is connected to
the PC.
8. If you are using a function generator, then set the connection for
Generator (internal or GPIB).
9. Display the page Scanning Head.
10. In the list Scanning Head, select the scanning head you have connected.
11. Click OK.
12. Only with the option VDD: Run test mode as described in
You will find more information on setting up the software in

SECTION

CHAPTER

7.7.

3.
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Setting the Optics
You set the optics using the scanning head control. See also
this.

SECTION

4.1 on

13. Point the scanning head at the object, either manually or using the
optional pan-tilt stage.
14. Zoom in the video camera so that the object appears as large as possible
in the video window. To do so, use the slider Zoom in the field Camera.
15. Now focus the video camera. To do so, first of all point the laser beam at
the top left corner of the video image. Otherwise the light from the laser
beam prevents the video camera focusing automatically. To adjust the
laser beam, use the icons Position. Then click Autofocus in the field
Camera.
16. Then point the laser beam at the object again.
17. Focus the laser beam with the icons

and

. As an option, you can

automatically focus the laser beam using the icon
information on this in SECTION 4.2.

. You will find more

18. Align the positions on the live video image with the position of the laser on
the measurement plane. To do so, click
or select Setup > 2D
Alignment. The software will maximize the video window. Distribute the
alignment points evenly over the whole measurement surface. If, for
example, you want to scan a rectangular surface, it would make sense to
choose four alignment points near the corners.
19. Move the laser beam to an alignment point on the object using the icons
Position in the scanning head control.
20. In the live video image, point the mouse precisely at the laser beam and
click. You can now see a target there. If the laser beam is not precisely in
the middle of the target, click again.
21. Repeat steps 19 and 20 for at least three more alignment points.
22. Once you have aligned all points, click
Alignment.

again or select Setup > 2D

You will find further information on 2D alignment in SECTION 4.4.

)
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To be able to import 3D geometries in 3D point mode (optional), you also
have to carry out a 3D alignment. See SECTION 4.5 on this.

1 Quick-start

Defining Scan Points
23. Go to scan point definition. To do so, in the toolbar of the application
window, click

. The software maximizes the video window and displays

a graphics toolbar (the icon
appears.

is activated). The dialog Object Properties

24. First of all delete all scan points which may already be defined. To do so,
select Edit > Select All and then Edit > Delete.
25. First click
in the graphics toolbar and then draw the largest possible
rectangle on the object.
26. You will see the rectangle you have drawn with a red edge and white
squares which mark the edge. You will see the scan points as blue points
inside the rectangle.
27. Please check whether the icon
active. If yes, then click
5.1.7).

in the dialog Rectangle Properties is

to display the scan points (refer also to

SECTION

28. Point the mouse at the grid. The cursor becomes a cross. You can now
move the grid with the scan points by clicking the grid and moving it using
the mouse.
29. You have now finished defining scan points. In the toolbar of the
application window, click

again to quit scan point definition.

30. Now point at the live video image and click a scan point. The laser beam
moves to this point on the object. Click additional scan points to check
and see if the laser beam is positioned precisely on the scan points.
You will find more detailed information on scan point definition in

CHAPTER

5.
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Setting Parameters
31. In the toolbar of the application window, click
Settings appears.

. The dialog Acquisition

32. Display the pages in the dialog from left to right and set the parameters
there. The suitable settings depend on the object. If you know suitable
settings, then set them. If not, use the settings in TABLE 1.1.
Table 1.1:

Parameters for an example measurement

Page
General
Channels1
Filter

Frequency

Measurement Mode: FFT
Averaging: Off
Remeasuring: Active
Vibrometer: Active, Direction + Z, Range 10 V, Coupling DC, Quantity Velocity
Reference 1: Active, Direction + Z, Range 10 V, Coupling DC, Quantity Voltage
Channel Vibrometer: Filter Type No Filter, Int / Diff Quantity Velocity (0)
Channel Reference 1: Filter Type No Filter
Bandwidth: 10 kHz
From: 0 kHz
To: 10 kHz
FFT Lines: 400

Window

Channel Vibrometer: Function Rectangle
Channel Reference 1: Function Rectangle

Trigger

Source: Off

SE

1

Settings

Channel Vibrometer: active
Channel Reference 1: not active
Speckle Tracking: Active
Slider: Fast

Vibrometer

Velocity: lowest available measurement range
Tracking Filter: Slow
Low Pass Filter: Off
High Pass Filter: Off

Generator

Active: Active

Only with option VDD: Some parameters on the page Channels are not available or are fixed.

33. Click OK.
You will find detailed information on the parameters for data acquisition in
6.

CHAPTER
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Single Point Measurement
34. If available, start signal output from the function generator. To do so, in the
toolbar of the application window, click

.

35. Start a continuous measurement. To do so, in the toolbar of the
application window, click
. The analyzer displays the measurement
signal on the vibrometer channel.

)

Autoscale the y-axis. To do so, in the toolbar of the analyzer, click

.

36. Click a scan point in the video window. The software will position the laser
beam on the object at this scan point. Check whether the display OVER in
the scanning head control is permanently red. If yes, then the
measurement range for the velocity is being exceeded at this scan point.
37. Repeat step 36 for a few additional scan points.
38. If the display OVER is red at several scan points, increase the
measurement range for the velocity. To do so, click
again, display the
page Vibrometer and select the next highest measurement range in the
list Velocity. Then click OK.
39. Repeat steps 37 to 38 until the measurement range for the velocity is no
longer exceeded.
40. Stop the continuous measurement. To do so, in the toolbar of the
application window, click

.

You will find detailed information on making measurements in

CHAPTER

7.

Scanning
41. Start the scan. To do so, in the toolbar of the application window, click
The dialog Save As appears.

.

42. Navigate to the saving location and enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

43. Click Save. The scan starts. The software immediately saves every scan
point measured.
44. In the video window you can follow the progress of the scan. See
CHAPTER 9 on this.
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Displaying Data
Select data sets

45. Display a spectrum. To do so, in the toolbar of the analyzer, click
select FFT in the context menu.
46. Click

and

to autoscale.

47. You can display other signals for spectra apart from the measurement
signal. To do so, click
While

and select Acceleration in the context menu.

is activated, the selected signal will be autoscaled directly.

48. Display the magnitude of the acceleration signal as well as its phase. To
do so, click
Zoom

and select Mag. & Phase in the context menu.

49. Zoom the range between 5 kHz and 10 kHz. To do so, point the mouse at
the x-axis at 5 kHz. The cursor becomes a magnifying glass.
50. Press the mouse button and drag to the right to 10 kHz.
51. Undo zooming. To do so, click

Set a cursor

52. Activate a cursor. To do so, click

.
.

53. Set the cursor in the analyzer. To do so, click in the diagram. A vertical
line will appear at the point which you have clicked.
Read data

54. You can see the cursor's coordinates in the legend. If the legend is not
visible on the right in the analyzer, select Analyzer > Legend to display it.
55. Move the cursor to the right or left using the mouse. The data in the
legend is updated simultaneously.
You will find detailed information on displaying data in

CHAPTER

8.

Now you have finished the introduction. You will find further example
measurements in SECTION 7.8.
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2 First Steps
Polytec's Scanning Vibrometer measures the two-dimensional distribution of
vibrations. The software in the measurement system has the following
functions:
•
•
•
•
•
•
•

Controlling the hardware
Defining scan points
Setting parameters for data acquisition
Generating excitation signals (as an option)
Acquiring digital data
Saving data
Displaying data and evaluating it

First of all, read the following sections to familiarize yourself with the basics of
how to work with the software.

2.1 System Requirements
So that you can work optimally with the software, please make sure that the
following components have been installed:
•
•
•

National Instruments driver NiDaq 7.4.1 (recommended)
Microsoft® DirectX 9
Current Service Packs for Windows® XP or Windows® 2000, you will find
detailed information on this in the Release Notes

Please use either Windows® XP or Windows® 2000 as your operating
system.

)

For desktop PCs, the operating system Windows® Vista is available on
request.

2.2 Installing the Software
To install the software, proceed as follows:

)

When installing the software, please make sure you pay attention to the
supplements and special features in the Release Notes !

1. Only for a new installation: Install the required hardware as described in
both your hardware manual under Cabling and in the manual for your data
acquisition board.
2. Check that your hardlock (dongle) is available and has been installed
correctly.

)

While the software is being installed, you are asked to choose whether
you have installed a local hardlock or a network hardlock. Please note that
acquisition mode is not available with a network hardlock.

3. Switch on your PC and log in with administrator rights. See your operating
system manual on this.
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4. Install the required software as described in the file
\\PSV \ Release Notes eng on your PSV DVD.
Now you have finished the installation. Should any problem occur during
installation, please contact Polytec.

2.3 Integrating the Hardware
CAUTION !
Danger from mishandling ! - Do not change any address or interrupt
settings ! This could prevent the software from running properly.

You can control two Polytec vibrometers using the software and as an option,
an external function generator as well. See also in SECTION 7.8.2 or
SECTION 7.8.6 on this. Connect up the devices as described in your hardware
manual.
IEEE-488 / GPIB

If you control some devices via IEEE-488 / GPIB, then we recommend you set
the following addresses:
•
•
•

RS-232

Vibrometer controller 1: IEEE-488 / GPIB address 5
Vibrometer controller 2: IEEE-488 / GPIB address 4
Function generator: IEEE-488 / GPIB address 10.

If you control vibrometers via RS-232, then the software recognizes the
controller connected to the lower COM port as Vibrometer Controller 1.

2.4 Starting the Software
To start the software, proceed as follows:
1. Check that the hardlock has been installed correctly on the PC or on the
network.
2. Connect up the PSV and start it as described in your hardware manual.
3. After you have done this, switch the PC on.
4. After a short while you will be asked to log in. You do not need
administrator rights to start the software. See your operating system
manual on this or contact your administrator.

)

If you want to change the hardware, you have to log in as administrator. A
password has not been set prior to delivery.

5. Double-click the icon
on the desktop or select Start > PSV. The
application window appears.
6. Change to acquisition mode. You may receive an error message and
information on it (refer to SECTION 2.5).
You can now work with the software.
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2.5 Modes in the Software: Acquisition and Presentation
In the software you work in two different modes: Acquisition and Presentation.
You can use some functions in both modes. Acquisition mode is not available
in the desktop version.
Presentation
mode

To go to presentation mode, click

or select View > Presentation.

Acquisition
mode

To go into acquisition mode, click

or select View > Acquisition.

When changing into acquisition mode, the software searches the PC
interfaces for external devices and initializes them. You may receive an error
message and information on it. You can switch off this error message as
described in SECTION 3.7.

Figure 2.1: Error message when changing into acquisition mode

If you want to check the connection between the devices and if necessary
correct it, select Setup > Preferences and open the page Devices.

)

Some Polytec instruments are automatically initialized in acquisition mode
and can not be changed. But when changing into presentation mode, all
the hardware used is enabled. This makes it easier to use the PSV
software in parallel to PMA or TMS software for example in the case of
MSA systems.

2.6 Windows in the Software
First of all, read the following sections to familiarize yourself with the various
windows in the software.
•
•
•
•
•
•
•
•

Application Window, refer to SECTION 2.6.1
Video Window, refer to SECTION 2.6.2
Analyzer, refer to SECTION 2.6.3
Project Browser, refer to SECTION 2.6.4
Presentation Window, refer to SECTION 2.6.5
Signal Processor, refer to SECTION 2.6.6
Arranging Windows, refer to SECTION 2.6.7
Zooming in Windows, refer to SECTION 2.6.8
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2.6.1 Application Window
After starting the software, the application window appears. At the top you will
see the title bar, menu bar and toolbar, at the bottom the status bar. In the
menu View, you can show (hide) the toolbar and the status bar.
Initially the application window is empty. By clicking
you change into
acquisition mode. There you will see the video window, an analyzer and the
project browser. The windows are described in the following sections in detail.
Click

to display additional analyzers.

Title bar
Menu bar
Toolbar

Video
window

Project
browser

Analyzer

Status bar

Help

Messages on
data acquisition

Figure 2.2: Example of the application window in acquisition mode
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In the application window you can display and evaluate data. To do so, you
can use various windows:
•
•

In acquisition mode: a video window, any number of analyzers.
In presentation mode: any number of presentation windows and
analyzers.

If you restart the software, then the arrangement and signal selection of the
windows opened most recently will be restored.
Menu bar

Every menu contains a group of commands for working with the software.
Some menus are only visible if an analyzer or a presentation window is open.

Toolbar

By clicking the icons, you can execute some commands quickly which you
would otherwise have to select in the menus.

Status bar

On the right, the status bar shows several settings for data acquisition. On the
left, in certain situations, you will see a short help text. For example, point the
mouse at one of the settings on the right and leave the cursor there for a
moment. Then on the left you will see which parameter it is for. For more
information on how to get help in the software, see SECTION 2.8.
When making a measurement, messages on data acquisition can appear in
the middle of the status bar. See SECTION 7.5 on this.

Scanning head
control

In acquisition mode you can show (hide) the scanning head control in the
application window. To do so, click
or select View > Scanning Head. You
adjust the optics using the scanning head control. See SECTION 4.1 on this.
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2.6.2 Video Window
The video window displays the live image of the video camera in the scanning
head.
Open

The video window appears when you change into acquisition mode.
Title bar
Toolbar

Live video
image
Legend

Scan points

List of
components

Figure 2.3: Example of the video window

Toolbar

By clicking the icons, you can execute some commands quickly which you
would otherwise have to select in the menus.To change between the 2D view
and the 3D view, click
. If you change from the 2D view to the 3D view, a
snapshot of the live video image is shown as a fixed-image. You can also use
the mouse to set the line of sight directly in the video window. To do so, click
. The mouse cursor becomes a

. Drag in the direction you require.

To change the view of the scan point status, click
SECTION 7.3 on this as well.

. Please see

Live video
image

In the live video image, you control the position of the laser beam. Apart from
that, you define there scan points and follow the progress of a scan. You
adjust the image settings of the live video image (contrast, brightness, color)
as described in SECTION 4.3.

Legend

On the left you see a legend for the status of the scan points. The legend also
shows the number of defined scan points and the estimated time needed for
the scan. The display of the status changes depending on which view you
have selected (Scan, Geometry or Laser Focus).
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Scan points

If scan points are defined, you can show (hide) them in the video window. To
do so, click
or select Scan > Scan Points. You see the scan points as
markers in different colors. These colors show the status of the scan points.

List of
components

In acquisition and presentation mode you can define geometry components
and assign scan points to the single components. See also SECTION 5.4.3 on
this.

Zoom function

In the video window you can zoom in on image sections and can pan the
zoomed sections. You will find the necessary tools in the toolbar of the
application window, refer also to SECTION 2.6.8.

2.6.3 Analyzers
Analyzers show measurement data and evaluated data in x-y diagrams. You
can follow current measurements in analyzers or use them to display
measurement data from a file. In presentation mode, an analyzer can also be
part of a presentation window. See SECTION 2.6.5 on this.
Open

An analyzer appears if you
•
•

start a single shot or a continuous measurement or
open a single point measurement.

If an analyzer is open, the menu bar of the application window is extended by
menus for working with analyzers. To open further analyzers, click
select Window > New Analyzer.

or

Title bar
Toolbar

Y-axis

X-axis

Scroll bar

Legend

Figure 2.4: Example of an analyzer

Title bar

If an analyzer has the function of a measurement window, you will see the
name Scan in the title bar. If you have already saved the measurement or
have opened a single shot or a continuous measurement, you will see the file
name in the title bar.
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Toolbar

You can show (hide) the toolbar by selecting Analyzer > Toolbar. By clicking
the icons you can quickly execute some commands from the menu Analyzer.

Diagram

You can see the data as a graph in x-y diagrams. You can set up the look of
the diagrams and the graphs yourself.

Legend

On the right you can show (hide) a legend for the diagrams. To do so, select
Analyzer > Legend.

Zoom function

In the analyzer you can zoom on diagram sections and can pan the zoomed
section. In the toolbar of the analyzer you will find the necessary tools, refer
also to SECTION 8.2.1.

Scroll bar

You can use the scroll bar to scroll if you have zoomed the x-axis.

2.6.4 Project Browser
In the project browser you can display folders in a tree structure with the
subdirectories and files in them. To do so, open a program on file
management, e.g. Microsoft® Explorer and use the mouse to drag the
required folder or folders into the project browser. These folders can now be
managed from here. Please note that all actions are executed directly in the
respective folder.

)

The folders in the project browser are not copies, but are direct links to
folders on your hard disk or network drives ! Changes made in the project
browser, e.g. deleting or renaming subdirectories and files are carried out
in parallel in your file management and in reverse.

Figure 2.5: Example of the project browser

)

You can not transfer individual files to the project browser. You can
remove folders again. To do so, click the folder with the right mouse
button and select Remove in the context menu. You can also delete
individual files.

The contents of the project browser remain saved, even after the program is
stopped. The display of contents is user-specific.
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Open

To open the project browser, click
or select View > Project Browser. You
can adapt the way the project browser is displayed, i.e. make it smaller and
move it to another part of the screen. If you drag the project browser near to
one of the edges of the software window and release the mouse button, the
project browser is automatically placed next to the corresponding window
edge. Click
in the title bar of the project browser to reduce its size again
and position it freely in the software window.

Add folder

To add another project folder to the project browser, click the project browser
with the right mouse button, however do not click a file or a folder. Select Add
Project Folder in the context menu. The dialog Select Folder appears.
Navigate to the required folder and click Select.

)

Alternatively you can also select File > Add Project Folder.

Click a file or a folder with the right mouse button to edit the contents in the
project browser. The commands shown in the pop-up menu differ depending
on the level in the tree structure, the type and number of objects selected and
the mode you are currently working in (acquisition or presentation). The
individual commands are explained in the following.
Explorer: Click here if you want to have the selected folder displayed in
Microsoft® Explorer as well. This command is only available for folders.
Refresh: Click here to update the display of folders and files in the project
browser.
Remove: Click here if you want to remove the selected objects from the
project browser, but do not want to delete them. This command is only
available for folders on the top level.
Rename: Click here if you want to give the selected object a different name.
Delete: Click here if you want to irrevocably delete the selected objects.
Before deleting them permanently, you have to confirm a safety check. This
command is only available for files.

)

You can only delete settings if they are saved in their own file (*.set) (refer
to SECTION 10.2.7 and SECTION 10.1.4). You can not delete the settings of
a scan.

Load: If you select Load, then the setting files (.set) that you selected in the
project browser are loaded. See also SECTION 10.1.4 on this.
Open: In principle, in the project browser you can open files from all
programs installed on your PC. Click Open and the selected file will be
opened using the corresponding program. If you open a file with the suffix
svd, a presentation window appears. If you open a file with the suffix spd, the
signal processor appears (as an option).
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New window: Click here if you want to display the file you have already
opened in a second window again.
Info: Click here if you want to display the file information on the file you have
already opened. See also SECTION 10.1 on this.
Close: Click here if you want to close the selected file.
Save As: Click here if you want to save the selected file under a different
name or in another directory.
Paste: This command is only available if you are using the optional signal
processor (refer also to SECTION 8.6). If you have copied data in the signal
processor, you can insert this data into the selected file by using the
command Paste.
Edit: If you select Edit, a macro window will appear with the macro you
selected in the project browser.
Run: If you select Run, then the macro you selected in the project browser is
executed.
Properties: This command is only available to you for combined files in
presentation mode. You will then see the dialog Create Combined File with
the individual files in the set order. See also SECTION 8.5 on this.
Import: In the project browser, you can also import geometries in the format
Universal File, ME’Scope or ASCII. A condition of this is that you are in
acquisition mode, you have a valid 3D alignment and you have selected point
mode in the scan point definition. See also SECTION 5.2.7 on this. Apart from
that, in presentation mode you can also import measurement data in the
format Universal File, ME’Scope or ASCII. See also SECTION 10.1.5 on this.
Copy and move

You can copy files or folders in the project browser into other directories. To
do so, mark them and holding the left mouse button pressed, drag the marked
objects onto the required directory.
To move files or folders in the project browser, proceed as described above.
Also hold the shift key pressed while you are dragging with the mouse.
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2.6.5 Presentation Window
In presentation windows you analyze scans in 2D and 3D diagrams.
Open

A presentation window appears when you open a scan. The menu bar of the
application window is then extended by menus for working with presentation
windows. You can then open further presentation windows by selecting
Window > New Window.

Title bar
Toolbar

Object under
investigation
(zoomed)
Gauge
Legend
List of
components
Selected scan
point

Analyzer

Figure 2.6: Example of a presentation window in the Single Scan Point view

Toolbar

You can show (hide) the toolbar by selecting Presentation > Toolbar. By
clicking the icons you can quickly execute some commands from the menus
Setup, Presentation and Animation.

View

You can display the presentation window in different views. To do so, click
and select the view required in the context menu. You can also select
Presentation > View.

Object

You see the object in all views. You can present the object in different ways.
To do so, click
and select the view style required in the context menu.
You can also select Presentation > View Style.

Gauge

On the left you can show (hide) a gauge for color-coding. To do so, select
Presentation > Gauge.
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Legend

On the right you can show (hide) a legend for the data displayed. To do so,
select Presentation > Legend.

List of
components

In acquisition and presentation mode you can define geometry components
and assign scan points to the single components. See also SECTION 5.4.3 on
this.

Analyzer

In the views Single Scan Point, Average Spectrum and Profile you will see an
analyzer at the bottom of the presentation window. See SECTION 2.6.3 on this.

Zoom function

In the presentation window you can zoom on the object in all views and in all
view styles and also pan the zoomed section. You will find the necessary tools
in the toolbar of the presentation window, refer also to SECTION 2.6.8.

2.6.6 Signal Processor (as an Option)
You can use the signal processor to recalculate measurement data for further
analysis and then compare the results with the original data. You can read
SECTION 8.6 to find out how to work with the signal processor.
Title bar
Toolbar
Formulae
editor
Calculation
table

Analyzer

Figure 2.7: Example of recalculating measurement data in the signal processor

Toolbar

In the toolbar you will find the most important arithmetic operations you can
execute with the signal processor. By clicking the icons, you can transfer the
formulae directly to the formulae editor instead of having to enter them using
the keyboard. The icons are active as soon as the cursor is in the formulae
editor. You can also select the function wizard to enter the formulae. To do so,
click
and then the required icon. See also SECTION 8.6.1 on this. Apart
from the icon for the function wizard, you will find a list with all available
formulae. By clicking in the list, you can directly apply the formula in the
formulae editor.
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Formulae editor

You are shown the contents of the selected table cell in the formulae editor.
This is also where you enter text or formulae which are to appear in the
selected cell.

Calculation
table

You enter the measurement data and the formulae in the cells of the
calculation table. By linking the individual cells via the formulae, the software
can make various arithmetic operations using the measurement data and then
display the results at any point in the computing chain. Apart from that, you
can also enter comments into the cells.

)

In the table cells, you can display either the formula or the result. To
switch over, select View > Formulae or press the key combination Ctrl + #.

For linking individual cells you establish references. A reference designates a
cell or a cell range in the table and informs the signal processor where the
values or data used in the formula are located. With the aid of references you
can use data or values of a cell in different formulae.
Depending on the operation that you want to execute in the signal processor,
you can either use relative or absolute cell links. Relative cell links are
references to cells that are given in relative to the position of the formula,
absolute references are cell links that always refer to cells at a certain
position. If a dollar symbol is prefixed to the letter and/or the number, e.g.
$A$1, then the column and/or cell link is absolute. Relative references are
automatically adapted in case of copying, absolute references are not
adapted.
Analyzer

The signal processing results are shown as a graph in the analyzer.

2.6.7 Arranging Windows
You can arrange all open windows in the application window using the
commands in the menu Window.
New window

To open further analyzers or presentation windows, click
Window > New Analyzer.

Cascade

You can arrange all windows over each other so that only the title bar and the
y-axis name are visible respectively. To do so, click
Cascade.

or select

or select Window >

Tiling
You can display all open windows so that they are completely visible and
horizontally and
maximum size. To do so, click
or
. You can also select Window > Tile
vertically
Horizontally or Window > Tile Vertically.
Close all

To close all open windows, select Window > Close All.

Window list

At the bottom of the menu Window you will find a list of open windows. To
activate a window – i.e. move it to the foreground – click it in the list.
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Window
settings

Window settings which you have made are automatically restored by the
software when you newly open the file. For this purpose, the window settings
are saved in a database under the complete path name of the file. This
database is located on the local hard disk of your PC. Each user which is
logged in Windows has its own database.
You can deactivate restoring the window layout and take over the settings of
the active window as default for opening other files. To do so, first you have to
change to presentation mode. Then select Setup > Preferences. The dialog
Preferences appears. Display the page Display.

Figure 2.8: Page Display in the dialog Preferences

Restore window layout at start of the software: Tick this box in order that,
at the next start of the software, the window layout will be restored like it was
during exiting the software.
Apply: Click here if you want to apply the window settings of the active
window (only presentation window) to other files of the same type. To activate
the window, click it. The window settings are applied to every newly opened
file.

)

2-14

In acquisition mode you can only load window settings from setting files.
See SECTION 10.1.4 on this.

2 First Steps

Reset: Click here if you want to reset the window settings for newly opened
files to default values.

)

The software needs a few minutes to open files in which the window
settings are to be restored. You can not abort the process.

2.6.8 Zooming in Windows
You can zoom on image sections in both the video window and also in the
presentation window. You will find the necessary tools in the toolbars of the
application window and of the presentation window.
Zoom

If you would like to take a closer look at a certain image section in either the
video or the presentation window, you can zoom on it.
Zooming in on the object helps you define the points and carry out 2D or 3D
alignment more accurately, thus enabling you to present the data more
precisely. This is an advantage, particularly if your object under investigation
has complex geometry or if your scan points are very close together.
To zoom in on a video or presentation window, proceed as follows:
1. Click

. The mouse cursor becomes a magnifying glass with a plus sign.

2. Holding the left mouse button pressed, draw a rectangle around the area
of the image which you want to zoom in on. You can repeat this step
several times.

)

If you zoom in the video window, on the left in the legend a smaller view of
the measurement object will appear with a frame marking the zoomed
section of it. This means you can always ascertain which part of the object
under investigation you are currently viewing. Once maximum
magnification has been attained, you will receive a message.

or
3. You can also zoom by scrolling with the middle mouse button (mouse
wheel).
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Pan the image
section

You can pan the zoomed image section.

)

Depending on the video board, the image section selected may not pan
smoothly, but may move across the screen in small jumps.

To do so, you have the following options:
1. Using the middle mouse button (mouse wheel), click in the zoomed view
in the video window. Hold the mouse button pressed and pan the image
section. If you have given the middle button a special function (e.g.
double-click), then you will have to proceed as described in step 2.
2. In point mode (APS, refer to SECTION 5.22) and during 2D alignment (refer
to SECTION 4.4), click
mouse button pressed.
Zoom out

and pan the image section while holding the left

You can zoom out again.
To undo zooming, scroll up with the middle mouse button (mouse wheel). To
undo all previous zoom actions at once, click

Exit zooming

To leave the zoom function again, click
remains.

.

. The last image section selected

2.7 Printing
You can print out analyzers, presentation windows and signal processors. The
title of the window as well as the date and time are automatically printed as a
header.
Print setup

To set the paper size, feed and orientation, select File > Print Setup. The
dialog Print Setup appears. Here you can select the current printer and set up
the page.

Preview

To see a print preview, select File > Print Preview.

Start

To print out the active window (analyzer or presentation window), click
or
select File > Print. If you want to print out a signal processor or if you have
selected the view Single Scan Point, Average Spectrum or Profile in the
presentation window, you can define whether you only want to print one of the
graphics or both. The dialog Print will then appear. Here you can select the
printer and set up further print properties. To start printing, then in the dialog
Print click OK.

2-16

2 First Steps

2.8 How to Get Help
You can get help in the software as online help and through short
explanations of commands. You can also display the version of the software
and the software options which are installed.
Online help

To open the online help, click

or select Help > Contents.

Contextsensitive help

For dialogs and windows you can get context-sensitive online help. There are
several ways of doing this:
1. Activate the window or dialog you need help with. To do so, click it.
2. Press the key F1. The corresponding page of the online help appears.
or
When a dialog is open, then click Help in this dialog. The corresponding page
of the online help appears.

Explanation of
commands

You can also get explanations for icons and commands without opening the
online help. To do so, point the mouse at the command or the icon and leave
the cursor there for a moment. The explanation appears on the left in the
status bar. For icons you will also see a brief description on a yellow
background next to the cursor.

Software version To display the version of the software, select Help > About PSV. The dialog
and options
About Polytec Scanning Vibrometer appears. To display the installed software
options, click Options in the dialog.
You can also display information on the operating system, the memory and on
the available space on the hard disk. To do so, click System Info.
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2.9 Controlling the Hardware with the PSV-A-PDA (as an Option)
With the optional PSV-A-PDA you can also call up several software functions,
such as focusing the laser beam, defining and deleting scan points, etc.
Read

SECTION

2.9.1 on starting the PDA.

Read
PDA.

SECTION

2.9.2 on setting the IP address of the network board in the

2.9.1 Starting the PDA
To start the PDA and to call up the required function, proceed as follows:
1. Install the PDA as described in your hardware manual.
2. Make sure that your WLAN Access Point is ready to use and switch it on
as described in your hardware manual.
3. Switch the PSV on and start the PSV software.
4. Switch the PDA on.
5. Switch WLAN on the PDA on as described in the manufacturer's manual.

)

Setting up the WLAN connection can take several minutes. You can not
connect the PDA to the PSV software until the WLAN connection has
been made. The WLAN connection is shown with an icon in the title bar.

6. Select Start > PDASoft.
7. If you want to activate the connection to the PSV software, click Yes in the
pop-up message. The user interface of the PDA software appears.
Title bar

Control panel

Menu bar

Figure 2.9: User interface of the PDA software
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Control panel

You can use this control panel to call up and execute the PDA functions. You
will find more information on this in SECTION 4.4 AND SECTION 4.5.6.

Menu bar

The menu bar contains additional functions. You will find more information on
this in SECTION 2.9.2. Apart from that, you make the connection to the PSV
software here. To do so, touch the icon

. Near the icon the PDA software

shows in which mode you are in the PSV software (2D alignment
alignment
mode

, scan point definition

, acquisition mode

Touch the icon

Functions

The PDA supports the following software functions:

•

or presentation

).

Exit button

•
•
•

, 3D

to exit the PDA software.

Controlling the optics (refer to SECTION 4.1.2)
Switching the scanning heads (only PSV-3D, refer to SECTION 4.5.6)
Defining and deleting alignment points (refer to SECTION 4.4 and
SECTION 4.5.6)
Defining and deleting scan points (refer to SECTION 5.2.2)
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2.9.2 Adapting the IP Address
So that the PDA can communicate with the PSV software, the IP address of
the network board which the WLAN Access Point is connected to must be
entered in PDA. On delivery of the PSV system, the correct IP address is set.
If you have to change this address at a later point in time, select Setup >
Preferences in the menu bar of the PDA. The dialog Preferences appears.

)

You can only change the IP address if the PDA is not connected to the
PSV software. If required, touch the icon

to disconnect it.

Figure 2.10: Dialog Preferences

Server IP Address: Here you enter the new IP address via the keyboard in
the PDA. To display the keyboard touch the icon

.

Network Timeout: Here you select the time in seconds that the software has
to wait until a message is issued. We recommend the presetting of 10
seconds.
Acoustic Messages: Tick this check box if you want to hear an acoustic
message when you are setting/deleting a scan or alignment point or when a
message is issued.
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3 Setting up the Software
Before making a measurement, you have to set up the software for data
acquisition.

)

In almost all views and modes you can use the right mouse button to call
up additional menus which contain several commands and functions that
are often needed at this point.

To set up the software, proceed as follows:
1. Go into acquisition mode. To do so, click

)

or select View > Acquisition.

You can also set some options in presentation mode.

2. Select Setup > Preferences. The dialog Preferences appears.
3. The dialog contains several pages, each with a group of parameters. To
display a certain page, click the name of the group.
4. Set the parameters on all pages. You will find information on this in the
following sections:
•
•
•
•
•
•
•

Devices setup in SECTION 3.1
Channel settings in SECTION 3.2
Scanning Head settings in SECTION 3.3
Geometry and window settings in SECTION 3.4
Lens Calibration (only MSA) in SECTION 3.5
Settings for dB Reference in SECTION 3.6
Messages in the software in SECTION 3.7

5. When you have set all parameters, click OK.
Test mode (only
MSA / MSV with
option VDD)

6. If you have installed the option VDD for the MSA / MSV (with VDD
decoder), run the test mode. See SECTION 7.7 on this.

PSV-3D

The measurement system PSV-3D enables you to measure and display
vibration vectors in three dimensions.

)

The settings in the software apply for all three controllers respectively. For
this reason, no distinction is made on the user interface between the
individual devices.
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3.1 Devices
On the page Devices you set which measurement system and which external
devices you want to control with the software.
Depending on the measurement system and equipment, the page Devices
may look different.

Figure 3.1: Page Devices

Junction Box: This list is only active for certain hardware configurations.
Junction boxes connected via the USB interface are recognized automatically
and displayed.

)

If you have the option of changing the hardware selection, you have to log
in as an administrator to change it.

To use the option VDD for MSA / MSV, you must select the junction box
VDD-Z-010, VDD-Z-011 or MSA-E-500 (VDD) or MSA-E-40x (VDD).

)

OFV-5000: To be able to run the test mode automatically, the controller
has to be controlled remotely via USB and has to be connected with VDD
Vib Controller 1 on the page Channels (refer to SECTION 3.2).
OFV-3001: In this case it is not possible to connect up a controller which
is remotely controlled. Only the reference signal is connected, but not the
vibrometer signal.

Device: Here the connected external devices are displayed.
Type: Here you select the camera type PAL or NTSC that you are using. If
you are using the junction box PSV-E-401 or PSV-E-401-3D, here you have to
select the camera PAL (S-Video) or NTSC (S-Video).
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Connection: Here you can select which interfaces should be searched to
look for external devices.
For the vibrometer controller you can either have the available interfaces
automatically searched for devices (Auto) or you can state where the devices
are connected (RS-232 or GPIB). You will speed up the start of the application
with a fixed preference. If the vibrometer controller is connected via the USB
interface, it will be recognized automatically. Then you do not have to make
any more settings for this controller.
If you are using a generator, you can also state whether the device is
integrated into the PC (internal) or whether it is an externally connected
device.
Address: If you have given a fixed connection, then select the address here
or carry out an automatic search for it.
Warning: If you change into acquisition mode or have changed any settings,
then the software will search the PC's interfaces for external devices and
initialize them. Here you mark the devices which you want a warning message
issued for if the software can not find them.

)

These warnings are not shown if under Setup > Preferences on the page
Messages you have selected accordingly Errors or Show None (refer also
to SECTION 3.7).

Activate PSV-3D You can operate the PSV-3D in 1D mode (PSV-3D (1D)) and in 3D mode
(PSV-3D (3D)). In contrast to 3D mode, in 1D mode the signals of every
scanning head are displayed and processed without transforming the
coordinates. The channels measured are designated as Vibrometer Top,
Vibrometer Left and Vibrometer Right.
PSV-3D in 3D
mode

To activate the PSV-3D in 3D mode, select the junction box PSV-E-401-3D or
PSV-E-400-3D.

)

If you want to change the hardware selection, you have to log in as
administrator.
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Figure 3.2: Page Devices for the PSV-3D

The first device shown to you in the list is the PSV-3D Multiplexer. This
enables you to control all three controllers via a single USB cable from the PC
using the software. Apart from that, under Connection you can select the
video camera which you would like to use to view your object. If you have
arranged the scanning heads relatively far apart, then we recommend that
you select the optional video camera Center.

)

If you are using a digital camera for PSV-3D as a center camera, select
Digital as the type. If you are not using the video camera Center and the
scanning heads are mounted close to each other, then the video camera
Left is closest to the middle for constructional reasons. If you are
measuring with the geometry scan unit, we recommend using the video
camera Top.

You will find information on connecting up the PSV-3D in the separate
hardware manual.
PSV-3D as
PSV-1D

To activate PSV-3D as PSV-1D, select the junction box PSV-E-401-1D or
PSV-E-400-1D. You will then only need one controller and one scanning
head. Your PSV-3D will then behave like a standard PSV.

)
PSV-3D in 1D
mode

To activate PSV-3D in 1D mode, select the junction box PSV-E-401-3D (1D)
or PSV-E-400-3D (1D). You can use 1D mode for fault diagnosis for 3D mode.

)
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Fault diagnosis
in 1D mode

If you have any misgivings about the measurement results in 3D mode being
correct, you can make a 1D measurement without coordinate transformation
and check the plausibility of the vibration signals in this mode. In doing so, the
limitations mentioned in the following apply.
If you operate the PSV-3D with just one scanning head, then you have to
deactivate the other two scanning heads (vibrometers). To do so, click
and display the page Channels, refer also to SECTION 3.2. Deactivate the two
vibrometers that you do not want to use for making measurements.
However you can also use the other two vibrometers to make reference
measurements. To do so, click
channels.

)

and mark the vibrometers as reference

The Vibrometer Top can not be used as a reference channel.

Once you have identified the scanning heads as reference channels, they are
not moved during scanning and can also not be controlled via the video
image. Move the reference scanning heads using the icons Position in the
scanning head controller. You will find more information on this in SECTION 4.1.
If the scanning heads have not been defined as reference channels, but
simply as Channel, then they are moved during scanning and every scanning
head supplies separate 1D information.

3.2 Channels
On the page Channels you set which channels you want to use to control
Polytec vibrometers.

Figure 3.3: Page Channels
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Channel: The number of channels displayed depends on which data
acquisition board(s) you are using and which junction box has been selected
on the page Devices (refer to SECTION 3.1). However, the number of channels
is only updated if you close the dialog Preferences by clicking OK and then
reopening it.

)

If you want to make a measurement with the MSA / MSV using the option
VDD, then you have to connect the channel with VDD Vib Controller 1 and
set the appropriate junction box on the page Devices (refer to
SECTION 3.1).

Description: A meaningful name for every channel is shown here.
Abbr. An abbreviated name for every channel is given here.
Vibrometer: In this column, a channel is only active if: a Polytec vibrometer is
connected, the vibrometer had already been switched on before changing into
acquisition mode and the correct connection has been set on the page
Devices. Here you select which vibrometer provides the signal for this
channel. You can use the software to control the connected vibrometers as
described in SECTION 7.8.6. For certain hardware configurations and
measurement modes, channels are already permanently connected.
In the following tables you will find the allocation of digital channels to the
different connections from the individual junction boxes.
Junction box
Channel

PSV-E-400-3D
PSV-E-400-1D
(3D / 1D)

PSV-E-400

1

VELO

VELO TOP

VELO TOP

VELO

VELO TOP

VELO TOP

2

REF 1

VELO LEFT

VELO LEFT

REF 1

VELO LEFT

VELO LEFT

3

REF 2

VELO RIGHT

VELO RIGHT

REF 2

VELO RIGHT

VELO RIGHT

4

REF 3

REF

REF

REF 3

REF

REF

51

REF 21

REF 21

REF 21

REF 21

REF 21

REF 21

61

REF 22

REF 22

REF 22

REF 22

REF 22

REF 22

1

REF 23

REF 23

REF 23

REF 23

REF 23

REF 23

81

REF 24

REF 24

REF 24

REF 24

REF 24

REF 24

7
1

PSV-E-401-3D
PSV-E-401-1D
(3D / 1D)

PSV-E-401

with PSV-E-408

Channel

MSA-E-500

MSA-E-40x

MSV-Z-040

1

VELO IN

VELO IN

VELO

2

REF IN

REF IN

REF

Channel
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Junction box

Junction box
VIB-E-220

VIB-Z-010

VIB-Z-012

VIB-Z-015

1

VELO

SIG IN

VELO

CHANNEL 1

2

REF

REF IN

REF 1

CHANNEL 2
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Channel

Channel

1

Junction box
VIB-Z-014

VIB-Z-016

VIB-Z-017

1

VELO

VELO

VELO

2

REF 1

REF 1

REF 1

3

REF 2

REF 2

REF 2

4

REF 3

REF 3

REF 3

Junction box
VDD-Z-010

VDD-Z-011

MSA-E-500 (VDD)

MSA-E-40x (VDD)

1

Vibrometer signal 1

Vibrometer signal 1

Vibrometer signal 1

Vibrometer signal 1

2

REF IN

REF 1

REF IN

REF IN

The vibrometer signal is not fed in through the junction box, it is only available directly in the software (only with option VDD).

Channel

Junction box
PSV-Z-040-H

PSV-Z-040 -F, -U

1

VELO

VELO

2

REF 1

REF

3

REF 2

-

4

REF 3

-

With the junction boxes PSV-E-40x, PSV-E-40x-3D, VIB-Z-012 and VIB-Z-016
you can select ICP® for the reference channels and also switch the
differential input for all channels on or off. You will find additional information
on this in SECTION 6.2.2 under the keywords ICP and Differential Input and
also in your hardware manual.
If in addition to the junction box PSV-E-40x or PSV-E-40x-3D, you are using
the junction box PSV-E-408, you can measure four additional reference
channels (Reference 21 to Reference 24) using a second data acquisition
board (PCI-4452).
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Allocate
With the PSV-3D, you can only adjust settings on the page Channels if you
channels for the have an additional reference (single point) vibrometer connected.
PSV-3D

Figure 3.4: Page Channels for the PSV-3D
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)

If you want to operate the PSV-3D in 1D mode (junction box PSV-E-40x3D (1D)), we recommend connecting the channels Vib Top, Vib Left and
Vib Right with the vibrometer PSV 3D. This way you can remotely control
all three controllers together.

)

If you want to operate the PSV-3D as a pure PSV-1D (junction box PSV-E40x-1D), then the allocation of the channels displayed does not match the
names on the junction box. Please note the following allocation: Vib
corresponds to VELO TOP, Ref1 corresponds to VELO LEFT, Ref2
corresponds VELO RIGHT and Ref3 corresponds to REF.
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3.3 Scanning Head
You can set up the optics of the measurement system on the page Scanning
Head. In the following the settings for the PSV-1D are described. Further
down you will find information on the settings for the PSV-3D and special
features for the MSA / MSV.

Figure 3.5: Page Scanning Head for the PSV-1D

Scanning Head: Select the scanning head of your measurement system
here. The scanning head PSV-I-400 is delivered with the LR (Long Range)
front lens as standard, as an option you can also have the MR (Mid Range)
front lens. It is necessary to make a distinction between the two front lenses in
the software to calculate the depth of focus correctly. Only PSV-200: Select
the OFV-055F if your scanning head is equipped with a color camera.
Preferred Scan Direction: Here you select how the laser beam is to be
moved when scanning. If the scan points are to be hit row by row, select XDirection. If the scan points are to be hit column by column, select YDirection. In the latter case the scanning time is shorter as the scanner mirror
for the y direction is smaller and thus has a shorter settling time. If you select
Auto, the software independently optimizes the order in which the scan points
are hit. Select Index, if the scan points are to be hit in ascending order
according to the index.

)

If you have selected Index, you can individually set the order by changing
the indices of the scan points (refer also to SECTION 5.4.2).
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Focus Sharpness: This line only appears if you have selected the scanning
head PSV-I-400 LR or MR. You can set the depth of focus here. The smaller
the value you select, the less often the focus is corrected during a
measurement. The standard value is 100%. However you can also set values
to be greater than 100%. But please note that frequent readjustment of the
focus can considerably increase the measurement time.

)

So that focus is adjusted during the measurement, in the menu Scan you
have to select the command Focusing during Scan.

Pan-Tilt Control: This line only appears if you have selected the scanning
head PSV-I-400 or OFV-056 above. Tick the box if you want to control the
optional pan-tilt stage using the software.
Flip Video: Here you can flip the live video image on the x- or y-axis and
thus, if necessary, set it up properly again. Normally the appropriate boxes for
the scanning head have already been selected. However you can also
change the setting as necessary, if, for example, you redirect the laser beam
with external mirrors and thus obtain a flipped image, or if the scanning head
has been mounted in such a way that it generates a flipped image.
Angle Correction: The vibrometer measures vibrations parallel to the laser
beam. If the laser beam is at an oblique angle to the measurement surface,
then an angle error occurs. Here you select whether the software is to correct
the angle error for the respective axis. The angle correction only provides
correct measurement values if you are measuring a flat surface at right angles
to the scanning head and a pure out-of-plane vibration. You should switch off
angle correction for curved surfaces.

)
Geometry scan
unit

The function Angle Correction is not available for PSV-3D and for MSA /
MSV.

You can adjust the laser of the geometry scan unit and enter an offset to the
distance measured. To do so, first of all activate the vibrometer laser, position
the laser to position 0° / 0° and mark the position on the object. Then activate
the geometry laser and point the laser at the marked position.
Current Position: Click here to apply the current position of the geometry
laser as angular deviation Offset X and Offset Y in the software.
Offset Distance: Here you enter the difference between the theoretical and
the real beam path in the scanning head. You will find this value (Geo Offset
Distance) on a label on the underside of the geometry scan unit. The value is
in the range of ± 3 mm.
Signal Level: Here you enter in % of the full scale value the signal level
threshold from which scan points should get the status Optimal Measured.
The higher the threshold is set the less scan points get the status Optimal
Measured.

)

3-10

You can enter values from approx. 40% to 100%. The lower limit depends
on the geometry scan unit used.
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Arrangement of
scanning heads
for the PSV-3D

In addition to the setting options for the PSV-1D, with the PSV-3D you can
mount the scanning heads at an angle relative to the video camera used. The
software will compensate for this tilt if you move the beam with the icons
Position in the scanning head control (refer to SECTION 4.1). So that the laser
beams can travel in the required direction, you have to set the tilt angle for
every scanning head. The respective tilt angles are given clockwise when
looking in the direction of the emitted laser beam. Two configurations have
already been predefined:
•

Staggered horizontally

•

Star-shaped

Figure 3.6: Page Scanning Head for the PSV-3D

Head Angle: Click

if you have the scanning heads mounted so that they

are staggered horizontally. Click
if you have the scanning heads
mounted in a star-shape. In both of these cases, the tilt angles will be entered
automatically.
If you have mounted the scanning heads with a different tilt, then please enter
the values yourself.
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Special features If you are using the MSA, you have other optional settings on the page
for the MSA
Scanning Head.

Figure 3.7: Page Scanning Head for the MSA

Scanning Head: Here you are shown the MSA-I-500 or respectively the
MSA-I-400 as the scanning head.

)

You will find the descriptions of Preferred Scan Direction and Flip Video
further up in the description of the dialog for the PSV-1D.

Indicator Position: Here you select at which position on the MSA monitor the
indicators are to be shown.
Show Indicators on Display: Tick this check box if the indicators for the
activity of the laser beam (on / off) and for the signal level on the MSA monitor
are to be displayed.
Show Crosshair on Display: Tick this check box if a crosshair is to be
shown on the MSA monitor. You can use this crosshair to help you accurately
find the center of the screen and launch the laser beam precisely.
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3.4 Geometry
On the page Geometry you can get the software to calculate hidden points
and have the focus values calculated automatically using the focal length of
the lens in the scanning head.

Figure 3.8: Page Geometry for the PSV-1D

Hidden points
calculation

Calculate Hidden Points: Tick this box if you want the software to calculate
which points are hidden by other parts of the geometry.

)

If you are working with a large number of scan points, this calculation can
take some time. In this case, you can deactivate the calculation here.

Tolerance for Calculating Hidden Points: Here you can enter a tolerance
value for recognizing hidden points. The tolerance value is used to
compensate the deviations between the defined geometry and the actual form
of the object under investigation. Scan points, which can only be reached by
the laser beam if they pass the geometry in a distance smaller than the
tolerance value, are marked as Hidden.
Recommended: Click here and the software will give you a recommendation
for the tolerance value which results depending on the typical distance
between scan points (approx. half).
Typical Distance between Scan Points: Here the software shows the
typical value for the distance between two scan points.
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Automatic
calculation of
focus values

Calculate Focus Values Automatically: Tick this check box if you want to
have all focus values calculated automatically on the basis of the focal length
of the lens in the scanning head. If you do not know the focal length of the
lens, then you will have to calculate it. To do so, start a scan with the function
Assign Focus Fast or Assign Focus Best (refer also to SECTION 5.6.2). Every
scan point is assigned a focus value. Then click Calculate.

)

Automatic calculation of focus values is not available for the MSA / MSV.

Calculate: Click here if you want to calculate the focal length of the lens in
the scanning head from the focus values identified. The focal length will then
be entered automatically.
Focal Length of Lens for Scanning Head: If the focal length of the lens in
the scanning head is known, you can also enter the value directly.

)

For the PSV-3D the focal length of the lenses for all three scanning heads
(Top, Left and Right) are entered here.

Figure 3.9: Page Geometry for the PSV-3D
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3.5 Lens Calibration (only MSA)
On the page Lens Calibration you enter the name or the type and resolution of
the lens used. The dialog contains already some lenses with the respective
values as standard. You can overwrite these entries and add any number of
other lenses.

Figure 3.10: Page Lens Calibration

Adapt lens
settings

You can adapt the lens settings at any time, independently of whether you are
in acquisition mode or in presentation mode (refer also to SECTION 2.5).
Lens Identifier: Here you can enter a name for the lens or the zoom factor of
the lens. This identifier is also saved in the scan.
Horizontal ... pixels for... µm: Here you enter the number of pixels in a
horizontal direction which corresponds to a certain section length your
microscope image in µm.
Vertical ... pixels for... µm: Here you enter the number of pixels in a vertical
direction which corresponds to a certain section length your microscope
image in µm.

Add lenses

You can only add further lenses for data acquisition if you are in acquisition
mode.
New: Click here to add a new lens to the list Lens Identifier. The new lens is
given the same name as the last one selected, supplemented by a
consecutive number, e.g. x20 (2). The number of pixels and the distance
(horizontal and vertical) of the last lens selected are also taken over.
Overwrite the entries with the appropriate values.
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Delete lenses

Delete: To delete a lens, select it in the list Lens Identifier and click here.
Then, if necessary, select another lens and click OK.

Determine
pixels and
distance

To determine the pixels and the distance for the lens used, proceed as
follows:
1. Exit the PSV software.
2. Place the stage micrometer supplied under the microscope and use the
keys on the junction box MSA-E-500 or MSA-E-40x to switch on the
strobe illumination.

3. Start the BCAMViewer. To do so, double-click the icon
desktop. The BCAMViewer window appears.

on the

Figure 3.11: Example of the BCAMViewer window

4. Double-click the name of the camera, e.g. A101f in the navigation area on
the left side of the window.
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5. Maximize the window and click
. The video image is displayed. If you
see a gray video image instead of the stage micrometer, you have to
deactivate the trigger as follows.

Figure 3.12: Video image with stage micrometer

6. To do so, select View > Properties. The dialog Properties appears.
7. Here display the page Trigger and deactivate the check box Use Trigger.
8. If the video image does not fill the BCAMViewer window completely, click
. The video image will be adapted to the window section.
9. Using the mouse, draw a frame over the stage micrometer in the video
window. In the status bar of the BCAMViewer, the width and height of the
frame is shown in pixels.
If you start the BCAMViewer again, you will be shown the last frame set. To
delete an existing frame, proceed as follows:
10. Click
. The frame is activated and maximized, i.e. it encloses the whole
video image.
11. Now, using the mouse, draw the required frame.
12. On the stage micrometer read the width and the height of the frame in µm
and in the status bar read the width and the height of the frame in pixels.
13. Close the BCAMViewer and start the PSV software.
14. Go into acquisition mode, open the dialog Preferences and display the
page Lens Calibration.
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15. Under Horizontal enter the width in pixels and in µm and under Vertical the
height in pixels and in µm.

)

Make sure that you switch the microscope illumination off again before
making a measurement.

3.6 dB Reference
On the page dB Reference you can define dB = 0. You can thus directly follow
an online measurement with a certain dB reference.

Figure 3.13: Page dB Reference

)

Changes you make here only have an effect on the global 0 dB reference
(applies to all Polytec products). If you want to change the local 0 dB
reference for the active document, you have to open the page in
presentation mode. See also SECTION 8.4 under 0 dB Reference on this.

Default Settings: Click here if you want to recover the original settings for
the 0 dB reference.
Quantity: All available physical quantities are shown here.
0 dB Reference: Here you can define the factor for the respective unit.
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Unit: The unit for the respective physical quantity is shown here.
Example:
Quantity

0 dB Reference

Unit

Displacement

2e-3

m

The 0 dB reference for the quantity Displacement is 2 mm.

)

If you want to evaluate combined signals (e.g. Vib & Ref1, see also
8.4 on this), define the 0 dB reference for both quantities.

SECTION

3.7 Messages
On the page Messages you select which system messages you would like to
have displayed.

)

Message windows which contain queries or advise you of faulty input will
appear in any case.

Figure 3.14: Page Messages

Show All: Click here if you would like to see all messages (notes, errors and
warnings).
Warnings: Click here if you would like to be informed of warnings and errors.
Errors: Click here if you would only like to see error messages.
Show None: Click here if you do not want to receive any system message.
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4 Setting the Optics
Depending on the model of the measurement system, you can control certain
optical functions:
Controlling the Hardware, refer to SECTION 4.1
Automatically Focusing the Laser Beam, refer to

SECTION

4.2

Image Settings of the Live Video Image, refer to SECTION 4.3. When doing so,
you adjust contrast, brightness and color of the video image.
Performing 2D Alignment, refer to SECTION 4.4. When doing so, the positions
on the live video image have to be aligned with the position of the laser beam
on the measurement plane.
Performing 3D Alignment, refer to SECTION 4.5. When doing so, the position
and alignment of the scanning head (PSV / MSA) or scanning heads (PSV-3D)
are determined in the coordinate system of the object.
You will find further information for a successful 3D alignment in

SECTION

4.6.

4.1 Controlling the Hardware
You can control certain functions of the hardware as described in
SECTION 4.1.1 and SECTION 4.1.2.
For the PSV-400, PSV-300 and the PSV-400-3D, you can use the software to
control all the optics and the optional pan-tilt stage.
For the MSA-500, MSA-400 or MSV-400 with the sensor head OFV-551 / -552,
you can use the software to position the laser beam and also remotely control
the beam shutter and the optional dimmer on the sensor head. You set the
other functions using the hardware. See your hardware manual on this.
For the MSV- / MMA-300 with the sensor head OFV-511 / -512 you can only
position the laser beam with the software. You set the other functions using
the hardware. See your hardware manual on this.
For the PSV-200 you can only use the software to focus and position the laser
beam. You control the video camera and the optional pan-tilt stage with the
video box. See your PSV-200 manual on this.

)

You can remotely control the connected vibrometer controller. To do so,
proceed as described in SECTION 6.2.8 or use the range changer in the
status bar.
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4.1.1 Controlling the Optics with the Software
To control the optics with the software, proceed as follows:
1. Go into acquisition mode. To do so, click

or select View > Acquisition.

2. If you do not see the scanning head control in the application window,
then click

to display it. You can also select View > Scanning Head.

3. Only scanning head MSV, MSA-I-500 and MSA-I-400: From the list Lens,
select the magnification which your microscope is set at.

)

If you can not see the list Lens in the scanning head control, then first of
all set up the software for your measurement system. See CHAPTER 3 on
this.

4. If necessary, maximize the video window. To do so, in the title bar of the
video window on the right, click .
5. If necessary, adjust the image settings of the live video image. See
SECTION 4.3 on this.
6. Using the icons in the scanning head control, you can now work as
described in the following.
Focus the laser
beam

Focus the laser beam with the icons
(close-up) and
(infinity). With the PSV-400 you can also focus the laser
beam automatically with the icon
. You will find more
information on this in SECTION 4.2. Above the icons you will
see the optical signal level shown as a bar. This makes
manual focusing easier. The LED OVER shows when the
set measurement range is exceeded. In this case it lights
up red. If it lights up permanently, then you have to select
the next highest measurement range.

Switch the laser
beam on or off
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If you are using junction box PSV-E-401, PSV-E-400,
PSV-E-401-3D or PSV-E-400-3D, you will see the box
Laser for every scanning head. Click the boxes to switch
the respective laser on or off.
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If you are using a scanning head with geometry scan unit
and switch to the geometry laser, then the box Laser for
the scanning head Top is not active. In this case it is not
the optical signal level of the vibrometer controller that is
shown, but the signal level of the geometry scan unit. If the
geometry scan unit receives too much light, the LED OVER
lights up red. You can switch on a filter to weaken the
intensity of the laser. To do so, mark the box Filter (refer
also to SECTION 5.5). If there is not enough light available,
the signal level display disappears. This means you can
tell whether your measurements will provide an acceptable
result. To display the signal level, the geometry scan unit
has to continuously determine the lighting conditions. This
is why the laser beam blinks approx. every 2 seconds.
If an additional vibrometer controller is connected and
active, then another field is shown in the scanning head
control. As this vibrometer controller is not connected up to
the system via the junction box, you can not switch the
laser beam on and off here. However, the display for signal
level, overrun of the measurement range as well as
focusing the laser beam are available to you as described
above.
Dim the laser
beam (as an
option)

If you are using the junction box MSA-E-500 with the
scanning head MSA-I-500 or the junction box MSV-E-40x
with the scanning head MSA-I-400, you can control the
beam shutter and use it to switch the laser on and off. To
do so, click the box Laser. You can also switch the laser
beam on or off directly by pressing the key LASER on the
sensor head. See the manual of the sensor head on this as
well. Apart from that, in the scanning head control, the
slider Laser Dimmer is shown as an option. By moving this
slider with the mouse in the direction Max. you can reduce
the light intensity of the laser beam.

Focus the MSA
laser beam (as an
option only for
MSA-500)

If you are using the junction box MSA-E-500 with the
scanning head MSA-I-500 and the option MSAGeo, you
can focus the laser beam. You focus the laser beam
manually with the icons
(close-up) and
(infinity).
Thereby the z-axis is moved upwards or downwards. You
can move the z-axis directly to the zero position. To do so,
click
. Then the z-axis is moved to the middle of the
traversing range. Furthermore, you can also focus the
laser beam automatically with the icon
. Thereby the zaxis is moved automatically and stopped at the position at
which the signal level is at maximum. Below the icon you
will find the position D of the z-axis (0 ... 250 µm). Read the
section above under Dim the laser beam to know how to
switch the laser beam on / off or dim the laser beam.
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Show channels

Here you can watch the modulation of the active channels
(Vib, Ref), for example as soon as you have started a
continuous measurement. You can use the slider
Generator to directly change the magnitude of the
generator signal. Apart from that, you can modulate
individual channels automatically by clicking
for the
corresponding channel. This optimizes the input range of
the data acquisition board or the sensitivity range of the
vibrometer controller respectively. You can modulate all
channels together automatically by clicking
while
holding the shift key pressed.
If you are using the PSV-400-3D, the channel is shown
separately for each scanning head (Vib Top, Vib Left, Vib
Right). The modulation is displayed before transformation
of coordinates. This is why you can check the cabling with
the aid of this display. If the signal from one of the scanning
heads is missing, then the display for this channel will be at
zero at the start of the measurement.

Position the laser
beam

You move the laser beam with the icons Position. To do so,

Zoom the video
camera

You zoom the video camera with the slider Zoom. Using
the mouse you can roughly set the slider. If the slider is
active, you can fine-tune it with the arrow keys ↑ and ↓. (To
activate the slider, click it.)

Focus the video
camera

You focus the video camera with the slider Focus. Using
the mouse you can roughly set the slider. If the slider is
active, you can fine-tune it with the arrow keys ↑ and ↓. (To
activate the slider, click it.)
You can also focus automatically. To do so, click
Autofocus. Automatic focusing can take several seconds
during which the software is inactive.

Pan-tilt stage (as
an option)

You control the motorized pan-tilt stage with the icons PanTilt. If you can not see the icons in the scanning head
control, then first of all activate the pan-tilt stage for the
software. See SECTION 3.3 on this. To pan the scanning

click the icon for the direction required. If you click
, the
laser beam is positioned in such a way that it is emitted at
a right angle to the front panel of the scanning head
(position 0; 0).
Under the icons you will see the position of the laser beam
in degrees related to the horizontal and vertical axis. With
the MSA / MSV system, the position is shown as a
percentage of the mirror deflection. At 100% the laser
beam is right over on the right /at the top.

head, click
.
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or

. To tilt the scanning head, click

or
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Set the zoom
factor for the
microscope

If you are using the scanning head MSA-I-500, MSA-I-400
or MSV, here you select the zoom factor set on the
microscope. The software uses the zoom factor set and the
position of the scan points on the video image to calculate
the coordinates of the scan points.

Enter coordinates
of axes

The element 2D Point is displayed if there is 2D geometry.
Right at the top, the Index of the selected scan point is
shown, below that its Status (refer to SECTION 7.3 as well).
Enter the distance between the scanning head and the
measurement object in the empty field and press Enter.
The one of the three axes for which you can define the
distance depends on the direction of the vibrometer
channel in the dialog Acquisition Settings (refer
toSECTION 6.2.2). The figures next to this apply to the
direction + Z.
As the axis which shows the distance of the measurement
object from the scanning head is in the opposite direction
to the laser beam, the coordinate for the object always has
the inverse sign. If you enter the distance between the
measurement object and the scanning head as zcoordinate, the software calculates the x- and ycoordinates of the respective scan point under the
assumption that the object is flat and is positioned
vertically to the 0° direction of the laser beam. The zcoordinate is thus the same for every scan point. The
origin of the coordinate system is the point at which the
laser beam is emitted in 0° direction from the front of the
scanning head.

y
z

x
P o in t o f o r ig in
B e a m

)

3D Point

The coordinate which shows the distance of the object
from the scanning head is used as a preset for the object
distance when exporting the geometry in Universal File
format and ME’Scope format.
For measurements with the close-up unit PSV-A-410 or
OFV-056-C, you have to add 41 millimeters to the stand-off
distance. This corresponds to the optical path length inside
the close-up unit (refer also to SECTION 10.2.3 and
SECTION 10.2.4).
The element 3D Point is displayed if there is 3D geometry.
Right at the top, the Index of the selected scan point is
displayed. Below that, the coordinates (X, Y, Z) of the scan
point are displayed. The coordinate system used here is
the one which you determined with the 3D alignment (refer
to SECTION 4.5).
The software calculates the distance D, i.e. the distance
between the selected scan point and the point at which the
laser beam in 0° direction intersects the plane of the front
of the scanning head. For the PSV-3D, the distance to the
scanning head Top is always given.
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4.1.2 Controlling the Optics with the PSV-A-PDA
To control the optics with the optional PDA, start the PDA as described in
SECTION 2.9.1. The user interface of the PDA software appears.

Figure 4.1: User interface of the PDA software

Position the
laser beam

Move the laser beam with the icons

,

,

and

. To do so, touch the

icon for the direction required. If you touch
, the laser beam is positioned in
such a way that it is emitted at a right angle to the front of the scanning head
(position 0; 0).

)

You can also use the 5-Way Navigation button on the PDA to position the
laser beam. To do so, press the button for the corresponding direction.

Focus the laser
beam manually
(PSV-1D)

Focus the laser beam manually with the icons
(close-up) and
(infinity). Below the icons you will see the optical signal level shown as a bar.
This makes manual focusing easier. The signal level displayed is identical to
that in the software and on the scanning head. The LED next to the icons
shows when the set measurement range is exceeded. In this case it lights up
red. If it lights up permanently, then you have to select the next highest
measurement range.

Focus the laser
beam
automatically

With the PSV-400 you can also focus the laser beam automatically with the

Switch the laser
on and off

You can switch the laser on or off in the scanning head by ticking or
deactivating the box Laser.
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icon

. See

SECTION

4.2 on this.
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4.2 Automatically Focusing the Laser Beam
With the PSV-400 you can automatically focus the laser beam. There are two
ways to do so:
•
•

Focusing with the Software, refer to SECTION 4.2.1
Focusing with the PDA (as an Option), refer to SECTION 4.2.2

4.2.1 Focusing with the Software
PSV

To automatically focus the laser beam with the software, click
scanning head control.

)
PSV-3D

in the

Automatic focusing can take several seconds during which the software is
inactive.

If you are making a measurement with the PSV-3D, hold the shift key pressed
while clicking
time.

. This allows all three laser beams to be focused at the same

4.2.2 Focusing with the PSV-A-PDA (as an Option)
PSV

Automatically focus the laser beam with the PDA by touching the icon

)
PSV-3D

.

Automatic focusing can take several seconds during which the software is
inactive.

If you are making a measurement with the PSV-3D, you can select the
scanning heads and focus them individually automatically.

4.3 Image Settings of the Live Video Image (2D View)
You adjust the image settings of the live video image in the dialog Display
Properties on the pages:
•
•

General, refer to SECTION 4.3.1 and
Video, refer to SECTION 4.3.2.

To open the dialog, double-click the live video image. You can also click the
live video image with the right mouse button and then select Video Properties
in the context menu.
You can also activate the video window (to do so, click it) and then select
Scan > Properties. Then display the appropriate page.

)

Depending on the type of measurement and the geometry, not all settings
options are shown in the dialog.
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4.3.1 General
On the page General, you set up the view of the video window on the screen.

Figure 4.2: Page General

Title

Show: If you would like to display a title above the video window, tick the box.
You enter the title on the right.
Font: Click here to format the title. The dialog Font appears.

Background

4-8

Here you select the background color for the video window.
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4.3.2 Video
On the page Video you adjust the camera settings.

Figure 4.3: Page Video

Monochrome: Here you can change color images to black and white.This is
recommended for measurements with the optional close-up unit PSV-A-410
or OFV-056-C, as it is equipped with a red filter.
Contrast: Here you set the contrast of the live video image.
Brightness: Here you set the brightness of the live video image.
Saturation: For color images you set the color saturation here (not for MSA /
MSV systems).
Illumination: This slider only appears for MSA / MSV systems. If you want to
use the strobe illumination in MSA / MSV operation to illuminate the sample,
you can adjust its brightness here. See your hardware manual on this as well.
Graphics Transparency: Here you adjust the transparency of all inserted
graphic elements (e.g. scan points, alignment points, crosshair, signal level).

)

Maybe, this function is not available to you depending on the configuration
of your system.

Defaults: Click here to load the default settings for the live video image.
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4.4 Performing 2D Alignment
To define scan points on the live video image and to move the laser beam
using the mouse, you have to align the positions on the live video image with
the position of the laser on the measurement plane. As you are aligning twodimensional coordinate systems, you have to align at least two points with
different horizontal and vertical coordinates.

)

You have to perform this 2D alignment in any case.

How?

You can perform 2D alignment with the software as described in the following
sections. However you can also use the optional PDA to help you.

When?

You have to realign when you
•
•

Tips

The following tips make it easier to align:
•
•

•
•

)

PSV-3D

are working at a different stand-off distance or
have zoomed the video camera.

The more points you align, the more precisely the software positions the
laser beam.
Distribute the alignment points evenly over the whole measurement
surface. If, for example, you want to scan a rectangular surface, it would
make sense to choose four alignment points near the corners.
Align those points which you want to position precisely when scanning.
To increase the precision, you can zoom in on image sections. Read
SECTION 2.6.8 on this.
If you want to import geometry data in point mode, you also have to
perform a 2D and 3D alignment first. You will find detailed information on
geometry import in SECTION 5.2.7.

If you are using the PSV-3D, then you are making a measurement with three
independent scanning heads. So you have to perform a 2D alignment for
every individual scanning head first as described in the following.
After that, you have to perform a 3D alignment to position the three laser
beams on one geometry point and have to transmit the vibration data into the
coordinate system of the object under investigation. 3D alignment is
described in SECTION 4.5.

)
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A 3D alignment without previous 2D alignment is possible. To make a
measurement however, you will need both.
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Start 2D
alignment

To perform 2D alignment, proceed as follows:
1. Click
or select Setup > 2D Alignment. The software maximizes the
video window and displays the scanning head control.
2. If necessary, delete all existing alignment points first. To do so, click the
video image with the right mouse button (not an alignment point) and
select Delete All in the context menu.
3. Click the video image with the right mouse button and deactivate Auto
Align in the context menu.

Position the
laser beam

4. Move the laser beam with the icons Position in the scanning head control
to an alignment point on the object, refer also to SECTION 4.1.1.
With a bit of practice, you can position the laser beam more quickly for
alignment by using the mouse to move it to approximately the right place
first. If necessary, you can then use the scanning head control for finetuning as described above. Hold the middle mouse button (mouse wheel)
pressed and drag across the video image with it. The laser beam follows
the mouse cursor, although not very precisely yet, as 2D alignment has
not yet been performed.

)

If you have allocated a special function to the middle mouse button (e.g.
double-click), then this method of alignment is not available.
To set the alignment points in detail on the object, you can use the
optional PDA. To do so, start the PDA as described in SECTION 2.9. The
user interface of the PDA software appears. The icon
tells you that you are in 2D alignment.

in the menu bar

Figure 4.4: User interface of the PDA software
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Center the laser beam by touching the icon
with the stylus and
position the laser beam by touching the corresponding icon for the
direction
,
,
and
. If you touch an arrow icon for more than
approx. one second, the PDA switches to fast forward. For fine
adjustment you can always briefly touch the icon again.

)
Define
alignment
points

You can also use the 5-Way Navigation button on the PDA to position the
laser beam. To do so, press the button for the corresponding direction.

5. In the live video image, point the mouse precisely at the laser beam and
click. You can now see a target there.
If you are using the optional PDA, define an alignment point by touching
the icon
. You can also use the central Enter key on the PDA. The
software searches for the laser beam in the video image and defines an
alignment point at this position. If the software does not find the laser
beam in the video image, defining the alignment point fails and a
corresponding message appears on the PDA.

)

Please make sure that you yourself are not caught by the video camera,
as your movement can interfere with the recognition of the laser beam.

6. If the laser beam is not precisely in the middle of the target, repeat step 5.
7. Repeat steps 4 to 6 for at least one other alignment point.
8. Once you have aligned all points, click
Alignment.

4-12
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Check
alignment
points

If you are using the optional PDA, you can check the defined alignment points
with the laser beam by toggling the points on the object. To do so, select View
> Toggle Points in the menu bar of the PDA.

Figure 4.5: Toggle alignment points

Then touch the icon
or
. The laser will toggle backwards or forwards
towards the defined alignment points.
Delete
alignment
points

To delete an individual alignment point, click it with the right mouse button and
select Delete in the context menu.

)

If you are using the optional PDA, then you can delete an alignment point
by positioning the laser beam on the alignment point and then touching
the icon
. The software searches for the laser beam in the video image
and deletes the alignment point at this position. If the software does not
find the laser beam in the video image, deleting the alignment point fails
and a corresponding message appears on the PDA. Please make sure
that you yourself are not caught by the video camera, as your movement
can interfere with the recognition of the laser beam.

To delete all the alignment points for one scanning head, click the video
image with the right mouse button and select Delete All in the context menu.
Special features
for PSV-3D

If you are performing 2D alignment with the PSV-3D, please also pay
attention to the following points:

)

Before starting with the 2D alignment, you have to enter the correct angle
of the scanning heads to the video camera in the dialog Setup >
Preferences on the page Scanning Head (refer to SECTION 3.3 under
Arrangement of scanning heads for the PSV-3D).
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1. For the PSV-3D define at least four alignment points for each scanning
head. When doing so, the following applies:
•

In the case of simple level surfaces, it is often already enough to use
four to six alignment points to get good results.

•

The larger the surface, the greater the deviations, particularly in the
areas close to the edge.

•

If the results of the alignment are not satisfactory (see below in section
Check alignment, step 3), then define at least ten alignment points per
scanning head.

2. To select the individual scanning heads, use the list in the scanning head
control or click the video image with the right mouse button and select one
of the scanning heads (Top, Left or Right) in the context menu.

)

When you select a new scanning head for alignment, the alignment points
of the other scanning heads which have already been defined are saved.
If you are using the optional PDA, select one of the three scanning heads
by touching the corresponding icon
.

Figure 4.6: User interface of the PDA software for the PSV-3D

3. Once you have defined all alignment points for one scanning head, then
select the other two scanning heads one after the other as described in
step 2 and define the alignment points for these scanning heads in the
same way.

)
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If you want to define scan points in the scan point definition, it is
necessary for the laser beam and the point clicked on the screen to match
as precisely as possible. If you import or teach-in the scan points as a
Universal File, then an approximate match is good enough.
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Align with Auto
Align

You can perform an automatic 2D alignment. To do so, proceed as follows:

)

Before starting with 2D alignment on the PSV-3D, you have to enter the
correct angle of the scanning heads to the video camera in the dialog
Setup > Preferences on the page Scanning Head (refer to SECTION 3.3
under Arrangement of scanning heads for the PSV-3D).

1. Click
or select Setup > 2D Alignment. The software maximizes the
video window and displays the scanning head control.
2. If necessary, delete all existing alignment points first. To do so, click the
video image with the right mouse button (not an alignment point) and
select Delete All in the context menu.
3. Click the video image with the right mouse button and select Auto Align in
the context menu.
4. In the video image, click the point on the object at which you want to
define the alignment point. The software will automatically position the
laser beam there and define an alignment point.

)

This function is not available for the MSA / MSV.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
2D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment

Now test the 2D alignment as follows:
1. If the scan points are shown in the live video image, click
them.

to hide

2. Point at the live video image and click a point on the measurement plane.
The laser beam moves to this point on the object.
3. Check if the position of the laser beam corresponds to that of the point
clicked. If this is not the case, repeat the 2D alignment.

)

The live video image shows a two-dimensional image of the threedimensional object. For this reason, the laser beam does not precisely hit
points which are not on the measurement plane.

4. Repeat steps 2 and 3 for a few more alignment points.
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4.5 Performing 3D Alignment
3D alignment is always necessary if you want to use 3D geometries. The
3D alignment determines the position and alignment of the scanning head
(PSV / MSA) or scanning heads (PSV-3D) in the coordinate system of the
object.

)

For the PSV-3D it is imperative that you perform 3D alignment.

)

With the micro scanning lenses PSV-A-CL80, PSV-A-CL150 and
PSV-A-CL300 it is not possible to perform 3D alignment ! The close-up
unit without micro-scanning lenses does not affect 3D alignment.

For 3D alignment you need points on the measurement object for which the
coordinate description is known in a cartesian coordinate system. You have to
hit these points with the laser. The software will then calculate the 3D
alignment.
In the following section you will find information on:
•
•
•

Performing 3D alignment for different systems, refer to SECTION 4.5.1
Supporting 3D alignment with the PSV-A-PDA, refer to SECTION 4.5.6
Information for a successful 3D alignment, refer to SECTION 4.6

4.5.1 Performing 3D Alignment for Different Systems
PSV

For the PSV you have the following options for performing 3D alignment.
PSV
Scanning head without geometry scan unit Scanning head with geometry scan unit
Go to SECTION 4.5.3.
Go to SECTION 4.5.2.

PSV-3D

For the PSV-3D you have the following options for performing 3D alignment.
PSV-3D
With geometry scan unit
Go to SECTION 4.5.5.

Without geometry scan unit
Go to SECTION 4.5.4.

MSA-500

For the MSA-500 you have the following options for performing 3D alignment.
To do this, you need the option MSAGeo.
MSA-500
3D alignment for the scanning head system
Go to SECTION 4.5.7.

)
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3D alignment for the object system
Go to SECTION 4.5.8.

Before you perform a 3D alignment, ensure that you have set the correct
magnification in the list Lens in the scanning head control. The software
uses the zoom factor set to calculate the position of the laser on the
measurement object.
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4.5.2 3D Alignment for the PSV without Geometry Scan Unit
If you are using a scanning head without geometry scan unit, for 3D alignment
you proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

Open dialog

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click

or select Setup > Dialog 3D Alignment.

You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

)

If your PSV is equipped with a scanning head with geometry scan unit, for
this 3D alignment deactivate the box Auto next to Assign Coordinates to
Point. If you want to use the geometry scan unit, read SECTION 4.5.3.

Figure 4.7: Dialog 3D Alignment for the PSV without geometry scan unit

Select the unit

3. Select the unit for the coordinates (m or mm).

Position the
laser beam

4. Now you can move the laser beam using the icons Position in the
scanning head control.
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Alternatively you can also use the mouse directly. Using the middle mouse
button (mouse wheel), click in the video image. This will make the laser
beam jump to your mouse cursor. To position the beam, hold the middle
mouse button pressed and drag with the mouse until the laser beam is
positioned on the required point on the object.

)

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in scanning
head control.
To increase the accuracy when hitting the required point, zoom the video
image. See SECTION 2.6.8 on this.

Define
alignment
points

5. Once you have found the precise position of the required point on the
object, in the dialog 3D Alignment select
Set New Alignment Point at
Laser Spot / Assign Laser Spot to Point. Now in the video image, click the
point which the laser beam is currently at. An alignment point will now be
defined there. The alignment point is marked using a black circle

.

6. Define four to seven alignment points in this way. You will find information
on appropriate arrangement of the alignment points in SECTION 4.6.
Delete
alignment
points

To delete an alignment point, click it in the video image with the right mouse
button and select Delete in the context menu.
To delete all the alignment points, click the video image with the right mouse
button and select Delete All in the context menu.

Set the
coordinates

7. Enter the coordinates for every alignment point.
If you enter the coordinates manually, click Add. The dialog Add
Coordinates appears.

Figure 4.8: Dialog Add Coordinates

Enter the values in the fields X, Y and Z and click Add. Once you have
entered coordinates for all the alignment points, click Close or press the
Escape key to leave the dialog.
If you want to import the coordinates e.g. from an external program, then
click Import. Then enter the file which you want to import the values from.

)
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When you import, all coordinate lines that already exist in the dialog 3D
Alignment will be deleted !
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)

If you are importing geometry from a file in ASCII format or a file in
Universal File format which does not contain data set 164 with the units of
the coordinates, you have to enter a scaling factor in the dialog 3D
Alignment (refer to FIGURE 4.9). The factor 1 stands for the unit 1 m, the
factor 0.01 for the unit 1 cm etc.

Figure 4.9: Dialog Scaling of Imported Coordinates

Delete
If the table contains too many coordinate lines, you can delete individual lines.
coordinate lines To do so, mark one or more lines and click Delete. Or mark the coordinate
lines you want to keep, click Invert Selection and then Delete. This way you
will delete all the undesired lines at once.
If you want to delete all coordinate lines at once, click Delete All.

)

Assign
coordinates

If alignment points on the video image are already linked with the
coordinates in the table, then the coordinates assigned to the points are
deleted, the alignment points themselves however remain.

8. Then in the dialog 3D Alignment, select

Assign Coordinates to Point.

9. In the dialog 3D Alignment, mark the first coordinate line in the table and
click the associated alignment point in the video image. A tick will appear
in each of the columns xyz and Laser. These show that the coordinates of
this line are now assigned to an alignment point. The circle in the video
image is now shown in bold
line.

and the marker in the table moves on one

10. Now, in the table, assign coordinates to each alignment point.

)

Every alignment point must have a coordinate line assigned to it here.
However, there can be coordinate lines which are not assigned to an
alignment point.
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Use mirror

If you make the measurement with the aid of a mirror, e.g. to scan a side of
the object under investigation which you can not reach directly with the laser
beam, you have to perform the 2D and 3D alignment on the mirror image.
Apart from that, in the dialog 3D Alignment mark the box Mirror.

)

Please note that for a scan, the scanning head can only be aligned either
to the mirror image or directly on the object. However, you can carry out
two scans with and without the mirror and then combine them (refer to
SECTION 8.5). To do so, you will need an individual 3D alignment for each
scan.

Specify quality

11. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 1 mm).

Calculate the
alignment

Once you have defined the alignment points and have assigned coordinates
to them, you can calculate the alignment.
12. Click Calculate. The software will now calculate the alignment. The
current quality of this alignment is shown in the dialog. If the 3D alignment
is successful, then the LED Status will turn green. If the LED lights up red,
then the alignment is not valid.

)
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If the value for the current quality exceeds the value for the target quality,
then a message will appear. The LED Status will turn yellow. Despite this,
you can use the 3D alignment.
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You can check the quality for the individual alignment points. The
alignment points for which the quality value for the respective scanning
head is lower than the value in the field Target Quality will have a tick in
the column Quality.

Figure 4.10: Successful 3D alignment for the PSV without geometry scan unit

)
Reassign the
laser position

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also reassign new laser positions to existing alignment points to
increase the quality of the measurement results. To do so, in the dialog 3D
Alignment select
Set New Alignment Point at Laser Spot / Assign Laser
Spot to Point. Then move the relevant laser beam to the point on the object
and click the alignment point in the video image with the left mouse button.
The new laser position is used to calculate the alignment again.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
3D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment
points

You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.
13. To do so, in the dialog 3D Alignment, select

Select and Check Point.

4-21

4 Setting the Optics

14. Then click an alignment point in the video image. The corresponding line
in the table is marked.
Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

If a valid 3D alignment is available, then the laser beam is moved to the
position calculated from the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beam hits the points on the object, the higher
the quality of the alignment.

Clear
assignment

If you have already assigned coordinates to an alignment point, delete the
respective table line in the dialog 3D Alignment. The assignment of the
alignment point to the coordinates is removed.

Add offset

Once you have calculated the 3D alignment, you can add an offset to the
coordinates. To do so, click Offset. The dialog Add Offset appears. Enter the
required offset and click OK. The offset is added to all coordinates and the
alignment is calculated again.

End alignment

15. Click

to leave the dialog 3D Alignment.

4.5.3 3D Alignment for the PSV with Geometry Scan Unit (as an Option)
The optional geometry scan unit will make it easier for you to perform 3D
alignment. If you are using a scanning head with geometry scan unit, for 3D
alignment you proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

Open dialog

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click
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or select Setup > Dialog 3D Alignment.
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You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

Figure 4.11: Dialog 3D Alignment for the PSV with geometry scan unit

Activate
geometry scan
unit

3. Mark the box Auto next to Assign Coordinates to Point to use the
geometry scan unit for 3D alignment.

Select the unit

4. Select the unit for the coordinates (m or mm).

Position the
laser beam

5. Now you can move the laser beam using the icons Position in the
scanning head control.
Alternatively you can also use the mouse directly. Using the middle mouse
button (mouse wheel), click in the video image. This will make the laser
beam jump to your mouse cursor. To position the beam, hold the middle
mouse button pressed and drag with the mouse until the laser beam is
positioned on the required point on the object.

)

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in the
scanning head control.
To increase the accuracy when hitting the required point, zoom the video
image. See SECTION 2.6.8 on this.
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Define
alignment
points

6. Once you have found the precise position of the required point on the
object, in the dialog 3D Alignment select
Set New Alignment Point at
Laser Spot / Assign Laser Spot to Point. Now in the video image, click the
point which the laser beam is currently at. An alignment point will now be
defined there. The alignment point is marked with a black circle
and a
line is added to the dialog 3D Alignment which is automatically assigned
to the alignment point. In the column Distance the distance measured to
this alignment point is entered. In the column Laser it shows that the point
has been defined.

)

When defining every alignment point, the software automatically switches
over to the geometry laser and carries out a distance measurement to the
alignment point. When defining the alignment points, you can save time
by activating the geometry laser first to avoid having to switch over. To do
so, select Scan > Geometry Laser.

7. Define three to twenty alignment points in this way. You will find
information on appropriate arrangement of the alignment points in
SECTION 4.6.
Delete
alignment
points

To delete an alignment point, click it in the video image with the right mouse
button and select Delete in the context menu. You can also mark the
corresponding line of the table in the dialog 3D Alignment and click Delete.
To delete all the alignment points, click the video image with the right mouse
button and select Delete All in the context menu.

Define and
assign
coordinates

You have the following options to define the object coordinate system (object
system):
•
•

•

Points with Free Coordinates: You mark at least three points and enter all
the coordinates of these points.
Origin, Axis, Plane: You mark the origin, any point of your choice along the
positive x-, y- or z-axis and any point in the positive half plane limited by
the selected axis (e.g. 0, + x, x / + y).
Three Points on Axes: You each mark any point on the positive x-, y- and
z-axis.

In the following the option Points with Free Coordinates is described in detail.
Both the other options will be explained to you briefly at the end of this
section.
8. Select Points with Free Coordinates from the list Coordinate Definition
Mode.
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9. Click the alignment point with the right mouse button and select Point with
Free Coordinates in the context menu. The dialog Assign Coordinates
appears.

Figure 4.12: Dialog Assign Coordinates

10. Here you enter the coordinates of the alignment point and click OK. XYZ
will appear next to the point.
11. Repeat steps 9 and 10 until you have assigned coordinates to at least
three alignment points.

)

Use mirror

If you have defined more than three alignment points, then you do not
have to assign coordinates to all the alignment points. However, only
alignment points which have had coordinates assigned to them will be
used to calculate the 3D alignment. For further information please read
SECTION 4.6.

If you make the measurement with the aid of a mirror, e.g. to scan a side of
the object under investigation which you can not reach directly with the laser
beam, you have to perform the 2D and 3D alignment on the mirror image.
Apart from that, in the dialog 3D Alignment mark the box Mirror.

)

Please note that for a scan, the scanning head can only be aligned either
to the mirror image or directly on the object. However, you can carry out
two scans with and without the mirror and then combine them (refer to
SECTION 8.5). To do so, you will need an individual 3D alignment for each
scan.

Specify quality

12. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 1 mm).

Calculate the
alignment

Once you have defined the alignment points and have assigned coordinates
to them, you can calculate the alignment.
13. Click Calculate. The software will now calculate the alignment. The
current quality of this alignment is shown in the dialog. If the 3D alignment
is successful, then the LED Status will turn green. If the LED lights up red,
then the alignment is not valid.

)

If the value for the current quality exceeds the value for the target quality,
then a message will appear. The LED Status will turn yellow. Despite this,
you can use the 3D alignment.
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You can check the quality for the individual alignment points. The
alignment points for which the quality value for the respective scanning
head is lower than the value in the field Target Quality will have a tick in
the column Quality.

Figure 4.13: Successful 3D alignment for the PSV with geometry scan unit

)
Reassign the
laser position

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also reassign new laser positions to existing alignment points to
increase the quality of the measurement results. To do so, in the dialog 3D
Alignment select
Set New Alignment Point at Laser Spot / Assign Laser
Spot to Point. Then move the relevant laser beam to the point on the object
and click the alignment point in the video image with the left mouse button.
The software will carry out a new distance measurement to the alignment
point. The new laser position and distance are used to recalculate the
alignment.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
3D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment
points
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You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.
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14. To do so, in the dialog 3D Alignment, select

Select and Check Point.

15. Then click an alignment point in the video image. The corresponding line
in the table is marked.
Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

Add offset

If a valid 3D alignment is available, then the laser beam is moved to the
position calculated from the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beam hits the points on the object, the higher
the quality of the alignment.

Once you have calculated the 3D alignment, you can add an offset to the
coordinates. To do so, click Offset. The dialog Add Offset appears. Enter the
required offset and click OK. The offset is added to all coordinates and the
alignment is calculated again.

)

If you have selected a different coordinate definition mode than Points
with Free Coordinates, then when an offset is added, the software will
automatically switch into the mode Points with Free Coordinates.

End alignment

16. Click

to leave the dialog 3D Alignment.

Alternative
coordinate
definition

Origin, Axis, Plane
To define the object coordinate system this way, replace steps 8 to 11 in
section Define and assign coordinates with the following:
1. Select Origin, Axis, Plane from the list Coordinate Definition Mode.
2. With the right mouse button, click the alignment point which you want to
define as origin and select Origin in the context menu. Next to the
alignment point a 0 will appear. The coordinates of the origin (0 / 0 / 0) will
be displayed in the dialog 3D Alignment.
3. With the right mouse button, click the alignment point which you want to
define on the x-axis for example and select Point on + x-axis in the context
menu. An + x will appear next to the point; an arrow will be drawn through
the point. The distance and the coordinates (+ x / 0 / 0) of the point are
shown in the dialog 3D Alignment.
4. With the right mouse button, click the alignment point which you want to
define in a half-plane and select for example Point on x / + y plane in the
context menu. An x / + y will appear next to the point. The distance and the
coordinates (x /+ y / 0) of the point are shown in the dialog 3D Alignment.
5. Now continue with the 3D alignment as described from step 12 onwards
further up.

)

In this coordinate definition mode, entering the target quality must also be
carried out. The current quality determined is always 0. If you have
defined more than three alignment points, then the surplus alignment
points are not used for calculating the 3D alignment.
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Three Points on Axes
To define the object coordinate system this way, replace steps 8 to 11 in
section Define and assign coordinates with the following:
1. Select Three Points on Axes from the list Coordinate Definition Mode.
2. Use the right mouse button to click the alignment point which the x-axis of
the coordinate system is to run through and select Point on + x-axis in the
context menu. An + x will appear next to the point; an arrow will be drawn
through the point.
3. Repeat step 2 for one more alignment point each on the y- and z-axis.
4. Now continue with the 3D alignment as described from step 12 onwards
further up.

)

In this coordinate definition mode, entering the target quality must also be
carried out. The current quality determined is always 0. If you have
defined more than three alignment points, then the surplus alignment
points are not used for calculating the 3D alignment.

4.5.4 3D alignment for the PSV-3D without Activated Geometry Scan Unit

)

If you are using the PSV-3D in 1D mode, you only have to perform the 3D
alignment for the scanning heads which are not marked as reference.

If you are using your PSV-3D without activated geometry scan unit, for 3D
alignment you proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

Open dialog

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click

or select Setup > Dialog 3D Alignment.

You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

)
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Deactivate the box Auto next to Assign Coordinates to Point. If you want
to use the geometry scan unit, read SECTION 4.5.5.
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Figure 4.14: Dialog 3D Alignment for the PSV-3D without activated geometry scan unit

Select the unit

3. Select the unit for the coordinates (m or mm).

Select scanning
head

4. In the scanning head control, select a scanning head, or with the right
mouse button, click the video image and select one of the scanning heads
(Top, Left or Right) in the context menu.

Position the
laser beam

5. Now you can move the laser beam using the icons Position in the
scanning head control.
Alternatively you can also use the mouse directly. Using the middle mouse
button (mouse wheel), click in the video image. This will make the laser
beam jump to your mouse cursor. To position the beam, hold the middle
mouse button pressed and drag with the mouse until the laser beam is
positioned on the required point on the object.

)

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in the
scanning head control.
To increase the accuracy when hitting the required point, zoom the video
image. See SECTION 2.6.8 on this.
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Define
alignment
points

6. Once you have found the precise position of the required point on the
object, in the dialog 3D Alignment select
Set New Alignment Point at
Laser Spot / Assign Laser Spot to Point. Now in the video image, click the
point which the laser beam is currently at. An alignment point will now be
defined there.
The alignment point is marked using a black circle. This icon shows you
which scanning head you are currently aligning:
designates the left,

)

the right and

the top scanning head.

If for example, you click on the same place in the video image for the top
and the left scanning head one after the other, you will be shown
all three scanning heads

. For

will appear.

7. In this way you define four to seven alignment points for all three scanning
heads. These alignment points can be the same for all three scanning
heads, but this is not necessary. You will find information on appropriate
arrangement of the alignment points in SECTION 4.6.
Delete
alignment
points

To delete an alignment point, click it in the video image with the right mouse
button and select Delete in the context menu.
To delete all the alignment points, click the video image with the right mouse
button and select Delete All in the context menu.

Set the
coordinates

8. Enter the coordinates for every alignment point.
If you enter the coordinates manually, click Add. The dialog Add
Coordinates appears.

Figure 4.15: Dialog Add Coordinates

Enter the values in the fields X, Y and Z and click Add. Once you have
entered coordinates for all the alignment points, click Close or press the
Escape key to leave the dialog.
If you want to import the coordinates e.g. from an external program, then
click Import. Then enter the file which you want to import the values from.

)
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When you import, all coordinate lines that already exist in the dialog 3D
Alignment will be deleted !
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)

If you are importing geometry from a file in ASCII format or a file in
Universal File format which does not contain data set 164 with the units of
the coordinates, you have to enter a scaling factor in the dialog 3D
Alignment (refer to FIGURE 4.16). The factor 1 stands for the unit 1 m, the
factor 0.01 for the unit 1 cm etc.

Figure 4.16: Dialog Scaling of Imported Coordinates

Delete
If the table contains too many coordinate lines, you can delete individual lines.
coordinate lines To do so, mark one or more lines and click Delete. Or mark the coordinate
lines you want to keep, click Invert Selection and then Delete. This way you
will delete all the undesired lines at once.
If you want to delete all coordinate lines, click Delete All.

)

If alignment points on the video image are already linked with the
coordinates in the table, then the coordinates assigned to the points are
deleted, the alignment points themselves however remain.
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Assign
coordinates

9. Then in the dialog 3D Alignment, select

Assign Coordinates to Point.

10. In the dialog 3D Alignment, mark the first coordinate line in the table and
click the associated alignment point in the video image. In the column xyz
a tick will appear which shows that the coordinates in this line are now
assigned to an alignment point. The circle in the video image is now
shown in bold

)

and the marker in the table moves on one line.

If you have assigned coordinates to an alignment point, then in the dialog
3D Alignment in the table Laser you will see for which scanning head you
have already defined the respective alignment point. The three dots in the
icon
stand for the three laser beams Top, Left and Right.

11. Now, in the table, assign coordinates to each alignment point.

)

Use mirror

Every alignment point must have a coordinate line assigned to it here.
However, there can be coordinate lines which are not assigned to an
alignment point.

If you make the measurement with the aid of a mirror or several mirrors, e.g.
to scan a side of the object which you can not reach directly with the laser
beam, you have to perform 2D and the 3D alignment for the respective
scanning head on the reflection of the object. Apart from that, in the dialog 3D
Alignment, tick the corresponding box in the column Mirror.

)

Please note that for a scan, each scanning head can only be aligned
either to the mirror image or directly on the object. However, you can carry
out two scans with and without the mirror and then combine them (refer to
SECTION 8.5). To do so, you will need an individual 3D alignment for each
scan.

Specify quality

12. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 1 mm).

Calculate the
alignment

Once you have defined the alignment points for all three scanning heads and
have assigned coordinates to them, you can calculate the alignment.
13. Click Calculate. The software will now calculate the alignment for each
scanning head. The current quality of this alignment is displayed in the
dialog for every scanning head. If 3D alignment for a scanning head is
successful, then the respective LED Status will be green. If the LED lights
up red, then the alignment is not valid.

)
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If the value for the current quality exceeds the value for the target quality
for one or more scanning heads, then a message will appear. The
respective LED Status will turn yellow. Despite this, you can use the 3D
alignment.
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You can check the quality for the individual alignment points. In the
column Quality up to three green markers will be displayed for one
alignment point if the quality value for the respective scanning head falls
below the value in the field Target Quality.

Figure 4.17: Successful 3D alignment for the PSV-3D without activated geometry scan unit

)
Reassign the
laser position

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also reassign new laser positions to existing alignment points to
increase the quality of the measurement results. To do so, in the dialog 3D
Alignment select
Set New Alignment Point at Laser Spot / Assign Laser
Spot to Point. Then move the respective laser beam to the point on the object
and click the alignment point in the video image with the left mouse button.
The new laser position is used to calculate the alignment again.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
3D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment
points

You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.
14. To do so, in the dialog 3D Alignment, select

Select and Check Point.
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15. Then click an alignment point in the video image. The corresponding line
in the table is marked.
Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

If there is valid 3D alignment, then the laser beams are moved to the
positions calculated for the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beams hit the points on the object, the higher
the quality of the alignment.

Clear
assignment

If you have already assigned coordinates to an alignment point, delete the
respective table line in the dialog 3D Alignment. The assignment of the
alignment point to the coordinates is removed.

Add offset

Once you have calculated the 3D alignment, you can add an offset to the
coordinates. To do so, click Offset. The dialog Add Offset appears. Enter the
required offset and click OK. The offset is added to all coordinates and the
alignment is calculated again.

End alignment

16. Click

to leave the dialog 3D Alignment.

4.5.5 3D Alignment for the PSV-3D with Geometry Scan Unit

)

If you are using the PSV-3D in 1D mode, you only have to perform the 3D
alignment for the scanning heads which are not marked as reference.

The geometry scan unit will make it easier for you to perform 3D alignment. If
you are using the PSV-3D with geometry scan unit, for 3D alignment you
proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

Open dialog

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click
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or select Setup > Dialog 3D Alignment.
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You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

Figure 4.18: Dialog 3D Alignment for the PSV-3D with geometry scan unit

Activate
geometry scan
unit

3. Mark the box Auto next to Assign Coordinates to Point to use the
geometry scan unit for 3D alignment.

Select the unit

4. Select the unit for the coordinates (m or mm).

Select scanning
head Top

5. In the scanning head control, select the scanning head Top or click the
video image with the right mouse button and select Scanning Head Top in
the context menu.

Position the
laser beam

6. Now you can move the laser beam using the icons Position in the
scanning head control.
Alternatively you can also use the mouse directly. Using the middle mouse
button (mouse wheel), click in the video image. This will make the laser
beam jump to your mouse cursor. To position the beam, hold the middle
mouse button pressed and drag with the mouse until the laser beam is
positioned on the required point on the object.

)

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in the
scanning head control.
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To increase the accuracy when hitting the required point, zoom the video
image. See SECTION 2.6.8 on this.
Define
alignment
points

7. Once you have found the precise position of the required point on the
object, in the dialog 3D Alignment select
Set New Alignment Point at
Laser Spot / Assign Laser Spot to Point. Now in the video image, click the
point which the laser beam is currently at. An alignment point will now be
defined there. The alignment point is marked with a black circle
and a
line is added to the dialog 3D Alignment which is automatically assigned
to the alignment point. In the column Distance the distance measured to
this alignment point is entered. In the column Laser it shows that the point
has been defined.

)

When defining every alignment point, the software automatically switches
over to the geometry laser and carries out a distance measurement to the
alignment point. When defining the alignment points, you can save time
by activating the geometry laser first to avoid having to switch over. To do
so, select Scan > Geometry Laser.

8. Define three to twenty alignment points in this way. You will find
information on appropriate arrangement of the alignment points in
SECTION 4.6.
Delete
alignment
points

To delete an alignment point, click it in the video image with the right mouse
button and select Delete in the context menu. You can also mark the
corresponding line of the table in the dialog 3D Alignment and click Delete.
To delete all the alignment points, click the video image with the right mouse
button and select Delete All in the context menu.

Define and
assign
coordinates

You have the following options to define the object coordinate system (object
system):
•
•

•

Points with Free Coordinates: You mark at least three points and enter all
the coordinates of these points.
Origin, Axis, Plane: You mark the origin, any point of your choice along the
positive x-, y- or z-axis and any point in the positive half plane limited by
the selected axis (e.g. 0, + x, x / + y).
Three Points on Axes: You each mark any point on the positive x-, y- and
z-axis.

In the following the option Points with Free Coordinates is described in detail.
Both the other options will be explained to you briefly at the end of this
section.
9. Select Points with Free Coordinates from the list Coordinate Definition
Mode.

4-36

4 Setting the Optics

10. Click the alignment point with the right mouse button and select Point with
Free Coordinates in the context menu. The dialog Assign Coordinates
appears.

Figure 4.19: Dialog Assign Coordinates

11. Here you enter the coordinates of the alignment point and click OK. XYZ
will appear next to the point.
12. Repeat steps 10 and 11 until you have assigned coordinates to at least
three alignment points.

)

Use mirror

If you have defined more than three alignment points, then you do not
have to assign coordinates to all the alignment points. However, only
alignment points which have had coordinates assigned to them will be
used to calculate the 3D alignment for the scanning head Top. For further
information please read SECTION 4.6.

If you make the measurement with the aid of a mirror or several mirrors, e.g.
to scan a side of the object under investigation which you can not reach
directly with the laser beam, you have to perform the 2D and 3D alignment on
the mirror image. Apart from that, in the dialog 3D Alignment, tick the
corresponding box in the column Mirror.

)

Please note that for a scan, each scanning head can only be aligned
either to the mirror image or directly on the object. However, you can carry
out two scans with and without the mirror and then combine them (refer to
SECTION 8.5). To do so, you will need an individual 3D alignment for each
scan.

Specify quality

13. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 1 mm).

Calculate the
alignment

Once you have defined the alignment points for the scanning head Top and
have assigned coordinates to them, you can calculate the alignment for the
scanning head Top.
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14. Click Calculate. The software will now calculate the alignment only for the
scanning head Top. The current quality of this alignment is shown in the
dialog. If 3D alignment for a scanning head Top is successful, then the
corresponding LED Status will be green. If the LED lights up red, then the
alignment is not valid.

)

As you have not yet defined any alignment points for the scanning heads
Left and Right you will definitely get a message. However, if the value for
the current quality for the scanning head Top exceeds the value for the
target quality, then this will also be listed in the message. The LED Status
will turn yellow. Despite this, you can use the 3D alignment.
You can check the quality for the individual alignment points. In the
column Quality one green marker will be displayed for one alignment point
if the quality value for the scanning head Top falls below the value in the
field Target Quality.

Figure 4.20: Successful 3D alignment for the Scanning Head Top with geometry scan unit

)
Reassign the
laser position

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also reassign new laser positions to existing alignment points to
increase the quality of the measurement results. To do so, in the dialog 3D
Alignment select
Set New Alignment Point at Laser Spot / Assign Laser
Spot to Point. Then move the relevant laser beam to the point on the object
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and click the alignment point in the video image with the left mouse button.
The software will carry out a new distance measurement to the alignment
point. The new laser position and distance are used to recalculate the
alignment.
Complete
alignment

Now perform 3D alignment for the scanning heads Left and Right. You define
the coordinates of the alignment points for these scanning heads with the aid
of the scanning head Top. To do so, continue as follows:
15. Move the laser beam of the scanning head Top to the required position.

)

While doing so, it is not absolutely necessary for the point to be on the
object or respectively in the video image. Read SECTION 4.6 on this.

16. Once you have found the precise position of the required point, in the
dialog 3D Alignment select
Assign Laser Spot to Point.

Set New Alignment Point at Laser Spot /

17. Now in the video image, click the point which the laser beam is currently
at. An alignment point will now be defined there. The alignment point is
marked with a circle
and a line is added to the dialog 3D Alignment
which is automatically assigned to the alignment point.
18. Select the scanning head Left and move the laser beam to the same point
at which you positioned the laser of the scanning head Top.
19. In the video image, click the point which the laser beam is currently at. An
alignment point is now defined there for the scanning head Left. The
alignment point is now marked with the circle

.

20. Select the scanning head Right and move the laser beam to the same
point at which you positioned the lasers of the scanning heads Top and
Left.
21. In the video image, click the point which the laser beams are currently at.
An alignment point is now defined there for the scanning head Right. The
alignment point is now marked with the circle

.

22. Now define four to seven alignment points this way for the scanning heads
Left and Right which also respectively have to be defined with the
scanning head Top. You will find information on appropriate arrangement
of the alignment points in SECTION 4.6.

)

Please note that the alignment points defined in this way are not used for
calculating the 3D alignment for the scanning head Top. You have to
define these alignment points with the scanning head Top so that the
coordinates for the alignment points for scanning heads Left and Right
can be calculated.

Once you have defined the alignment points for all three scanning heads, you
can calculate the alignment for all three scanning heads.
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23. Click Calculate. The software will now calculate the alignment for each
scanning head. The current quality of this alignment is displayed in the
dialog for every scanning head. If 3D alignment for a scanning head is
successful, then the respective LED Status will be green. If the LED lights
up red, then the alignment is not valid.

)

If the value for the current quality exceeds the value for the target quality
for one or more scanning heads, then a message will appear. The
respective LED Status will turn yellow. Despite this, you can use the 3D
alignment.
You can check the quality for the individual alignment points. In the
column Quality up to three green markers will be displayed for one
alignment point if the quality value for the respective scanning head falls
below the value in the field Target Quality.

Figure 4.21: Successful 3D alignment for the PSV-3D with geometry scan unit

)

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
3D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment
points
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You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.

4 Setting the Optics

24. To do so, in the dialog 3D Alignment, select

Select and Check Point.

25. Then click an alignment point in the video image. The corresponding line
in the table is marked.
Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

Add offset

If there is valid 3D alignment, then the laser beams are moved to the
positions calculated for the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beams hit the points on the object, the higher
the quality of the alignment.

Once you have calculated the 3D alignment, you can add an offset to the
coordinates. To do so, click Offset. The dialog Add Offset appears. Enter the
required offset and click OK. The offset is added to all coordinates and the
alignment is calculated again.

)

If you have selected a different coordinate definition mode than Points
with Free Coordinates, then when an offset is added, the software will
automatically switch into the mode Points with Free Coordinates.

End alignment

26. Click

to leave the dialog 3D Alignment.

Alternative
coordinate
definition

Origin, Axis, Plane
To define the object coordinate system this way, replace steps 9 to 12 in
section Define and assign coordinates with the following:
1. Select Origin, Axis, Plane from the list Coordinate Definition Mode.
2. With the right mouse button, click the alignment point which you want to
define as origin and select Origin in the context menu. Next to the
alignment point a 0 will appear. The coordinates of the origin (0 / 0 / 0) will
be displayed in the dialog 3D Alignment.
3. With the right mouse button, click the alignment point which you want to
define on the x-axis for example and select Point on + x-axis in the context
menu. An + x will appear next to the point; an arrow will be drawn through
the point. The distance and the coordinates (+ x / 0 / 0) of the point are
shown in the dialog 3D Alignment.
4. With the right mouse button, click the alignment point which you want to
define in a half-plane and select for example Point on x / + y plane in the
context menu. An x / + y will appear next to the point. The distance and the
coordinates (x /+ y / 0) of the point are shown in the dialog 3D Alignment.

)

In this coordinate definition mode, entering the target quality must also be
carried out for the scanning head Top. The current quality determined is
always 0. The target quality will be used later on to align the scanning
heads Left and Right.

5. Now continue with the 3D alignment as described from step 14 onwards
further up.
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Three Points on Axes
To define the object coordinate system this way, replace steps 9 to 12 in
section Define and assign coordinates with the following:
1. Select Three Points on Axes from the list Coordinate Definition Mode.
2. Use the right mouse button to click the alignment point which the x-axis of
the coordinate system is to run through and select Point on + x-axis in the
context menu. An + x will appear next to the point; an arrow will be drawn
through the point.
3. Repeat step 2 for one more alignment point each on the y- and z-axis.

)

In this coordinate definition mode, entering the target quality must also be
carried out for the scanning head Top. The current quality determined is
always 0. The target quality will be used later on to align the scanning
heads Left and Right.

4. Now continue with the 3D alignment as described from step 14 onwards
further up.
4.5.6 Supporting out 3D Alignment with the PSV-A-PDA
To perform a 3D alignment with the optional PDA, you essentially proceed as
described in SECTION 4.5.2 TO SECTION 4.5.5. You can use the PDA for the
following functions:
•
•
•
•
•
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Selecting the scanning head
Positioning the laser beam
Defining alignment points
Deleting alignment points
Checking alignment points
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Start the PDA as described in
software appears. The icon
alignment.

SECTION

2.9. The user interface of the PDA

in the menu bar tells you that you are in 3D

Figure 4.22: User interface of the PDA software

Select scanning
head (PSV-3D)

If you are using the PSV-3D, you can select the scanning head with the PDA
software.

Figure 4.23: User interface of the PDA software for the PSV-3D

To select one of the three scanning heads, touch the corresponding icon
.
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Position the
laser beam

Center the laser beam by touching the icon

laser beam by touching the corresponding icon for the direction
and

)

Define
alignment
points

..
If you touch an arrow icon for more than approx. one second, the PDA
switches to fast forward. For fine adjustment you can always briefly touch
the icon again.

Please make sure that you yourself are not caught by the video camera,
as your movement can interfere with the recognition of the laser beam.

respective point on the object under investigation and touching the icon
.
The software searches for the laser beam in the video image and deletes the
alignment point at this position. If the software does not find the laser beam in
the video image, deleting the alignment point fails and a corresponding
message appears on the PDA.
Please make sure that you yourself are not caught by the video camera,
as your movement can interfere with the recognition of the laser beam.

If there is a calculated 3D alignment available, you can check the defined
alignment points with the laser beam by toggling the points on the object. To
do so, proceed as follows:
1. In the software in the dialog 3D Alignment, select
Point.

Select and Check

2. Select View > Toggle Points in the menu bar of the PDA.

Figure 4.24: Toggle alignment points

4-44

,

You can delete an alignment point by positioning the laser beam on the

)
Check
alignment
points

,

You define an alignment point by touching the icon
. The software
searches for the laser beam in the video image and defines an alignment
point at this position. If the software does not find the laser beam in the video
image, defining the alignment point fails and a corresponding message
appears on the PDA.

)
Delete
alignment
points

with the stylus. Position the
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3. Touch the icon

. The laser will go directly to the coordinates of the next

line of the table. Touch the icon
. The laser will go directly to the
coordinates of the previous line of the table. With the PSV-3D, all three
lasers go directly to the coordinates.

)

If you delete an alignment point, there is no valid 3D alignment any more
and you can no longer toggle the coordinates of the alignment points.

4.5.7 3D Alignment for the Scanning Head System of the MSA
At the 3D alignment for the scanning head system of the MSA, the coordinate
system is defined automatically by the software in the scanning head system
depending on the vibrational direction of the vibrometer channel.

)

Before you perform a 3D alignment, ensure that you have set the correct
zoom factor in the list Lens in the scanning head control.

For 3D alignment, proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

)
Open dialog

An automatic 3D alignment for the scanning head system is only possible
if a valid 2D alignment is available.

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click

or select Setup > Dialog 3D Alignment.
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You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

Figure 4.25: Dialog 3D Alignment for the MSA (scanning head system)

Select the unit

3. Select the unit for the coordinates (m, mm or µm).

Specify quality

4. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 10 µm).

Perform and
calculate
alignment

5. Click Auto. The coordinate definition mode is changed to Origin, Axis,
Plane. The software advises you that the vibrational direction of the
vibrometer channel is used for the orientation of the scanning head
system and that the 3D alignment will be performed and calculated
automatically.
6. Confirm this message with Yes.

)

If you still want to change the vibrational direction, click No and change
the Direction of the vibrometer channel in the dialog Acquisition Settings
on the page Channels (refer to SECTION 6.2.2).
The software determines the coordinate system in the scanning head
system and performs the 3D alignment automatically. The origin of the
scanning head system is positioned in the middle of the video image and
at the position D = 0 µm of the z-axis in the measurement microscope.
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The software will calculate the alignment. The current quality of this
alignment is shown in the dialog. If the 3D alignment is successful, then
the LED Status will turn green. If the LED lights up red, then the alignment
is not valid.

)

If the value for the current quality exceeds the value for the target quality,
then a message will appear. The LED Status will turn yellow. Despite this,
you can use the 3D alignment.
You can check the quality for the individual alignment points. The
alignment points for which the quality value for the respective scanning
head is lower than the value in the field Target Quality will have a tick in
the column Quality.

Figure 4.26: Automatic 3D alignment for the MSA (scanning head system)

)
Check
alignment
points

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.
7. To do so, in the dialog 3D Alignment, select

Select and Check Point.

8. Then click an alignment point in the video image. The corresponding line
in the table is marked.
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Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

End alignment

If a valid 3D alignment is available, then the laser beam is moved to the
position calculated from the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beam hits the points on the object, the higher
the quality of the alignment.

9. Click

to leave the dialog 3D Alignment.

4.5.8 3D Alignment for the Object System of the MSA
At the 3D alignment for the object system of the MSA, you will define the
coordinate system in the object coordinate system. This is required for you if
you want to import or export geometries or you want to generate combined 3D
files.

)

Before you perform a 3D alignment, ensure that you have set the correct
magnification in the list Lens in the scanning head control.

For 3D alignment, proceed as follows:
2D alignment

1. If you have not performed 2D alignment yet, do it now as described in
SECTION 4.4.

Open dialog

2. Click
or select Setup > 3D Alignment. The video window is maximized
and the dialog 3D Alignment appears. You can show or hide the dialog. To
do so, click
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or select Setup > Dialog 3D Alignment.
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You can also click the video image with the right mouse button and select
Dialog 3D Alignment in the context menu. The dialog 3D Alignment
appears.

Figure 4.27: Dialog 3D Alignment for the MSA (object system)

Select the unit

3. Select the unit for the coordinates (m, mm or µm).

Position the
laser beam

4. Now you can move the laser beam using the icons Position in the
scanning head control.
Alternatively you can also use the mouse directly. Using the middle mouse
button (mouse wheel), click in the video image. This will make the laser
beam jump to your mouse cursor. To position the beam, hold the middle
mouse button pressed and drag with the mouse until the laser beam is
positioned on the required point on the object.

)

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in the
scanning head control.
To increase the accuracy when hitting the required point, zoom the video
image. See SECTION 2.6.8 on this.
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Define
alignment
points

5. Once you have found the precise position of the required point on the
object, in the dialog 3D Alignment select
Set New Alignment Point at
Laser Spot / Assign Laser Spot to Point. Now in the video image, click the
point which the laser beam is currently at. An alignment point will now be
defined there. The alignment point is marked with a black circle
and a
line is added to the dialog 3D Alignment which is automatically assigned
to the alignment point. In the column Distance the distance measured to
this alignment point is entered. In the column Laser it shows that the point
has been defined.

)

When defining every alignment point, the software automatically focuses
the laser beam and calculates the coordinates of the alignment point from
the position of the z-axis in the measurement microscope.

6. Define three to twenty alignment points in this way. You will find
information on appropriate arrangement of the alignment points in
SECTION 4.6.9.
Delete
alignment
points

To delete an alignment point, click it in the video image with the right mouse
button and select Delete in the context menu. You can also mark the
corresponding line of the table in the dialog 3D Alignment and click Delete.
To delete all the alignment points, click the video image with the right mouse
button and select Delete All in the context menu.

Define and
assign
coordinates

You have the following options to define the object coordinate system (object
system):
•
•

•

Points with Free Coordinates: You mark at least three points and enter all
the coordinates of these points.
Origin, Axis, Plane: You mark the origin, any point of your choice along the
positive x-, y- or z-axis and any point in the positive half plane limited by
the selected axis (e.g. 0, + x, x / + y).
Three Points on Axes: You each mark any point on the positive x-, y- and
z-axis.

In the following the option Points with Free Coordinates is described in detail.
Both the other options will be explained to you briefly at the end of this
section.
7. Select Points with Free Coordinates from the list Coordinate Definition
Mode.
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8. Click the alignment point with the right mouse button and select Point with
Free Coordinates in the context menu. The dialog Assign Coordinates
appears.

Figure 4.28: Dialog Assign Coordinates

9. Here you enter the coordinates of the alignment point and click OK. XYZ
will appear next to the point.
10. Repeat steps 8 and 9 until you have assigned coordinates to at least three
alignment points.

)

If you have defined more than three alignment points, then you do not
have to assign coordinates to all the alignment points. However, only
alignment points which have had coordinates assigned to them will be
used to calculate the 3D alignment. For further information please read
SECTION 4.6.

Specify quality

11. In the field Target Quality enter the maximum value by which the
alignment points may deviate from the given coordinates (e.g. 10 µm).

Calculate the
alignment

Once you have defined the alignment points and have assigned coordinates
to them, you can calculate the alignment.
12. Click Calculate. The software will now calculate the alignment. The
current quality of this alignment is shown in the dialog. If the 3D alignment
is successful, then the LED Status will turn green. If the LED lights up red,
then the alignment is not valid.

)

If the value for the current quality exceeds the value for the target quality,
then a message will appear. The LED Status will turn yellow. Despite this,
you can use the 3D alignment.
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You can check the quality for the individual alignment points. The
alignment points for which the quality value for the respective scanning
head is lower than the value in the field Target Quality will have a tick in
the column Quality.

Figure 4.29: Successful 3D alignment for the MSA (object system)

)
Reassign the
laser position

You can sort the entries in the table in ascending or descending order in
every column. To do so, click the head of the respective column.

You can also reassign new laser positions to existing alignment points to
increase the quality of the measurement results. To do so, in the dialog 3D
Alignment select
Set New Alignment Point at Laser Spot / Assign Laser
Spot to Point. Then move the relevant laser beam to the point on the object
and click the alignment point in the video image with the left mouse button.
The software will focus again the laser beam and calculate the coordinates of
the alignment point from the position of the z-axis in the measurement
microscope. The new position and coordinates are used to recalculate the
alignment.

Abort alignment You can abort the alignment at any time. To do so, click
or select Setup >
3D Alignment. You will be given a message that the alignment was not
finished correctly and you can now decide whether you want to repeat it or
not.
Check
alignment
points
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You can also retrospectively check the assignment of the alignment points on
the video image with the coordinates in the table in the dialog 3D Alignment.
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13. To do so, in the dialog 3D Alignment, select

Select and Check Point.

14. Then click an alignment point in the video image. The corresponding line
in the table is marked.
Or click a line in the table. The corresponding alignment point is displayed
blue in the video image.

)

Add offset

If a valid 3D alignment is available, then the laser beam is moved to the
position calculated from the x-, y- and z-coordinates. You can visually
check the quality of the alignment at the respective alignment point. The
more accurately the laser beam hits the points on the object, the higher
the quality of the alignment.

Once you have calculated the 3D alignment, you can add an offset to the
coordinates. To do so, click Offset. The dialog Add Offset appears. Enter the
required offset and click OK. The offset is added to all coordinates and the
alignment is calculated again.

)

If you have selected a different coordinate definition mode than Points
with Free Coordinates, then when an offset is added, the software will
automatically switch into the mode Points with Free Coordinates.

End alignment

15. Click

to leave the dialog 3D Alignment.

Alternative
coordinate
definition

Origin, Axis, Plane
To define the object coordinate system this way, replace steps 7 to 10 in
section Define and assign coordinates with the following:
1. Select Origin, Axis, Plane from the list Coordinate Definition Mode.
2. With the right mouse button, click the alignment point which you want to
define as origin and select Origin in the context menu. Next to the
alignment point a 0 will appear. The coordinates of the origin (0 / 0 / 0) will
be displayed in the dialog 3D Alignment.
3. With the right mouse button, click the alignment point which you want to
define on the x-axis for example and select Point on + x-axis in the context
menu. An + x will appear next to the point; an arrow will be drawn through
the point. The distance and the coordinates (+ x / 0 / 0) of the point are
shown in the dialog 3D Alignment.
4. With the right mouse button, click the alignment point which you want to
define in a half-plane and select for example Point on x / + y plane in the
context menu. An x / + y will appear next to the point. The distance and the
coordinates (x /+ y / 0) of the point are shown in the dialog 3D Alignment.
5. Now continue with the 3D alignment as described from step 11 onwards
further up.

)

In this coordinate definition mode, entering the target quality must also be
carried out. The current quality determined is always 0. If you have
defined more than three alignment points, then the surplus alignment
points are not used for calculating the 3D alignment.
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Three Points on Axes
To define the object coordinate system this way, replace steps 7 to 10 in
section Define and assign coordinates with the following:
1. Select Three Points on Axes from the list Coordinate Definition Mode.
2. Use the right mouse button to click the alignment point which the x-axis of
the coordinate system is to run through and select Point on + x-axis in the
context menu. An + x will appear next to the point; an arrow will be drawn
through the point.
3. Repeat step 2 for one more alignment point each on the y- and z-axis.
4. Now continue with the 3D alignment as described from step 11 onwards
further up.

)

In this coordinate definition mode, entering the target quality must also be
carried out. The current quality determined is always 0. If you have
defined more than three alignment points, then the surplus alignment
points are not used for calculating the 3D alignment.

4.6 Further Information for Successful 3D Alignment
In the following sections you will receive informations on how you can
optimally perform the 3D alignment and on what you have to pay attention to.
•
•
•
•
•
•
•
•
•
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Positioning scanning heads appropriately, refer to SECTION 4.6.1
Defining 3D alignment points with or without geometry scan unit, refer to
SECTION 4.6.2
Positioning alignment points appropriately, refer to SECTION 4.6.3
Evaluating the quality of the alignment, refer to SECTION 4.6.4
Editing 3D alignment points, refer to SECTION 4.6.5
Receiving optimal results with the geometry scan unit, refer to
SECTION 4.6.6
Merging individual measurements (Stitching), refer to SECTION 4.6.7
Merging individual measurements with mirror and geometry scan unit,
refer to SECTION 4.6.8
Special features for the 3Dalignment with the MSA, refer to SECTION 4.6.9
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4.6.1 Positioning Scanning Heads Appropriately (only PSV-3D)
For the PSV-3D, it is important to position the scanning heads in such a way
that a 3D signal can be calculated from the signals from the three scanning
heads. Ideally you position the three scanning heads in front of the object
arranged as an equilateral triangle. If it is not possible to do this precisely,
change the angles slightly. Avoid all three laser beams being in one plane. For
all measurement points the following must apply: Every laser beam must
clearly project from the plane through which the other two laser beams are
mounted.
For surfaces which scatter diffusely, such as white tear testing spray or
reflective film you will attain optimal results if every laser beam hits the
surface at an angle of approx. 40° to the surface normal. For surfaces with
partially directional backscattering (e.g. processed metal surfaces, car
paints), an angle of approx. 20° to the surface normal is optimal.
Please make sure that all measurement points can be reached by all
scanning heads respectively. For very jagged objects it may be necessary to
deviate from the optimal angle or several measurements will have to be made
from different positions and then be collated afterwards.
For small measurement surfaces we recommend setting up the distance of
the scanning heads to the center of the object in such a way that the scanning
heads are at a visibility maximum. However, should the distance across the
measurement surface change more for larger measurement objects than the
distance between two visibility maxima (204 mm, refer also to theory manual),
then this recommendation does not make any sense. In this case you should
select the smallest possible distance which you need to reach the whole area
of interest with the laser beam.
4.6.2 Defining 3D Alignment Points with or without Geometry Scan Unit
If you have a scanning head with the geometry scan unit PSV-A-420
available, you can choose whether you want to use the geometry scan unit for
3D alignment or not.
Generally we recommend using the geometry scan unit for 3D alignment. It
makes it easier to carry out 3D alignment and the accuracy requirements of
the coordinates of the points on the object under investigation are lower. The
geometry scan unit also allows 3D alignment if no points with known
coordinates are available.
With the PSV-3D it can be advantageous to work without the activated
geometry scan unit. This is the case if the laser beams are to provide very
good cover on small objects (size of area of interest approx. 1 ... 10 cm). Here
the information on selecting the alignment points as described in
SECTION 4.6.3 is very important. For small or flat objects it can be useful to
perform the 3D alignment without the activated geometry scan unit but using
a larger replacement object on which points with precisely measured
coordinates are marked. After finishing 3D alignment, the object is positioned
in place of the replacement object.
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4.6.3 Positioning Alignment Points Appropriately (PSV / PSV-3D)

)

In this section, the points on the object which are used for alignment are
called alignment points.

Your selection of alignment points depends on whether you are performing 3D
alignment with or without the geometry scan unit. If you are performing 3D
alignment with the PSV-3D with activated geometry scan unit, then the
following recommendations for 3D alignment with the geometry scan unit only
apply for the scanning head Top which the geometry scan unit is installed on.
As it is not possible to attach geometry scan units to the scanning heads Left
and Right, the distances between these scanning heads and the points on the
object can not be measured. For these scanning heads, the recommendations
for 3D alignment without geometry scan unit always apply.

)

When selecting the alignment points, make sure that the scanners in the
scanning heads always use optimal linearity at an angle of around ± 12°.
This angle range should be used as well as possible. Larger angles
should be avoided where possible.
PSV-3D with geometry scan unit

Scanning head Top

Scanning head Left

Scanning head Right

Read further information on:
Read further information on:
Appropriate Alignment Points for the 3D Alignment Appropriate Alignment Points for the 3D Alignment
with Geometry Scan Unit
without Geometry Scan Unit

Appropriate Alignment Points for the 3D Alignment with Geometry Scan
Unit
If you are working with the geometry scan unit, the laser angles set and the
distances measured are used to calculate the position and orientation of the
scanning head. At least three alignment points are necessary for 3D
alignment. The alignment points have been optimally selected if the surface of
the triangle formed by these points in space is as large as possible.
So it is particularly important that the alignment points in three-dimensional
space are not along one line. In this case, the surface of the triangle formed
would be zero. Despite this, the software can successfully calculate 3D
alignment. The calculated position of the scanning head however is then one
of any number of solutions and thus undefined.
When using the coordinate definition mode Points with Free Coordinates you
can set up to twenty alignment points with free coordinates. By setting
additional alignment points, errors in the coordinates when positioning the
laser and making the distance measurement have less effect on the results of
the 3D alignment. Setting additional alignment points is particularly
recommended if the uncertainty of the coordinates is greater than 1 mm.
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Appropriate Alignment Points for the 3D Alignment without Geometry
Scan Unit
If you are deactivating the geometry scan unit, the laser angles set and the
distances measured are used to calculate the position and orientation of the
scanning head. The distances between the scanning head and the points on
the object are unknown and can not contribute towards calculating the 3D
alignment. For this reason, without a geometry scan unit, three alignment
points are not enough; you will have to define at least four alignment points.

)

The following information on defining appropriate alignment points also
applies to the scanning heads Left and Right of the PSV-3D if the
geometry scan unit on the scanning head Top is activated for 3D
alignment.

The selection of the four alignment points for 3D alignment is virtually optimal
if the volume of the tetrahedron they form is as large as possible. Here,
arrangements in which the point of the tetrahedron points in the direction of
the scanning heads is advantageous in comparison to arrangements in which
the point of the tetrahedron points away from the scanning heads.
If the alignment point are arranged unfavorably, then this can lead to
ambiguous solutions. In particular if all the alignment points with the point at
which the laser is emitted from the scanning head can form an imaginary
cylinder together, then the calculated position of the scanning head is one of
many possible solutions and thus undefined. This is then also virtually the
case if all alignment points are on one plane which is small in comparison to
its distance from the scanning head.
You can define up to seven alignment points for 3D alignment. By defining
additional alignment points, errors in the coordinates and from positioning the
laser have less effect on the results of the 3D alignment. Additional alignment
points are always an advantage if the 3D alignment needs to be particularly
precise. This is in particular the case with the PSV-3D because here the
results of the 3D alignment are not only needed for positioning the laser but
also for the coordinate transformation of the measurement values.
With the PSV-3D you can perform 3D alignment for the scanning head Top
with the geometry scan unit. After that, the alignment points for scanning
heads Left and Right can be set advantageously. As alignment of scanning
heads Left and Right has been preceded by a 3D alignment for the scanning
head Top, any points in the coordinate system of the object can be measured.
This means that alignment points can be used for the 3D alignment which are
not on the measurement object. In particular for the point of the tetrahedron, a
replacement object can temporarily be placed between the object and the
scanning heads. For small objects, additional alignment points can be defined
on a replacement object behind the object under investigation.
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4.6.4 Evaluating Quality of the 3D Alignment (PSV / PSV-3D)
The Current Quality shown in the dialog 3D Alignment is a measure of how
well the given alignment points can be hit again with the aid of their
coordinates, the position calculated in 3D alignment and the orientation of the
scanning head. On its own, the current quality displayed does not provide any
information on how well it has been possible to reconstruct the position of the
scanning head in the object's coordinate system through 3D alignment.
Example: With 3D alignment with the geometry scan unit, the three alignment
points are approximately in a line. As described in SECTION 4.6.3, no clear
solution for the scanning head position is found when calculating the 3D
alignment. Despite this, a lower value is shown for the current quality because
from the results of the 3D alignment, the given points on the object under
investigation can be hit very accurately.
A lower value for the displayed quality of the 3D alignment is thus only an
indicator for high quality if, when selecting the alignment points, the advice in
SECTION 4.6.3 has been followed.
You will find another way to evaluate the quality of the 3D alignment in the 3D
view. There you can display the scanning head position relative to the
geometry. To do so, activate in the dialog Display Properties on the page 3D
View the check box Scan Range (refer to SECTION 8.1.3). The software shows
the position of the scanning head with the aid of stylized laser beams at the
four positions with maximum angle (x ± 20°; y ± 20°). With the PSV-3D, the
positions of all three scanning heads are shown.

)

The page 3D View is only displayed if you have defined scan points.

For the PSV-3D, you can calculate the distance of the scanning heads to each
other with the aid of the macro ScanHeadPositions.bas. Then using a
measuring tape you can evaluate whether the distances that are calculated
via the 3D alignment correspond with the reality.
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4.6.5 Editing 3D Alignment Points
3D alignment points that have already been defined can be edited. In doing so
you can:
•
•
•

define object system alignment points as alignment points.
change the coordinate definition mode.
modify coordinates of the alignment points in definition mode Points with
Free Coordinates.

Defining Object System Alignment Points as Alignment Points
To define an object system alignment point (an alignment point defined with
the aid of a coordinate definition mode) as a normal alignment point, click it
with the right mouse button and select Alignment Point in the context menu.
The alignment point remains but it is no longer an object system alignment
point, see also SECTION 4.5.3, SECTION 4.5.5 or SECTION 4.5.8 on this. The
special identification which identifies it as an object system alignment point
disappears as well.
Changing Coordinate Definition Mode
Independently of which coordinate definition mode you have defined the
alignment points in (Points with Free Coordinates; Origin, Axis, Plane; Three
Points on Axes), you can still retrospectively change the definition mode. To
do so, proceed as follows:
1. In the dialog 3D Alignment, select another definition mode. The object
system alignment points become alignment points without identification. If
a valid 3D alignment had already been carried out however, the
coordinates of the alignment points are retained.
2. Click the alignment point you want to edit with the right mouse button and
select the corresponding command in the context menu (refer also to
SECTION 4.5.3, SECTION 4.5.5 or SECTION 4.5.8).
Modifying Coordinates of Alignment Points with Free Coordinates
To modify free coordinates of alignment points which have already been set,
proceed as follows:
1. Click an alignment point with the right mouse button and select Point with
Free Coordinates in the context menu. The dialog Assign Coordinates
appears (refer also to FIGURE 4.12).
2. Here you enter the correct values and click OK.

4-59

4 Setting the Optics

4.6.6 Receiving Optimal Results with the Geometry Scan Unit
The distance is measured between the scanning head and the point which the
laser is aimed at with the aid of the geometry scan unit. The geometry scan
unit needs enough light scattered back for it to provide optimal results. To
ensure this, proceed as follows:
1. Switch the geometry laser on. To do so, select Scan > Geometry Laser.
2. If the LED OVER displays overload of the measurement range in the
scanning head control, switch the filter on. To do so, click the box Filter in
the scanning head control.

)

If you are using a geometry scan unit with a toggle switch FILTER, switch
on the filter on the geometry scan unit (refer to hardware manual).

3. Watch the signal level in the scanning head control. The signal level
should make up at least one third of full scale.
With a low signal level, interference reflection from the optics in the beam
path can cause distances measured to be too short. The threshold below
which these measurement errors actually occur is generally around a signal
level of 10%. It varies slightly from instrument to instrument and depends on
how dirty or clean the optics are. The reason for this is that the geometry laser
in contrast to the vibrometer laser does not work with a focused laser beam
and is therefore influenced by all reflections which appear in the beam path.

)

A third of full scale is usually attained at distances of up to 3 m, measured
on a white surface which scatters diffusely. Keep to this signal level for 3D
alignment and then you will be sure not to get a measurement error in the
distance measurement.

4.6.7 Merging Individual Measurements (Stitching)
With the aid of 3D alignment, measurement objects from several positions
can be acquired and the individual results can be combined retrospectively.
As you move the scanning heads or the object between the individual
measurements, you have to perform a 3D alignment in the new position
again.
Without a geometry scan unit, the laser beams have to be able to hit at least
four alignment points with known coordinates for every measurement
segment. This can be done for example in advance of the measurement with
the aid of a coordinate measurement device.
With a geometry scan unit you have the option of measuring points for the
next measurement segment at the edge of the respective measurement
segment. To do so, define alignment points which are not marked as object
system alignment points. After 3D alignment has been calculated, the
coordinates of these alignment points are displayed in the dialog 3D
Alignment, however they are not used for calculating this 3D alignment.
In the case of the PSV-3D with a geometry scan unit, it is advantageous if you
do not change the relative position of the scanning heads. You can reach this
e.g. with the aid of an optional tripod at which all three scanning heads are
mounted on one holder or by moving the object under investigation. In this
case you will only have to redo the 3D alignment for the scanning head Top.
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3D alignment for the scanning heads Left and Right remains valid. This is
because the coordinates of the alignment points from the scanning heads Left
and Right are calculated from the new position of the scanning head Top. At
the same time the previously measured distances from the scanning head Top
and thereby the adjusted mirror angles of the scanning head Top enter the
calculation. The alignment points changed that way have thus the same
position relative to the scanning head Top as they have before. Using these
changed coordinates, the positions of the scanning heads Left and Right will
then be recalculated. In doing so, the previously adjusted mirror angles of
these scanning heads enter the calculation. Summarized, this means that the
scanning heads Left and Right are at the same position relative to the
scanning head Top as they are before. But relative to the object, all three
scanning heads are moved.

)

Please note that using this procedure the alignment points of the scanning
heads Left and Right are no longer situated on the object. Therefore, at
these coordinates the laser beams do no longer hit each other on the
object as well. In this case, you can ignore this.

4.6.8 Merging Individual Measurements with Mirror and Geometry Scan Unit
If you want to measure two sides of an object, then you can measure one side
directly and the other side with the aid of a mirror. To do so, proceed as
follows:
1. Mark points on the surface of the mirror. This can be done with surface
mirrors, for example by putting stickers on the corners of the mirror.
2. Perform a 3D alignment directly on the object with the aid of the geometry
scan unit (i.e. without using the mirror).
3. Define at least three corners of the mirror as alignment points.
4. Calculate 3D alignment. This will determine the coordinates of the points
marked on the mirror. However, these coordinates will not be used for 3D
alignment.
5. If necessary, change to coordinate definition mode Points with Free
Coordinates.
6. Define the alignment points on the surface of the mirror as Points with
Free Coordinates.
7. Delete the original object system alignment points which you defined
directly on the object.
8. Now you can calculate 3D alignment for the measurement via mirrors by
marking the box Mirror and recalculating the 3D alignment.

)

With the PSV-3D you have to mark the box Mirror for all three scanning
heads respectively. If you have performed 3D alignment for the scanning
heads Left and Right as described in SECTION 4.5.5, then you do not have
to do anything other than recalculate the 3D alignment. This is because
the relative position of the scanning heads to each other is not changed.
Thus the same applies as already described in SECTION 4.6.7.
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4.6.9 Special Features for the 3D Alignment with the MSA

)
Positioning
alignment
points
appropriately

In this section, the points on the object which are used for alignment are
called alignment points.

If you are working with the MSA-500 and the option MSAGeo, the laser
position and the position of the z-axis in the measurement microscope are
used to calculate the position and orientation of the object coordinate system.
At least three alignment points are necessary for 3D alignment. The alignment
points have been optimally selected if the surface of the triangle formed by
these points in space is as large as possible.
So it is particularly important that the alignment points in three-dimensional
space are not along one line. In this case, the surface of the triangle formed
would be zero. Despite this, the software can successfully calculate 3D
alignment. The calculated position of the object coordinate system however is
then one of any number of solutions and thus undefined.
When using the coordinate definition mode Points with Free Coordinates you
can set up to twenty alignment points with free coordinates. By setting
additional alignment points, errors in the coordinates when positioning the
laser and the z-axis have less effect on the results of the 3D alignment.
Setting additional alignment points is particularly recommended if the
uncertainty of the coordinates is greater than 10 µm.

Merging
individual
measurements

With the aid of 3D alignment, regions of bigger measurement objects can be
acquired and the individual results can be combined retrospectively. As you
move the object between the individual measurements, you have to perform a
3D alignment at the new position again.

)
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A new 3D alignment is not applicable if you move the measurement object
only with the aid of an offset.
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5 Defining Scan Points (APS)
Before a scan you first of all have to define the scan points. To do so, you
draw geometrical figures on the live video image as you would in graphics
software. The software offers the following functions for this:
Standard mode, refer to

SECTION

Point mode (optional), refer to

5.1

SECTION

5.2

Common functions in both modes, refer to
Editing scan points (not APS), refer to

SECTION

SECTION

5.3

5.4

Carrying out geometry scan (optional), refer to SECTION 5.5
Teaching-in focus values (optional), refer to SECTION 5.6
Standard mode

In standard mode you can draw rectangles, ellipses, polygons and lines. You
can set up the grid for every figure individually and it can also be polar or
hexagonal.

Point mode (as
an option)

In point mode you do not draw figures but define and edit single scan points
and their connections. You can take over scan point definitions from the
standard mode and fine-tune them. Point mode is only available if you have
the option APS Professional. In point mode you can define scan points with
both the PSV software and also the optional PDA. See SECTION 5.2.1 or
SECTION 5.2.2 on this.

)

With the PSV or the PSV-3D (1D), 2D geometries are created in standard
and point mode (refer also to SECTION 3.1). With a valid 3D alignment you
can also import 3D geometries.

In point mode for PSV-3D, you can import scan points from an external file or
teach them in with the aid of the three scanning heads. This is also possible
with the PSV if you use the optional geometry scan unit.
If you are using a scanning head with the geometry scan unit, you can
proceed as follows:
1. Define the scan points in standard or point mode as described in
SECTION 5.1 or SECTION 5.2 respectively.
2. Exit scan point definition and carry out a geometry scan as described in
SECTION 5.5.
3. Go to point mode. In doing so, the scan points and the measured
coordinates are retained.
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The following table contains an overview of the geometries which you can
define with the PSV, PSV-3D and the MSA.
System

Standard

Standard with
geometry
scan unit

Point

Point with
geometry
scan unit

Point with
geometry
import

PSV

2D

3D

2D

3D

3D

PSV-3D (3D)

3D

3D

3D

3D

3D

PSV-3D (1D)

2D

3D

2D

3D

3D

2D

1

2D

1

3D

MSA
1

Define

-

-

You can define 3D geometries for the MSA-500 with the option MSAGeo.

To define scan points, proceed as follows:
1. Go into acquisition mode. To do so, click

.

2. If necessary, align the positions on the live video image with the position
of the laser on the measurement plane or perform a 3D alignment. See
SECTION 4.4 or SECTION 4.5 on this.
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3. In the toolbar of the application window, click
or select Setup > Define
Scan Points. The software maximizes the video window and displays a
graphics toolbar. Areas of the live video image can be crosshatched.
These areas are outside the range you can scan.

Figure 5.1: Available range for defining the scan points

)

The possible scan area depends on the scanning head, zoom of the
camera and correct 2D or 3D alignment respectively.

4. Go to the required mode.
To scan a flat object, click
(standard mode) or
(point mode) in the
graphics toolbar. Point mode is only available if you have the option APS
Professional.
5. Define scan points as described in SECTION 5.1 and SECTION 5.2. You can
see how many scan points you have defined in the legend of the live video
image. Below that you see the estimated time needed for the scan. The
estimation is based on the time for data acquisition at all scan points and
the settling time of the scanner mirrors.

)

You can also define scan points in the crosshatched area of the live video
image. However, when scanning, these scan points themselves are not
hit, but the next attainable point respectively.
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6. If you have defined all the scan points, click
in the toolbar of the
application window again to quit scan point definition.
Zoom

To position the scan points exactly, you can zoom in the video image. Read
SECTION 2.6.8 on this.

Test

As the live video image shows a two-dimensional image of the threedimensional object, it is possible that the laser beam does not hit some of the
scan points exactly. So check the scan points as follows:
7. Point at the live video image and click a scan point. The laser beam
moves to this point on the object.
Only PSV-400: You can also approach the scan points with the optional
PSV-A-PDA or the hand set PSV-Z-051. See SECTION 5.2.2 and your
hardware manual on this.
Only PSV-300: You can also position the laser beam on scan points using
the hand set PSV-Z-051. See your hardware manual on this.
8. Check if the position of the laser beam on the object corresponds to that
on the live video image.
9. Repeat steps 7 and 8 for a few more scan points.

5.1 Standard Mode
In standard mode you draw geometric figures. While doing so, you can use
following functions:
•
•
•
•
•
•
•
•
•

Drawing lines, refer to SECTION 5.1.1
Drawing rectangles and squares, refer to SECTION 5.1.2
Drawing ellipses and circles, refer to SECTION 5.1.3
Drawing polygons, refer to SECTION 5.1.4
Rotating figures, refer to SECTION 5.1.5 and changing their shape, refer to
SECTION 5.1.6
Distributing scan points among figures, refer to SECTION 5.1.7
Setting up the grid for each figure individually, refer to SECTION 5.1.8
Defining vertex points of ellipses, refer to SECTION 5.1.9
Setting properties of lines, refer to SECTION 5.1.10

To go to standard mode, in the graphics toolbar, click
Properties appears.

)
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. The dialog Object

If you define scan points with the PSV-3D in standard mode, then these
points have already have 3D coordinates assigned to them. These
coordinates have been calculated from the preceding 3D alignment of the
three scanning heads and their mirror angles. It is not possible to make a
calculation of this kind with the PSV or PSV-3D (1D). To be able to obtain
3D data with the PSV or PSV-3D (1D) despite this, you have to import the
data in point mode or determine it using the geometry scan unit.
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5.1.1 Drawing Lines
To draw a line, proceed as follows:
1. Click

.

2. Point at the live video image. The cursor becomes a cross.
3. Click the corners of the line.
4. Double-click the last corner.
5.1.2 Drawing Rectangles and Squares
To draw a rectangle or a square, proceed as follows:
1. Click

.

2. Point at the live video image. The cursor becomes a cross.
Rectangle

There are two ways of drawing a rectangle:
3. Point at a corner of the rectangle.
4. Press the mouse button and drag to the diagonally opposite corner.
or
5. Point at the center of the rectangle.
6. Press the control key and the mouse button simultaneously and drag
across to a corner point.

Square

There are two ways of drawing a square:
7. Point at a corner of the square.
8. Press the shift key and the mouse button simultaneously and drag to the
diagonally opposite corner.
or
9. Point at the center of the square.
10. Press the control key, shift key and the mouse button simultaneously and
drag across to a corner point.
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5.1.3 Drawing Ellipses and Circles
To draw an ellipse or a circle, proceed as follows:
1. Click

.

2. Point at the live video image. The cursor becomes a cross.
Ellipse

There are two ways of drawing an ellipse:
3. Point at a corner of the rectangle enclosing the ellipse.
4. Press the mouse button and drag to the diagonally opposite corner.
or
5. Point at the center of the ellipse.
6. First press and hold the control key and then the mouse button and drag
across to a corner point of the rectangle enclosing the ellipse.

Circle

There are two ways of drawing a circle:
7. Point at a corner of the square enclosing the circle.
8. First press and hold the shift key and then the mouse button and drag to
the diagonally opposite corner.
or
9. Point at the center of the circle.
10. Press the control key, shift key and the mouse button simultaneously and
drag across to a corner point of the square enclosing the circle.

5.1.4 Drawing Polygons
To draw a polygon, proceed as follows:
1. Click

.

2. Point at the live video image. The cursor becomes a cross.
3. Click at least three corners of the polygon.
4. Double-click the last corner. The software connects it to the first corner.
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5.1.5 Rotating Figures
To rotate figures, proceed as follows:
1. Select the figures as described in

SECTION

5.3.2.

There are now two ways of rotating figures:
2. In the dialog Object Properties you enter the absolute angle of rotation in
the field Rotation of the group Object.
or
3. Click

.

4. Point at one of the white markers which mark the edge of the figures. The
cursor becomes a

.

5. Press the mouse button and drag in the direction you want to rotate in.
The anchor point is the center of the figures.
5.1.6 Changing the Shape of a Figure
You can retrospectively insert corners in figures and move corners
individually. To do this, proceed as follows:
1. Select the figures as described in
2. Click

SECTION

5.3.2.

.

To insert a corner:
3. Point at the edge of the figure. The cursor becomes a

.

4. Click the edge of the figure. The software inserts a corner point at this
place.
To move a corner point:
5. Point at the corner. The cursor becomes a

.

6. Press the mouse button and drag in the direction required.
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5.1.7 Distributing Scan Points among Figures
Using the icons
,
,
and
in the dialog Object Properties you
can distribute scan points among figures. To do this, first select the figures as
described in SECTION 5.3.2. Then click
: You are defining scan points inside and on the edges of the figures (not
active for lines).
: You are defining scan points only within the figures (not active for lines).
: You are only defining scan points on the edges of the figures.
: You are deleting the scan points inside and on the edges of the figures.
5.1.8 Setting up the Grid
In standard mode, every figure has got its own grid. To set up the grid, first of
all select the figure as described in SECTION 5.3.2. In the dialog Object
Properties you can then
•
•
•

select the type of grid
set the density of the grid points
rotate the grid.

You can not set up a grid for lines and figures which only have scan points on
the edge (refer to SECTION 5.1.7).
Type of grid

To select the type of grid, click
for a right-angled grid,
for a polar grid or
for a hexagonal grid.

Density of grid
points
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You enter the density of the grid points in the dialog Object Properties in the
respective fields Density. You can also enter decimals. The density is
independent of the dimensions of the figure, it always refers to the height of
the live video image.
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For a figure with a right-angled grid, in the dialog the fields Density X and
Density Y appear. The density of the grid points dx, y determines the distance
between the grid points ax, y as follows:
hy
a x, y = -------d x, y

Equation 5.1

hy … Height of the live video image.
For a figure with a polar grid, the fields Density radial and Density tang
appear. The radial density dradial determines the distance between the grid
points on the beams aradial as follows:
hy
a radial = -----------d radial

Equation 5.2

hy … Height of the live video image.
The tangential density dtang is equal to the number of grid points on the circles.
For a figure with a hexagonal grid, the field Density appears. The density of
the grid points d determines the distance between neighboring grid points as
follows:
h
a = -----y
d

Equation 5.3

hy … Height of the live video image.
Rotate grids

You can rotate a grid relatively to its figure. To do so, enter the angle of
rotation in the field Rotation of the group Grid.

5.1.9 Defining Vertex Points of Ellipses
The software approximates ellipses by using polygons (at least quadrangles).
You can set the number of vertex points. To do this, first select the ellipse as
described in SECTION 5.3.2. In the dialog Object Properties, the field Vertex
Points then appears, in which you can enter the required number of vertex
points. The number of vertex points then also applies for all ellipses which you
subsequently draw.

)

If you define scan points on the edge of an ellipse (refer to SECTION 5.1.7),
every vertex point becomes a scan point.
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5.1.10 Setting Properties of Lines
Lines and figures which only have scan points on the edge (refer to
SECTION 5.1.7) do not have a grid. However, you can set the density of the
scan points on the lines. To do this, first select the figure as described in
SECTION 5.3.2.
Resolution

In the dialog Object Properties, the field Resolution appears. Here you enter a
value. This value reflects the number of scan points on one line, the length of
which corresponds to the height of the video image. This also applies to
rectangles, polygons and ellipses whose scan points are only on the edge.

Width

For lines, the field Width also appears. The width determines the size of a
shadow around the line. Within the shadow, the scan points that are behind
the line are hidden. This means, for example, you can delete scan points on
cables which obscure the view of the object.

5.2 Point Mode (as an Option)
Point mode is only available if you have the option APS Professional. In point
mode you do not draw figures but edit single scan points and their
connections. While doing so, the following functions are available to you:
•
•
•
•
•
•
•
•
•
•
Take over scan
point definition

Defining single scan points using the software, refer to SECTION 5.2.1
Defining single scan points using the optional PSV-A-PDA, refer to
SECTION 5.2.2
Defining connections between scan points, refer to SECTION 5.2.3
Deleting connections, refer to SECTION 5.2.4
Refining the scan point grid, refer to SECTION 5.2.5
Merging scan points in the grid, refer to SECTION 5.2.6
Importing scan points, refer to SECTION 5.2.7
Teaching-in scan points with the geometry scan unit, refer to
SECTION 5.2.8
Defining scan points with Auto Align, refer to SECTION 5.2.9
Editing scan points, refer to SECTION 5.2.10

You can take over scan point definitions from the standard mode and finetune them. To do so, proceed as follows:
1. Draw figures in standard mode as described in

SECTION

5.1.

2. Go to point mode. To do so, in the graphics toolbar, click
. A message
window appears. To separately save the scan points which have already
been defined and to then define new ones, click Save. To add more to
those which already exist, click Continue.

)
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If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.
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3. Click Continue. The software groups all scan points which have already
been defined and selects the group.
4. Undo grouping. To do so, click

. The software selects all scan points.

5. Undo the selection. To do so, click the live video image outside the scan
points.
6. You can now edit scan points as described in SECTION 5.2.10. Apart from
that, you can define single scan points as described in SECTION 5.2.1 and
SECTION 5.2.2.
Only PSV-400: You can also approach the scan points with the optional
PSV-A-PDA or the hand set PSV-Z-051. See SECTION 5.2.2 and your
hardware manual on this.
Only PSV-300: You can also position the laser beam on scan points using
the hand set PSV-Z-051. See your hardware manual on this.
7. You can edit connections of scan points as described in SECTION 5.2.3 and
SECTION 5.2.4.
Additional
functions

If you have performed 3D alignment (refer to SECTION 4.5) respectively, you
have also following possibilities to define scan points:
•

•

•

)

Importing scan points (PSV-3D or optional for PSV and MSA). See
SECTION 5.2.7 on this.
If you know the geometry of the object and it is saved in an external
program, you can simply import the required scan points as a Universal
File. You can also import Vibrant ME'Scope structural data and ASCII
data. For this purpose, an additional file filter is available in the dialog
Open. See also SECTION 10.1.5 on this.
Teaching-in scan points with the geometry scan unit PSV-A-420 (only
PSV-3D or as an option for PSV) See SECTION 5.2.8 on this.
If there is no data available on the object, you can define the scan points
yourself. See also in SECTION 5.2.1 and following on this.
Defining scan points with Auto Align. See also SECTION 5.2.9 on this.
If you change from standard mode into point mode, scan points that have
already been defined remain.
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5.2.1 Defining Single Scan Points with the Software
There are two ways of defining a scan point:
1. Click

.

2. Point at the live video image and click. A scan point is defined at this
place.
Or:
1. Move the laser beam on the object to the point at which you want to define
a scan point. See SECTION 4.1 on this.
2. Click

.

5.2.2 Defining Single Scan Points with the PSV-A-PDA (as an Option)
You can use the optional PDA to help you define single scan points. To do so,
proceed as follows:
1. Go to point mode. To do so, in the graphics toolbar, click

.

2. Start the PDA as described in SECTION 2.9. The user interface of the PDA
software appears. You identify being in scan point definition with the icon
in the menu bar.

Figure 5.2: User interface of the PDA software
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Position the
laser beam

3. Center the laser beam by touching the icon

with the stylus.

4. Position the laser beam by touching the icons

)

,

,

and

.

If you touch an arrow icon for more than approx. one second, the PDA
switches to fast forward. For fine adjustment you can always briefly touch
the icon again.

Define scan
points

5. You define a scan point by touching the icon

Delete scan
points

6. You can delete a scan point by positioning the laser beam on a scan point

Toggle scan
points

You can use the optional PDA to toggle defined scan points with the laser
beam. To do so, proceed as follows:

and touching the icon

.

.

1. Select View > Toggle Points in the menu bar of the PDA.

Figure 5.3: Toggle scan points

2. Touch the icons
or
backwards or forwards.

. The laser will toggle the defined scan points
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Select the
scanning head
(PSV 3D)

If you are using the PSV-3D, you can also select the scanning heads with the
PDA software.

Figure 5.4: User interface of the PDA software for the PSV-3D

To select one of the three scanning heads, touch the corresponding icon
.
You can define and delete the scan points for every scanning head as
described above.
5.2.3 Defining Connections between Scan Points
There are several ways of connecting scan points.
•
•
•

)

Connect two scan points and thus define a line.
Connect three scan points and thus define a triangle.
Automatically connecting selected scan points with each other.
In point mode it is useful to select the view
(refer also to
5.3.2). You can then see which areas are enclosed by scan
points.

SECTION

Connect two
scan points

To connect two scan points, proceed as follows:
1. Click

.

2. Point at the first scan point. The cursor becomes a cross.
3. Click the scan point.
4. Point at the second scan point.
5. Double-click.
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Connect three
scan points

To connect three scan points, proceed as follows:
1. Click

.

2. Point at the first scan point. The cursor becomes a cross.
3. Click the scan point.
4. Point at the second scan point and click.
5. Point at the third scan point and click. The software connects this scan
point to the first one.
Connect
selected scan
points

To automatically connect scan points, proceed as follows:
1. Select the points you want to connect as described in SECTION 5.4.1.
2. Click
. The software connects all selected scan points so that triangles
are created.

5.2.4 Deleting Connection
To delete connections, proceed as follows:
1. Click

.

2. Point at a connection. The cursor becomes a

.

3. Select the connection. To do so, click it.
4. To select further connections, click them while holding the shift key
pressed. You can also draw a rectangle with the mouse and use it to
select connections which are partially or completely in the rectangle.
5. To remove a connection from the selection, click the connection while
holding the shift key pressed.
6. To select all connections, press the key combination Ctrl + A or select Edit
> Select All.
7. To delete the selected connections, press the Delete key or select Edit >
Delete.

)

To delete a triangle, you only have to delete one of the connections. The
software automatically deletes the other connections.
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5.2.5 Refining Scan Point Grid
If you have defined single scan points and connections in point mode, you can
then refine the resulting grid. This means you increase the number of scan
points in the grid and thus their density. Here, the software first of all
calculates the distances between the selected scan points and sets an
additional scan point in the middle on the connection. In the case of a
quadratic polygon, an additional scan point is set in the middle.
To fine-tune the grid, proceed as follows:
1. Select several connected scan points as described in

SECTION

5.4.1.

2. Click
or select Scan > Refine Grid. The software automatically inserts
one more scan point respectively between the selected scan points.
5.2.6 Merging Scan Points in the Grid
If you have defined single scan points and connections in point mode, you can
merge neighboring scan points. This means you reduce the number of scan
points in the grid and thus their density. To do this, the software first
calculates the distances between the selected scan points. Then, starting
from the minimum distance found, the software merges two points into one
point if their distance is less than the minimum distance + 50%. The positions
of the scan points on the video image and, if available, the 3D coordinates of
the scan points are calculated by averaging the values of the two points that
have been merged.
To merge scan points, proceed as follows:
1. Select several connected scan points as described in

SECTION

5.4.1.

2. Click
or select Scan > Merge Points. The software will merge
neighboring scan points as described above.
5.2.7 Importing Scan Points
The icon and the command for geometry import are only available for the
• PSV with the option Data Import: Geometry,
• MSA with the option MSAGeo and the option Data Import: Geometry, and
• PSV-3D.

)
)
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A prerequisite for importing scan points is a valid 3D alignment (refer to
4.5).

SECTION

If you are importing geometry from a file in Universal File format in which
geometry components are defined (refer to SECTION 5.4.3), then these
components are only incorporated for data set 82 (refer to table in
SECTION 10.2.3).
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To import scan points, proceed as follows:
1. Click
or in the menu select Scan > Import Geometry. The dialog Open
appears.

Figure 5.5: Dialog Open

2. Select the required file type.

)

A simple ASCII format is supported for importing geometries. Here, only
the point coordinates are imported, not the connections between the
points.

3. Navigate to the saving location and select the required file.
4. Click Open. The scan points from the selected file are taken over in the
video image. The indices of the scan points are also taken over.

)

If you are importing geometry from a file in ASCII format or a file in
Universal File format which does not contain data set 164 with the units of
the coordinates, then in the dialog Scaling of Imported Coordinates you
have to enter a scaling factor (refer to FIGURE 5.6). The factor 1 stands for
the unit 1 m, the factor 0.01 for the unit 1 cm etc.
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Figure 5.6: Dialog Scaling of Imported Coordinates

)

If the object is deep, the imported points are not precisely on the object in
the on-screen display. However despite this, during scanning, the laser
beams hit the scan points precisely. If you want to correct the display on
the screen, you can move the single points in the video image to the right
position. This, however, does not have any effect on the measurement
results.

Import scan
For the geometry import you can have the position of the scan points on the
points with Auto video image modified. To do so, click the video image with the right mouse
Align
button and select Auto Align in the context menu. Then import the scan points
as described above.

)

This function is not available for the MSA / MSV.

As soon as the import is finished, a message window is displayed with the
query as to whether the scan points in the video image are to be repositioned.
Click Yes. The software moves the laser beam of the scanning head (for PSV3D the scanning head Top) to the points, determines the position of the laser
beam on the screen and positions the scan point exactly at this point.

)
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Work with large
geometries

If the imported geometry is larger than the image section of the object in the
video window, the video window is reduced correspondingly and the geometry
is shown completely in both the 2D view as well as the 3D view.

Figure 5.7: Example of geometry which is large

Generally several scan points will then be given the status Not Reachable or
Hidden (refer to SECTION 7.3). Points that are not reachable will not be
measured in a scan, hidden points can be measured after a warning
message.
To acquire the entire geometry of the object, proceed as follows:
1. Select the scan points which are not to be measured with the current
measurement setup. See SECTION 5.4.1 on this.
2. Assign the status Disabled to these scan points. See
this.

SECTION

5.4.2 on

3. Start a scan as described in SECTION 7.2.
4. Change the position of the measurement setup so that you can scan
another part of the object. To do so, perform a new 3D alignment as
described in SECTION 4.5 and disable the scan points which are not to be
measured.
5. Start another scan.
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6. Repeat the steps 4 and 5 until you have acquired the whole geometry.

)

If you are using 3D geometries, you can then merge the individual
measurements to a combined file as described in SECTION 8.5.

5.2.8 Teaching-in Scan Points with the Geometry Scan Unit (only PSV and PSV-3D)
If the object you are making measurements on does not have a continuous
surface on which you can define a grid of scan points (e.g. a sheet of glass
which has only been covered with reflective film in certain places), you can
define individual scan points with the aid of the optional geometry scan unit.
PSV and
PSV-3D (1D)

1. Only PSV-3D: Select the scanning head Top.
2. Position the laser beam at the point at which you want to define a scan
point.

)

You can also use the hand set PSV-Z-051 on this or the optional PDA.
Position the laser beam with the arrow keys on the hand set. Once the
laser beam has reached the correct position on the object, press the
button TEACH on the hand set. See your hardware manual on this as
well.
You can read SECTION 5.2.2 to find out how to define scan points with the
PDA.

3. Click
. If the geometry laser is not active yet, the software will now
switch over to it. The software makes a distance measurement. At the
same time, both the coordinates of the point on the object and the position
of the point on the video image are determined automatically.

)

You can accelerate the speed at which new points are taught-in by
switching over to the geometry laser first. To do so, click Scan > Geometry
Laser. In this case the software does not keep on switching back and
forwards between the vibrometer and the geometry laser for every single
point.

Once you have taught-in all the scan points, you can link them together to
become a surface as described in SECTION 5.2.3.
PSV-3D (3D)

If the positions of the scanning heads are known, you can acquire the
geometry of the object by manually teaching-in the scan points.
1. Point all three laser beams at a point which you want to define as the scan
point.

)
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2. Click
. This then automatically determines the coordinates of the point
on the object and the position of the point on the video image. You can
use the mouse to move this blue point. However this does not have any
effect on the calculated 3D coordinates; it only affects the display in the
video image.

)

In the scanning head control, additional information is displayed in the
element 3D Point. X, Y and Z describe the coordinates of the selected
scan point. D shows the distance between the scan point and the front
panel of the scanning head Top.

3. Once you have defined all scan points, you can connect them with each
other. See SECTION 5.2.3 on this.
4. Click

to finish scan point definition. You can now start scanning.

5.2.9 Defining Scan Points with Auto Align, only PSV-3D (3D)
You can also define single scan points with Auto Align. To do so, proceed as
follows:
1. Click the video image with the right mouse button and select Auto Align in
the context menu.
2. Hold the control key pressed and in the video image click the place on the
object at which you want to define the scan point. Depending on the
lighting conditions, the surface of the object etc., the software positions
the three laser beams precisely at this point and defines a scan point.
Modifying 3D
Coordinates

If the three laser beams jump to other positions after clicking
, then you
have not performed the 2D alignment precisely enough. The 3D coordinates
were only determined approximately via the video image. If the three laser
beams do not meet at one point, then you could change the distance between
the coordinates and the scanning heads. You can use this to minimize the
distances of the laser spots. The minimal attainable distance is limited by the
accuracy of the 3D alignment. To modify the coordinates, proceed as
described in SECTION 5.4.2 under Modify 3D coordinates.
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5.2.10 Editing Scan Points
If you have defined single scan points in point mode, you can select scan
points and modify them.
Selecting Scan
Points

You can select points as also described in SECTION 5.4.1 and modify the
selected points as described in the following. To do so, click exactly the
selected scan points with the right mouse button and select then the desired
modification in the context menu.

)

If you are clicking beside the selected scan points with the right mouse
button, select Modify Selected Points and then the desired modification in
the context menu.

Disable

If the selected scan points are not to be measured, you can disable them. To
do so, select Disable. The scan points are then disabled for measurements,
geometry scans and for the function Assign Focus Best.

Enable

To undo disabling, select Enable.

Modify 3D
coordinates

If 3D geometry data is available, you can modify the 3D coordinates of single
scan points. See SECTION 5.4.2 under Modify 3D coordinates on this.
With the PSV you can then only modify the 3D coordinates of single scan
points if there is 3D geometry, i.e. after importing geometry or after a
geometry scan. See SECTION 5.2.7 or SECTION 5.5 on this.

Triangulate 3D
coordinates
(only PSV-3D)

To triangulate the 3D coordinates of the selected scan points, select
Triangulate 3D Coordinates. Using 2D and 3D alignment of all three scanning
heads, the software calculates the 3D coordinates of the scan points. You will
find more information on this in your theory manual.

Interpolate 3D
coordinates

If 3D geometry data is available for the selected scan points, you can
interpolate the 3D coordinates of the selected scan points. To do so, select
Interpolate 3D Coordinates. The software will then calculate the average
distance of the neighboring points to the scanning head (Top with PSV-3D).
The 3D coordinates are determined from this distance, taking into
consideration the position of the selected scan points on the video image.
With the PSV you can then only interpolate the 3D coordinates of single scan
points if there is 3D geometry, i.e. after importing geometry or after a
geometry scan. See SECTION 5.2.7 or SECTION 5.5 on this.

Delete 3D
coordinates
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5.3 Common Functions in Both Modes
Several functions are available to you in both modes. They are described in
the following sections.
•
•

Showing and hiding scan points, refer to SECTION 5.3.1
Editing figures, refer to SECTION 5.3.2

5.3.1 Showing and Hiding Scan Points
To show and hide the scan points in the live video image, in the toolbar of the
application window, click
or select Scan > Scan Points. You see the scan
points as blue markers. You see the connections between the scan points as
lines.
5.3.2 Editing Figures
Present figures

Using the icons
,
,
and
, you can present figures in different
ways. To do this, first select the figures as described below. Then click
:You can see the scan points and their connections.
: You can see the scan points, their connections and cross-hatching of the
areas enclosed by the scan points. As a general rule, these areas are
different from the geometric figures you have drawn.

)

In presentation mode, areas which are enclosed by scan points are shown
as enclosed areas.
: You see the connections between the scan points.
: You see cross-hatching of the areas enclosed by scan points.

Select figures

To edit figures, you have to select them first. To do this, proceed as follows:
1. Click

.

2. Point at a figure. At the right below the cursor, a cross

appears.

3. Click. The software marks the edge of the figure with white markers.
4. To select further figures, click them while holding the control key pressed.
The software marks every selected figure with white markers.
5. To select all figures, press the key combination Ctrl + A or select Edit >
Select All.
6. To remove a figure from the selection, click the figure while holding the
control key pressed. The white markers disappear.
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Move figure

To move figures, select them as described above and then use the mouse to
drag them in the direction required. You can also use the arrow keys.
Scan points which you have defined in point mode can be moved individually
or in groups. You move single scan points, whether connected or
freestanding, in exactly the same way as you move figures (see above). If you
want to move several scan points at the same time, then you have to select
them first. To do so, you have the following options:
•
•

)

Hold the control key pressed and click the single scan points. Then
release the control key.
Mark the scan points you would like to move. To do so, use the mouse to
draw a rectangle which encloses these scan points.
If you want to add even more scan points to this selection, hold the shift
key pressed and draw another rectangle.

Move the scan points with the mouse.
Scale figures

To scale figures, proceed as follows:
1. Select the figures as described above. If you want to scale scan points
which you defined in point mode, then first of all select them as described
above under Move figures. Then click
points.

to group the selected scan

2. Point at one of the white markers which mark the edge of the figures. The
cursor becomes a double arrow.
There are now following ways to scale:
3. Press the mouse button and drag in one of the directions the double arrow
is pointing in. The anchor point is opposite the scan point you are
dragging.
or
Press the control key and the mouse button and drag in one of the
directions the double arrow is pointing in. The anchor point is the center of
the figures.
or
Press the shift key and the mouse button and drag across to a corner
point. The figures are resized in proportion horizontally and vertically.
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Duplicate
figures

Delete figures

To duplicate figures, proceed as follows:
1. Select the figures as described above.
2. Click

or select Edit > Copy. The figures are copied onto the clipboard.

3. Click

or select Edit > Paste.

To delete figures, proceed as follows:
1. Select the figures as described above.
2. Press the Delete key or select Edit > Delete.

Group figures

To group figures, proceed as follows:
1. Select the figures as described above.
2. Click

.

3. To undo grouping, click
Arrange figures

Undo and Redo

.

Using the four icons
,
,
and
, you can arrange figures behind
each other (not in point mode). To do this, first of all, select one of the figures
as described above. Then click
or

: The figure moves into the foreground or background.

or

: The figure moves one layer forwards or backwards.

You can undo up to 50 operations and then redo them. To do so, click

and

or select Edit > Undo and Edit > Redo.
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5.4 Editing Scan Points (not APS)
You can also edit scan points if you have already finished scan point
definition. To do so, you have the following options:
•
•
•

Selecting scan points, refer to SECTION 5.4.1
Modifying scan points, refer to SECTION 5.4.2
Defining geometry components, refer to SECTION 5.4.3

5.4.1 Selecting Scan Points
Select scan
points with the
mouse

To select scan points with the mouse you have the following options:
1. To select several scan points adjacent to each other, hold the shift key and
the left mouse button pressed and draw one or more rectangles across
the required scan points.
or
To select several scan points that are not adjacent to each other, hold the
control key pressed and click the required scan points.

Select all scan
points

2. To select all scan points, press the key combination Ctrl + A.
or
Select Edit > Select All.
or
Click the object with the right mouse button and select Select Points in the
context menu. The dialog Select Scan Points appears.

Figure 5.8: Dialog Select Scan Points

Select All and click OK.
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Select scan
points with
certain
properties

To select scan points which have certain properties, proceed as follows:
1. Select Edit > Select Points or click the object with the right mouse button
and select Select Points in the context menu. The dialog Select Scan
Points appears (refer to FIGURE 5.8).
2. Here you select the criteria according to which you want to select the
points and click OK.

)

If you want to select the scan points on the basis of their index, you can
display the indices. See SECTION 8.1.2 on this.

3. If you want to select points with different properties, then also tick the box
Cumulative and repeat steps 1 and 2 as often as necessary.
4. To undo the selection, click

again.

5.4.2 Modifying Scan Points
To retrospectively modify the selected scan points, select Edit > Modify
Selected Points or click one of the selected scan points with the right mouse
button and select the required command in the context menu.

)

If you are clicking beside the selected scan points with the right mouse
button, select Modify Selected Points and then the desired
modification in the context menu.

Figure 5.9: Command selection to modify scan points

You have the option of the following functions:
•
•
•
•
•
•
•

Change indices
Disable / Enable
Modify 3D coordinates (only with 3D geometries)
Triangulate 3D coordinates (only for PSV-3D)
Interpolate 3D coordinates (only with 3D geometries)
Clear 3D coordinates (only with 3D geometries)
Geometry scan

5-27

5 Defining Scan Points (APS)

•
•
•
•
•
Display indices

Assign focus best (only with option APS Professional)
Assign focus manual (only with option APS Professional)
Interpolate focus values (only with option APS Professional)
Clear focus values or recalculate them
Select marginal points

You set up the display of scan point indices in the dialog Display Properties in
the 3D view. To open the dialog, display the 3D view. To do so, click
.
Double-click the video image and display the page Data or click the video
image with the right mouse button and select Data Properties in the context
menu. You will also find a detailed description of the dialog in SECTION 8.1.

Change indices

To change the indices of selected scan points, select Change Indices. The
dialog Change Indices appears.

Figure 5.10: Dialog Change Indices

At the top you are shown the indices for selected scan points.
Add Offset: Click here if you want to add a certain amount to the indices of
the selected scan points or want to subtract it from them. In the field Offset
enter the required value. For a negative offset you have to enter an additional
minus sign (−).
Example:
The selected scan points have the indices 1 - 21.
Offset: 10
The new indices will be 11 - 31.
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Re-index: Click here if you want to renumber the selected scan points. In the
field Index 1st Scan Point enter the value at which the new numbering is to
start.
In addition to that, select the direction of the numbering, starting with the first
scan point.
Example:
The selected scan points have the indices 27 - 52.
Index 1st Scan Point: 30
Direction: left - right, top - bottom
The new indices will be 30, 31, 32, ... They are assigned to the selected
scan points from left to right and from top to bottom.

)

The numbering of the indices only affects the display on the screen. It has
no influence on the order in which the points are scanned.

On conflict with these changes, take the following action: Here you
select how the software is to react if there is a conflict after changing the
indices, i.e. numbers are assigned twice. If you select Assign New Indices,
then the selected scan points are assigned the required indices. Indices for
other scan points which already exist are then counted up, starting with the
highest index + 1.
Example:
You have defined 2500 scan points and want to newly assign the indices 1
- 200 to the scan points 200 - 400.
Index 1st Scan Point: 1
If there is conflict due to these changes, take the following action: Assign
New Indices
The selected scan points are given the indices 1 - 200. The scan points
which originally had the indices 1 - 200 will be given the indices 2501 2701.

)

Independently of whether you abort assignment of new indices or carry it
out anyway, you will see a message as to whether a conflict occurred.

Disable

If the selected scan points are not to be measured, you can disable them. To
do so, select Disable. The scan points are then disabled for measurements,
geometry scans and for the function Assign Focus Best.

Enable

To undo disabling, select Enable.
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Modify 3D
coordinates

You can modify the 3D coordinates of single scan points. To do so, for the
selected scan point, select Modify 3D Coordinates. The dialog Modify 3D
Coordinates appears.

Figure 5.11: Dialog Modify 3D Coordinates

Here you can modify the values of the x-, y- and z-coordinates and also the
distance determined by the geometry scan. If you move the laser beams with
the aid of the slider Laser Beam Distance, the values in the fields are
automatically updated. If however you modify the values in the fields, the
slider remains in the set position.
You can also modify the 3D coordinates of several scan points at the same
time. To do so, proceed as follows:
1. Select several scan points as described in

SECTION

5.4.1.

2. Click one of the scan points with the right mouse button and select Modify
3D Coordinates in the context menu.
3. Modify the 3D coordinates as described above and click OK. The change
to the 3D coordinates of that scan point is added to the 3D coordinates of
all selected scan points. This allows you to move the position of several
scan points in the same direction.
Triangulate 3D
coordinates
(only PSV-3D)

To triangulate the 3D coordinates of the selected scan points, select
Triangulate 3D Coordinates. Using 2D and 3D alignment of all three scanning
heads, the software calculates the 3D coordinates of the scan points. You will
find more information on this in your theory manual.

Interpolate 3D
coordinates

If 3D geometry data is available for the selected scan points, you can
interpolate the 3D coordinates of the selected scan points. To do so, select
Interpolate 3D Coordinates. The software will then calculate the average
distance of the neighboring points to the scanning head (Top with PSV-3D).
The 3D coordinates are determined from this distance, taking into
consideration the position of the selected scan points on the video image.
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Delete 3D
coordinates

To delete the 3D coordinates of the selected scan points, select Delete 3D
Coordinates. Then the software deletes the 3D coordinates and uses the
values of the 2D alignment to hit the scan points.

Geometry scan

If you want to modify the 3D coordinates of the selected scan points, select
Geometry Scan. The software will carry out a geometry scan as described in
SECTION 5.5.

Assign focus
best

Select Assign Focus Best to automatically focus the selected scan points
respectively and to assign them a focus value. See also section 5.6.2 on this.

)

Automatically assigning focus values is not used for the MSA as the focus
values will already be assigned during the geometry scan.

Assign focus
manual

Select Assign Focus Manual to manually assign a focus value to the
respective scan points selected. See also SECTION 5.6.1 on this.

Interpolate
focus values

To interpolate the focus values of the selected scan points, select Interpolate
Focus Values. The focus values of the selected scan points are interpolated
linearly from the focus values of the adjacent points.

Clear focus
values

To clear the focus values of the selected scan points, select Clear Focus
Values.

Recalculate
focus values

If, in the dialog Preferences on the page Geometry, you have marked the box
Calculate Focus Values Automatically and for the selected scan points 3D
coordinates are existent then you can recalculate the focus values of the scan
points based on the focal length of the lens in the scanning head and their
distance to the scanning head.

Select marginal
points

To select the marginal points of the figure of the marked scan point, select
Select Marginal Points.

5.4.3 Defining Geometry Components
In the video window of acquisition mode and in the presentation window in
presentation mode, you can define geometry components and assign scan
points to the individual components. The components are displayed in a list
on the left in the video window or presentation window respectively. As default
there is only one component initially, the Root Component.

)

In acquisition and presentation mode, you can show and hide the scan
points allocated to a component. This does not affect the average
spectrum of the points.
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Edit
components

To edit the root component or any other component, click the component with
the right mouse button and select Edit in the context menu. The dialog Edit
Component appears.

Figure 5.12: Dialog Edit Component

Name: Here you enter the desired name for the component.
Description: Here you can add a text to describe the components more
precisely.

)

Add component

To add a component, with the right mouse button click the component below
which you want to add a new component and select Add in the context menu.
You can also click the components with the left mouse button and then press
the Insert key. The software generates a New Component at the required
position. You can edit this component as described above.

)
Remove
component

You can create any structure for the components.

To remove a component, click the required component with the right mouse
button and select Remove in the context menu. You can also click the
components with the left mouse button and then press the Delete key. If you
press the key combination Shift + Delete, the selected component will be
deleted without inquiry.

)
Assign scan
points

If you only want to change the name of the component, click the
component with the left mouse button and then press the key F2. Enter
the new name.

Scan points that were assigned to deleted components are automatically
assigned to the root component.

To assign the individual geometry components scan points, proceed as
follows:
1. Select the scan points you want to assign to a geometry component as
described in SECTION 5.4.1.
2. Select the component which the scan points should belong to. To do so,
click the component with the right mouse button and select Add Selected
Points in the context menu.
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3. Repeat these two steps until all scan points have been assigned to the
required components.

)

Scan points which you have not assigned to any other component are
always automatically assigned to the root component.

Show and hide
scan points

To show and hide the scan points of individual components, activate or
deactivate the corresponding check box in front of the component name.

Select scan
points of a
component

To select the scan points of a component, click the component with the right
mouse button and select Select Points in the context menu. You can also
double-click the component.

)
Select all scan
points of a
component

To select the scan points of several components, double-click the required
components while pressing the control key.

To select all scan points of a component, i.e. the scan points of the secondary
components as well, click the component with the right mouse button and
select Select All Points in the context menu.

5.5 Carrying out a Geometry Scan (as an Option)
Using the following measurement systems, you can carry out a geometry
scan:
•
•

PSV or PSV-3D with the geometry scan unit, refer to SECTION 5.5.1
MSA-500 with the option MSAGeo, refer to SECTION 5.5.2

5.5.1 PSV or PSV-3D with the Geometry Scan Unit
If you are using the scanning head PSV-I-400 with the optional geometry scan
unit PSV-A-420, you can determine the distance between the scanning head
and the object, even if you do not know the object geometry.

)

If you are using the PSV-3D, then the geometry scan unit is on the
scanning head Top.

You can use the geometry scan unit to assign 3D coordinates to scan points.
To do so, first of all define the scan points as described in CHAPTER 5 and then
determine the 3D coordinates of the scan points.
The geometry scan unit provides the scanning head with a second laser apart
from the vibrometer laser to determine the object geometry. In contrast to the
vibrometer laser, the geometry laser can not be focused. This means that in
general it generates a larger spot of light than the vibrometer laser. To check
whether the laser is also hitting the required points at the edges or periphery
of the object under investigation, you can switch over to the geometry laser at
any time. If the spot of light from the geometry laser only partially hits the
object, it is not possible to make a distance measurement and you have to
correct the laser position again. Apart from that, with the aid of the geometry
laser you can check and see if your scanning head is still adjusted correctly. If
both laser beams with the same setting do not hit the same point on the
object, then the scanning head is probably misaligned.
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Geometry laser

To switch between the vibrometer laser and the geometry laser, select Scan >
Geometry Laser.

Geometry point

To make a distance measurement between the scanning head and the object,
position the laser beam at any point on the object and select Scan >
Geometry Point. The software will make a distance measurement to this point,
will calculate the x-, y- and z-coordinates of this point from the results of this
measurement and the current mirror angles and will display these
coordinates.

Figure 5.13: Display of the coordinates for the PSV or PSV-3D

If there is a valid 3D alignment, then the coordinates are given in the object
coordinate system that you defined through the 3D alignment. Otherwise the
coordinates are given in the scanning head system which you can define as
described in SECTION 4.1.1 under Enter coordinates of axes.
Geometry scan
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To scan an object, the 3D geometry of which is not yet known by the software,
select Scan > Geometry Scan. If applicable, the software switches over to the
geometry laser automatically. The geometry laser is positioned at every scan
point, measures the distance from the scanning head and determines every x, y- and z-coordinate as described above under Geometry Point. If the
software has determined the coordinates of all scan points, you can check the
geometry by switching to the 3D view. You also can check individual
coordinates of the scan points by selecting the corresponding scan point and
reading the coordinates in the scanning head control. Afterwards you can
start a scan. When you start, it automatically switches over to the vibrometer
laser.

)

A prerequisite for a geometry scan is a valid 3D alignment.

)

If the geometry scan has not been carried out correctly or you have
canceled it, you will get a status report (refer to FIGURE 5.14). You can
decide whether to finally abort the geometry scan or whether to
remeasure the remaining scan points or to have them interpolated. See
SECTION 7.2 or SECTION 9.1 and your theory manual on this. Independently
of whether you have carried out the geometry scan or have aborted it, you
can subsequently check the status of the scan points and if necessary
take further measures. See SECTION 5.4.1 and SECTION 7.3 on this.
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Figure 5.14: Status report if geometry scan is incomplete

The 3D coordinates of the geometry points are determined in the coordinate
system of the alignment points (object system). The coordinates are
displayed in the element 3D Point.
Filter

The geometry scan unit is equipped with a filter which you can use to weaken
the intensity of the laser beam.
Usually you initially make a distance measurement (Geometry Point) without
this filter. If the scanning head is receiving too much light, you will be advised
to use the filter. In this case switch the filter on. If you are using a geometry
scan unit without a toggle switch, the filter is switched on or off in the
software. To do so, click the box Filter in the scanning head control. If you are
using a geometry scan unit with a toggle switch FILTER, the filter is switched
on or off on the geometry scan unit. See your hardware manual on this.
If you are using a geometry scan unit without a toggle switch, then initially the
scan is carried out without this filter for a geometry scan. If the scanning head
receives too much light at some scan points, these scan points are
automatically remeasured with the filter switched on.

Transform 2D
geometry to 3D
geometry

You can transform the 2D geometry of a three-dimensional object into 3D
geometry. Prerequisite is that you have previously performed a 3D alignment.
To transform 2D geometry into 3D geometry, then start a geometry scan. This
makes the three-dimensional geometry of the object known to the software.
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5.5.2 MSA-500 with the Option MSAGeo
If you are using the MSA-E-500 junction box with the MSA-I-500 scanning
head, you can determine the position of the focus point on the z-axis, even if
you do not know the object geometry.
You can use the option MSAGeo to assign 3D coordinates to scan points. To
do so, first of all define the scan points as described in CHAPTER 5 and then
determine the 3D coordinates of the scan points.
Geometry point

To make a geometry point measurement, position the laser beam at any point
on the object and select Scan > Geometry Point. The software will calculate
the x-, y- and z-coordinates of this point from the results of this measurement
and the position of the z-axis in the measurement microscope and will display
these coordinates.

Figure 5.15: Display of the coordinates for the MSA

If there is a valid 3D alignment, then the coordinates are given in the object
coordinate system that you defined through the 3D alignment. Otherwise the
coordinates are given in the scanning head system which you can define as
described in SECTION 4.5.7.
Geometry scan
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To scan an object, the 3D geometry of which is not yet known by the software,
select Scan > Geometry Scan. The software focuses the laser beam at every
scan point, measures the position of the z-axis in the measurement
microscope and determines every x-, y- and z-coordinate as described above
under Geometry point. If the software has determined the coordinates of all
scan points, you can check the geometry by switching to the 3D view. You
also can check individual coordinates of the scan points by selecting the
corresponding scan point and reading the coordinates in the scanning head
control. Afterwards you can start a scan. When you start, it automatically
switches over to the vibrometer laser.

)

A prerequisite for a geometry scan is a valid 3D alignment.

)

If the geometry scan has not been carried out correctly or you have
canceled it, you will get a status report (refer to FIGURE 5.14). You can
decide whether to finally abort the geometry scan or whether to
remeasure the remaining scan points or to have them interpolated. See
SECTION 7.2 or SECTION 9.1 and your theory manual on this. Independently
of whether you have carried out the geometry scan or have aborted it, you
can subsequently check the status of the scan points and if necessary
take further measures. See SECTION 5.4.1 and SECTION 7.3 on this.
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The 3D coordinates of the geometry points are determined in the coordinate
system of the alignment points (object system). The coordinates are
displayed in the element 3D Point.
Transform 2D
geometry to 3D
geometry

You can transform the 2D geometry of a three-dimensional object into 3D
geometry. Prerequisite is that you have previously performed a 3D alignment.
To transform 2D geometry into 3D geometry, then start a geometry scan. This
makes the three-dimensional geometry of the object known to the software.

5.6 Teaching-in Focus Values (as an Option)
You have the option of assigning focus values to the scan points. This makes
it easier to focus if several objects are to be scanned which are at different
distances from the scanning head, or if the object has three-dimensional
geometry. A focus value is determined when focusing automatically. You have
the option of saving the focus values determined in this way with the object
geometry. They can then be used for any number of measurements, providing
the object geometry remains the same. Teaching-in the focus values is only
available if you have the option APS Professional.
There are different ways of assigning focus values to the scan points:
•
•

Assigning focus values manually, refer to SECTION 5.6.1 (single scan
points)
Assigning focus values automatically, refer to SECTION 5.6.2 (all scan
points, fast or optimal or calculate automatically)

5.6.1 Assigning Focus Values Manually
You can manually assign focus values to single scan points. This is
particularly useful if the object under investigation is made up of one or more
planes which are equidistant from the scanning head, i.e. the object is not at
an angle to the scanning head.
Assign a focus
value

To assign a focus value manually, proceed as follows:
1. Use the middle mouse button to position the laser beam at the point at
which you want to determine the focus value and then click

)

.

If you have assigned a special function to the middle mouse button (e.g.
double-click), position the laser beam using the icons Position in the
scanning head control.

2. Select the scan points which you want to assign a focus value to as
described in SECTION 5.4.1.
3. Click one of the scan points with the right mouse button and select Assign
Focus Manual in the context menu. The focus value determined
previously is assigned to all selected scan points.

)

If you click next to the selected scan points with the right mouse button,
you select Modify Selected Points and then Assign Focus Manual in the
context menu.

4. You can now check the focus settings as described in

SECTION

5.6.3.
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5. Then you can start a scan.

)

If you have not assigned focus values to all scan points, when the scan
starts you will be given the message that not all scan points have a valid
focus value. You can repeat Assign Focus Manual or start the scan
anyway.

Reset focus
value

To reset a manually assigned focus value, click the scan point with the right
mouse button and select Clear Focus Values in the context menu.

Interpolating
focus values

To interpolate the focus values of the selected scan points, select Interpolate
Focus Values. The focus values of the selected scan points are interpolated
linearly from the focus values of the adjacent points.

5.6.2 Assigning Focus Values Automatically

)

Automatically assigning focus values is not used for the MSA as the focus
values will already be assigned during the geometry scan.

Calculate
automatically

If, for the scan points 3D coordinates are existent, you can automatically
calculate all focus values of the scan points based on the focal length of the
lens in the scanning head and their distance to the scanning head. To do so,
mark the respective box in the dialog Preferences on the page Geometry
(refer to SECTION 3.4). If you do not know the focal length of the lens, then you
will have to calculate it. To do so, start a scan with the function Assign Focus
Fast or Assign Focus Best. Every scan point is assigned a focus value. Then
click Calculate. The focal length of the lens is entered and used for calculating
the focus values.

Assign Focus
Fast

Select Scan > Assign Focus Fast to assign a focus value to all scan points
quickly. Scan points at different distances from the scanning head are
approached using one scanning head (PSV) or all three scanning heads
(PSV-3D) and are automatically focused. For the PSV, you have to enter the
correct coordinates for the distance in the element 2D Point in the scanning
head control before you use Assign Focus Fast (refer also to SECTION 4.1).

)

This method is only suitable for level surfaces which are positioned at
right angles to the laser beam.

In contrast, for the PSV-3D and for 3D geometries in the PSV which have
been imported or determined by a geometry scan, the precise position of the
scan points is used. The focus values for all other scan points are then
calculated by the software.
Assign Focus
Best

Select Scan > Assign Focus Best to automatically focus all scan points
respectively and to assign them a focus value. This can take up to 10 seconds
per scan point. For the PSV-3D focusing is done with all three scanning heads
at the same time.

)
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If you abort Assign Focus Best, the focus values determined until then are
saved and used for the subsequent scan. For all scan points which have
not had a focus value determined, the focus value last set is used for a
scan. The function Focusing during Scan is not activated.
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Assign focus
values

To automatically assign focus values to all scan points, proceed as follows:
1. Select Scan > Assign Focus Fast or Scan > Assign Focus Best. The scan
points are focused automatically as described above and the focus values
are saved with the object geometry.
2. In the menu Scan, Focusing during Scan is activated by the software. This
has the effect that during a scan, the focus values are set for every scan
point using the optics.
3. You can now check the focus settings as described in

SECTION

5.6.3.

4. Then you can start a scan.

)

If you have canceled Assign Focus Best, when the scan starts, you will be
given the message that not all scan points have a valid focus value. You
can repeat Assign Focus Best or start the scan anyway.

5.6.3 Checking the Focus Settings
If you click a scan point and leave the mouse cursor there, then the focus
values of this scan point are displayed on a yellow background next to the
cursor. The current focus value is shown as a percentage and as an absolute
value. The value 0% (0) means that the optics in the scanning head have
been moved right to the end in the direction close-up (N). The value 100%
(3 300) means that the optics in the scanning head have been moved right to
the end in the direction infinity (F).
At the same time the optics are set to the focus value of this scan point.
If the focus values are not to be taken into consideration during scanning,
select Scan > Focusing during Scan to deactivate focusing during a scan.
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6 Parameters for Data Acquisition
There are several ways for you to set the parameters for data acquisition. See
SECTION 6.1 on this.
You will find a description of all parameters in

SECTION

6.2.

6.1 Setting the Parameters
To set the parameters for data acquisition, you have the following options:
•
•
•

In the status bar
In the dialog Acquisition Settings
By loading the settings from a file

Status bar

You can set some parameters on the right in the status bar. The parameters
which are shown there depend on the measurement mode set. To see which
parameters they are, point at a setting and leave the cursor there for a
moment. The parameter is then shown on a yellow background next to the
cursor and also on the left in the status bar. To set a parameter, click the
arrow on the right of it and select the required setting in the context menu.

Dialog

You can set all parameters in the dialog Acquisition Settings. To do this,
proceed as follows:
1. Click
or select Acquisition > Settings. The dialog appears. It consists
of several pages each with a group of parameters respectively. To display
a certain page, click the name of the group.
2. Display the page General and set the parameters. You will find information
on this in SECTION 6.2.1. The pages in the dialog can change with the
measurement mode selected.
3. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
4. When you have set all parameters, click OK.

File

You can load settings from setting files and measurements. See
SECTION 10.1.4 on this. You can save the current settings as described in
SECTION 10.2.7.
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6.2 Description of the Parameters
The individual measurement parameters are described in detail in the
following sections:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Measurement mode and averaging on the page General, refer to
SECTION 6.2.1
Channel allocation on the page Channels, refer to SECTION 6.2.2
Filter settings on the page Filter, refer to SECTION 6.2.3
Frequency settings in measurement mode FFT on the page Frequency,
refer to SECTION 6.2.4
Windowing of the input signals on the page Window, refer to SECTION 6.2.5
Trigger settings on the page Trigger, refer to SECTION 6.2.6
Signal Enhancement and Speckle Tracking on the page SE, refer to
SECTION 6.2.7
Vibrometer settings on the page Vibrometer, refer to SECTION 6.2.8
Generator settings on the page Generator (as an option), refer to
SECTION 6.2.9
Frequency settings in measurement mode Zoom-FFT (as an option) on
the page Frequency, refer to SECTION 6.2.10
Settings to the measurement mode FastScan (as an option), refer to
SECTION 6.2.11
Settings to the measurement mode Time (as an option), refer to
SECTION 6.2.12
Settings to the measurement mode MultiFrame (as an option), refer to
SECTION 6.2.13
Frequency settings in measurement mode MultiFrame (as an option) on
the page Frequency, refer to SECTION 6.2.14

6.2.1 General
On the page General, you set the measurement mode, averaging and
automatic remeasuring.

Figure 6.1: Page General
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Measurement
Mode

On the left you select the measurement mode. The measurement mode FFT
is available as standard, all others are optional. The pages in the dialog can
change with the measurement mode selected. If, for example, you select the
measurement mode FastScan, then a page appears with parameters for
FastScan. Other pages disappear.

Averaging

On the right you set the averaging. In measurement modes FastScan and I / Q
(only with option VDD) you can not average. By averaging you can improve
the signal-to-noise ratio of spectra. You will find detailed information on
averaging in your theory manual.
Off: You do not average.
Magnitude: Select magnitude averaging if you
•

are neither using a reference signal nor a trigger

or
•

are using stochastic excitation – for example, in a wind tunnel.

Complex: Select complex averaging if you
•

are using a reference signal or a trigger

and
•

are using deterministic excitation.

On the right you enter the number of averages. The time needed for a
measurement will increase by this factor.
Peak Hold: Select Peak Hold for averaging if you want to calculate and
display the respective maximum of the spectra over the set number of
averages.

)

Peak Hold is not available in the measurement mode Time.
If you select Peak Hold averaging, you can not make any further quality
adjustment for Signal Enhancement (Fast ... Best, refer to SECTION 6.2.7).

You will find more information on the measurement mode Peak Hold in your
theory manual.
Time: In measurement mode Time you can only select Time averaging. A
prerequisite for this is that you trigger the measurements.

)

Please note that spectra and time signals with the Scan Status Overrange
are not taken into account when averaging. But if all spectra previously
acquired have the status Overrange, then first of all these spectra will be
averaged and displayed. Only when the first spectrum will be captured
without Overrange, the average counter is reset and the previously
measured spectra with the status Overrange are rejected. Any other
spectra with the status Overrange are then also rejected.
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Remeasure

At the bottom you can activate automatic remeasuring. After a scan all the
scan points with the status Overrange, Invalidated and Not Measured are
then remeasured at a slightly different position. If Signal Enhancement is
active for at least one channel (refer to SECTION 6.2.7), then scan points with
the status Valid are also remeasured in the measurement modes FFT,
ZoomFFT and MultiFrame.

)

You can also start remeasuring manually. See SECTION 7.2 on this. After
changing from acquisition to presentation mode you can also identify
single scan points to be remeasured. See SECTION 9.1 on this.

Principal
With the option PCA (Principal Component Analysis) you can make a MIMO
Component
data acquisition. To do so, mark the box Principal Component Analysis
Analysis (MIMO) (MIMO) in the lower part of the dialog.

)

So that you can start MIMO data acquisition, you have to have selected
Magnitude or Complex as averaging. On the page Channels specify at
least two reference channels and on the page Generator tick the box
Multiple Channel (refer also to SECTION 6.2.2 and SECTION 6.2.9).

You will find more information on MIMO data acquisition in your theory
manual.
6.2.2 Channels
On the page Channels you activate the required measurement channels and
set their parameters for digital data acquisition. For certain hardware
configurations and measurement modes, parameters on the page are not
available or are set permanently.
Work in the
table

To accelerate adjustment of the settings, you can use the icons
and

(Copy)

(Insert) above the table. To do so, tick the required cell(s), line(s) or

column(s) as described in the following. Then click

, mark the cell(s),

line(s) or column(s) which you want to transfer the settings to and click

.

Or:
Click with the right mouse button and select Copy or Insert in the context
menu.
•
•
•
•

•

•
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To mark a cell, click it.
To mark a line, click the first cell of this line.
To mark a column, click the head of this column.
To mark several consecutive cells, lines or columns, hold the shift key
pressed and mark the first and last cell /start of line / column head with the
mouse.
To mark several cells, lines or columns which are not consecutive, hold
the control key pressed and mark the respective cells /starts of line /
column heads with the mouse.
If you want to mark the whole table, click the cell Channel.
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In the same way you can copy settings into and out of other applications such
as Microsoft® Excel.

Figure 6.2: Page Channels

Channel: Here the channels are displayed that are available to you for your
system.

)

For the PSV-3D, the channels Vibrometer 3D and Reference 1 as well as
Reference 21 to Reference 24 are available to you.
If you want to operate the PSV-3D as a pure PSV-1D (junction box PSV-E40x-1D), then the allocation of the channels displayed does not match the
names on the junction box. Pay attention to the following allocation:
Vibrometer corresponds to VELO TOP, Reference 1 corresponds to VELO
LEFT, Reference 2 corresponds to VELO RIGHT and Reference 3
corresponds to REF.

Active: Here you mark the channels you want to make measurements on.
Ref: This column only appears if there are more than two input channels
available in the software. A channel is either an answer channel or a
reference channel. The channel Vibrometer is always an answer channel.
For systems with two channels the channel Reference 1 is always a reference
channel. For systems with more than two channels you can select which
channel is the reference channel (apart from Vibrometer). To do so, mark it in
the column Ref. If the column Ref is not marked for one channel, it is used as
the answer channel, even if it is called Reference.
The first reference channel is given special treatment. It serves as a phase
reference for the other channels if you
•
•

average magnitudes (refer to SECTION 6.2.1) or
do not use a trigger (refer to SECTION 6.2.6).

When calculating the frequency response function, all possible combinations
of type answer channel / reference channel are formed.
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Example:
Vibrometer & Reference 1: answer channels
Reference 2 & Reference 3: reference channels
The following signals are available as frequency response function:
Vibrometer / Reference 2
Vibrometer / Reference 3
Reference 1 / Reference 2
Reference 1 / Reference 3
When using more than one reference channel, frequencies are respectively
formed as a total answer signal / reference signal. This is correct with an
excitation signal and several reference signals (e.g. self-excited system,
vibrometer and microphone as reference).

)

When using the measured frequency responses for Experimental Modal
Analysis, please note that these can not easily be fed in to a multireference procedure in the modal analysis software package. To do this, it
is also necessary to determine the transmission function. For these
calculations the total answer signal of every individual sample point must
be divided up into the individual references (Principal Component
Analysis, only with option PCA). This is only possible if the reference
signals are uncorrelated (refer also to SECTION 6.2.9). If you are running a
principal component analysis, you have to select at least two reference
channels. You will find detailed information on this in your theory manual.

Index: Here you enter the index of the scan point at which you are measuring
the reference. You can read this index under 2D Point or 3D Point in the
scanning head control if you click the scan point with the mouse. Then click
the pertinent line in the column Index and enter the displayed value there.

)

The default setting in the column Index is 0. A reference point index of 0 is
however ignored when calculating the reference. In principle the number
of scan points is the highest possible value which you can enter in the
field Index. However, the software allows you to enter higher values so
that you can make several measurements with the same index and then
can reunite them in an external program.

Direction: Here you can enter the direction of the vibration. The default
setting is +Z. However you can also select another direction (± X / Y / Z) for all
channels apart from Vibrometer 3D. With the direction of the vibrometer
channel you set the orientation of the scanning head system. See
SECTION 4.5.3 and your theory manual on this.
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)

In the presentation window you can also retrospectively change the
vibrational direction, see SECTION 9.1 on this.

)

The values from the columns Index and Direction are used when
exporting in UFF and ME’Scope. You can change the settings for export
again (refer to SECTION 10.2.3 and SECTION 10.2.4).
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Range: Here you select the input range of the data acquisition board for
every channel.
Coupling: Here you select the input coupling for every channel. For
vibrometer channels you have to set DC coupling, for other sensors DC
coupling is recommended. Only PSV-200-1: For certain hardware
configurations, select the input coupling via the cabling of the data acquisition
board. See your PSV-200 hardware manual on this.
Impedance: This column is only shown if the Spectrum data acquisition board
MI-3025 is installed. In this case you can set the input resistance of the board
here (50 Ω or 1 MΩ).
ICP: If you are using one of the junction boxes VIB-Z-012, VIB-Z-016,
PSV-E-40x or PSV-E-40x-3D and in the list Junction Box on the page Devices
you have set it accordingly, you can switch ICP® on and off for the channel
REF or REF 1 and if applicable, for REF 2, REF 3 and REF 21 to REF 24.

)

If you are using such a junction box and have activated ICP®, then we
recommend to use DC coupling as for frequency response measurements
you should select the same coupling for all channels. While doing so, pay
attention that with ICP® being activated a high pass filter with an extreme
low cutoff frequency (0.02 Hz) is automatically switched on. The settling
time of the high pass filter can take several minutes meanwhile exceeding
the measurement range is indicated.

Quantity: Here you select the physical quantity which you want to measure
on the respective channel.

)

Using a digital filter, the software can integrate or differentiate the time
signal of some measured quantities. See SECTION 6.2.3 on this.
If the quantity Displacement, Velocity or Acceleration is selected, then the
spectra of both the others are calculated by integration or differentiation.
This also applies to the quantities Angle, Angular Velocity and Angular
Acceleration.

Factor: Here you enter the calibration factor for every channel, i.e. the
measurement value which corresponds to an analog input signal of one volt. If
a vibrometer is connected up (refer to SECTION 3.2), the software will enter the
calibration factor for this channel corresponding to the measurement range
set on the page Vibrometer (refer to SECTION 6.2.8).
Unit: Here, the software enters the SI unit of the set quantity.
Differential Input: If you are using one of the junction boxes VIB-Z-012,
VIB-Z-016, PSV-E-40x or PSV-E-40x-3D, then here you can activate the
differential input for all selected channels. You can thus avoid ground loops
and generally improve reliability. All activated channels are switched to
ungrounded by the differential input so that distortions through harmonics of
the mains frequency (humming) can no longer appear in the spectrum.
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6.2.3 Filters
On the page Filters you set the digital filters for the input signals
•

to limit the bandwidth

and
•

for differentiation or integration.

The page Filters is divided into two parts. In the first part you select the filter
type to limit the bandwidth – high pass, low pass etc. – and select the
integration or differentiation filter. In the second part you set the filter
parameters to limit the bandwidth, i.e. cutoff frequency and quality. You can
also see the frequency response there.
Work in the
table

To accelerate adjustment of the settings, you can use the icons
and

(Copy)

(Insert) above the table. To do so, tick the required cell(s), line(s) or

column(s) as described in the following. Then click

, mark the cell(s),

line(s) or column(s) which you want to transfer the settings to and click

.

Or:
Click with the right mouse button and select Copy or Insert in the context
menu.
•
•
•
•

•

•

To mark a cell, click it.
To mark a line, click the first cell of this line.
To mark a column, click the head of this column.
To mark several consecutive cells, lines or columns, hold the shift key
pressed and mark the first and last cell /start of line / column head with the
mouse.
To mark several cells, lines or columns which are not consecutive, hold
the control key pressed and mark the respective cells /starts of line /
column heads with the mouse.
If you want to mark the whole table, click the cell Channel.

In the same way you can copy settings to and from Microsoft® Excel.
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Select

In the first part of the page Filters you select the filter types you want for each
channel.

Figure 6.3: Page Filters, part 1 to select the filter

Filter Type: Here you select the type of filter to limit the bandwidth.
Definition: You click here to set the filter parameters to limit the bandwidth.
The second part of the page Filters appears (see below).
Int / Diff Quantity: Using digital filters, the software can integrate or
differentiate the time signal of some measured quantities. Here you select the
physical quantity the software is to calculate. The number on the right next to
the quantity tells you which arithmetic operation is being carried out, refer to
TABLE 6.1.
Table 6.1:

Filters for integration / differentiation

Number

)

Arithmetic operation

1

Integrate once

0

No filter

-1

Differentiate once

-2

Differentiate twice

During integration and differentiation a time delay of half the sample time
occurs (sample time = 1 / sample frequency). This leads to a frequencydependent phase shift. In case of a differentiation done twice, no time
delay occurs.
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Set the
parameters

In the second part of the page Filters you set the filter parameters to limit the
bandwidth. There you can define the filters for several channels one after the
other.

Figure 6.4: Page Filters, part 2 to set the parameters

Channel: Here you select the channel you want to set the filter for.
Filter Type: Select the type of filter here.
Quality: Here you select the quality of the filter.
Cutoff Frequencies: Enter the cutoff frequency( / ies) of the filter here in
Hertz.
The software uses the parameters set to calculate the frequency response
and displays it.
To apply all settings, at the bottom right, click Back. The software returns to
the first part of the page Filters (see above).
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6.2.4 Frequency
You set the parameters for calculating the frequency spectra on the pages
Frequency and Window. In the measurement mode Zoom-FFT, the page
Frequency is adapted to the Zoom-FFT. See SECTION 6.2.10 on this. In
measurement mode MultiFrame, additional parameters appear on the page
for the MultiFrame measurement. See SECTION 6.2.14 on this.

Figure 6.5: Page Frequency in measurement mode FFT

Frequency
range

At the top left you set the frequency range to be measured.
Bandwidth: Here you select the bandwidth in kilohertz.
From and To: Here you can limit the frequency range which is displayed and
evaluated. If you control a function generator using the software, then with
Periodic Chirp and Pseudo Random, excitation only takes place in this
frequency range.

FFT

At the bottom you set the parameters for the Fast Fourier Transformation
(FFT).
FFT Lines: Here you select the number of FFT lines that you want to analyze
(up to 6 400 or up to 12 800 as an option).

)

As an option to the 12 800 FFT lines, you can still select up to 819 200 FFT
lines. Please note that if you are using this high number of FFT lines
together with selecting many channels, your system can use its full
capacity. Depending on the configuration of your system it is then not
possible to use all settings.

Used: The number of FFT lines shown here corresponds to the frequency
range between From and To (see above).
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Overlap: This parameter only appears for certain hardware configurations in
the measurement modes FFT and Zoom-FFT. The software only takes the
parameter into account for measurements with averaging and without trigger.
With overlap you can significantly reduce the time for a measurement, in
particular for narrow bandwidths. As a rule of thumb, for a two-channel
measurement, the following applies:
•
•
•

Up to 2.5 kHz bandwidth: 75% overlap
From 2.5 to 5 kHz: 50%
Over 5 kHz: 0%.

You will find more information on overlap in your theory manual.
Sample
frequency and
resolution

The software calculates the following parameters and shows them at the top
right.
Sample Frequency:

f Sample = 2.56 ⋅ BW

Equation 6.1

n FFT
t Sample = --------BW

Equation 6.2

1
Δf = -------------t Sample

Equation 6.3

BW … Bandwidth
Sample Time:
nFFT … Number of FFT lines
BW … Bandwidth
Resolution:
tSample … Sample time
Max. Velocity: This parameter only appears with the option VDD. Due to the
processing power of the PC, when using the option VDD only signals up to
this maximum vibrational velocity can be acquired. The value depends on the
bandwidth and the number of FFT lines (see above).
6.2.5 Window
You set the parameters for calculating the frequency spectra on the pages
Frequency and Window.You set windowing of the input signals on the page
Window. With suitable windowing you can prevent leakage. You will find
information on this in your theory manual.
Work in the
table

To accelerate adjustment of the settings, you can use the icons
and

(Copy)

(Insert) above the table. To do so, tick the required cell(s), line(s) or

column(s) as described in the following. Then click

, mark the cell(s),

line(s) or column(s) which you want to transfer the settings to and click
Or:
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Click with the right mouse button and select Copy or Insert in the context
menu.
•
•
•
•

•

•

To mark a cell, click it.
To mark a line, click the first cell of this line.
To mark a column, click the head of this column.
To mark several consecutive cells, lines or columns, hold the shift key
pressed and mark the first and last cell /start of line / column head with the
mouse.
To mark several cells, lines or columns which are not consecutive, hold
the control key pressed and mark the respective cells /starts of line /
column heads with the mouse.
If you want to mark the whole table, click the cell Channel.

In the same way you can copy settings to and from Microsoft® Excel.

Figure 6.6: Page Window

Function: Here you select a window function which is suitable for your
application. See your theory manual on this.
Parameter: The window functions Tapered Hanning, Force and Exponential
can be fine-tuned with a parameter. In TABLE 6.2, the parameters are
described.
Table 6.2:

Parameters for window functions

Window function

Description of the parameter

Default

Tapered Hanning

Rise and decay time in percent of the sample
time

10

Force

Length of the window in percent of the sample
time

5

Exponential

Quotient from window length and decay
constant

4
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6.2.6 Trigger
You set the parameters for triggering on the page Trigger. You will find
information on the influence of the trigger in your theory manual.

Figure 6.7: Page Trigger

Source

On the left you select the trigger source.
Off: You measure without a trigger.

)

To measure phases you need a trigger or a reference signal.

External (TTL): You trigger on an external trigger signal.

)

Depending on the data acquisition board, using external trigger signals is
not available for all bandwidths or sample frequencies (refer also to
TABLE 6.3).
CAUTION !
Danger from too high voltage ! - Only connect voltages in the range of 0 to
5 V to the input for the external trigger ! Otherwise you could damage the data
acquisition board.

Analog: You trigger on one of the analog input signals. Select the channel the
trigger signal is connected to below.

)
Conditions

When scanning, do not trigger on the vibrometer signal.

On the right you set the trigger conditions.
Rising or Falling: Here you select which edge is used to trigger.
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Level: If you trigger using one of the analog input signals, you set the trigger
threshold here. 100% threshold corresponds to the input range of the channel
(refer to SECTION 6.2.2).
Pre-trigger: Here you set the trigger time. If the data acquisition is to start
before the trigger time, enter a positive value. If data acquisition is to start
after the trigger time (Post-trigger), enter a negative value.

)

If you are using the analog trigger, no limitations exist. You will find the
limitations for using the external trigger in the following table. If you do not
keep the limitations, the external trigger will be switched off.

Table 6.3:

Limitations for using the external trigger

System

Data acquisition
board

PSV-400-B

PCI-4451

no limitation

PSV-400-B

PCI-4461

only up to 12 800 FFT lines
only up to 1 048 576 samples

PSV-400-H4

PCI-4452

only up to 40 kHz bandwidth or
only up to 102.4 kHz sample frequency

PSV-400-H4

PCI-4462

only up to 12 800 FFT lines
only up to 1 048 576 samples

PSV-400-M2

PCI-6111

no pre-trigger

PSV-400-M4

PCI-6110

no pre-trigger

PSV-400-M2-20

MI.3025

> 2 MHz bandwidth: no limitation
≤ 2 MHz bandwidth: no pre-trigger

PSV-400-3D

PCI-4452

only up to 40 kHz bandwidth or
only up to 102.4 kHz sample frequency

PSV-400-3D

PCI-4462

only up to 12 800 FFT lines
only up to 1 048 576 samples

MSA-500-M2

PCI-6111

no pre-trigger

MSA-500-M2-20

MI.3025

> 2 MHz bandwidth: no limitation
≤ 2 MHz bandwidth: no pre-trigger

MSA-400-M2

PCI-6111

no pre-trigger

MSA-400-M2-20

MI.3025

> 2 MHz bandwidth: no limitation
≤ 2 MHz bandwidth: no pre-trigger

MSV-400-M2

PCI-6111

no pre-trigger

MSV-400-M2-20

MI.3025

> 2 MHz bandwidth: no limitation
≤ 2 MHz bandwidth: no pre-trigger

PSV-300-U

PCI-4451

no limitation

PSV-300-H

PCI-4452

only up to 40 kHz bandwidth or
only up to 102.4 kHz sample frequency

PSV-300-F

PCI-6111

no pre-trigger

MSV-300-F

PCI-6111

no pre-trigger

MSV-300-M

MI.3025

> 2 MHz bandwidth: no limitation
≤ 2 MHz bandwidth: no pre-trigger

Limitation
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Gate signal (as
an option)

As an option, you can control data acquisition with an external gate signal.
You will find information on this in your hardware manual. You do not have to
set special parameters for this.

6.2.7 Signal Enhancement (SE)
On the page SE you set the parameters for Signal Enhancement (SE) and
Speckle Tracking. When scanning, with Signal Enhancement and Speckle
Tracking, you get an approximately even noise level for all scan points. You
will find information on measuring with Signal Enhancement in SECTION 7.8.1
and in your theory manual.

)

If you want to mark the whole table, click the cell Channel.

Figure 6.8: Page SE

)

Activate

On the left you can activate Signal Enhancement.

)
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The measurement mode Time is an exception. The dialog page SE only
appears if on the page General you have set Time for Averaging. For
PSV-400-H4 and PSV-400-3D this page always appears.

Measurement mode Time with averaging Time: With active SE, a median
algorithm is used for averaging. This makes higher demands on your PC
with regards to memory and calculation speed.
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Channel: Here you mark the channels which Signal Enhancement is to be
active for. For PSV-400-H4 and PSV-400-3D here you additionally activate
dropout detection and elimination. You will find more information on this in
SECTION 7.8.1.

)

Activate Signal Enhancement for all channels which may have dropouts.
This is generally the case for the vibrometer channel. For reference
channels, the following applies: If a vibrometer is connected, measure on
treated surfaces if possible and switch Signal Enhancement off. To treat
surfaces, stick reflective film on them or apply metallic paint. If you are
measuring with the vibrometer, but not on treated surfaces, activate
Signal Enhancement.

Speckle Tracking: If Signal Enhancement is active for the vibrometer
channel, then you can activate Speckle Tracking for this channel on the right.
Without Speckle Tracking, every scan point is measured at the same position
when averaging. So it is possible that you will always measure a dark
speckle. With Speckle Tracking, the position of every scan point is slightly
changed on averaging - at a 1 meter stand-off distance by about 50 μm. You
are then also quite likely to measure some bright speckles.
Averaging

At the right you set how often additional averaging is carried out with Signal
Enhancement.

)

Please note that spectra and time signals with the Scan Status Overrange
are not taken into account when averaging. But if all spectra previously
acquired have the status Overrange, then first of all these spectra will be
averaged and displayed. Only when the first spectrum will be captured
without Overrange, the average counter is reset and the previously
measured spectra with the status Overrange are rejected. Any other
spectra with the status Overrange are then also rejected.

Fast: Averaging is only carried out as often as set on the page General (refer
to SECTION 6.2.1).
Standard: Depending on the optical signal level, averaging is carried out up
to three times as often as set.
Best: Averaging is carried out up to five times as often as set.
In the measurement mode Time, the number of times averaging is carried out
always corresponds to the figure given on the page General.
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6.2.8 Vibrometer
You set the parameters of the controller for data acquisition on the page
Vibrometer. You will find information on suitable settings in your hardware
manual. If you are controlling a second vibrometer, then you set the
parameters for both controllers on the page Vibrometer. You will find
information on controlling a second vibrometer in SECTION 7.8.6.
The parameters displayed on the page Vibrometer depend on which
controllers are connected (refer to SECTION 3.2). The parameters for the
controllers OFV-5000 and also OFV-3001 and OFV-3001S are described
below. If you would like any information on other controllers, refer to your
vibrometer manual. There you will also find information on suitable settings.

Figure 6.9: Page Vibrometer for the controller OFV-5000

Figure 6.10: Page Vibrometer for the controller OFV-3001 S
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Controller: Here you can select the controller which the settings are to apply
to. If there are two controllers installed, you can switch between the two of
them and define the settings for each of them individually.

)

Only OFV-5000 as of firmware version 2.0:
The software queries the time delay of the measurement range set on the
vibrometer controller. The time delay is used to correct the phase of the
spectra. The high and low pass filter should be left switched off as their
delay times are not being corrected.
The correction can only be made approximately. The remaining phase
error in the acoustic area is up to 3° and increases for frequencies above
20 kHz with increasing frequency up to 35°.
In the time domain this correction is not active !

Apply to Both: If both controllers are identical, i.e. the same type and
equipped with identical decoders, then the settings for one can be transferred
directly to the other. To do so, mark the box.
Velocity: Here you select the measurement range for the velocity. For the
controller OFV-5000, the decoder descriptions are shown in plain text. OFV3001 and OFV-3001S: If a measurement range is available in several velocity
decoders, then to the left of the measurement range you can see an
abbreviation for the active velocity decoder. The abbreviations are explained
in TABLE 6.4.
Table 6.4:

Abbreviations for velocity decoders in the OFV-3001 / OFV-3001S

Abbreviation

Velocity decoder

HF

OVD-02
OVD-04

LF

OVD-06

DC

PLL-DC

PLL

OVD-01

Displacement: This line only appears if the controller is equipped with an
optional displacement decoder. Here you select the measurement range for
the displacement.

)

Even if you are only measuring and evaluating the displacement signal,
the measurement range for the velocity must not be exceeded (see
above).

Tracking Filter: Here you set the tracking filter.
Low Pass Filter: Here you set the low pass filter. Only PSV-300-H and
PSV-200-1: If you select the setting User Defined, then the field Cutoff
Frequency appears at the bottom. There you can enter multiples of 0.4 kHz,
up to a maximum of 102.4 kHz.

)

The settings for the low pass filter and the high pass filter have only an
effect on the velocity output (VELOCITY OUTPUT).
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High Pass Filter: Here you set the high pass filter.

)

If you are using the vibrometer to scan, switch the high pass filter off.

Max. Frequency: Here the respective maximum frequency is shown for the
selected measurement range.
6.2.9 Generator (as an Option)
As an option, you can control certain function generators using the software.
You will find information on this in SECTION 7.8.2 and SECTION 7.8.3. You set
the parameters for signal output on the page Generator.

Figure 6.11: Page Generator

General
parameters

Active: If sometimes you are not working with the function generator, you can
switch it off here for the software. Otherwise signal output starts automatically
when scanning. Apart from that, you will suppress corresponding warnings
and error messages.
Multiple Channel: Only PSV-400-H4 and PSV-300-H: Activate three
generator channels here.

)

Using the junction box PSV-E-401 or PSV-E-401-3D four generator
channels are available to you.

For signals with randomly generated numbers (Pseudo Random, White
Noise, Burst Random), different signals are generated using various random
number sequences, otherwise identical signals on all three channels. You will
find more information on this in SECTION 6.2.2.

)
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If you want to carry out a principal component analysis, you have to mark
the box Multiple Channel (MIMO) (only with option PCA, refer also to
SECTION 6.2.1) and select White Noise or Burst Random. Uncorrelated
signals are only emitted with these waveforms.
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Waveform: Here you select the waveform you want to emit. Some
parameters on the page Generator change with the waveform selected. You
will find an explanation of these parameters and information on some of the
waveforms in the following. In the measurement mode FastScan, a sinusoidal
signal with the frequency of the FastScan is always used for excitation.
Wait for Steady State: Here you enter the time in seconds which the excited
object needs to attain steady-state condition. The software delays data
acquisition by this time after you have
•
•

started signal output or
closed the dialog Acquisition Settings with OK.

Amplitude and Offset: Here you enter the peak amplitude and DC offset of
the signal in volts for high-impedance termination of the function generator.
The following conditions must be fulfilled:
Magnitude + Offset ≤ 10 V

Equation 6.4

Only 33120 A and 33250 A:
Offset ≤ Magnitude

Equation 6.5

If one of the conditions is not fulfilled, the software changes the offset.

)

Many function generators such as the HP or the internal function
generator have an output impedance of 50 Ω. If you terminate such a
function generator with 50 Ω, then the output voltages are only half the
size set.
This is of particular importance for spectrum generators which have an
output impedance of < 1 Ω. The data acquisition board of Spectrum is
preset to be terminated with 50 Ω (default setting). To change the setting
to 1 MΩ, display the page Channels in the dialog Acquisition Settings
(refer to SECTION 6.1).
Only for external function generators: The display of the generator shows
peak-to-peak amplitude and offset for the termination with 50 Ω. With highimpedance termination the display shows twice the applied voltage at the
output.

Amplifier: This check box only appears for PSV / MSA / MSV-M2-20 systems
with the generator board MI.6030 by Spectrum. Mark the box to increase the
voltage of the generator output from ± 3 V to ± 10 V.
Sine, Rectangle, Frequency: For the waveforms Sine, Rectangle, Triangle, Ramp and User
Triangle, Ramp, Defined, you enter the repeat frequency of the signal in hertz here.
User Defined
Sweep

Start Frequency, End Frequency and Sweep Time: For a Sweep, you enter
the start and end frequency in hertz here. The start frequency can be higher
than the end frequency. You also enter the duration of the sweep in seconds.
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Periodic Chirp, For the waveforms Periodic Chirp and Pseudo Random, sinusoidal signals
Pseudo Random are emitted to all FFT lines at the same time, but only in the frequency range
between From and To on the page Frequency (refer to SECTION 6.2.4).
Only 33250 A: The waveforms are not available in the measurement mode
Zoom-FFT.
Only 33120 A: The waveforms are not available in the measurement mode
Zoom-FFT or if 12 800 FFT lines are set.
With Periodic Chirp, the phases of the sinusoidal signals are adapted so that
the energy of the resulting signal is maximized. With Pseudo Random, the
phase of the sinusoidal signals is random.
Amplitude Correction File: As standard, with Periodic Chirp and Pseudo
Random all sinusoidal signals have the same amplitude. If you need other
amplitudes or frequencies, you can generate a correction file and list it here.
To do this, tick the box and then click Browse. The dialog Open appears, in
which you can navigate to correction files. You will find a short description of
the format required in the file Amplitude Correction Sample.txt in the directory
Examples (shortcut on the desktop). You can also use this file as a template
for your own correction files.
Burst Chirp,
Burst Random

The waveforms Burst Chirp and Burst Random are only available for certain
hardware configurations. The number of samples for Burst Random is limited
to 524 288 (1/2 Megasample).
Burst Start and Burst End: Here you enter when the burst is to start and
when it is to end (input in percent of the sample time).

User Defined
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If you need other waveforms, you can generate them yourself. You will find a
short description of the format required in the file UserDef Sample.txt in the
directory Examples (shortcut on the desktop). You can also use this file as a
template for waveforms you want to generate. To load a waveform you have
generated, select the waveform User Defined and then click Browse. The
dialog Open appears, in which you can navigate to files you have generated.

6 Parameters for Data Acquisition

6.2.10 Frequency in the Measurement Mode Zoom-FFT (as an Option)
In the measurement mode Zoom-FFT you can also make high-resolution FFT
measurements. To do this, you need the option Zoom-FFT. The page
Frequency is then adapted to the Zoom-FFT.

Figure 6.12: Page Frequency in the measurement mode Zoom-FFT

Frequency
range

At the top left you set the frequency range to be measured.
Center Freq. Here you enter the center frequency in kilohertz.
Bandwidth: Here you select the bandwidth in kilohertz.

)

For PSV / MSA / MSV-400-M2-20 and MSV-300-M you can only use
frequencies up to 2 MHz.

Range: The software calculates the frequency range to be measured and
shows it here.
FFT

At the bottom you set the parameters for the Fast Fourier Transformation
(FFT).
FFT Lines: Here you select the number of FFT lines that you want to analyze.
The number is odd because the frequency range measured is symmetrical
about the center frequency.
Overlap: This parameter only appears for certain hardware configurations.
You will find information on this in SECTION 6.2.4 and in your theory manual.

Resolution

The software calculates the following parameters and shows them at the top
right.
n FFT – 1
Sample Time:
t Sample = ------------------Equation 6.6
BW
nFFT … Number of FFT lines
BW … Bandwidth
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Resolution:

1
Δf = -------------t Sample

Equation 6.7

tSample … Sample time

)

The highest attainable resolution depends on the frequency range
measured (see above).

Max. Velocity: This parameter only appears with the option VDD. Due to the
processing power of the PC, when using the option VDD only signals up to
this maximum vibrational velocity can be acquired. The value depends on the
bandwidth and the number of FFT lines (see above).
6.2.11 FastScan (as an Option)
In the measurement mode FastScan you can scan individual frequencies
quickly. You will find information on this in SECTION 7.8.4. You set the
parameters for this on the page FastScan.

Figure 6.13: Page FastScan

Frequency: Here you enter the frequency in hertz at which you want to fast
scan.

)

If you control a function generator using the software, then in the
measurement mode FastScan, a sinusoidal signal at the FastScan
frequency is always used for excitation.

Bandwidth: Here you enter the bandwidth in hertz. As a general rule it can be
said: The smaller the bandwidth, the better the signal-to-noise ratio, but the
slower the scan.
Max. Velocity: This parameter only appears with the option VDD. Due to the
processing power of the PC, when using the option VDD only signals up to
this maximum vibrational velocity can be acquired. The value depends on the
bandwidth and the number of FFT lines (see above).
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6.2.12 Time (as an Option)
In the measurement mode Time you can save time signals instead of spectra
for scans. To do this, you need the option Time Domain Data. You can select
up to 64 Megasamples (67 108 864 samples). However, please note that the
amount of memory required increases with the number of samples. The
minimum disk space a measurement requires can be approximated using the
following formula:
File size in bytes > Active channels ⋅ Number of samples ⋅ 4
Depending on the number of samples and the hardware configuration, there
are limitations on the generator signals Burst Chirp, Burst Random and White
Noise. In this case the software will give you corresponding messages. Either
reduce the number of samples or select a different excitation signal (see also
SECTION 6.2.9 on this).
For PSV / MSA / MSV-400-M2-20 the maximum number of samples from a
sample frequency of 10.24 MHz upwards is limited by the memory of the data
acquisition board. The higher the sample frequency you select, the more
samples are possible.
The software will try to use the main memory during data acquisition to buffer
the acquired data.
While the contents of the buffer are being transferred to the hard disk, socalled buffer overruns can occur which lead to the data acquisition being
aborted. All data which had been acquired before this point in time however
will be saved. So make sure that your PC has got a large enough main
memory (RAM). In an ideal case this is 64 MB more than the file size
calculated above. If the size of the main memory used (RAM) should not be
sufficient, the software will issue you with a warning. If possible, close all
other applications during data acquisition.
Data acquisition in the measurement mode Time generates extremely large
files with numerous samples. Once the file size has reached 2 GB, the
software will give you a warning.
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You set the parameters for the measurement mode Time on the page Time.

Figure 6.14: Page Time

Sample Freq. Here you select the sample frequency in kilohertz.
Samples: Here you select the number of samples. You can select in the list or
enter any number.
The software calculates the following parameters and shows them on the
right.
n Sample
Sample Time:
t Sample = --------------Equation 6.8
f Sample
nSample … Number of samples
fSample … Sample frequency
Resolution:

1
Δt = -------------f Sample

Equation 6.9

fSample … Sample frequency
Max. Velocity: This parameter only appears with the option VDD. Due to the
processing power of the PC, when using the option VDD only signals up to
this maximum vibrational velocity can be acquired. The value depends on the
sample frequency and the number of samples (see above).
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6.2.13 MultiFrame (as an Option)
In the measurement mode MultiFrame you can divide measurements on
combustion engines into frames and analyze the frames individually. You will
find information on this in SECTION 7.8.5. You set the parameters for this on
the pages MultiFrame and Frequency.

Figure 6.15: Page MultiFrame

Frame
boundaries

At the top left you set how you determine the frame boundaries.
Manual: If you want to set the frame boundaries manually in the analyzer,
select Manual. The start of the engine cycle is determined by a trigger signal
at TRIG IN.
Engine Cycle: If the frame boundaries are to be set automatically by the
engine cycle, select Engine Cycle. Start and end of the engine cycle are
determined by a trigger signal (TTL, rising edge) at MultiFrame. All frames are
the same length.
Frame Cycle: If the frame boundaries are to be set automatically by the
frame cycle, select Frame Cycle. The start of the engine cycle is determined
by a trigger signal (TTL, rising edge) at TRIG IN. A second trigger signal (TTL,
rising edge) at MultiFrame ends the frame.

Number of
frames

At the top right you set the number of frames and the pulses per cycle.
Frames: Here you enter how many frames an engine cycle has.
Pulses per Engine Cycle: Here you enter how many trigger pulses are
emitted per engine cycle. If Frame Cycle is active (see above), the number of
pulses per cycle must be an integer multiple of the number of frames.

Averaging of
frames

You can analyze the spectra of the individual frames and the average of all
frames. At the bottom you set how the software averages.
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Magnitude or Complex: Here you select how the software averages over the
frames. Averaging over the frames is independent of the averaging on the
page General (refer to SECTION 6.2.1).
6.2.14 Frequency in the Measurement Mode MultiFrame (as an Option)
In the measurement mode MultiFrame you can divide measurements on
combustion engines into frames and analyze the frames individually. You will
find information on this in SECTION 7.8.5 and SECTION 6.2.13. On the page
Frequency additional parameters then appear for MultiFrame measurements.

Figure 6.16: Page Frequency in the measurement mode MultiFrame

At the bottom right, set the number of samples.
Samples: Here you select the number of samples.
The software calculates the sample time and the lower RPM limit RPMmin
which it can acquire with the parameters set and shows them on the right in
the middle.
n Sample
Sample Time:
t Sample = ------------------------Equation 6.10
2.56 ⋅ BW
nSample … Number of samples
BW … Bandwidth
RPM min:

120
RPM min = -------------t Sample

Equation 6.11

tSample … Sample time
You will find information on the other parameters on the page Frequency in
6.2.4.

SECTION
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7 Making Measurements
You can make single point measurements and scan using the software.
Please read SECTION 7.1 and SECTION 7.2 on this.
In the video window you can follow the progress of a scan. Read
on this.
In

SECTION

SECTION

7.3

7.4 you will find more over measurement options using PSV-3D.

When a measurement is running, the status bar can display messages on it.
See SECTION 7.5 on this.
In SECTION 7.6 you will find information on what you have to pay attention to if
you stop a measurement.
Only with option VDD: You must run the test mode at regular intervals before
making measurements. See SECTION 7.7 on this.
In SECTION 7.8 you will find a few application examples which give you
detailed instructions on various measurement tasks.

7.1 Single Point Measurement
You can make single point measurements as single shots or as a continuous
measurement.
Single shot

With a single shot, the software makes a single measurement and then ends
data acquisition. You can also stop single shots manually.

Continuous
measurement

With a continuous measurement, the software repeats single shots until you
manually stop data acquisition. You can only save the last single shot.
To make a single point measurement, proceed as follows:

Preparation

1. Go into acquisition mode. To do so, click

or select View > Acquisition.

2. Set the software up for data acquisition as described in

CHAPTER

3.

3. Set the optics and position the laser beam to point at the place where you
want to make a measurement. See CHAPTER 4 on this.
4. Focus the laser beam (manually or automatically in the scanning head
control). See SECTION 4.1 and SECTION 4.2 on this.
5. Only with option VDD: You must run the test mode at regular intervals
before making measurements. See SECTION 7.7 on this.
6. Set the parameters for data acquisition. See

CHAPTER

6 on this.
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Start

7. Start a single shot or a continuous measurement. To do so, click

or

. You can also select Acquisition > Single Shot or Acquisition >
Continuous.
Follow the
measurement

8. During the measurement, you can display data in analyzers as described
in SECTION 8.2 and SECTION 8.4.
9. During the measurement, the status bar and scanning head control can
display messages on data acquisition. See SECTION 7.5 on this.

Stop

10. To stop the measurement, click
see SECTION 7.6 on this as well.

or select Acquisition > Stop. Please

7.2 Scanning
A scan is a sequence of single point measurements. The order in which the
software approaches the scan points is determined by an internal algorithm.
For every scan point, the software carries out the following steps:
•
•
•
•
•
•

Position the laser beam at the scan point.
Set the optics of the scanning head to the focus value of the scan point
(only with option APS Professional, refer to SECTION 5.6).
Wait for the end of the settling time of the scanner mirrors.
Make a single shot.
Assign scan point status.
Save measurement data.

After a scan, the software can automatically remeasure certain scan points or
you can start remeasuring manually. You can also mark single scan points in
presentation mode to be remeasured and then remeasure this file in
acquisition mode.
To scan, proceed as follows:
Preparation

1. Go into acquisition mode. To do so, click

or select View > Acquisition.

2. Set the software up for data acquisition as described in
3. Set the optics. See

CHAPTER

CHAPTER

4 on this.

4. Define the scan points as described in CHAPTER 5.
5. Set the parameters for data acquisition. See CHAPTER 6 on this.
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Start

6. Start the scan. To do so, click
or select Acquisition > Scan. If the
function generator is active (refer to SECTION 6.2.9), signal output starts.
The software creates a file for the scan. The dialog Save As appears.

Figure 7.1: Dialog Save As

Save

7. Navigate to the saving location and enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

8. At the bottom in the dialog you can enter additional information to give the
file more precise properties. This information is part of the file properties
which you can also view and edit in the Explorer. It will be displayed to you
when you open a file in presentation and also in the dialog File
Information (see also SECTION 2.6.4 on this).
9. Click Save. The scan starts. The software immediately saves every scan
point measured.

)

If you have selected the 3D view in acquisition mode, the software will
change over to the 2D view on starting the scan. Thus you can follow the
movement of the laser beam on the object in the live video image.
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Follow the scan

10. You can follow the progress of the scan in the video window as described
in SECTION 7.3. During the scan, you can display data in analyzers as
described in SECTION 8.2 and SECTION 8.4.
11. During the scan, the status bar and scanning head control can display
messages on the data acquisition. See SECTION 7.5 on this.

Stop the scan
and continue

12. Once the total sample time has expired, the software ends data
acquisition and displays a message. However, you can also stop the scan
manually. You will find more details on this in SECTION 7.6.
13. You can continue a stopped scan. To do so, select Acquisition > Continue.

Remeasure

14. After the scan you can remeasure the scan points with the status
Overrange, Invalidated and Not Measured at a slightly different position.
To do so, select Acquisition > Remeasure. If Signal Enhancement is active
for at least one channel (refer to SECTION 6.2.7), then scan points with the
status Valid are also remeasured in the measurement modes FFT,
ZoomFFT and MultiFrame.

Remeasure File

15. If you have marked single scan points in presentation mode to be
remeasured (refer to SECTION 9.1), you can remeasure them. To do so,
select Acquisition > Remeasure File. The dialog Open appears. Navigate
to the saving location, select the file and click Open.

)

In addition to that, the software can also remeasure the points
automatically, see SECTION 6.2.1 on this.

7.3 Following Scans in the Video Window
In the video window you follow the progress of scans. While scanning, you
can see what status the scan points get. You will find a description of the
video window in SECTION 2.6.2.
Show and hide
scan points

To show and hide the scan points in the video window, click
or select
Scan > Scan Points. To the left of the live video image you can see a legend
for the status. There are different views here to select from:
•
•
•

Scan
Geometry
Laser Focus

To change the views, click
Scan Status

.

Before a scan, all scan points have got the status Not Measured.
If you do not want to scan single scan points, you can assign them the status
Disabled. See SECTION 5.4.2 on this.
If you define the scan points, then scan points which are outside the scan
area of at least one scanning head are given the status Not Reachable.
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If you are working with 3D geometries and parts of the object hides scan
points so that they can not reached by at least one laser beam, these scan
points are identified as Hidden. A prerequisite for this is that in the dialog
Preferences on the page Geometry you have activated Hidden Points
Calculation (refer to SECTION 3.4).
When scanning, the software gives every scan point the status Valid, Optimal
or Overrange.
The status Optimal can only occur if Signal Enhancement is active for at least
one channel (refer toSECTION 6.2.7). At these scan points, the signal-to-noise
ratio is relatively high.
At scan points with the status Overrange the input range of the data
acquisition board was exceeded on at least one channel.

)

Please pay attention that the software determines the Scan Status
Overrange as well under certain circumstances even though the resulting
time signal is displayed unaffected. This is due to the fact that depending
on the measurement settings you are working with a higher sample rate
as actual be visible in the resulting time signal (Oversampling). If a brief
voltage peak causes an overloading, then the scan point get the status
Overrange while the decimated time signal is displayed correctly.

If Signal Enhancement is active, scan points can change their status between
Valid and Optimal at the end of the scan.
After the scan, you can manually assign the scan points the status
Invalidated. You will find details on this in SECTION 9.1.
Geometry
Status

If there are no 3D coordinates available, the scan points are given the status
No 3D Coordinates. If you are working with a 3D geometry or the distance
sensor, you can see whether scan points were measured with the geometry
scan unit (status Measured or Optimal Measured) or were calculated with the
aid of triangulation of the three laser beams (status Triangulation, only
PSV-3D).

)

Optimal Measured are scan points whose detected signal strength is
greater than the threshold given in the dialog Setup Preferences on the
page Scanning Head under Signal Level (refer to SECTION 3.3).

Other options are Imported (via ASCII, Universal File or ME’Scope files with
the aid of the optional geometry import, refer to SECTION 5.2.7), Interpolated
(not or wrongly calculated 3D coordinates have been interpolated from the
coordinates of the neighboring scan points) and Modified (the coordinates of
the scan points were changed retrospectively).
If the distance measurement has failed, the affected scan points are given the
status Failed. If the signal strength of the geometry scan unit being too high or
too low is the reason for the measurement failing, then you will see this from
the status Too much Light or respectively Too little Light. In all cases this
means that these scan points do not have any valid 3D coordinates.
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Laser Focus
Status

If no focus value has been assigned, the scan points are given the status No
Laser Focus. If you have assigned a focus value (refer to SECTION 5.6.1 and
SECTION 5.6.2), you will see here if you Assigned Manually, Assigned Fast or
Assigned Best the focus value.
If the software has interpolated the focus value of single scan points from
those of the neighboring points, these are given the status Interpolated. Scan
points for which no focus value could be determined using the method Assign
Focus Best are labeled as Failed.
If, in the dialog Preferences on the page Geometry, you have marked the box
Calculate Focus Values Automatically, and the selected scan points have 3D
coordinates then the software calculates the focus values automatically.
These scan points get the status Calculated.

7.4 Using PSV-3D with only One Scanning Head
Thus, you can also use your PSV-3D as a single system with only one
scanning head and only one controller (standard PSV with junction box
PSV-E-40x-1D), you have to activate it first (refer to SECTION 3.1, PSV-3D as
1D). In the settings, you then have to pay attention to the following:
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•

The PSV software behaves like with a standard PSV and shows even only
one controller and one scanning head in the scanning head control.

)

Please note that, for this purpose, you can only use the scanning head
Top. But it will not be shown as Scanning Head Top in the software.

•

The channel allocation does not match the names on the junction box.
Please note the following allocation: Vib corresponds to VELO TOP, Ref1
corresponds to VELO LEFT, Ref2 corresponds VELO RIGHT and Ref3
corresponds to REF.

)

If you want to use the PSV-3D in 1D mode, you have to activate it first.
Please read SECTION 3.1, PSV-3D in 1D mode and fault diagnosis in 1D
mode on this.
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7.5 Messages while Measuring
During a measurement, the status bar and scanning head control can display
messages on data acquisition. A list of messages, their causes and
information on prevention can be found in TABLE 7.1.
Table 7.1:

Messages on data acquisition

Message
OVERRANGE
VIB
(status bar)

)

Cause
The voltage on the
vibrometer channel
exceeds the input
range set.

If the message appears permanently

See

Click
and display the page Channels.
Set the input range on the page Channels
to 10 V. Then display the page Vibrometer
and increase the measurement range for
the velocity step by step.

SECTION

6.2.2

The message OVERRANGE VIB can also appear briefly which is caused by noise peaks due to
dropouts. In this case, do not reset the input range.

OVERRANGE
REF
(status bar)

The voltage on the
reference channel
exceeds the input
range set.

NO TRIGGER
(status bar)

Triggering is set but
Click
, display the page Trigger and
the software can not
check
the
trigger settings. Also check the
detect a trigger signal.
cabling.

Display OVER The measurement
is red
range for the velocity
(scanning head has been exceeded.
control)

Click
, display the page Channels and
set the next highest input range of this
reference channel.

SECTION

6.2.2

6.2.6 and
hardware manual

SECTION

Click
, display the page Vibrometer and
set the next highest measurement range
for the velocity.

SECTION

6.2.8

7.6 Stopping a Measurement
With single shots and with scanning, the software ends data acquisition once
the total sample time has expired. You can also stop measurements manually.
Continuous measurements have to be stopped manually.
To stop a measurement, click
Single point
measurement

or select Acquisition > Stop.

If you stop a single point measurement, the following applies:
•

•

If there are less than three seconds to the end of the sample time, the
software carries out the measurement completely and then ends data
acquisition.
If there are more than three seconds to the end of the sample time, the
software aborts the measurement. In the measurement modes FFT and
Zoom-FFT, you can always display and save the time signal for aborted
measurements, but may not be able to save a spectrum. For long sample
times, single shot is recommended if you want to evaluate and save
spectra.
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Scan

If you stop a scan, the following applies:
All completely measured scan points are already saved. You can evaluate the
scan the same as you can a completed one.

7.7 Test Mode (as an Option)
In the test mode, the software calculates the errors which are caused by the
analog components during signal processing. Prior to demodulation, the
software corrects these errors using special algorithms. To do this, you need
the option VDD.
You have to run test mode after having installed both the option VDD and the
hardware, and having set up the software, and then repeat it regularly. In
doing so, the following applies:
•
•

)

If you only want to measure to 10 nanometers accuracy or less, you
should run the test mode again every three months.
If you want to measure more accurately than 10 nanometers or if the
ambient temperature has changed by ± 5°C or more, repeat the test mode
every day.
Test mode can be carried out automatically for the controller OFV-5000 if
the controller is controlled remotely via the RS-232-interface. Test mode is
then run every time the software is started.

To run the test mode, you will need
•
•

a test object which is vibrating – for example, a loudspeaker. The
displacement amplitude should be at least 1 μm.
a piece of reflective film.

To run test mode, proceed as follows:
1. Switch the PSV or MSA / MSV on and wait for 30 minutes. The
components are then in thermal equilibrium.
2. Only PSV: Attach a piece of reflective film to the test object and point the
scanning head at it.
3. Let the test object vibrate.
4. Only PSV: Open the beam shutter on the scanning head, fine-position
and focus the laser beam on the reflective film. The signal level display
should light up completely.
Only MSA / MSV: Open the beam shutter on the sensor head, fineposition and focus the laser beam on the test object. The signal level
display should light up completely.
5. In the software, select Setup > VDD Test.

)
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If the command is not active, select Setup > Preferences, display the page
Devices, and in the list Junction Box select the junction box VDD-Z-01x,
MSA-E-500 (VDD) or MSA-E-40x (VDD), refer also to SECTION 3.1.
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The software records the vibration and calculates the correction factors
for the errors caused by analog components.
Should test mode fail, then first of all check the cabling and the test assembly.
If cabling and the test assembly are correct, then it is possible that the
displacement amplitude of the test object is too small.
If test mode is successful, you can now start a measurement as described in
7.1 or SECTION 7.2.

SECTION

7.8 Example Measurements
Here you will find a few application examples which give you detailed
instructions on various measurement tasks.
•
•
•
•
•
•

Optimizing input signals with Signal Enhancement, refer to SECTION 7.8.1
Controlling external function generator (as an option), refer to
SECTION 7.8.2
Controlling internal function generator (as an option), refer to
SECTION 7.8.3
Measurement with FastScan (as an option), refer to SECTION 7.8.4
MultiFrame measurement (as an option), refer to SECTION 7.8.5
Controlling a second vibrometer, refer to SECTION 7.8.6

7.8.1 Optimizing Input Signals with Signal Enhancement and Speckle Tracking
When scanning with Signal Enhancement and Speckle Tracking, you get an
approximately even noise level for all scan points.

)

Principle

Speckles occur when laser light is scattered back from optically rough
surfaces. The light scattered back from a certain point can cause
constructive or destructive interference. Correspondingly, the detector
sees a bright or a dark speckle. Dark speckles lead to dropouts in the
vibrometer signal. Dropouts increase the noise level significantly.

Signal Enhancement works as follows:
•

•
•

In measurement mode FFT, Zoom-FFT or MultiFrame, you suppress
dropouts in averaged spectra using Signal Enhancement and Speckle
Tracking. In addition, the software evaluates the noise level of the single
scan points. You will find more information on this in your theory manual.
In measurement mode Time with averaging Time, the software uses a
median algorithm for averaging with active Signal Enhancement.
Only for PSV-400-H4 and PSV-400-3D: If possible, time signals were
acquired with a higher sample frequency (input sample frequency) as the
one which corresponds to the selected bandwidth or sample frequency
(output sample frequency - Oversampling). In the highly sampled time
signals, the software searches the spikes caused by dropouts. If the
length of these spikes are shorter as the duration for acquiring two
samples in the decimated output time signal, then the spike is replaced by
an interpolated sample value. The Oversampling factor must thereby be at
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least four (Oversampling factor = factor between input sample frequency
of the data acquisition board and the selected output sample frequency).
This is always the case with bandwidths ≤ 20 kHz or sample frequencies
≤ 51.2 kHz.
Activate

To activate Signal Enhancement and Speckle Tracking, proceed as follows:
1. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
2. Display the page SE.
3. On the left you mark the channels which Signal Enhancement is to be
active for. You will find information on this in SECTION 6.2.7.
4. If Signal Enhancement is active for the vibrometer channel, then you can
activate Speckle Tracking for this channel on the right.
5. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
6. Click OK.
You can now start a measurement as described in SECTION 7.1 or SECTION 7.2.

7.8.2 Controlling an External Function Generator (as an Option)
Using the software you can control certain function generators via an IEEE488 / GPIB interface. To do this, you need the option External Signal
Generator.

)

You can set which generator you are using via Setup > Preferences on the
page Devices.

The software supports the following function generators:
•
•
•
•

HP 33120 A
Agilent 33120 A
Agilent 33250 A
PREMA ARB 1000.

To control an external function generator, proceed as follows:
Make a
connection

1. Connect your PC to the function generator via an IEEE 488 / GPIB or RS232 interface.
2. Switch the function generator on.
3. Only 33120 A: Configure the interface of the function generator as
described in its manual. Set HPIB / 488 or RS-232 as the interface and as
HPIB address 10.
4. Start the software or go into acquisition mode.
5. Select Setup > Preferences and open the page Devices. Here you set the
correct connection to the generator (refer also to SECTION 3.1).
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6. Click OK. The generator is initialized.
Set the
parameters

7. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
8. Display the page Generator.
9. At the top left, tick the box Active to activate the function generator.
10. Set the parameters for the signal you want to emit. You will find
information on this in SECTION 6.2.9.
11. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
12. Click OK.

Signal output

13. Start (stop) the signal output of the function generator. To do so, click
or select Acquisition > Generator.

)

When scanning, the signal output starts automatically.

You can now start a measurement as described in SECTION 7.1 or SECTION 7.2.
7.8.3 Controlling Internal Function Generator (as an Option)
Using the software you can control the internal function generator of the PSV400, PSV-300, MSA-500, MSA-400, MSV-400 or MSV-300. To do this, you
need the option Internal Signal Generator. The output signal of the internal
function generator is available at a BNC jack on the junction box (refer to
hardware manual).

)

You can set which generator you are using via Setup > Preferences on the
page Devices.

To control the internal function generator, proceed as follows:
Set the
parameters

1. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
2. Display the page Generator.
3. At the top left, tick the box Active to activate the function generator.
4. Set the parameters for the signal you want to emit. You will find
information on this in SECTION 6.2.9.
5. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
6. Click OK.
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Signal output

7. Start (stop) the signal output of the function generator. To do so, click
or select Acquisition > Generator.

)

When scanning, the signal output starts automatically.

You can now start a measurement as described in SECTION 7.1 or SECTION 7.2.
7.8.4 FastScan (as an Option)
You can fast scan at individual frequencies. To do this, you need the option
FastScan. The principle of FastScan is a regression in the time domain.
To carry out a FastScan, proceed as follows:
Set the
parameters

1. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
2. Display the page General and select the measurement mode FastScan. In
the dialog a page with parameters for FastScan appears. The pages
Frequency, Window and Trigger disappear.
3. Display the page FastScan and set the parameters. You will find
information on this in SECTION 6.2.11.
4. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
5. Click OK.

Measure

6. You start and stop FastScans the same way as normal scans. See
SECTION 7.2, SECTION 7.5 and SECTION 7.6 on this.

)

With a FastScan there is no leakage. Triggers are not active. If you are
controlling a function generator with the software, then a sinusoidal signal
with the frequency of the FastScan is used for excitation.

Display data

7. You can display data for FastScans as described in
spectra.

Evaluate

8. You can evaluate FastScans as described in CHAPTER 9, but only at the
frequency of the FastScan. You can not define any other frequency bands.
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7.8.5 MultiFrame Measurement (as an Option)
Using the software you can divide measurements on combustion engines into
frames and analyze the frames individually. To do this, you need the option
MultiFrame and a trigger signal (TTL) which determines the start of an engine
cycle. For the frame cycle you will need a second trigger signal which
determines the end of a frame. You connect this second trigger signal to the
channel with the highest number (REF3 or REF24). In the software, the
channel will be named MultiFrame.
M o to r C y c le (E x a m p le : 4 F r a m e s , 1 P u ls e p e r M o to r C y c le )
T r ig g e r :
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Figure 7.2: Schematic representation of setting frame boundaries

There are three ways of setting the frame boundaries (refer also to
6.2.13):

SECTION

•
•
•
Manually

Manually
Automatically with the aid of the engine cycle
Automatically with the aid of the frame cycle

If you manually set the frame boundaries in the analyzer, the start of the
engine cycle is determined by a trigger signal at TRIG IN (TTL).
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Engine cycle

If the frame boundaries are set automatically by the engine cycle, the start
and the end of the engine cycle are determined by a trigger signal (TTL, rising
edge) at MultiFrame. All frames are the same length.

Frame cycle

If the frame boundaries are set automatically by the frame cycle, the start of
the engine cycle is determined by a trigger signal (TTL, rising edge) at TRIG
IN. A second trigger signal (TTL, rising edge) at MultiFrame ends the frame.
To make a MultiFrame measurement, proceed as follows:

Cabling

Table 7.2:

One way of cabling the system and the necessary settings in the software for
this is shown in TABLE 7.2. In principle other versions of cabling would also be
possible.
Example of connecting up the trigger signals for MultiFrame measurements

Determining the frame
boundaries

Cabling

Setting in the software

Manually

Trigger signal for the start of the engine Source: External (TTL), Rising
cycle: TRIG IN
Pre-trigger: 0%

Engine Cycle

Trigger signal for the start and the end
of the engine cycle: MultiFrame

Frame Cycle

Trigger signal for the start of the engine Source: External (TTL), Rising
cycle: TRIG IN
Pre-trigger: 0%
Trigger signal for the end of a frame:
MultiFrame

Set the
parameters

Source: Analog
Pre-trigger: 0%
Channel: MultiFrame, Rising
Source: 25%
Pulses per Engine Cycle: 1

1. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
2. Display the page General and select the measurement mode MultiFrame.
A page with parameters for the MultiFrame measurement appears in the
dialog.
3. Set all other parameters on the page General. You will find information on
this in SECTION 6.2.1.
4. Display the page MultiFrame and set the parameters. You will find
information on this in SECTION 6.2.13.
5. Display the page Frequency. Set the parameters as described in the next
two steps.
6. At the top left, set the bandwidth.
7. At the bottom right, set the number of samples. Above that, the software
shows the lower RPM limit RPMmin which it can acquire with the bandwidth
and number of samples set. Set the number of samples so that the lower
RPM limit is 5 to 40% below the RPM the engine is running at.
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8. Display the page Window and set the window functions. As a general rule,
the window function Tapered Hanning with a parameter of 10 is suitable
for MultiFrame measurements. You will find more information on
windowing in SECTION 6.2.5 and in your theory manual.
9. Display the page Trigger and set the parameters according to

TABLE

7.2.

10. Set 0% pre-trigger.
11. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
12. Click OK.
If you set the boundaries of the frames manually, then now follow steps 13 to
18. If you set the boundaries automatically, you can jump these steps and
continue with step 19.
Set frame
boundaries
manually

13. Start a single point measurement. To do so, click

.

14. In the analyzer you will see a MultiFrame toolbar and in the diagram, the
boundaries of the frames. In the MultiFrame toolbar, click

.

15. Point at a boundary in the diagram. The cursor becomes a ↔.
There are two ways of moving the boundaries:
16. To move a boundary, use the mouse to drag it to the right or left into the
required position. You can only move each boundary in a certain range
which depends on the neighboring boundaries.
17. To move all boundaries at the same time, press the shift key and drag to
the right or left into the required position. All boundaries move at the same
time and retain the same respective distances to each other.
18. When you have adjusted all boundaries, click
again. Initially the
boundaries jump back into their old positions in the analyzer. The new
boundaries are not shown until you start a new measurement.
Measure

19. You start and stop MultiFrame measurements as described in SECTION 7.1,
SECTION 7.2, SECTION 7.5 and SECTION 7.6.

Display data

20. You can display data for MultiFrame measurements as described in
CHAPTER 8.
21. In analyzers you can also display the spectra of the individual frames and
the average of all frames. To (de)activate the display of a spectrum, click
the corresponding icon in the MultiFrame toolbar.
22. In presentation windows, you can either only display an individual frame
or the average respectively. Select the data set you want to display in the
list Frame

in the legend for the object.
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Exporting
23. If you export a MultiFrame measurement as a Universal File or in
Universal File or
ME’Scope format (refer to SECTION 10.2.3), the software will create an own
ME’Scope
file for every single frame and for the average.
7.8.6 Controlling a Second Vibrometer
Apart from the PSV, MSA or MSV, you can control a second Polytec
vibrometer at the same time. To do this, you need an IEEE488 / GPIB board or
a free RS232 interface in your PC.
Supported
controllers
Table 7.3:

You will find an overview of the controllers and interfaces supported as well as
information on cabling in TABLE 7.3.

Supported controllers and interfaces

Vibrometer

IEEE-488 / GPIB

RS-232

RS-232 cable

CLV-1000 / 2000 / 3000

-

x

Null modem (cross-wired)

CLV-2534

-

x

Null modem (cross-wired)

HLV-1000

-

x

Null modem (cross-wired)

NLV-1232

-

x

Null modem (cross-wired)

NLV-2500

-

x

Null modem (cross-wired)

OFV-2500

-

x

Null modem (cross-wired)

OFV-3000 / 3001 / 3001 S

x

x

1:1

OFV-3020 / 3020 S

x

x

1:1

OFV-3300-1 / 3300-2

x

x

1:1

OFV-3310 / 3320

x

x

1:1

OFV-5000

-

x

Null modem (cross-wired)

OFV-5000-S

-

x

Null modem (cross-wired)

Supported
commands

The connection supports the following commands:
•

Set the parameters of the controller for data acquisition.

Only Vibrometer Controller 1 (refer to
•
•
•
•
•
•
•
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2.3):

Query exceeding the measurement range (OVERRANGE).
Query the optical signal level.
OFV-5000 with scanning head PSV-I-400: Focus the laser beam
automatically (Autofocus).
OFV-5000 with sensor head OFV-505: Focus the laser beam
automatically (Autofocus).
OFV-5000 with sensor head OFV-551 / -552: Control the beam shutter, dim
the laser beam (as an option).
OFV-3001S with scanning head OFV-056: Focus the laser beam.
OFV-3001S and OFV-3001 with the sensor head OFV-303: Focus the
laser beam.

7 Making Measurements

To control a vibrometer, proceed as follows:
Make a
connection

1. Connect the PC to the controller via an IEEE-488 / GPIB or RS-232
interface, refer also to TABLE 7.3.

)

If you are using an RS-232 interface, then set 9 600 Baud on the
controller, on the OFV-5000 and OFV-2500 controller 115 200 Baud.

2. Switch the controller on.
3. Only OFV-3300-1 and OFV-3310: Use the key ↑ on the front panel of the
controller to switch its display to the menu SETTINGS. Then you can
monitor the current settings on the display.
4. Start the software or go into acquisition mode.
5. Select Setup > Preferences. The dialog Preferences appears.
6. Display the page Devices. Make the necessary settings here (refer also to
SECTION 3.1).
7. Display the page Channels.
8. In the column Vibrometer, connect the controller to the digital channel it is
providing the signal for. You will find information on this in SECTION 3.2.
9. Click OK. The controller is initialized.
Set the optics

10. If you can not see the scanning head control in the application window,
select View > Scanning Head to display it. At the top you can see the
optical signal level as a bar.

)

If you are using the sensor head OFV-551 / -552, you can control the beam
shutter and use it to turn the laser on and off. To do so, mark the box
Laser. Apart from that, as an option, the slider Laser Dimmer is displayed.
By moving this slider with the mouse in the direction Max. you can reduce
the light intensity of the laser beam.

OFV-505

OFV-551 / 552

Figure 7.3: Elements of the scanning head control
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11. OFV-5000 with scanning head PSV-I-400 or sensor head OFV-505: You
can focus the laser beam automatically with the icon

.

12. OFV-3001S with scanning head OFV-056: You can focus the laser beam
using the icons
Set the
parameters

(close-up) and

(infinity).

13. Click
or select Acquisition > Settings. The dialog Acquisition Settings
appears.
14. Display the page Vibrometer.
15. Set the parameters of the controller for data acquisition. You will find
information on this in SECTION 6.2.8 and in your vibrometer manual.
16. Set the parameters on all other pages of the dialog. You will find
information on this in SECTION 6.2.
17. Click OK.
You can now start a measurement as described in SECTION 7.1 or SECTION 7.2.
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8 Displaying Data
You can set up the properties of the data display. See SECTION 8.1 on this.
In the software you work with the following windows to display data:
•
•

In acquisition mode: a video window, any number of analyzers
In presentation mode: any number of presentation windows, analyzers
and signal processors

You will find a description of the analyzer in
You can work in analyzers. Read

SECTION

SECTION

2.6.3.

8.2 on this.

To evaluate the scan, open a presentation window and then set up the window
and the view of the measurement object. Read SECTION 8.3 on this.
You can select the data set that is displayed in the analyzer. Read SECTION 8.4
on this.
If you are working with 3D geometries, you can merge several individual
scans to a combined file (stitching). Read SECTION 8.5 on this.
Afterwards you can use your measurement data as the basis for further
calculations. Read SECTION 8.6 on this.

8.1 Setting up Display Properties
In the dialog Display Properties, you can select the following settings:
•
•
•

Setting up the object, refer to SECTION 8.1.1
Setting up the view style of measurement data, refer to
Setting up 3D view, refer to SECTION 8.1.3

SECTION

8.1.2

To open the dialog, double-click the object or click it with the right mouse
button and select General Properties, Data Properties or 3D View Properties
in the context menu.
To set up the view style of the measurement data and the 3D view in
acquisition mode, you have to change to the 3D View. To do so, in the video
window, click
. However, you will then no longer see a live video image
but, as in presentation mode, a snapshot of the video image at the time at
which you changed the view.

)

In acquisition mode, you can only switch to 3D View if you have defined
scan points.

To set up the 3D view in presentation mode, you have to change to the 3D
View. To do so, in the presentation window, click

)

.

In presentation mode, you can only switch to the 3D View if you have
selected the view Object, Single Scan Point or Average Spectrum.
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8.1.1 Setting up the Object
The contents of this page are different depending on whether you are in
acquisition mode or in presentation mode.
If you are in acquisition mode, to open the dialog, you can also activate the
video window (to do so click it) and then select Scan > Properties. Then
display the page General.

)

Depending on the type of measurement and the geometry, not all settings
options are shown in the dialog.

If you are in presentation mode, to open the dialog, you can also activate the
presentation window (to do so click it) and then select Presentation >
Properties. Then display the page General.

Figure 8.1: Page General

Title

At the top you set up the title of the object.
Show: If you would like to display a title over the object, mark the box. You
enter the title on the right.
Font: Click here to format the title. The dialog Font appears.

Colors

At the bottom you select the background color of the object and the color of
the data in the legend (only in presentation mode).
Background: Here you select the background color of the object.
Legend: Here you select the color of the data read in the legend (only in
presentation mode).
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8.1.2 Setting up View Style of Measurement Data
The contents of this page are different depending on whether you are in
acquisition mode or in presentation mode.
If you are in acquisition mode, to open the dialog, you can also activate the
video window (to do so click it) and then select Scan > Properties. Then
display the page Data.

Figure 8.2: Page Data in acquisition mode

Monochrome Video Image: Tick the box if you want the change the video
image from color to black and white.
Show Data Grid: Tick the box if you want to see the grid that the scan points
are on.
Indices: Tick the box to show the index of scan points. Select whether the
indices of all scan points are to be shown or only the indices of selected scan
points. In the list below select the color which is to be used to show the
indices.

)

Depending on the type of measurement and the geometry, not all settings
options are shown in the dialog.

If you are in presentation mode, to open the dialog, you can also activate the
presentation window (to do so click it) and then select Presentation >
Properties. Then display the page Data.

)

New settings on this page with the exception of Scale Z-Range are
immediately effective, i.e. without clicking Apply or closing the dialog.
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Figure 8.3: Page Data in presentation mode

View style of the Data Transparency: Here you enter how transparently the superimposed
measurement
data is to be shown in the presentation window.
data

)

In the view style Wireframe this selection is not active.

Monochrome Video Image: Tick the box if you want the change the video
image from color to black and white.
Show Data Grid: Tick the box, if you want to see the grid which the scan
points are on in addition to the superimposed measurement data.

)

In the view style Wireframe this selection is not active.

Indices: Tick the box to show the indices of the scan points. Select whether
the indices of all scan points are to be shown or only the indices of selected
scan points. In the list below select the color which is to be used to show the
indices.
Set up the
isolines

Number of Isolines: Here you select how close the isolines are to each
other.
Isoline Thickness: Here you select the thickness of the isolines.

Scale Z-Range

Left or Right: If you have selected the display type Real & Imag. for example
(refer to SECTION 8.4), here you can select which part you want to scale.
Automatically: The software can autoscale maximum and minimum of the zrange individually. To do so, mark the appropriate box Max and Min.
Manually: Through entries in the fields Max and Min you can scale the data
manually. To do so, you have to deactivate the corresponding box
Automatically. Here you enter the z-range in which the data is to be pictured.
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8.1.3 Setting up 3D View
If you are in acquisition mode, to open the dialog, you can also activate the
video window (to do so click it) and then select Scan > Properties. Then
display the page 3D View.
If you are in presentation mode, to open the dialog, you can also activate the
presentation window (to do so click it) and then select Presentation >
Properties. Then display the page 3D View.

Figure 8.4: Page 3D View

)

Changes made to the view style or the sight are immediately effective, i.e.
without clicking Apply or closing the dialog.

Light Source: Tick the box to switch on the illumination model. It simulates
illuminating the object from the direction of the observer.

)

Depending on the shape of the object, the display of light and shadow
may have a detrimental effect on the quality of the presentation. In this
case, deactivate the box to switch off the illumination model.

Axes: Tick the box to display a coordinate system top left next to the object.
Zero Position: Tick the box to view the object in its original position in
addition to viewing the measurement results.
Scan Range: Tick the box to show lines to help you display the position of the
scanning heads in front of the object. In this way you can see whether the 3D
alignment has provided a useful result.

)

You can only show the Scan Range for measurements with 3D geometries
(only PSV / PSV-3D). The boxes Scan Range, Video and Transparency are
not shown for combined files (refer to SECTION 8.5).
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Figure 8.5: Layout of the position of the three scanning heads

Video: Tick the box to show the video image.

)

For 3D-geometries, the video image is only shown if:
• the 2D alignment is good quality, i.e. the laser beam hits the precise
position on the video image,
• for the scan points 3D coordinates are existent and
• at least four scan points have been defined which cover a larger area
of the video image.

Transparency: Here you enter how transparently the video image is to be
displayed.
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Sight

The icons in the field Sight show the line of sight of the object. You can move
the object more precisely by clicking these icons than by dragging with the
mouse.
Sight on the object from the front
Sight on the object from the back
Sight on the object from the left
Sight on the object from the right
Sight on the object from the above
Sight on the object from the below
Sight of the video camera (only for 3D geometries; for this purpose
the same limitations apply as with the display of the video image, see
above under Video)
Sight on the object at an angle from front, left and above
Rotating the object around the line of sight
You can show (hide) a coordinate system which shows you the resulting
orientation of the object (see above, Axes).

)

You can also set the line of sight directly in the video window or
presentation window using the mouse. To do so, click
to select the
mode Rotate. Then click the object and using the mouse drag it into the
direction you require.

Projection

Here you select the type of projection of the object.
Perspective: The object is shown in perspective, i.e. parts in the front of the
image become larger, parts in the background of the picture are shown
smaller.
Parallel: All parts of the object are shown the same size regardless of their
distance from the observer.

)

Parallel projection makes it easier to differentiate between in-plane and
out-of-plane vibrations. Particularly with out-of-plane vibrations, the
perspective layout viewed from the top can give the impression that the
object is being stretched and contracted again.
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8.2 Working in Analyzers
Analyzers show measurement data and evaluated data in x-y diagrams. You
will find a description of the analyzer in SECTION 2.6.3.
You select the data set to be displayed in the analyzer as described in
SECTION 8.4.
Analyzers offer user-friendly functions to present data quickly and usefully.
•
•
•

Zooming in analyzers, refer to SECTION 8.2.1
Setting cursors and reading data, refer to SECTION 8.2.3
Scaling axes, refer to SECTION 8.2.2.

You will find more functions in the dialog Analyzer Properties.
•
•

Setting up presentation of graphs, refer to SECTION 8.2.4. There you can
scale and set line style and color of the graph.
Setting up diagrams, refer to SECTION 8.2.5. To do so, select Analyzer >
Properties and display the corresponding side. Alternatively, click the
analyzer with the right mouse button and select the required function in
the context menu.

The analyzer simultaneously shows up to 0.5 mega-samples for time series
as standard. If the measurement contains more data, then this is reloaded
during scrolling. If you want to see several time values at once, then to do so
you can increase the number of time values shown simultaneously as
described in SECTION 9.4.2.

)

The maximum number of time values shown simultaneously can only be
increased in presentation mode. In acquisition mode the analyzer always
shows only a maximum of 0.5 mega-samples.

8.2.1 Zooming in Analyzers
You can zoom on sections of the diagrams.
Zoom the x- or
y-axis

To zoom the x- or y-axis individually, proceed as follows:
1. Point at an edge point of the section required on the axis. The cursor
becomes a magnifying glass.
2. Press the mouse button and drag horizontally or vertically to the other
edge point.

Scroll the x-axis The scroll bar below the diagram shows the position of the zoomed section on
the whole x-axis range. You can scroll along the x-axis with the current zoom
factor. To do so, move the bar in the scroll bar to the right or to the left. You
can also click the arrows to the right and left of the scroll bar.
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Zoom both xand y-axis

To zoom both x- and y-axis simultaneously, proceed as follows:
1. Click

or select Analyzer > Zoom In.

2. In the diagram, point at a corner of the section required.
3. Press the mouse button and drag to the diagonally opposite corner.
Pan the zoomed
section

You can pan the zoomed diagram section. To do so, you have the following
options:
1. Using the middle mouse button (mouse wheel), click in the zoomed
diagram. Hold the mouse button pressed and pan the diagram section. If
you have given the middle button a special function (e.g. double-click),
then you will have to proceed as described in step 2.
2. Click
or select Analyzer > Pan. You can now pan the diagram section
while pressing the left mouse button.

Zoom out

To undo the last zoom action or autoscaling, click
Zoom Out.

or select Analyzer >

To undo all previous zoom actions, click
while holding the shift key
pressed. You can also select Analyzer > Zoom Out holding the shift key
pressed.
8.2.2 Scaling the Axes
You can scale the y-axis automatically or scale the x- and y-axis manually.
Autoscale the
y-axis

When you have started a measurement or are displaying another data set,
then the y-axis range is often unsuitable. You can then autoscale, i.e. the
software selects the y-axis range displayed corresponding to the y-range of
the data. To do so, click
Scale off again, click

or select Analyzer > Auto Scale. To switch Auto
again.
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Scale manually

In the dialog Analyzer Properties you can scale manually and set further
scaling properties. To open the dialog, point at an axis (the cursor becomes a
magnifying glass) and double-click. You can also activate the analyzer (to do
so, click it), select Analyzer > Properties and then display the page Ranges.

Figure 8.6: Page Ranges

Max and Min: Here you enter the x- and y-axis ranges you want to display.

)

If you want to display two diagrams (e.g. Mag. & Phase), here you can
define the y-axis ranges respectively.

Scale: This box only appears if the active analyzer is displaying a spectrum.
Here you select logarithmic or linear scaling of the x-axis.
Round Values: Here you select whether the axis values displayed should be
round. The software then rounds the values in Min and Max to be suitable.
Round Values is also active when zooming. The zoomed section is then
usually slightly larger than selected.
8.2.3 Setting Cursors and Reading Data
In the analyzer you can set cursors to read individual data points. Cursors are
represented by thin vertical lines. In display type Nyquist you can not set any
cursors. You will find details on how to animate time data in SECTION 9.4.2.
Single cursor

To set a single cursor, proceed as follows:
1. Click

or select Analyzer > Cursor.

2. Click in a diagram.
Read data
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Cursor
properties

In the cursor properties you can set what is to be shown in the legend or the
diagram. To show the cursor properties, click
or select Analyzer > Cursor
Properties. The dialog Cursor Properties appears.

Figure 8.7: Dialog Cursor Properties

Here you can also choose to have a horizontal line displayed at the cursor
position in the diagram.
Differential
cursor

You can set two cursors and read the difference between coordinates. To do
so, proceed as follows:
1. Click

or select Analyzer > Differential Cursor.

2. In the diagram, point at the first point you require.
3. Press the mouse button and then drag to the right or left to the second
point. The difference between the coordinates also appears in the legend.
4. To show the cursor properties, click
or select Analyzer > Cursor
Properties. The dialog Differential Cursor Properties appears.

Figure 8.8: Dialog Differential Cursor Properties

5. Here you select the required additional properties.
Band cursor

You can set a band cursor and read different data from the marked area such
as the RMS value, the minimum and maximum, the average and the standard
deviation. Apart from that, the software can adjust the frequency response
function of a one-dimensional oscillator and calculate both the peak position
and the attenuation. To do so, proceed as follows:
1. Click

or select Analyzer > Band Cursor.

2. In the diagram, point at the first point you require.
3. Press the mouse button and then drag to the right or left to the second
point. The data you selected in the Cursor Properties will appear in the
legend or the diagram.
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4. To show the cursor properties, click
or select Analyzer > Cursor
Properties. The dialog Band Cursor Properties appears.

Figure 8.9: Dialog Band Cursor Properties

5. Here you select the required additional data in the legend or displays in
the diagram.

)
Harmonic
cursor

The peak fit is only available for spectra.

You can set a harmonic cursor and thus display up to 12 cursor lines of the
2nd, 3rd, 4th etc. order of the fundamental frequency. To do so, proceed as
follows:
1. Click

or select Analyzer > Harmonic Cursor.

2. In the diagram click the required frequency. In diagram the selected
number of cursor lines appears.
3. To show the cursor properties, click
or select Analyzer > Cursor
Properties. The dialog Harmonic Cursor Properties appears.

Figure 8.10: Dialog Harmonic Cursor Properties

4. Select the required number of lines and whether corresponding horizontal
lines are to be shown.

8-12

8 Displaying Data

Move the cursor You can move a cursor to the right or left. To do this, proceed as follows:
1. Point at the cursor. The mouse cursor becomes a ↔.
2. Press the mouse button and then drag to the right or left to the required
point. The data in the legend is updated simultaneously.
You can also move a single cursor using the keys → and ←.
Delete the
cursor

To delete cursors you have set, click

,

,

or

again.

Copy cursor
values

You can copy the values of the cursor currently set via the clipboard in a text
file. To do so, proceed as follows:
1. Set the required cursor, differential cursor, band cursor or harmonic
cursor.
2. Click the diagram with the right mouse button and select Copy Cursor
Values in the context menu.
3. For example, you can now open a text editor and paste the cursor values
there from the clipboard.

8.2.4 Setting up the Presentation of Graphs
You set up the presentation of the graphs in the dialog Analyzer Properties. To
open the dialog, point at a diagram and double-click. You can also activate the
analyzer (to do so, click it), select Analyzer > Properties and then display the
page Data.

Figure 8.11: Page Data

Data Set: If the analyzer is displaying several diagrams – for example,
magnitude and phase – then this is where you select the data set for which
you want to set up the presentation.

)

If you want to display the spectrum of several frames, here you can also
select the respective frame (e.g. 1, 2, 3 etc.) and set up its presentation.
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Color: Here you select the color of the graph.
Line and Marker: Here you select the view style of the graph and, if
applicable, the marker. In the view styles Marker, Histogram, Thin bars and
Thick bars, only measured y-values are displayed. In the other view styles,
the software interpolates between the measured values.
8.2.5 Setting up Diagrams
You set up the look of the diagrams in the dialog Analyzer Properties. The
current settings in the dialog are also valid for all analyzers you now open. To
open the dialog, double-click an axis name. You can also activate the
analyzer (to do so, click it), select Analyzer > Properties and then display the
page General.

Figure 8.12: Page General

Grid

At the top you set up the grid.
Show: Tick the box to display a grid in the diagram.
Color and Style: Here you select the color and line style of the grid.

Title

In the middle you set up the diagram title.
Show: If you would like to display a title over the diagram, tick the box. You
enter the title on the right.
Font: Click here to format the title. The dialog Font appears.

Colors

At the bottom you set up the background color of the diagram and the color of
the data in the legend.
Background: Here you select the background color of the diagram.
Legend: Here you select the color of the data read in the legend.
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8.3 Working in Presentation Windows
You analyze scans in presentation windows. You will find a description of the
presentation window in SECTION 2.6.5.
Depending on which functions you are working with in the presentation
window, you display it in different views:
•
•
•

Setting up the view of the presentation window, refer to SECTION 8.3.1
Selecting the view style of the data, refer to SECTION 8.3.2
Setting up display properties, refer to SECTION 8.1. You will find more
presentation options in the dialog Display Properties. You can scale there
and set up the appearance of different views.

The presentation window offers user-friendly functions to present data quickly
and usefully.
•
•
•

Zooming in analysis windows, refer to SECTION 8.3.3
Setting cursors and reading data, refer to SECTION 8.3.4
Selecting the color palette, refer to SECTION 8.3.5

You can select the data set that is displayed in the presentation window. Read
SECTION 8.4 on this.
Apart from the display functions, in the presentation window you also have
possibilities to evaluate the measurement data. Read CHAPTER 9 on this.
8.3.1 Setting up the View of the Presentation Window
Depending on which functions you are working with in the presentation
window, you display it in one of four different views:
•
•
•
•

Object
Single Scan Point
Average Spectrum
Profile.
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To set the view of the presentation window, click
and select the view
required in the context menu. You can also select Presentation > View and
then the required view. In the view Object, you will see the data superimposed
on the video image, refer also to SECTION 8.3.2. In the other three views you
see the presentation window divided horizontally: at the top the view Object
and at the bottom an analyzer. You work in the analyzer as described in
SECTION 8.2.

Figure 8.13: Presentation window in the view Object (3D)

Object

You will see the data superimposed on the video image. You can present the
data itself in different ways, see SECTION 8.3.2 on this. You can set up the look
of the object and the video image (background color, title, transparency etc.)
as described in SECTION 8.1.1.

Single Scan
Point

In the upper part of the presentation window you see the object. At the bottom
you see an analyzer. The analyzer displays the spectrum at the single scan
points. At the top, you select the scan point for which the spectrum is shown.
To do so, set a cursor at this scan point as described in SECTION 8.3.4.

Average
Spectrum

At the top you see the object. At the bottom the analyzer displays the average
spectrum of all scan points. The average spectrum is calculated from the
amplitude spectra of the valid scan points. See also SECTION 9.1 on this.

Profile

At the top you see the object. You can draw profile sections on the object as
described in SECTION 9.3. You will see the profiles at the bottom in the
analyzer.

)
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8.3.2 Selecting the View Style of the Data
In the presentation window you see the data superimposed on the video
image. You can present the data in different ways:
•
•
•
•
•

Surface
Wireframe
Isolines
Scan Points
Status Points

In all view styles you can change between the 2D and the 3D view. To do so,
click
. In all view styles apart from Status Points you will see the data
color-coded. You can select the color palette for this as described in
SECTION 8.3.5. To the left of the object you can show (hide) a gauge for colorcoding. To do so, select Presentation > Gauge.
To select the view style of the data, click
and select the view style
required in the context menu. You can also select Presentation > View Style
and then the required view style.
You can display the live video image outside the scan points.
Surface

The software interpolates between the scan points.

Wireframe

You will see the connecting lines between the scan points as a color-coded
grid.

Isolines

You will see equal data values connected with color-coded isolines. You can
set up the presentation of the isolines (number, thickness) as described in
SECTION 8.1.2.

Scan Points

You see each scan point as a color-coded marker which corresponds to its
data. In addition to that, you can display the index of each scan point. See
SECTION 8.1.2 on this.

Status Points

You see the scan points as markers in different colors. The color shows the
status of the scan point. See also SECTION 7.3 on this.

3D View

You can set up the 3D view style (projection, colors, size) as described in
SECTION 8.1.3. You can set the line of sight directly in the presentation window
using the mouse. To do so, click
in the direction you require.

3D Geometry

. The mouse cursor becomes a

. Drag

You will find detailed information on the presentation of 3D geometries in your
theory manual.
Read

SECTION

4.5.3 to see how to convert 2D geometry into 3D geometry.
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8.3.3 Zooming in Presentation Windows
To zoom in a presentation window, proceed as described in SECTION 2.6.8.
8.3.4 Setting Cursors and Reading Data
If you would like to read data at single scan points, you can set a cursor on
the object. You see the cursor as a blue marker. In the view Profile you can
not set a cursor.
Set a cursor

To set a cursor, proceed as follows:
1. Display the Object or Single Scan Point view. To do so, click
select Object or Single Scan Point.

and

2. Display any view style. To do so, click
and select the view style in the
context menu. You can select scan points in both the surface view and
also the 3D view.
Select scan
points

3. Point at a scan point and click. The scan point is shown as a blue marker.

Read data

In the legend you can see the data of the scan point which the cursor is at. If
the legend is not visible on the right of the object, select Presentation >
Legend to display it.
In the view Single Scan Point you wills see the spectrum at this scan point at
the bottom in the analyzer.

Move the cursor You can move the cursor to other scan points using the mouse. The data in
the legend is updated simultaneously. In the view Object you can move the
cursor within a joined area using the arrow keys as well.

)
Delete the
cursor
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You can zoom in on the view to be able to see details more clearly. Read
2.6.8 on this.

SECTION

To delete the cursor or to clear selection, in the toolbar of the presentation
window, click

.

8 Displaying Data

8.3.5 Selecting the Color Palette
You can choose between different color palettes for color-coding in the
presentation window. To do this, proceed as follows:
1. Click
or select Setup > Color Palette. The dialog Color Palette
Selection appears.

Figure 8.14: Dialog Color Palette Selection

2. Click the color palette required. Default setting is the color palette redgreen.
3. Click OK.
Or:
With the right mouse button, click the gauge on the left in the presentation
window and select the required color palette from the list.

8.4 Selecting the Data Set Displayed
To display a certain data set, select in the following order:
1. Time signal or type of spectrum
2. Channel or combination of channels
3. Signal or function
4. Display type in which the signal or function is shown
5. 0 dB reference
6. Only in presentation windows of data you have captured in FFT mode:
Frequency band.
The selection depends on
•
•

the measurement mode,
averaging, trigger and reference signal; see your theory manual on this as
well,
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•

which displays have already been selected – for example, you can only
display a frequency response for frequency spectra and a combination of
channels.

)

With the PSV-3D you can also select the channels Vib 3D or Vib X, Vib Y
and Vib Z and also combinations of channels such as Vib X & Ref 1.

First of all you have to define frequency bands. Read

SECTION

9.2 on this.

If an analyzer is part of a presentation window (refer to SECTION 8.3.1), select
the data set shown in the presentation window. If possible, the analyzer
displays the same data set.
To display a certain data set, proceed as follows:
Domain

1. Click

or select Analyzer > Domain or Presentation > Domain.

2. Select the time signal, a spectrum or the RMS signal in the context menu.

)

Channel

Measurement modes FFT, Zoom-FFT and MultiFrame: To calculate and
display a frequency spectrum, the software needs to acquire a complete
sampling time. Therefore, during a continuous measurement, the
spectrum of the last complete measurement is displayed at the same
time as the time signal of the current measurement.

3. Click

or select Analyzer > Channel or Presentation > Channel.

4. Select a channel or a combination of channels in the context menu. If you
want to use user defined data sets, select the channel Usr, Usr X, Usr Y,
Usr Z or Usr 3D. You will find more information on this in the manual on
Polytec File Access as well.
Signal

5. Click

or select Analyzer > Signal or Presentation > Signal.

6. Select a signal or a function in the context menu. The abbreviations used
are explained in TABLE 8.1.
Table 8.1:

Abbreviations for functions

Abbreviation
AP

Autopower

CP

Crosspower

FRF

Frequency Response Function

H1

Frequency Response Function

H2

Frequency Response Function

Principal Inputs
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Display type

7. Click
Type.

or select Analyzer > Display Type or Presentation > Display

8. Select the way in which the vibration is shown in the context menu.

)

In the display type Magnitude [dB (A)], the magnitude measured is
frequency-weighted according to the standard EN 60 651 (IEC 651) (Aweighting). The A-weighting approximately describes the acoustic
sensitivity of a human at low magnitudes. The following figure shows the
frequency-weighting curve. Outside the range shown, the software
weights as follows: Below 10.0 Hz at -70.4 dB and above 20 000 Hz at -9.3
dB.
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Figure 8.15: Frequency-weighting curve for the display type Magnitude [dB(A)]

)

In the display type Nyquist, the real part of the magnitude is plotted over
the x-axis and the imaginary part over the y-axis. You can limit the
frequency range of the display type Nyquist by first of all zooming the xaxis in another display type so that the desired frequency range is
displayed and then changing to the display type Nyquist.
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0 dB Reference

9. Select Setup > Preferences and display the page dB Reference.

Figure 8.16: Page dB Reference

10. If the settings are to apply to all the Polytec software installed in the PC,
mark Global 0 dB reference (used for all Polytec products).
If the settings are only to apply to the file which is currently open, mark
0 dB reference for the active document.
The column Quantity shows the available physical quantities, the column Unit
the respective applicable unit (ISO).
11. In the column 0 dB Reference you define the factor for the respective unit.

)

Depending on the size of the opened file, it can take quite a while for the
new value to be applied !
Example:
Quantity

0 dB Reference

Unit

Displacement

2e-3

m

The 0 dB reference for the quantity Displacement is 2 mm.
12. If you want to evaluate combined signals (e.g. Vib & Ref 1), define the 0 dB
reference for both quantities. The software then automatically determines
the 0 dB reference of the combined signals.

)

8-22

If you want to recover the original settings for the 0 dB reference, click
Default Settings.
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Frequency band You have three different ways of selecting the frequency band displayed:
(only in
presentation
13. Select the frequency band in the toolbar of the presentation window in the
windows)
list
. If no frequency bands are defined, then the only entry
in the list is Entire Bandwidth.
or
Press the key Pg Dn or Pg Up. You will see the next or previous frequency
band.
or
Either display the view Single Scan Point or the average spectrum. To do
so, click

and select Single Scan Point or Average Spectrum.

14. In the toolbar of the analyzer, click
the analyzer in color.

. You see the frequency bands in

15. Click the required frequency band in the analyzer. The software shows
this frequency band at the top.
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In TABLE 8.2 you will find a summary of how to select domain, channel, signal
and display type.
Table 8.2:

Click

Selecting the data set displayed

Or select Analyzer >
or Presentation >

1.
Domain
2.

Display of

Time signal, spectrum or RMS FFT, 1/3 Octave
signal
RMS
Time
Channel or combination of
channels

Vib, Vib 3D
Ref 1, Ref 2, Ref 3
References (MIMO)
Vib & Ref 1, Vib & Ref 2, Vib & Ref 3,
Vib 3D & Ref 1
Ref 1 & Ref 2, Ref 1 & Ref 3, etc.

Signal or function

Displacement
Velocity
Voltage
Acceleration
FRF Displacement / Voltage
AP Displacement2
AP Velocity2
AP Acceleration2
Multiple Coherence (MIMO)
Virtual Coherences (MIMO)
Principal Inputs Voltage2 (MIMO)

Way in which the signal or
function is shown

Magnitude
Magnitude [dB], Magnitude[dB(A)]
Mag. & Phase, Mag.[dB] & Phase
Phase
Real
Imaginary
Real & Imag.
Instant Value
Nyquist

Channel

3.

Signal

4.

Display type

Example

You can also evaluate the spectrum with a single cursor. Read
on this.
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8.5 Generating Combined 3D Files (Stitching)
If you are using PSV-3D, you can merge individual measurements with 3D
geometries and 3D vibration data to form combined files. This also works with
PSV-1D with 3D-geometries, which have either been imported or determined
using a geometry scan. For this, the following conditions have to be met:
•

•

•

•

The individual measurements must have been made with PSV-3D, or with
PSV-1D combined with 3D geometries which were either imported or
determined via a geometry scan.
The coordinate systems of all individual measurements must have the
same origin and the same orientation. This means that for 3D alignment
the same coordinate system must have been used for the alignment
points of all files.
All individual measurements must have been made using the same basic
settings. These include the number of channels, the definition of the
reference channel, units, averaging mode and trigger settings as well as
the setting for the optional Principal Component Analysis (MIMO).
However you can select different vibrometer settings, generator signals,
input ranges, vibrational directions of the channels and calibration factors.

)

If you are combining measurements with different vibrometer settings,
please make sure that the possible different time delays are only
corrected under the following conditions:
• as of OFV-5000 with firmware version 2.0:
• as of PSV 8.3
• acquisition of measurement data in the spectral range (FFT)
No correction is made in the time domain !

•

The indices of the scan points may not appear twice. Read more on this
under Change Indices in SECTION 5.4.2.
Exception: identical scan points which are included in several individual
measurements and have the same indices in every individual
measurement.

)

You can not combine 1D vibration data with different vibrational directions
which are existent for scan points with the same indices to 3D vibration
data.

You can also generate a new combined filed from several combined files. In
doing so, proceed in the same way as when merging individual
measurements. In the following section you will find information on:
•
•

Merging individual measurements, refer to SECTION 8.5.1
Working with combined files, refer to SECTION 8.5.2
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8.5.1 Merging Individual Measurements
To merge several individual measurements to a combined file, proceed as
follows:
1. Select File > New > Combined File. The dialog Create Combined File
appears.

Figure 8.17: Dialog Create Combined File

Add individual
measurements

2. Click
next to the field Contained Files. The dialog Browse For Folder
appears.

Figure 8.18: Dialog Browse For Folder

3. Navigate in the directory containing the individual measurements you
want to merge and click OK.
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4. Mark the individual measurements you would like to merge. To select
several individual files at the same time, hold the control key pressed and
mark the files using the mouse. To select several consecutive files at the
same time, hold the shift key pressed and mark the first and the last of
these measurements with the mouse.

Figure 8.19: Dialog Create Combined File

)

In the column Point Indices the indices of the scan points of all individual
files are displayed. Possible overlaps are marked in red. You can change
the indices directly in this dialog. To do so, click Change Indices. The
dialog Change Indices appears (refer also to SECTION 5.4.2).

5. Click Copy if you want to include the selected files in the combined file.
Or:
Click Link if you want to link the selected files to the combined file.

)

If you only link individual measurements, then retrospective changes to
these measurements will have an effect on the combined file !

6. Tick the box Relative Path if for linked files only the position in the file
system relative to the combined file is to be saved. In this case the links
also remain valid if you copy the combined file with the linked files e.g.
into another directory and thereby retain the relative folder structure.
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7. Click

next to the field Combined File. The dialog Save As appears.

Figure 8.20: Dialog Save As

8. Navigate to the directory in which you want to save the combined file and
enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

9. Click Save.

)

Remove
individual
measurements

If you defined geometry components in the individual measurements
(refer to SECTION 5.4.3), then they will be shown in the combined file with
the respective hierarchy.

10. To remove files from the list of individual measurements for the combined
file, mark them as described in step 4 and click Remove.
11. Click OK.
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8.5.2 Working with Combined Files
The same functions are available to you for combined files as they are for
individual measurements. All other operations after merging will however only
be saved in the combined file. The individual measurements remain
unaffected by this.
As a general rule, every change to a file is marked with an asterisk (*) in the
file name as soon as you make the change. An exception to this are the
frequency bands which are immediately saved after being recalculated. Also
the changes that result of you invalidate scan points are saved immediately.
Display
combined file

To open the combined file, double-click the file name in the project browser or
click it with the right mouse button and select Open in the context menu.
In the 3D view you can simultaneously see the geometry and the vibration
data from all parts of the object that you scanned in the individual
measurements in three dimensions. Between the geometry parts, you will only
see connecting lines if the scan points which are involved have identical
coordinates. This is for example the case if you make each of your individual
measurements on the same complete geometry.
In the 2D view you can see the geometry and the vibration data of the
individual measurements. To show the individual measurements
consecutively, select them in the list Contained File.
If you have defined geometry components in the individual measurements,
you will see these in the list Components. You can edit the geometry
components as described in SECTION 5.4.3.

)

To draw a profile section (refer to SECTION 9.3) you have to select 2D view.
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Figure 8.21: 2D view of an individual measurement from the combined file

In the project browser your can see the individual measurements as well as
the settings with which these measurements were made. To do so, click the
plus sign ( ) in front of the name of the combined file or in front of the name of
the individual measurements.

Figure 8.22: Combined file, individual measurements and settings

)
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You can load the scan point definition of the combined file directly from
the project browser. The scan point definition of a combined file, however,
does not contain the positions of the scan points on the video image.
During loading the scan point definition, these positions will be
recalculated based on the currently valid 2D alignment.
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Overlap of
individual
measurements

Depending of how you defined the scan areas of the individual
measurements, parts of the combined file in the 3D view can overlap.
If the combined file contains scan points twice which have the same indices,
the software prioritizes the data according to the order of the individual
measurements in the dialog Create Combined File (refer to FIGURE 8.17): the
individual measurement which ranks first in the list Combined File has the
priority 1. With the combined file, in case of scan points measured twice, the
video image will be displayed with the geometry data, measurement data etc.
from that individual measurement which contains these scan points and has
the highest priority.

Sort individual
measurements

To adapt the display, you have to change the order of the files. To do so,
proceed as follows:
1. Open the dialog Create Combined File. To do so, in the project browser
click the combined file with the right mouse button and select Properties in
the context menu.

)

You can only select the Properties if the combined file is not opened.

2. In the list Combined File mark the individual measurement which you want
to move.
3. Click
or
in the list.

, to move the selected individual measurement up or down

4. Click OK.
Apply frequency You can apply frequency bands from one of the individual measurements to
bands
the combined file. To do so, proceed as follows:
1. Open the combined file.
2. Open the frequency band definition (refer to

SECTION

9.2.2).

3. Holding the left mouse button pressed, drag the entry Frequency Band of
the required individual measurement from the project browser to the
frequency band definition.
4. Close the frequency band definition. A message box appears with the
question whether the frequency bands are to be recalculated.
5. Click Yes.
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8.6 Recalculating Data in the Signal Processor (as an Option)
If you want to further analyze measurement data you have already acquired,
you can recalculate it and present the results in a direct comparison with the
original data. For this purpose the signal processor is available which you can
transfer the data to and can then process it further. The data calculated this
way is shown in the analyzer of the signal processor. You can also save this
data with the scan and display it again at any time. Please read on this:
•
•
•
•
•

Making a calculation, refer to SECTION 8.6.1
Saving calculated data, refer to SECTION 8.6.2
Displaying measurement results, refer to SECTION 8.6.3
Saving formulae, refer to SECTION 8.6.4
Application examples for editing measurement data, refer to SECTION 8.6.5

8.6.1 Making a Calculation
To recalculate the data, you have to open the respective scan, transfer the
measurement data to the signal processor and carry out the required
arithmetic operations there.
Open the signal
processor

To open the signal processor, select File > New > Signal Processor. The
signal processor appears.

Figure 8.23: Signal processor

You will find a description of the signal processor in
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Open a scan

1. To open the scan in the presentation window, click
Open. The dialog Open appears.

or select File >

Figure 8.24: Dialog Open

2. Navigate to the saving location and select the file type and name. To make
it easier to identify the files, you see meta-information at the bottom in the
dialog – for example, the data acquisition board and the settings with
which the data was measured.
3. Click Open. If you open a scan, a presentation window appears. If you
open a single point measurement, an analyzer appears.
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Recalculate
measurement
data

To recalculate the data in the open file, please proceed as follows:
1. In the presentation window, use the mouse to select one or more scan
points, click with the right mouse button and select Copy Selected Points
in the context menu. The data of the selected scan point(s) is copied.
or
Select Copy All Points in the context menu. The data from all scan points
will be copied.
or
1. If you have selected the view Average Spectrum, click the analyzer with
the right mouse button and select Copy in the context menu. The dialog
Copy appears.

Figure 8.25: Dialog Copy

Select Signal Processor and click OK. The data is copied.
2. Change to the signal processor.
3. Click a cell (e.g. A1) with the right mouse button and select Paste or Paste
Link in the context menu. The copied data is inserted in the signal
processor or inserted and linked.

)

Inserted data contains a reference to the original file and remains in the
corresponding cell, even if you select other data in the sequence or close
the scan or the signal processor. Linked data in contrast is updated in the
formula as soon as you select other scan points and is lost as soon as you
close the scan or the signal processor.

4. If you have selected and pasted several scan points and want to display
the data for a single scan point, select it in the index in the signal
processor analyzer (refer to FIGURE 8.26).
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5. If you want to display certain frames for the selected scan points, click the
number of the particular frames in the analyzer of the signal processor.
After calculating you can display an individual graph for every frame (refer
to FIGURE 8.26 and SECTION 8.6.3).

Figure 8.26: Selection of index and frames in the analyzer of the signal processor

6. Click another cell (e.g. A2) and then activate the input line by clicking it.

)

You can insert a reference to another cell into the formula by holding the
Alt key pressed and then clicking the required cell.

7. Here you enter the required command and confirm it with Enter.
You can also use the icons to enter some commands in the formulae
editor directly or you can take over the formula in the formulae editor by
clicking it in the list next to the icon for the function wizard. You can also
use the function wizard.

Figure 8.27: Icons for calculations in the signal processor

To activate the function wizard, click
. Then when you click one of the
icons, a dialog is opened which supports you entering the parameters.
You will find an example of the function wizard in SECTION 8.6.5 under Post
processing time series. The signal processor carries out this calculation
and shows the results in the analyzer.

)
)

You will find an overview of the formulae stored in the signal processor in
will find application examples for the signal processor in

TABLE 8.3. You
SECTION 8.6.5.

You can also enter any comments you like as text in the individual cells. In
this case you just do not set an equal sign at the start of the respective
text. Invalid formulae are shown in red.
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Table 8.3:

Overview of the arithmetic operations of the signal processor

Command

Icon

Arithmetic operation

Add (+)

By entering + you add two scalars, two strings, two Vib data sets or one Vib
data set and one scalar or join two sets.

Sub (−)

By entering − you subtract two scalars, two Vib data sets or one Vib data set
and a scalar or two quantities.

Mul (*)

By entering * you multiply two scalars, two Vib data sets or one Vib data set
with a scalar or intersect two sets.

Div (/)

By entering / you divide two scalars or two Vib data sets by each other, one
Vib data set by a scalar or one scalar by a Vib data set.

Card

By entering Card you calculate the cardinality (number of elements) in a set.

Power (^)

By entering ^ you raise the value of x to the power of y (written like: x^y, i.e.
xy); x and y can be scalars or Vib data sets.

The following arithmetic operations apply for a scalar or Vib data set:
Re

By entering Re you calculate the real part.

Im

By entering Im you calculate the imaginary part.

Abs

By entering Abs you calculate the absolute value.

Arg

By entering Arg you calculate the phase.

Exp

By entering Exp you calculate the exponential function.

Ln

By entering Ln you calculate the natural logarithm (base e).

Sin

By entering Sin you calculate the sine (radian).

Cos

By entering Cos you calculate the cosine (radian).

Tan

By entering Tan you calculate the tangent (radian).

ASin

By entering ASin you calculate the arc sine (radian).

ACos

By entering ACos you calculate the arc cosine (radian).

ATan

By entering ATan you calculate the arc tangent (radian).

Sign

By entering Sign you calculate the sign of the value x. The result is - 1 for x =
negative, + 1 for x = positive and 0 for x = 0.

Deg

By entering Deg you convert radians into degrees.

Rad

By entering Rad you convert degrees into radians.

Round(x)
Ceil(x)

By entering Ceil you round up real numbers to the next integer e.g. Ceil(1.1) =
2 or Ceil(1.9) = 2

Floor(x)

By entering Floor you round down real numbers to the next integer e.g.
Floor(1.1) = 1 or Floor(1.9) = 1

Pi
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By entering Round you round real numbers to the next integer e.g.
Round(1.1) = 1 or Round(1.9) = 2

By entering Pi you add the constant π to the formula.

Frame

By entering Frame you extract the specified frame or frames from the Vib data
set. If the second parameter is a scalar, its real part is rounded up or down to
the next integer and its imaginary part is ignored.

Point

By entering Point you extract the specified sample point or points from the Vib
data set. If the second parameter is a scalar, its real part is rounded up or
down to the next integer and its imaginary part is ignored.
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Table 8.3:

Overview of the arithmetic operations of the signal processor

Command

Icon

Arithmetic operation

ReIndex

By entering ReIndex you change the indices of the measurement points of a
Vib data set.
Parameter: ReIndex(VibData, [SrcInd, DstInd])
Requirements:
- SrcInd and DstInd can each be an IndexSet or an individual index.
- SrcInd is optional with Default {*} and DstInd is optional with Default 0
- From SrcInd and the IndexSet of VibData an intersection is formed. This
intersection must have the same number of elements as DstInd otherwise
an error message appears.
- The intersection of DstInd and the IndexSet of VibData must be empty. The
measurement points from SrcInd get then the indices of DstInd whereby
their order remains conserved.
Example 1:
ReIndex(VibData, {*}, 0) = ReIndex(VibData) This changes the index to 0 for
a Vib data set which contains an individual sample point.
Example 2:
VibData has the measurement points 1 ... 100; ReIndex(VibData, {21..30},
{101..110}) The result has the indices 1..20,31..110.

FrameUnion
(VibData)

By entering FrameUnion you combine the frames of up to 10 Vib data sets.
The maximum total number of combined frames is 12. You can use this to
compare a sample point with an identical index from different measurements.

PointUnion
(VibData)

By entering PointUnion you combine the sample points of up to 10 Vib data
sets. If sample points occur in more than one data set, those found first are
used.

DisplayUnion
(VibData)

By entering DisplayUnion you combine the frames of up to 10 Vib data sets.
The maximum total number of combined frames is 12. You can use this to
compare sample points with a different index from different measurements if
each of the measurements only contains one sample point respectively.

Extract
ExtractX
(VibData, xMin,
xMax)

By entering Extract you extract the specified frequency line numbers or
samples. The default starting value is 0 and the full scale value is the
maximum number - 1. The full scale value must be larger than the starting
value.
ExtractX works in the same way as Extract. Here, however, you enter only
start and end of the range to be extracted in the physical quantity of the x-axis
(Hz or s).
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Table 8.3:

Overview of the arithmetic operations of the signal processor

Command

FFT

Integrate
Differentiate
Resample
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Icon

Arithmetic operation
By entering FFT you calculate the Fourier Transformation of the Vib data set.
Parameter: FFT(VibData1, [Lines, Window, WndPar1, WndPar2])
Requirements:
- VibData1 must be a real signal.
- The lines must be in the range of 25 ... 1 048 576. If you do not specify the
lines, the maximum possible number will be assumed.
- The length of the vector for the Vib data set must be at least twice the
number of lines, rounded up to the next power of 2.
- The window function (Window) has to be on of the following character
strings:
"Rectangle"
"Bartlett"
"Blackman Harris"
"Exponential"
"Flat Top"
"Force"
"Hamming"
"Hanning"
"Tapered Hanning"
If you do not specify any type of window, "Rectangle" will be assumed.
- WndPar1 and WndPar2 are parameters of the selected window function if
applicable (refer also to SECTION 6.2.5). Please note that WndPar2 is not
currently used.
By entering Integrate you integrate the Vib data set.
Requirement: The input data must be real.
By entering Differentiate you differentiate the Vib data set.
Requirement: The input data must be real.
By entering Resample you have the Vib data set sampled again at the new
specified sample rate.
Requirement: The input data must be real.

IFFT

By entering IFFT you calculate the inverse Fourier Transformation.
Note: With a measurement which is not triggered, the phase in the Vib
channel is replaced by the differential phase to the Ref channel. The
calculation of the inverse FFT can provide unexpected results which are hard
to interpret.

Filter

By entering Filter you filter a Vib data set.
Requirement: The input data must be real.
For Type select one of the character strings "low pass", "high pass", "bandpass" or "notch".
For Quality select one of the character strings "very low", "low", "medium",
"high" or "very high".
For Flow select the cutoff frequency for low pass and high pass and the lower
cutoff frequency for band-pass and notch.
For Fhigh select the upper cutoff frequency for band-pass and notch.
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Table 8.3:

Overview of the arithmetic operations of the signal processor

Command

Icon

Arithmetic operation

FilterCoeff

By entering FilterCoeff you calculate a Vib data set which contains the filter
core of the selected filter.
For Fsamp enter the sample frequency.
For Type select one of the character strings "low pass", "high pass", "bandpass" or "notch".
For Quality select one of the character strings "very low", "low", "medium",
"high" or "very high".
For Flow select the cutoff frequency for low pass and high pass and the lower
cutoff frequency for band-pass and notch.
For Fhigh select the upper cutoff frequency for band-pass and notch.

Transmission

By entering Transmission you calculate a Vib data set which contains the
transmission function of the selected filter.
For Fsamp enter the sample frequency.
For Type select one of the character strings "low pass", "high pass", "bandpass" or "notch".
For Quality select one of the character strings "very low", "low", "medium",
"high" or "very high".
For Flow select the cutoff frequency for low pass and high pass and the lower
cutoff frequency for band-pass and notch.
For Fhigh select the upper cutoff frequency for band-pass and notch.
For Count enter the number of frequency lines for which the transmission
function is to be calculated.

Min, Max,
Mean, StdDev

By entering Min, Mean, Max or StdDev, you respectively calculate the
minimum, average or maximum of a deviation or the standard deviation of a
Vib data set which contains an individual sample point. The return value is a
scalar.
You can calculate Mean for real or complex data. You can only apply all the
other functions to real data.

ArgMin,
ArgMax
(VibData)

By entering ArgMin or ArgMax the abscissa (x-coordinate) of the minimum or
maximum in a real Vib data set which contains an individual sample point is
given.

8-39

8 Displaying Data

Table 8.3:

Overview of the arithmetic operations of the signal processor

Command

Icon

Arithmetic operation

StatMin,
StatMax,
StatMean,
StatStdDev

By entering StatMin, StatMean, StatMax or StatStdDev, you respectively
calculate the minimum, average or maximum of a deviation or the standard
deviation of a Vib data set. The return value is a Vib data set with an
individual measurement point with the index 0.
You can calculate StatMean for real or complex data. You can only apply all
the other functions to real data.
) It can make sense to apply StatMean to a data set which only contains a
single measurement point. This does not change the data set but means that
the point index is set to 0. Points with the index 0 can be compared to all
other indexed points.

Scale
(VibData, xMin,
xMax, xName,
xUnit, yMin,
yMax, yName,
yUnit, yScale,
Name,
0dBReference,
Power)

By entering Scale you modify scaling information of a Vib data set. This
function is usually used to adapt the scaling after operations such as FFT or
Integrate as these operations change the dimensions of the axes. The
following list contains the changes you can make using the command Scale.
- VibData: Data set
- xMin, xMax: Boundaries of the x-axis
- xName: Name of the x-axis
- xUnit: Unit of the x-axis
- yMin, yMax: Boundaries of the y-axis
- yName: Name of the y-axis
- yUnit: Unit of the y-axis
- yScale: The y values are multiplied with yScale
- Name: Name of the data set
- 0dBReference: Reference value of the dB display
- Power: 1 or 2
Power = 1 shows that it is a power signal. 10 dB then corresponds to a
multiple of ten.
For other signals you set Power = 0.20 dB corresponds to a multiple of 10.

Resolution
(VibData)

By entering Resolution the distance between the frequency lines or samples
of a Vib data set are given.

NumValues
(VibData)

By entering NumValues the number of samples or frequency lines of a Vib
data set is given.

Points
(VibData)

By entering Points the set of sample points in a Vib data set is given.
By entering Abscissa a Vib data set of a sample point with the index 0 is
emitted for which the ordinates (y-axis) show that same values as the
abscissa (x-axis).

Abscissa
(VibData)
Direction
(VibData, dir)

By entering Direction you extract the data in vibrational direction of a 3D Vib
data set. The direction is set with the variables dir (0 for x direction, 1 for y
direction, 2 for z direction)

Make3D
(VibData)

By entering Make3D you combine 1D Vib data sets to a 3D Vib data set. If you
combine less than three Vib data sets, the missing ones are replaced with 0.

)
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You can display either the formula or the result in the table cells. To switch
over, select View > Formulae or press the key combination Ctrl + #.
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You can also enter sets and complex numbers. You place sets in curly
brackets and complex numbers as an option in round brackets. In TABLE 8.4
and TABLE 8.5 the input conventions are explained on the basis of examples.
Table 8.4:

Examples for entering sets

Command
{1,2}
{1:5} or {1 .. 5}
{1,4,7 ... 9}

Table 8.5:

Cell links

Meaning
1 and 2
1 to 5
1, 4 and 7 to 9

{}

empty set

{*}

general set

Examples for entering complex numbers

Command

Meaning

0;1 or (0;1)

i

− 1.23E4;− 5.67E8
or(− 1.23E4;− 5.67E8)

– 1.23E4 – 5.67E8 ⋅ i

You will find a description what kind of cell links you can generate in the signal
processor in SECTION 2.6.6 under Calculation table. A distinction is made
between relative and absolute cell links:
Relative Cell Links: If you create a formula, the references to cells are
shown relative to the position of the cell which contains the formula. For
example the cell B6 contains the formula =A5. The signal processor searches
the value in the cell which is located one cell above and one cell on the left of
B6. References of this type are called relative cell links. If you copy a formula
in which relative cell links are used, then the links were automatically adapted
after inserting the formula to refer to other cells in relative to the position of
the formula.
Absolute Cell Links: If you want to prevent that the links will be adapted
when copying a formula in another cell, use an absolute cell link. If, for
example, a formula multiply the cell A5 by the cell C1 (=A5*C1) and is copied
into another cell, both references will be adapted. You can generate an
absolute cell link to the cell C1 by entering a dollar symbol ($) in front of the
part of the link that should not be changed. To generate, for example, an
absolute cell link to the cell C1 enter (=A5*$C$1) in the formula.
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Example
calculations

Differentiation in the Frequency Range
In the following table you will find an example for differentiation in the
frequency range.
Cell

Function

Description

A1

=Complex spectrum

From measurement

B1

=IFFT(A1)

Transformation in the time domain

B2

=Differentiate(B1)

Differentiation in the time domain

=2*Pi()*(0;1)*Abscissa(A1)

Multiplication with 2 π i f in the frequency
range corresponds to a differentiation in
the time domain.

A2
A3

=A1*A2

B3

=IFFT(A3)

Transformation in the time domain

To calculate B2, first of all transform into the time domain and then
differentiate there. To calculate B3, multiply in the frequency range with a
function which corresponds to a differentiation in the time domain. The result
is the same apart from fringe effects and shifts in the order of magnitude of
the sampling. Multiplication with 2 πf corresponds to a high pass,
multiplication with i of a phase shift by 90°.
Integration in the Frequency Range
In the following table you will find an example for the integration in the
frequency range.
Cell

Function

Description

A1

=Complex spectrum

From measurement

B1

=IFFT(A1)

Transformation in the time domain

B2

=Integrate(B1)

Integration in the time domain

=2*Pi()*(0;1)*Abscissa(A1)

Division by 2 π i f in the frequency range
corresponds to an integration in the time
domain.

A2
A3

=A1/A2

B3

=IFFT(A3)

Transformation in the time domain

To calculate B2 first of all transform into the time domain and then integrate
there. To calculate B3, multiply in the frequency range with a function which
corresponds to an integration in the time domain. The result is the same apart
from an additive constant.
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Average over Partition
In the following table you will find an example for creating the average over a
partition.
Cell

Function

Description

A1

=Single sample point

A2

=(sign(Abscissa(A1)-4000) Function which has the value 1 in the
-sign(Abscissa(A1)-6000)) / interval [4 kHz .. 6 kHz] and has the value 0
2
outside

A3
A4

From measurement

=A1*A2

Value outside the interval [4 kHz .. 6 kHz]
are set to 0.

= Mean(A3)/Mean(A2)

Average in the range [4 kHz .. 6 kHz]

Power Spectral Density
In the following table you will find an example for calculating the power
spectral density.
Cell

)
Set up the
signal
description

Function

Description

A1

=Complex spectrum

A2

= abs(A1)^2/Resolution(A1) Power spectral density

You will find detailed examples in

From measurement

SECTION

8.6.5.

You can adapt the presentation of the recalculated measurement data in the
analyzer. To do so, proceed as follows:
1. Click the cell which contains the recalculated measurement data with the
right mouse button and select Signal Description in the context menu. The
dialog Signal Description appears.

Figure 8.28: Dialog Signal Description

2. Fill in the fields as described in the following and click OK.

)

Entries in this dialog are saved and shown in any case, even if the input
data for the signal calculation changes ! If you do not enter anything in a
field, the original value from the input data is retained or adapted.
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Name: Here you enter the description of the recalculated measurement data.
This name is shown in the respective cell. After saving the measurement data
it will also appear on the list of available signals in the presentation window,
refer also to SECTION 8.6.2.
X-Axis: Here you enter the description for the x-axis.
Y-Axis: Here you enter the description for the y-axis.
Minimum: Here you enter the lower value for the scale of the x- or y-axis.
Maximum: Here you enter the upper value for the scale of the x- or y-axis.
Unit: Here you enter the abbreviation for the unit of the x- or y-axis.
Scale: Here you enter the factor by which the presentation of the
measurement values is to be magnified or reduced.
0 dB Reference: If you have selected a view with [dB], here you enter the
value which corresponds to 0 dB (reference value).
Power: If for example the signal includes a cross power spectrum, here you
enter the value 1. If the signal is not a power signal, here you enter the value
0 (default).
8.6.2 Saving Calculated Data
You can add the measurement data which you calculated in the signal
processor to the original file as user defined data sets. To do so, you have the
following options:

)

The indices of the scan points in the original file have to match the indices
of the data set. If not, only the data with corresponding indices is taken
over. The geometry of the objects, i.e. the number of scan points should
be the same. If not, a message will appear and you will be asked whether
you want to take over the data sets.

1. Mark the cell which contains the recalculated measurement data in the
signal processor.
2. Click it with the right mouse button and select Copy in the context menu.
3. Then click with the right mouse button the name of the original file in the
project browser and select Paste in the context menu.
Or:
1. Mark the cell which contains the recalculated measurement data in the
signal processor.
2. Holding the left mouse button pressed, drag to the presentation window.
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Or:
1. Mark the cell which contains the recalculated measurement data in the
signal processor.
2. Holding the left mouse button pressed, drag to the name of the original file
in the project browser.
You will immediately have another channel available with the name Usr, Usr
X, Usr Y, Usr Z or Usr 3D. In the list of signals you will find the recalculated
measurement data listed with the name which you entered in the dialog Signal
Description.
Properties

You can display the properties of the user defined signals and change or
delete them. To do so, click

and select the channel Usr, Usr X, Usr Y, Usr

Z or Usr 3D in the context menu. Then click
and select Properties in the
context menu. The dialog Properties of User Defined Signals appears.

Figure 8.29: Dialog Properties of User Defined Signals

Signals

On the left you will see the user defined signals with the name you entered in
the dialog Signal Description.

Domain and
channel

On the right your are shown the domain, channel and name of the signal and
other properties. You can change these properties for every signal.

Delete

You can delete user defined signals. To do so, mark the signal and click
Delete. The user defined data set is deleted from the file.
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To set the properties of several user defined signals to the same value,
proceed as follows:
1. Mark the corresponding signals in the list. To do so, hold the Control key
pressed and click the signals.
2. Enter the desired common property on the right.
3. As soon as you change the signal selection or click OK the changes to the
signals are accepted.
8.6.3 Displaying Measurement Results
At the same time as the new calculation of the data, the updated graph is
shown in the analyzer. The analyzer of the signal processor has the functions
described in SECTION 2.6.3. If you mark several table cells, then you will be
shown the respective frames for selection. If you select several frames, you
will be shown the respective graphs in parallel.

Figure 8.30: Presentation of several graphs in the analyzer

If you would like to stop updating the graph at a certain point in the arithmetic
chain, click
. The presentation then corresponds to the contents of the
table cell selected at that moment in time. All subsequent arithmetic steps are
carried out anyway, but do not have any effect on the presentation of the
graph. Changes in the formulae before the position marked with
however
still have an effect on the adaptation of the presentation up to this point.
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8.6.4 Saving Formulae
To save formulae after you have recalculated the measurement data, proceed
as follows:
1. Click

or select File > Save As. The dialog Save As appears.

Figure 8.31: Dialog Save As

2. Navigate to the saving location and enter the file name.
3. Click Save.

)

The file saved in this way does not contain any measurement data itself
but only references to data. The reference among other things includes
the full path name of the original file. If you move or rename the scan, then
the references to the measurement data become invalid. To permanently
save your results, you have to add them to the original file. A file in the
format Signal processor data (*.spd) does not contain any data, just
calculation specifications !
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8.6.5 Application Examples for Editing Measurement Data
Complex
average
spectrum
through all scan
points

During data acquisition, the software calculates an average spectrum across
all scan points. However, it is not complex averaging but the amplitudes of the
individual spectra are calculated and these amplitudes are averaged. In this
example you are shown how you can use the signal processor in presentation
mode to help you calculate the complex averaged spectrum across all scan
points and can then save it so that you have access to it at all times.
1. Select File > New> Signal Processor to generate a new signal processor
document.
2. Open the file EXAMPLE2.SVD and display in the domain FFT the channel
Vib & Ref1 and the signal H1 Velocity / Voltage.
3. In the presentation window click the object with the right mouse button
and select Copy All Points in the context menu.
4. Change to the signal processor.
5. Click the cell A1 with the right mouse button and select Paste in the
context menu. The data is available in the signal processor document.
6. Select the cell A2. To do so, click it.
7. Here you enter the command =StatMean(A1) and confirm it with Enter.
The signal processor calculates the complex average through all scan
points and shows this in the analyzer.

Figure 8.32: Display of the complex average through all scan points

)

The average through all scan points is given the index 0.

8. Click
in the analyzer toolbar and select the view Mag. [dB] & Phase
in the context menu to display both the magnitude and also the phase of
the average spectrum.
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9. Click the cell A2 with the right mouse button and select Signal Description
in the context menu. The dialog Signal Description appears.

Figure 8.33: Dialog Signal Description

10. In the field Name enter the description Complex Average Spectrum and
click OK to close the dialog.
11. Arrange the signal processor and the presentation window so that they
are both completely visible. To do so, select Window > Tile Horizontally.
12. Click the cell A2 in the signal processor.
13. Click the cell A2 again and holding the left mouse button pressed, drag
the mouse cursor across to the presentation window. Release the mouse
button there. This then means that the data in the cell A2 are added to the
channel Usr as a user defined signal Complex Average Spectrum.
Or:
14. Click the cell A2 with the right mouse button and select Copy in the
context menu.
15. Change to the presentation window and here, if applicable, select the view
Average Spectrum.
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16. Select Edit > Insert. The complex average spectrum is added to the
document EXAMPLE2.SVD as a user defined signal Usr.

Figure 8.34: Display of complex average spectrum

17. Save this file with a different name. You can now display the complex
average spectrum again at any time. To do so, open the file you saved
and select
•
•
•
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the channel Usr in the toolbar of the analyzer and
the signal Complex Average Spectrum in the toolbar of the analyzer.
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Multiplication of An FRF (Frequency Response Function) is generated by dividing an answer
an FRF with the signal (vibrometer signal) by a reference signal (excitation signal). The same
reference signal applies to the signals H1 and H2. This means that the FRF has for example
the unit Velocity / Voltage. The advantage of this process is that fluctuations in
the excitation over the duration of the scan do not have any great effect
because the measurement at every scan point relates to the excitation
measured at this scan point. However, it is often desirable to show the answer
in its original unit. This example shows how with the aid of the signal
processor you can multiply the FRF with the average spectrum through all
scan points of the excitation signal and can save and display the result in the
original file.
1. Select File > New> Signal Processor to generate a new signal processor
document.
2. Open the file EXAMPLE2.SVD and display in the domain FFT the channel
Vib & Ref1 and the signal H1 Velocity / Voltage.
3. In the presentation window click the video image with the right mouse
button and select Copy All Points in the context menu.
4. Change to the signal processor.
5. Click the cell A1 with the right mouse button and select Paste in the
context menu. The data is available in the signal processor document.
6. Change to the presentation window.
7. Here you select the signal Voltage of the channel Ref1.
8. In the presentation window click the video image with the right mouse
button and select Copy All Points in the context menu.
9. Change to the signal processor.
10. Click the cell A2 with the right mouse button and select Paste in the
context menu. The data is available in the signal processor document.
11. Click the cell A3.
12. Here you enter the command =A1*StatMean(A2) and confirm it with Enter.
The signal processor first of all calculates the average of the spectra of
the excitation signal through all scan points (StatMean(A2)) and multiplies
the result at every spectrum of the signal H1, which is taken from the cell
A1. The result is shown in the cell A3.
13. Click the cell A3 with the right mouse button and select Signal Description
in the context menu. The dialog Signal Description appears (refer also to
FIGURE 8.33).
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14. In the field Name enter the description H1 Vib * Ref1 Velocity.

)

For the functions Integrate, Differentiate, FFT and IFFT the software
automatically adapts the axis name and the unit. For the other functions,
enter the name in the dialog.

15. In the field Y-Axis, enter the description Velocity.
16. In the field Unit of the Y-Axis enter the unit m / s and click OK to close the
dialog.
17. Arrange the signal processor and the presentation window so that they
are both completely visible. To do so, select Window > Tile Horizontally.
18. Click the cell A3 in the signal processor.
19. Click the cell A3 again and holding the left mouse button pressed, drag
the mouse cursor across to the presentation window. Release the mouse
button there. This means then that the data in the cell A3 are added to the
channel Usr as a user defined signal H1 Vib * Ref1 Velocity.
20. Change to the presentation window.
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21. Here you select the view Single Scan Point.

Figure 8.35: Display of the multiplication of FRF and reference signal

22. Save this file with a different name. From now on you can display the
signal H1 multiplied with the average spectrum of the reference channel at
any time. To do so, open the file you saved and select the channel Usr
and the signal H1 Vib * Ref1 Velocity in the presentation window.
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Post processing With the software option Time Domain Data, you can also capture data in the
time series
domain Time. With the aid of the signal processor this data can be evaluated.
The following example shows the analysis of a time series of the response of
a loudspeaker to a rectangular excitation signal.
1. Select File > New> Signal Processor to generate a new signal processor
document.
2. Open the file Ex Time.pvd and display in the domain Time the channel Vib
and the signal Velocity.
3. Click the analyzer with the right mouse button and select Copy in the
context menu. The dialog Copy appears.
4. Select Signal Processor, click OK and change to the signal processor.
5. Click the cell A1 with the right mouse button and select Paste in the
context menu. The data is available in the signal processor document.
6. Click the cell A1. In the analyzer of the signal processor you will see a
graphic representation of the time series measured.
7. Click the cell A2.
8. Here you enter the command =Integrate($A$1) and confirm it with Enter.
9. Click the cell A2 with the right mouse button and select Signal Description
in the context menu. The dialog Signal Description appears (refer also to
FIGURE 8.33).
10. In the field Name, enter the description Integrated to Displacement.

)

For the functions Integrate, Differentiate, FFT and IFFT the software
automatically adapts the axis name and the unit. For the other functions,
enter the name in the dialog.

11. In the field Y-Axis, enter the description Displacement.
12. In the field Minimum of the Y-Axis, enter the value − 10 e − 6.
13. In the field Maximum of the Y-axis, enter the value 10 e − 6.
14. In the field Unit of the Y-Axis enter the unit m and click OK to close the
dialog.
The analyzer will now display the displacement signal gained by
integrating the velocity signal. Along the time axis you will be able to see a
linear decay in the signal. This decay is caused by a negative offset on the
velocity signal which has an increased effect due to insufficient
modulation of the data acquisition board when acquiring the velocity
signal.
15. Copy the contents of cell A2 into cell B2. To do so, select cell A2 and
press the key combination Ctrl + C. Then select cell B2 and press the key
combination Ctrl + V.
16. Click in the formulae editor where the formula from cell B2 is displayed.
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17. There replace the parameter ($A$1) of the function Integrate by entering
($A$1-Mean($A$1)) and confirm the changing with Enter.
This changing to the formula means that the offset from the time series is
subtracted in cell A1. For this purpose, first of all the average of the time
series is determined and this average is subtracted from every time value
in the time series. As the time series is periodic in the time window
measured, this has the effect of completely correcting for the offset.
Then the integration is calculated.
18. Click the cell B2.
19. Then also select the cell A2. To do so, hold the control key pressed and
click the cell A2.
The analyzer in the signal processor now shows two graphs. One
corresponds to the signal in cell B2 and one to the signal in cell A2.
Through a direct comparison of the graphs you can clearly see the
disappearance of the linear decay by correction of the offset.
20. Click the cell B3 and activate the input line. Then click
in the toolbar of
the signal processor. This command inserts a template for the function
FFT into the input field and the formulae editor.
Replace the descriptions VibData with B2, Lines with 256 and Window
with "Rectangle" and delete the two descriptions WindowParameter. In
doing so, make sure that you put the value "Rectangle" in inverted
commas.
Alternatively click the cell B3, activate the input line, click

and then

. The dialog Function Wizard appears.

Figure 8.36: Dialog Function Wizard

Here you enter the above mentioned values and click OK.
21. Confirm the change with Enter.
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22. Click the cell B3 with the right mouse button and select Signal Description
in the context menu. The dialog Signal Description appears (refer also to
FIGURE 8.33).
23. In the field Name, enter the description FFT Displacement.
24. In the field X-Axis, enter the description Frequency.
25. In the field Unit of the X-Axis, enter the unit Hz and click OK to close the
dialog.
From the 512 samples of the integrated time series in cell B2, the signal
processor will now calculate an FFT with 256 lines and will display this in
the analyzer.
26. Arrange the signal processor and the presentation window so that they
are both completely visible. To do so, select Window > Tile Horizontally.
27. Click the cell B2 in the signal processor.
28. Click the cell B2 again and holding the left mouse button pressed, drag
the mouse cursor to the analyzer. Release the mouse button there. This
process adds the data in cell B2 as a user defined signal Integrated to
Displacement to the channel Usr.
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29. Repeat steps 27 and 28 for the cell B3. Thus you add the contents of the
cell as a user defined signal FFT Displacement.

Figure 8.37: Display of post processing time series

30. Save this file with a different name. You can now display the integrated
time series and the FFT calculated from it at any time. To do so, open the
file you saved and select the channel Usr in the domain FFT or Time.
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9 Evaluating Scans
The software offers numerous possibilities to evaluate scans. To do this, first
open the scan as described in SECTION 10.1.2. Depending on which
measurement mode you used to acquire the data, you will see the results of
your measurement in the time or frequency range.
You can see which mode a measurement was made in by opening the
additional information in the dialog at the bottom of a file. Read
SECTION 10.1.1 on this.
If you have opened a scan, you will see in the status bar which mode the
measurement was made in.
If you open a scan, which has been generated in FFT mode, in presentation
mode for the first time, you will see the root mean square of the magnitude
over the entire bandwidth. You can apply certain evaluation functions directly
to the root mean square. See SECTION 9.1 and SECTION 9.3 on this. You can
also evaluate sections of the measured spectrum – for example, in the
proximity of resonance or 1/3 octave bands. First of all you have to define
these frequency bands as described in SECTION 9.2. At the peak frequencies
of the frequency bands you can also animate the vibration, see SECTION 9.4
on this. You can also evaluate the spectrum with a single cursor, see
SECTION 9.2.1 on this.
In FastScan mode you only measure a certain individual frequency.
Correspondingly you will only see a surface-like presentation of the data of
this frequency if you open the scan in presentation mode.
If you open a scan generated in Time mode for the first time in presentation
mode, you will see the root mean square of the magnitude over the whole
sample time. With the time data animation you can present the momentary
magnitude of the sample time for selected ranges.

9.1 Processing Data
You can prepare a scan for display with the following commands in the menus
Edit and Presentation:
•
•
•
•
•
•

Invalidate
Valid
Validate All Points
Invalidate Not Optimal Points
Interpolate Data
Filter Data

Apart from that, you can change the specification of the vibrational direction.
You can undo some commands.
In presentation mode you can mark the scan points you have already
measured to be remeasured. To do so, allocate the points the scan status
Invalidated as described in the following. Then change back into acquisition
mode and open the file to remeasure as described in SECTION 7.2.
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In principle, you could allocate all scan points the scan status Invalidated, but
this is only necessary for those points which have not provided any
meaningful measurement result (e.g. those with a bad signal-to-noise ratio).
For scan points with the scan status Invalidated the software does not display
any measurement data. The averaged spectrum over all scan points is
corrected correspondingly.

)

Invalidated

Scan points with the status Optimal can only be present if Signal
Enhancement was active during scanning (refer to SECTION 7.8.1 and
SECTION 6.2.7).

To allocate the status Invalidated to one or more scan points, proceed as
follows:
1. Place a cursor at the scan point or points. See SECTION 8.3.4 on this.
2. Press the key combination Ctrl + space bar or select Edit > Modify
Selected Points > Invalidate.

Valid

3. To return to the original status of the scan points, press the key
combination Shift + space bar or select Edit > Modify Selected Points >
Validate.

Validate All
Points

To allocate all scan points their original status, select Edit > Validate All
Points.

Invalidate Not
Optimal Points

You can allocate the status Invalidated to all scan points which do not have
the status Optimal. This command is only active if
•
•

Signal Enhancement was active during scanning (refer to
and SECTION 6.2.7)
not all scan points have got the status Optimal.

SECTION

7.8.1

To do this, proceed as follows:
1. Select Edit > Invalidate Not Optimal Points.
2. To return to the original status of the scan points, select Edit > Invalidate
Not Optimal Points again.

)

Interpolate Data

For scan points with the status Overrange or Invalidated the software does
not display any measurement data. You can interpolate and display data from
neighboring scan points for these as well as for not optimal scan points.

)
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If you had changed the status of single scan points with the command
Invalidate (see above), these scan points are also allocated their original
status.

The software allocates the status Overrange while scanning. You can
allocate the status Invalidated manually (see above).
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To interpolate, proceed as follows:
1. Select Presentation > Interpolate Data. If you would like to interpolate not
optimal points as well, then in addition to that select Edit > Invalidate Not
Optimal Points.
2. To undo the command, select Presentation > Interpolate Data again.

)

Filter Data

If Interpolate Data is active, then in ASCII export the interpolated data is
saved. If you export as Universal File and ME’Scope or access via Polytec
File Access, you will obtain the original data.

You can smooth the display of scans with a filter. Filtering is done on two
levels. First of all median averaging and then center value filtering of
neighboring scan points is carried out.
To smooth the display, proceed as follows:
1. Select Presentation > Filter Data.
2. To undo the command, select Presentation > Filter Data again.

Change
specification of
vibrational
direction

)

If Filter Data is active, then in ASCII export the smoothened values are
saved. If you export as Universal File and ME’Scope or access via Polytec
File Access, you will obtain the original data.

)

The commands Interpolate Data and Filter Data represent measures
taken to rid measurements of interference signals and noise levels. When
defining the quantity of scan points, already ensure that there is a
sufficient scan point density, depending on the maximum vibration
frequency in the object to be measured. Careful scan point definition also
helps avoiding interference signals caused by unsuitable selection of scan
points, e.g. glancing incidence at the edge of an object or undesirable
measuring in object openings.

You can still retrospectively change the direction of the vibration in the
presentation window. The vibrational direction shown in the legend is the one
you selected in the dialog Acquisition Settings on the page Channels (refer to
SECTION 6.2.2). Here you can select the direction of the vibration.

)

You can not change the direction of the vibration for 3D data.
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Figure 9.1: Selecting vibrational direction

With 2D geometries the direction of the vibration defines the scanning head
coordinate system. Read up on this in SECTION 4.1.1 (Enter coordinates of
axes) as well and in your theory manual.

9.2 Evaluating Sections of a Spectrum
You can evaluate sections of the measured spectrum. There are two ways to
do so:
•
•

Setting cursors and evaluating frequency range (Cursor Mode), refer to
SECTION 9.2.1
Defining frequency bands (not in mode Time), refer to SECTION 9.2.2

9.2.1 Setting Cursors and Evaluating the Frequency Range (Cursor Mode)
Requirement

With a single cursor you can evaluate spectra for scans which contain a
complete spectrum. Scans without a complete spectrum are those,
•
•
•
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in which only frequency bands are saved (refer to SECTION 10.2.1),
which were measured in the measurement mode FastScan or
which were measured in the measurement mode Time.
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For evaluation, proceed as follows:
1. Select the domain FFT.
2. From the list Frequency Band in the toolbar of the presentation window,
select the entry Cursor.

Figure 9.2: Selecting the entry Cursor

3. Set a single cursor in the analyzer as described in SECTION 8.2.3. The
frequency and the magnitude at the current cursor position can be seen in
the legend on the right. If the legend is not visible on the right in the
analyzer, select Analyzer > Legend to display it. In the presentation
window you will see the vibration position which the object under
investigation takes at the selected frequency.
4. Drag the cursor while holding the left mouse button pressed to the left or
right. This updates the data in the legend and the presentation window.

)

If you do not set a cursor or delete the cursor you had set, you can also
enter the required frequency directly in the legend of the presentation
window.

9.2.2 Defining Frequency Bands (not in Time Mode)
To analyze the spectrum with the aid of frequency bands, start by entering the
start and end frequencies of the frequency band in the frequency band
definition. The software determines the peak frequency and the bandwidth of
the frequency bands.
Requirement

You can define frequency bands for scans,
•
•

whose file is not write-protected and
which contain a complete spectrum.

Scans without a complete spectrum are those
•
•
•

in which only frequency bands are saved (refer to SECTION 10.2.1),
which were measured in the measurement mode FastScan or
which were measured in the measurement mode Time.
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Save

The software saves the frequency band definition in the scan as soon as you
save the scan. Read SECTION 10.2.1 on this. The software loads the frequency
band definition when you open the scan again. You can also save the
frequency band definition separately as an ASCII file and load it into several
scans. See SECTION 10.2.5 and SECTION 10.1.3 on this.

)
Define

As a general rule, every change to a file is marked with an asterisk (*) in
the file name as soon as you make a change.

To define frequency bands, proceed as follows:
1. Either display the view Single Scan Point or Average Spectrum. To do so,
click

and select Single Scan Point or Average Spectrum.

2. Open the frequency band definition. To do so, click
or select Setup >
Frequency Bands. The dialog Frequency Band Definition appears.
3. Enter the start and end frequencies of the frequency bands as described
below. You have two possibilities to do this: directly in the analyzer or in
the dialog Frequency Band Definition. The software determines the peak
frequencies of the frequency bands for the data set displayed in the view
set.
4. You can change between different views or display other data sets without
closing the frequency band definition. The software does not determine
the peak frequencies again at that point. To determine the peak
frequencies again, in the dialog Frequency Band Definition click

.

5. If the software is to calculate 1/3 octave bands, then in the dialog
Frequency Band Definition click

.

6. When you have defined all frequency bands, close the frequency band
definition. To do so, click
again or select Setup > Frequency Bands.
The software calculates the root mean square of the frequency bands and
saves them in the scan.
Analyzer

To enter start and end frequency of a frequency band directly in the analyzer,
proceed as follows:
1. Click

in the analyzer or select Analyzer > Show Bands.

2. Point at the diagram (not at the edge of the diagram).
3. Point at the start point of the required frequency band.
4. Press the mouse button and then drag right or left to the end point. The
software displays the frequency band in color and enters it in the dialog
Frequency Band Definition (see below).
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Dialog

To enter start and end frequency of a frequency band in the dialog Frequency
Band Definition, proceed as follows:
1. The dialog Frequency Band Definition consists of a toolbar and a table,
the frequency band editor. If you can not see the table, display it. To do so,
click

in the toolbar of the frequency band definition.

Figure 9.3: Dialog Frequency Band Definition

2. In the toolbar, click

. A new line is added to the bottom of the table.

3. Enter the start frequency in hertz. The start and end frequency must be on
FFT lines. The software replaces the value entered by the next possible
one.
4. Press Tab or click the corresponding cell in the column End.
5. Enter the end frequency in hertz.
6. Press Enter. The software enters the peak frequency and the bandwidth in
the frequency band editor and displays the frequency band in the analyzer
in color.
Select

To delete or copy frequency bands from the definition, you have to select
them first. To do this, proceed as follows:
1. Click the frequency band in the analyzer or its line number in the
frequency band editor.
2. To select further frequency bands, press the Control key and click the
number of the line in the frequency band editor.
3. To select all frequency bands or to undo a selection, click the top left of
the table.
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Delete

To delete frequency bands from a definition, proceed as follows:
1. Select the frequency bands as described above.
2. Press the Delete key or in the dialog Frequency Band Definition click

Copy

.

You can copy a frequency band definition via the clipboard into another scan.
To do this, proceed as follows:
1. Select the frequency bands as described above.
2. In the dialog Frequency Band Definition click

.

3. Close the current frequency band definition. To do so, in the presentation
window click

or select Setup > Frequency Bands.

4. Open the scan into which you want to copy the frequency bands.
5. Open the frequency band definition again. To do so, click
Setup > Frequency Bands.
6. In the dialog Frequency Band Definition click
Drag with the
mouse

or select

.

You can also apply frequency bands to another scan in the project browser by
dragging with the mouse. To do so, proceed as follows:
1. Holding the left mouse button pressed, drag the entry Frequency Band
from the project browser to the frequency band definition.

Figure 9.4: Entry Frequency Band in the project browser

2. Close the frequency band definition. A message box appears with the
question whether the frequency bands are to be recalculated.
3. Click Yes.
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9.3 Displaying Profiles
You can display profiles of the data. To do this, you first draw profile sections
on the object. You will see the profiles at the bottom in the analyzer. The
software automatically saves the profile sections in the scan and loads them
when you reopen the scan.

)
Draw profile
section

If you want to draw profile section in a file (including a combined file) or
want to display a profile, you first of all have to change over to 2D view.

To draw a profile section on the object, proceed as follows:
1. Display the view Profile. To do so, click
context menu.

and select Profile in the

2. Display the view style Surface, Wireframe, Isolines or Scan Points. To do
so, click
3. Click

and select the view style in the context menu.
.

4. Point at the object and click the start point of the profile section. The
cursor becomes a

.

5. Click as many other vertex points as you like. You can see the profile at
the bottom in the analyzer.
6. To define the end point of the profile section, double-click.
Select profile
sections

To edit profile sections, you have to select them first. To do this, proceed as
follows:
1. Click

.

2. Point at a profile section. The cursor becomes a

.

3. Click. The software marks the vertex points of the profile section with
white markers.
4. To select or deselect further profile sections, click them while holding the
Control key pressed.
5. To select all profile sections, press the key combination Ctrl + A or select
Edit > Select All.
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Move profile
sections

To move profile sections, proceed as follows:
1. Select the profile sections as described above.
2. Point at one of the lines (not at a vertex point). The cursor becomes a

.

3. Press the mouse button and drag in the direction required.
Move vertex
points

You can change the shape of profile sections by moving the individual vertex
points. To do this, proceed as follows:
1. Select a profile section as described above.
2. Point at a vertex point. The cursor becomes a

.

3. Press the mouse button and drag in the direction required.
Duplicate profile To duplicate profile sections, proceed as follows:
sections
1. Select the profile sections as described above.
2. Click
or select Edit > Copy. The profile sections are copied onto the
clipboard.
3. Click

)
Delete profile
sections

or select Edit > Paste.

If you do not have selected a profile section, you can save data onto the
clipboard with Edit > Copy as described in SECTION 10.2.11.

To delete profile sections, proceed as follows:
1. Select the profile sections as described above.
2. Press the Delete key or select Edit > Delete.

Animate

You can animate the profiles' vibrations. See

Undo and Redo

You can undo up to 50 operations and then redo them. To do so, click
or select Edit > Undo and Edit > Redo.
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9.4 Animating Vibrations
For you to be able to animate the measured vibration, during the scan either
the signal has to be triggered (phase-related measurement) or a reference
signal has to have been captured.

)

In measurement mode Time you can not capture a reference signal.

How you animate vibrations in the different measurement modes, you read in:
•
•

Measurement mode FFT, Zoom-FFT, FastScan, MultiFrame, refer to
SECTION 9.4.1
Measurement mode Time, refer to SECTION 9.4.2

9.4.1 Measurement Mode FFT, Zoom-FFT, FastScan, MultiFrame
If you have carried out a measurement in one of the above mentioned modes,
you can set how many images per animation cycle are shown.
To animate a vibration, proceed as follows:
Preparation

1. Define frequency bands for the scan. See

SECTION

9.2 on this.

2. Display the frequency band whose peak frequency you want to animate.
Or:
Go to cursor mode (refer to

SECTION

9.2.1).

3. Display the FFT spectrum. To do so, click
context menu.

and select FFT in the

4. Display a complex signal.

)

For complex signals, the display type Phase is available.

5. It is useful to display the 3D view. To do so, click
. You can animate in
all view styles apart from the view style Status Points.
6. If in the list Select Frequency Band in the toolbar of the presentation
window, you select the entry Cursor, then depending on the size of the file
and the memory capacity of your PC, the following dialog may appear:

Figure 9.5: Resorting data

)

If you do not have enough memory available, you will receive the
message that you have to reduce the amount of data (refer to FIGURE 9.6
or FIGURE 9.7).

9-11

9 Evaluating Scans

If you click Cancel here, you will be given the following message:

Figure 9.6: Dialog to reduce the amount of data (general)

It is recommended that you use the suggested value or enter a higher
one. Thus you reduce the amount of data which is processed for
animation, i.e. only every n-th sample point is used. Click OK.
Subsequently the data will be resorted and you can start animation.

)
User defined
data sets

If you set a smaller step size than the one suggested, the subsequent
resorting of the data can take quite some time !

If you are working with user defined data sets (see
well), you can also evaluate these.

SECTION

8.6 on this as

7. To do so, click
and select the channel Usr in the context menu. It is
also necessary to resort the data on this. If you abort this, here the dialog
Data will also appear. In addition you can also limit the number of frames
here to reduce the amount of data. The same recommendations as above
also apply here.

Figure 9.7: Dialog to reduce the amount of data (for user defined data sets)
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Start

There are two ways of starting animation:
8. To start the animation in the active presentation window, click
or
select Animation > Start. The software shows the signal in the display type
Instant Value and animates the vibration. You can see the instantaneous
angle in the legend in the field Angle
. If the legend is not visible
on the right of the object, select Presentation > Legend to display it.
or
To start animations simultaneously in all open presentation windows,
select Animation > Start All.

Velocity

9. To increase or decrease the speed of the animations, select Animation >
Increase Speed or Animation > Decrease Speed.

Stop

There are two ways of stopping animations:
10. To stop the animation in the active presentation window, click
select Animation > Stop.

again or

or
To stop all current animation, select Animation > Stop All.
Step forward,
step backward

You can make animations run forwards or backwards image by image. To do
so, click
and
or select Animation > Step Forward and Animation >
Step Backward. You will see the next or previous animation frame
respectively.
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Frames per
animation cycle

If you have carried out the measurement in FFT mode, you can set the
number of frames per animation cycle in the dialog Preferences. To open the
dialog, select Setup > Preferences. Then display the page Display.

Figure 9.8: Page Display in the dialog Preferences

Number of Animation Frames: Here you enter how many frames per
animation cycle you want to see. The minimum number is 8, the default
setting is 18.
Angular Resolution: The software calculates the phase angle between the
data of two frames and displays it here.
Maximum Number of Displayed Samples: Here you enter an upper limit for
the number of samples to be shown simultaneously in the time domain.
Scale
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You can change the degree of deflection in the animation with non-scalar
data. To do so, you have three possibilities:
•

To increase the deflection shown, click
Up.

or select Presentation > Scale

•

To show the deflection with the default setting, click
Presentation > Auto Scale.

•

To weaken the deflection shown, click
Down.

or select

or select Presentation > Scale

9 Evaluating Scans

Display
vibrational
directions (only
3D data)

Once you have made a measurement with the PSV-3D, you can show the
vibrations of the object individually in x, y and z direction. You can also
combine displaying two vibrational directions with each other. To display and
hide the vibrations in the various directions, click the icons
,
and
.
If the icon is activated, then the vibration is being shown in the respective
plane. If the icon is deactivated, then the vibration is not being shown in the
respective plane.

Figure 9.9: Presentation window in the view Object

Save

You can save animations in multimedia format *.avi. See
this.

SECTION

10.2.6 on
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9.4.2 Measurement Mode Time
If you have carried out the measurement in Time mode, you will see the
animation in the time domain. To animate a vibration, proceed as follows:
Preparation

1. Display the time domain. To do so, click
context menu.

and select Time in the

Depending on the size of the scan file and capacity of your PC's memory,
the following dialog may appear:

Figure 9.10: Dialog for reducing the time data step size

It is recommended that you use the suggested value or enter a higher
one. Click OK. This means that the time data is resorted and the z-axis
scaled correspondingly and you can start the animation in time domain.

Figure 9.11: Resorting data

)

If you set a smaller step size than the one suggested, the subsequent
resorting of the time data can take quite some time !

Figure 9.12: Scaling the z-axis

)
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If you click Cancel during resorting, the dialog Data to reduce the time
data step size appears again (see above). To return to the RMS domain,
click Cancel again.
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2. It is useful to display the 3D view. To do so, click
. You can animate in
all view styles apart from the view style Status Points.
3. Select the section within the sample time in which the data is to be
animated. There are two ways to do so:
Enter the start and end time directly into the legend to the right of the
presentation window. If the legend is not visible, select Presentation >
Legend to display it.
or
Open an analyzer. To do so, click

and select Single Scan Point. Click

and with a further mouse click, set the starting point directly in the
diagram. (As initially the starting point is identical with the current point in
time, it is marked by a red line.)
Hold the mouse button pressed and drag it to the right. A second black
line will appear which marks the end point. If the line is in the right place,
release the mouse button.
Start

There are two ways of starting animation:
4. To start the animation in the active presentation window, click
or
select Animation > Start. You can see the defined time frame and the
current status of the animation and also the step size in the legend.
or
To start animations simultaneously in all open presentation windows,
select Animation > Start All.
You can let the animation run forwards or backwards and stop it at any time,
change its speed or save it as described in the following:

Velocity

5. To increase or decrease the speed of the animations, select Animation >
Increase Speed or Animation > Decrease Speed.

Stop

There are two ways of stopping animations:
6. To stop the animation in the active presentation window, click
select Animation > Stop.

again or

or
To stop all current animation, select Animation > Stop All.
Step forward,
step backward

You can make animations run manually forwards or backwards. To do so, click

Save

You can save animations in multimedia format *.avi. See
this.

and
or select Animation > Step Forward and Animation > Step
Backward. You will see the next or previous animation frame respectively.
SECTION

10.2.6 on
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10 Managing Data
To manage your measurement data, the following functions are available:
You will find information on opening, loading and importing files, settings and
data in SECTION 10.1.
You will find information on saving and exporting files, settings and data in
10.2.

SECTION

10.1 Opening, Loading and Importing
The software can make the following management functions:
•
•
•
•
•

Opening files, refer to SECTION 10.1.1
Opening scans, single point measurements and signal processor
documents, refer to SECTION 10.1.2
Loading frequency band definitions, refer to SECTION 10.1.3
Loading and deleting settings, refer to SECTION 10.1.4
Importing data in Universal File or ME’Scope format, refer to
SECTION 10.1.5

10.1.1 Opening or Loading Files
Open

The software can open the following files:
•
•
•
•

Load

Scans in the proprietary binary format Scan Data (*.svd), refer to
SECTION 10.1.2
Single point measurements in the proprietary binary format Single Point
Data (*.pvd), refer to SECTION 10.1.2
Signal processor files in the proprietary binary format Signal Processor
Files (*.spd), refer to SECTION 10.1.2
Frequency band definitions in the ASCII format, refer to SECTION 10.1.3

The software can load or import the following files:
•
•
•

Settings in the proprietary binary format Settings Files (*.set), refer to
SECTION 10.1.4
Measurement data in the format Universal Files (*.unv), (*.uff), (*.asc),
refer to SECTION 10.1.5
Measurement data in the format MEScope Block Files (*.blk), refer to
SECTION 10.1.5
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File Information

If you have opened a file you can display additional information that you
saved with the file. To do so, click
or select File > Info. You can also use
the command Info in the project browser. See also SECTION 2.6.4 on this. The
dialog File Information appears.

Figure 10.1: Dialog File Information

File Information: Here you see the file name with the complete file path, the
user, the creation date, and with which software version the measurement
was made.
Comment: Here you see comments on the measurement. You can complete
the comment by clicking Comment at the bottom. The dialog Comment
appears. You can now complete the text on the measurement and save it by
clicking OK.
Scan Points: Here you see which scan status the scan points have gotten
during the measurement.
Hardware: Here you see with which junction box and data acquisition board
the measurement was made.
General, Frequency, Sampling, Trigger, etc. Here you see the
measurement mode and the settings with which the measurement was made.
Export ASCII: You can export the file informations as an ASCII file. To do so,
click Export ASCII at the bottom. The dialog Save As appears. Here navigate
to the saving location, enter the file name and click Save.
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Printing: You can print out the file informations. To do so, click Print. The
dialog Print appears. Here you can select the printer and set up further print
properties. To start the printing process, click OK.
10.1.2 Opening Scans, Single Point Measurements and Signal Processor Documents
In presentation mode you can open scans and single point measurements in
the proprietary binary formats Scan Data (*.svd) and Single Point Data
(*.pvd). There are two ways of doing this:
•
•
•

Dialog Open
List of most recent files in the menu File
Project browser

You can also open the last scan measured if you change into presentation
mode. To do this, follow the instructions in the software.
Open via dialog

To open a scan or a single point measurement, proceed as follows:
1. Click

or select File > Open. The dialog Open appears.

Figure 10.2: Dialog Open
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2. Navigate to the saving location and select the file type and name. To make
it easier to identify the files, look at meta-information at the bottom in the
dialog – for example, the data acquisition board and the settings with
which the data was measured.
3. Click Open. If you open a scan, a presentation window appears. If you
open a single point measurement, an analyzer appears.
Open via file list In presentation mode, in the menu File at the bottom there is a list with up to
nine files which you last opened. In the menu File at the bottom there is a list
with up to nine files which you last opened.To open one of these files again,
click it in the list.
Open via project You can use the project browser to open the files, see
browser
Open on this.

SECTION

2.6.4 under

10.1.3 Loading Frequency Band Definition
In presentation mode, you can load frequency band definitions in ASCII
format.

)

When you load a frequency band definition, the existing one is
overwritten.

To load a frequency band definition, proceed as follows:
1. Open the scan you want to load a frequency band definition for. See
SECTION 10.1.2 on this.
2. Open the frequency band definition. To do so, click
Frequency Band Definition appears.
3. In the dialog Frequency Band Definition, click
appears.

. The dialog

. The dialog Open

4. Navigate to the saving location and select the file.
5. Click Open.
6. Close the frequency band definition. To do so, click

again.

10.1.4 Loading and Deleting Settings
In acquisition mode, you can load settings from files in the proprietary binary
format Settings Files (*.set) and from scans.You can only delete settings if
they are saved in a setting file (*.set). You can not delete the settings of a
scan.

)
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You will find information on saving the current settings in

SECTION

10.2.7.
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You can load the following information from setting files and scans:
•

Frequency band definition

(not possible from setting files)

•

Settings for data acquisition in the dialog Acquisition Settings
possible for identical data acquisition boards)

•

Scan point definition

•

Settings of the optics
(alignment, only PSV-400 and PSV-300: zoom
and focus of the video camera)

•

Window layout

(only

(not possible from scans)

To load the settings, you have two options:
•
•
Load via dialog

Dialog Open
Project browser

To load settings via the dialog, proceed as follows:
1. Click

or select File > Load Settings. The dialog Open appears.

Figure 10.3: Dialog Open
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2. Navigate to the saving location, select the file type and the file. At the
bottom in the dialog, you can select which settings you want to load. To do
so, click the corresponding check box.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. Click OK. A message box appears with the question whether you want to
overwrite your settings until now. Click Yes. The selected settings will be
loaded.
Load via project
browser

To load settings via the project browser, proceed as follows:
1. Open the project browser (refer to

SECTION

2.6.4).

2. Open a directory which contains setting files or scans.
3. Click the plus sign ( ) in front of the setting file (*.set), the scan (*.svd) or
the single point measurement (*.pvd) which you want to load the settings
from. You will see a list of settings which are saved in the file.

Settings in the setting file

Settings in the scan

Figure 10.4: List of saved settings

Load individual
settings

4. If you only want to load certain settings from a file, mark them. To mark
several settings at once, hold the control key pressed and click the
respective settings.
5. Double-click the selected line(s).
Or:
Click the marked settings with the right mouse button and select Load in
the context menu.

Load all
settings

6. If you want to load all settings from a setting file, double-click the file
name.
Or:
Click the file name with the right mouse button and select Load in the
context menu.
7. A message box appears with the question whether you want to overwrite
your settings until now. Click Yes.
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Delete

To delete settings, proceed as follows:

)

You can only delete settings if they are saved in a setting file (*.set). You
can not delete the settings of a scan.

1. Open the project browser (refer toSECTION 2.6.4).
2. Click the plus sign ( ) in front of the setting file (*.set), whose settings you
want to delete. You will see a list of settings which are saved in the file
(refer to FIGURE 10.4).
Delete
individual
settings

3. If you only want to delete certain settings from the setting file, mark them.
To mark several settings at once, hold the control key pressed and click
the respective settings.
4. Click the marked settings with the right mouse button and select Delete in
the context menu.

Delete the
setting file

5. If you want to delete the setting file, click the file name with the right
mouse button and select Delete in the context menu.

10.1.5 Importing Universal File or ME’Scope
You can import data in Universal File or ME’Scope format in presentation
mode. This data is saved as user defined data sets and can then be analyzed.
This thus enables you for example to import modal adaptations to the spectra
from ME’Scope and to make comparisons with the original data in the
software.
To import data in Universal File or ME’Scope format, proceed as follows:
1. Open the scan you want to import the data into. See
this.

SECTION

10.1.2 on
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2. Select File > Import. The dialog Open appears.

Figure 10.5: Dialog Open

3. Navigate to the saving location and select the file type and name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

4. Click Open. The point data is imported and the dialog Properties of
Signals to be Imported appears.

Figure 10.6: Dialog Properties of Signals to be Imported

5. Mark the signals which you want to import and if necessary set the
parameters for import. You will find information on this in the following.
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6. Click Import.
Signals

On the left you mark the signals which you want to import. To do so, you have
to activate the corresponding box Name. If you want to import all signals. click
Select All. If you want to remove superfluous signals to keep up the overview,
mark them and click Remove.

Domain and
channel

On the right your are shown the domain, channel and name of the signal and
other properties. You can adapt these properties for every signal for import.
To set the properties of several user defined signals to the same value,
proceed as follows:
1. Mark the corresponding signals in the list. To do so, hold the Control key
pressed and click the signals.
2. Enter the desired common property on the right.
3. As soon as you change the signal selection or click OK the changes to the
signals are accepted.

Combine

You can group signals with the same properties from different scan points
(different indices). To do so, mark the corresponding signals by clicking the
individual signals while holding the control key pressed or alternatively, while
holding the shift key pressed, click the first and the last signal required.

Figure 10.7: Combining signals

Then click Combine. The signals are combined and selected for import.

)

If a combination is not possible you will receive a message which tells you
which conditions need to be fulfilled.
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Generate 3D
signals

You can group together signals with the same properties and indices but with
different directions into a 3D signal. To do so, mark the corresponding signals
by clicking the individual signals while holding the control key pressed or
alternatively, while holding the shift key pressed, click the first and the last
signal required. Then click Generate 3D.

Figure 10.8: Generating 3D signals

The signals are grouped together to a 3D signal, are positioned under a
separate headline and are marked for import.

Figure 10.9: Generated 3D signal

)
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The separate positioning of the 3D signals only works in Windows® XP or
Vista. In Windows® 2000 a new column Domain is inserted in which the
3D signals can be seen.
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10.2 Saving and Exporting
The software provides the following ways of saving and exchanging data:
•
•
•

•
•
•
•
•
•
•
•
•
•
•

Saving scans in the proprietary binary format Scan Data (*.svd), refer to
SECTION 10.2.1
Saving scans with frequency band data, but without point data in the
proprietary binary format Scan Data (*.svd), refer to SECTION 10.2.1
Saving scans with user defined data sets, but without frequency band data
and original point data in the proprietary binary format Scan Data (*.svd),
refer to SECTION 10.2.1
Saving single point measurements and average spectrum in the
proprietary binary format Single Point Data (*.pvd), refer to SECTION 10.2.2
Exporting measurements in the format Universal File (*.uff, *.unv) as an
option, refer to SECTION 10.2.3
Exporting measurements in the format ME’Scope Files (*.str, *.blk, *.shp)
as an option, refer to SECTION 10.2.4
Saving frequency band definitions in the format ASCII Files (*.txt) or in the
format Frequency Band Description (*.fbd), refer to SECTION 10.2.5
Saving animations in the multimedia format AVI Files (*.avi), refer to
SECTION 10.2.6
Saving settings in the proprietary binary format Settings Files (*.set), refer
to SECTION 10.2.7
Exporting measurement data in the format ASCII Files (*.txt), refer to
SECTION 10.2.8
Exporting measurement data in the Wave Sound format Sound Files
(*.wav), refer to SECTION 10.2.9
Saving windows in different graphics formats, refer to SECTION 10.2.10
Copying measurement data in ASCII format, signal processor data,
graphics, and window settings onto the clipboard, refer to SECTION 10.2.11
Saving recalculated scans as signal processor document in the format
Signal Processor Data (*.spd), refer to SECTION 8.6.4

10.2.1 Saving Scans
Complete scan

When you start a scan, the software automatically creates a file for the scan
and prompts you to save. See SECTION 7.2 on this. When scanning, the
software saves the following data in proprietary binary format Scan Data
*.svd:
•
•
•
•

Settings (refer also to SECTION 10.2.7)
Spectra at all completely measured scan points (single point spectra)
Average spectrum of all scan points
Root mean square of the magnitude over the entire bandwidth

Even if you abort a scan, the software has saved all scan points which had
already been measured.
In presentation mode, you can define frequency bands for a scan (refer to
9.2) and draw profile sections (refer to SECTION 9.3). The software
automatically saves the frequency band definitions and profile sections in the
scan.
SECTION
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Frequency
bands

In presentation mode, often only certain sections of the frequency range
measured are of interest. For these sections you usually define frequency
bands and then evaluate only those frequency bands. You can then save this
scan without the single point spectra, as the frequency bands contain all
relevant information. This means you can save a lot of disk space. The scan
is then subject to certain limitations:
•
•

You can not define any other frequency bands.
The view Single Scan Point is not available.

Please note that the average spectrum saved corresponds to the original data
and not to the spectrum created by removing invalidated single points (refer
also to SECTION 9.1).
To save a scan without single point spectra, proceed as follows:
1. Open the scan you want to save. See SECTION 10.1.2 on this.
2. Define the frequency bands which you want to evaluate. See
on this.

SECTION

9.2

3. Select File > Save Bands. The dialog Save As appears.
4. Navigate to the saving location and enter the file name. The software
suggests the file name scan name_b. However, you can also select
another file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

5. Click OK.
10.2.2 Saving Single Point Measurement and Average Spectrum
In acquisition mode, you can save the measurement in the active analyzer in
the proprietary binary format Single Point Data *.pvd. In presentation mode,
you can save the single scan point or the average spectrum displayed from a
scan. Please note that the average spectrum saved corresponds to the
original data and not to the spectrum created by removing invalidated single
points (refer also to SECTION 9.1). In doing so, the software saves the following
data:
•
•
•
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Time signals
Spectra
Parameters for data acquisition and evaluation.
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To save, proceed as follows:
1. Select File > Save Analyzer As. The dialog Save As appears.

Figure 10.10:Dialog Save As

2. Navigate to the saving location and enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. At the bottom in the dialog you can enter meta-information to give the file
more precise properties. This meta-information is part of the file properties
which you can also view and edit in Explorer. You can also call up this
information using the command Info in the project browser (refer
toSECTION 2.6.4).
4. Click Save.
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10.2.3 Exporting Universal File (as an Option)
In both acquisition and presentation mode, you can export data in Universal
File format which is compatible with the modal analysis software from the
companies SDRC (MTS), LMS and STAR and Vibrant (ME'Scope). To do this,
you need the option Universal File Format.

)

You can export Universal Files in acquisition mode, but not in APS mode.

Scan points with the status Not Measured, Overrange or Invalidated are not
exported. Data evaluation with Presentation > Filter Data and Presentation >
Interpolate Data does not have any effect on export, the measured data is
exported. Only with option VDD: Measurements in measurement mode I / Q
can not be exported as Universal Files.
Signals which have been gained from the original signals through integration
and differentiation can be exported.
To export a Universal File, proceed as follows:
1. If you want to carry out a Universal File export in presentation mode, open
the scan you want to export. See SECTION 10.1.2 on this.
2. Select File > Export > Universal File. The dialog Save As appears.

Figure 10.11:Dialog Save As

3. Navigate to the saving location and enter the file name.

)
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If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.
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4. Click Save. The dialog Universal File Export appears.

Figure 10.12:Dialog Universal File Export in presentation mode
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5. If you export the data in acquisition mode, you are only offered displaying
objects to choose from.

Figure 10.13:Dialog Universal File Export in acquisition mode

6. Mark the signals which you want to export and set the parameters for
export. You will find information on this in the following.
7. Click OK.
You can correct the entries from a scan again for the current export and also
enter new settings for files which already exist. The changes however do not
have any effect on the scan saved.
Signals
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On the left you mark the signals which you want to export. The selection
depends on whether you are exporting in acquisition or in presentation mode,
which signals you measured and whether frequency bands have been
defined. If Display Objects (Elements) is ticked, then a graphic representation
of the scan points and their connections is exported.

)

If you want to export a Universal File in acquisition mode, here you can
only select the display of the objects.

)

You can export user defined data sets but not average spectra.
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Parameters

On the right you set the parameters for export.

)

If you have defined geometry components (refer to SECTION 5.4.3), then
only the component names for the data sets 82 and 58 will be taken into
account for export.

Compatibility: Here you select the modal analysis software which the
Universal File is to be compatible with. You will find a brief description of the
data sets used in TABLE 10.1. For detailed information on this, see the manual
for your modal analysis software.
Table 10.1: Data sets which are exported in the Universal File

Data set

Description

Header

General information,
e.g. file name, date,
comment

Units

Nodes
(Geometry)

SDRC (MTS)
151

LMS

STAR

Vibrant

151

151

151

Units of the signals and 164
coordinates
Double
precision

164
Double
precision

164
Double
precision

164
Double
precision

Coordinates of the scan 2411
points
Double
precision

2411
Double
precision

15
Single
precision

2411
Double
precision

Elements
Graphic representation 2412 + 82
(Trace Lines) of the scan points and Integer
their connections

82
Integer

82
Integer

2412 + 82
Integer

Frequency
bands

A data set for every
frequency band and
every signal

55
Single
precision

55
Single
precision

55
Single
precision

55
Single
precision

Scan points

A data set for every
signal and every scan
point

58
Single
precision

58
Single
precision

58
Single
precision

58
Single
precision

UNIX: Tick the box if you carry out modal analysis under UNIX. Text lines will
then be ended with a line feed to be UNIX compatible. Special characters in
the comment – for example, German umlauts – are not adapted to UNIX.
Channel: Here you select the channel for which you want to see or change
the direction of the vibration or the reference excitation.
Channel <Name>: Here you can see the direction of the vibration or the
reference excitation for the selected channel (e.g. Ref 3) and change it if
necessary.

)

It is not possible to specify the vibrational direction for the channel
Vibrometer 3D.
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Reference Point: If you have selected a reference channel and have
measured the reference signal at one of the scan points, then you can enter
the index of this reference point here.

)

Please pay attention that the settings for the vibrational direction and the
reference point do not have any effect on exporting user defined signals
(channel Usr or Usr X, Usr Y, Usr Z). We recommend before exporting,
that you check and, if necessary, change the properties of the user
defined signals as described in SECTION 8.6.2.

Index Offset: Here you can enter an offset which the software adds to the
indices of the scan points. This helps you to avoid an index being allocated
more than once if you want to evaluate several scans at the same time.
Object Distance: Here you enter the stand-off distance in meters, measured
from the front of the scanning head. In proprietary file format, the coordinates
of the scan points are saved as angles, in the Universal File however in
cartesian coordinates. Thus the stand-off distance is required for the
conversion. For measurements with the close-up unit PSV-A-410 or OFV-056C, you have to add 41 millimeters to the stand-off distance. This corresponds
to the optical path length within the close-up unit. As a preset, the software
shows the distance here which you have given in the legend in the element
2D Point (refer toSECTION 4.1). You can correct this distance here again,
however this does not have any effect on the distance saved in the scan.

)

This field does not appear for 3D geometries.

Comment: Here you can enter a comment up to 80 characters long.
10.2.4 Exporting ME’Scope (as an Option)
In both the acquisition and also presentation mode, you can export files in
ME’Scope format. To do this, you need the option ME’Scope.
In acquisition mode, you can export the object geometry so that you can
makes further use of it in other applications for example. You can export
scans in presentation mode. Export will provide up to three files with the
following data:
•
•
•

Single points in the format *.blk (block)
Frequency bands in the format *.shp (shape)
Geometry in the format *.str (structure)

Scan points with the status Not Measured, Overrange or Invalidated are not
exported. Data evaluation with Presentation > Filter Data and Presentation >
Interpolate Data does not have any effect on export, the measured data is
exported. Only with option VDD: Measurements in measurement mode I / Q
can not be exported as ME'Scope.
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To export to ME'Scope, proceed as follows:
1. If you want to carry out an ME’Scope export in presentation mode, open
the scan you want to export. See SECTION 10.1.2 on this.
2. Select File > Export > ME'Scope. The dialog Save As appears.

Figure 10.14:Dialog Save As

3. Navigate to the saving location and enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.
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4. Click Save. The dialog ME’Scope Export appears.

Figure 10.15:Dialog ME’Scope Export in presentation mode
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5. If you export the data in acquisition mode, you are only offered displaying
objects to choose from.

Figure 10.16:Dialog ME’Scope Export in acquisition mode

6. Mark the data which you want to export and set the parameters for export.
You will find information on this in the following.

)

Signals with different x-axes, e.g. signals of the domains Time and FFT,
can not be exported together. Export these signals individually one after
the other.

7. Click OK.
You can correct the entries from the scan again for the current export and also
enter new settings for files which already exist. The changes however do not
have any effect on the scan saved.
Signals

On the left you mark the signals which you want to export. The selection
depends on whether you are exporting in acquisition or in presentation mode,
which signals you measured and whether frequency bands have been
defined. If Display Objects (Elements) is ticked, then a graphic representation
of the scan points and their connections is exported.

)

If you want to export data in ME'Scope format in acquisition mode, here
you can only select the display of the objects.

)

You can export user defined data sets but not average spectra.
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Parameters

On the right you set the parameters for export.
Channel: Here you select the channel for which you want to see or change
the direction of the vibration or the reference excitation.
Channel <Name>: Here you can see the direction of the vibration or the
reference excitation for the selected channel and change it if necessary.

)

It is not possible to specify the vibrational direction for the channel
Vibrometer 3D.

Reference Point: If you have selected a reference channel and have
measured the reference signal at one of the scan points, then you can enter
the index of this reference point here.

)

Please pay attention that the settings for the vibrational direction and the
reference point do not have any effect on exporting user defined signals
(channel Usr or Usr X, Usr Y, Usr Z). We recommend before exporting,
that you check and, if necessary, change the properties of the user
defined signals as described in SECTION 8.6.2.

Index Offset: Here you can enter an offset which the software adds to the
indices of the scan points. This helps you to avoid an index being allocated
more than once if you want to evaluate several scans at the same time.
Object Distance: Here you enter the stand-off distance in meters, measured
from the front of the scanning head. In proprietary file format, the coordinates
of the scan points are saved as angles, in ME'Scope format however, as
cartesian coordinates. Thus the stand-off distance is required for the
conversion. For measurements with the close-up unit PSV-A-410 or OFV-056C, you have to add 41 millimeters to the stand-off distance. This corresponds
to the optical path length within the close-up unit. As a preset, the software
shows the distance here which you have given in the legend in the element
2D Point (refer toSECTION 4.1). You can correct this distance here again,
however this does not have any effect on the distance saved in the scan.

)

This field does not appear for 3D geometries.

Comment: Here you can enter a comment up to 255 characters long.
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10.2.5 Saving Frequency Band Definitions
In presentation mode, you can save the current frequency band definition in
the ASCII format or as Frequency Band Description. To do so, proceed as
follows:
1. Open the frequency band definition. To do so, click
Frequency Band Definition appears.
2. In the dialog Frequency Band Definition, click
appears.

. The dialog

. The dialog Save As

3. Navigate to the saving location, enter the file name and select the file type
Frequency Band Description (*.fbd) or ASCII Files (*.txt).

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

4. Click Save.
5. Close the frequency band definition. To do so, click

again.

10.2.6 Saving Animations
In presentation mode, you can save animations in the multimedia format
AVI Files (*.avi). You will find information on animations in SECTION 9.4.
To save an animation, proceed as follows:
1. Open the scan you want to save an animation for. See
this.

SECTION

10.1.2 on

9.4.1 or

SECTION

9.4.2.

2. Set up your animation as described in

SECTION

3. Select File > Save Animation. The dialog Save As appears.

)

If the presentation window contains an analyzer, you can select whether
you would like to save an animation from top graphics, the bottom
graphics or both.

4. Navigate to the saving location and enter the file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

5. Click Save.
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10.2.7 Saving Settings
In acquisition mode, you can save the current settings in the proprietary
binary format Settings Files (*.set). A setting file contains:
•

Settings for data acquisition in the dialog Acquisition Settings

•
•

Scan point definition
Settings of the optics (alignment, only PSV-400 and PSV-300: zoom and
focus of the video camera)

•

Window layout

To save settings, proceed as follows:
1. Click
or select File > Save Current Settings As. The dialog Save As
appears.

Figure 10.17:Dialog Save As

2. Navigate to the saving location and enter a file name.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. Click OK. All current settings are saved in the file.
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10.2.8 Exporting Measurement Data in ASCII Format
You can export the data in the active analyzer or presentation window as an
ASCII file. The coordinate system for ASCII export depends on whether you
want to export 3D or 2D geometries. With 3D geometries always the complete
x-, y-, z-coordinates are exported. With 2D geometries the coordinate system
depends on whether you have entered the distance Z of the object in the
element 2D Point in the scanning head control (refer to SECTION 4.1.1, Enter
coordinates of axes). If this is the case, then also the complete x-, y-, zcoordinates are exported. Depending on the vibrational direction of the
channel the coordinate in vibrational direction is set to 0. If no distance is
entered, the coordinate system for ASCII export corresponds to the
coordinate system of the live video image which you set the scan points on.
The upper left corner in the coordinate system of the live video image is
defined as u = 0, v = 0, the bottom right corner as u = 4 / 3, v = 1.
To calculate the angles of the scanner mirrors from the coordinates, you will
need the information from the 2D or 3D alignment respectively. You will get
this from Polytec File Access.

)

In principle, always during export in ASCII format only the data is exported
which has been displayed in the presentation window. If you have hidden
components, this data will not be exported. If you have evaluated data
(Filter Data or Interpolate Data), the evaluated data is exported.

To export the measurement data in ASCII format, proceed as follows:
1. Select File > Export > ASCII. The dialog Save As appears.

Figure 10.18:Dialog Save As
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2. Navigate to the saving location, enter the file name and select the file
extension.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. If you are exporting in presentation mode, you will see a selection at the
bottom of the dialog. Select which data you want to export from the upper
view or the lower view. You can export different data consecutively several
times.

)

If you are exporting all bands or all points, then a file is generated for
every frequency band or every scan point.

4. Click Save.
10.2.9 Exporting Measurement Data in the Wave Sound Format
You can export data (time signals and spectra) in the active analyzer or
presentation window as a file in the Wave Sound format Sound Files (*.wav).
During exporting spectra, an inverse FFT is calculated on this. Make sure that
for this purpose you will need a valid phase and "Rectangle" as the window
function, so that you will receive the expected results.

)

Therefore, we recommend exporting spectra in the Wave Sound format
only when you have a complex signal for the measurement, and you have
used a trigger and the window function "Rectangle".

To export in the Wave Sound format, you proceed as follows:
1. Select File > Export > Wave Sound. The dialog Save As appears.
2. Navigate to the saving location, enter the file name and select the file
extension.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. Click Save.
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10.2.10 Saving Graphics
You can save the active window in different graphics formats. The title bar and
the frame are not saved. The live video image is saved without scan points.
To save, proceed as follows:
1. Select File > Save Graphics. The dialog Save As appears.

Figure 10.19:Dialog Save As

2. Navigate to the saving location, enter the file name and select the file
type.

)

If you have the project browser displayed (refer to SECTION 2.6.4), you will
then automatically be shown the directory marked there as saving
location.

3. If you are saving the graphics from presentation mode in the view Single
Scan Point, Average Spectrum or Profile, then at the bottom of the dialog
you see the field Select view. Select whether you want to save the upper,
the lower or both graphics.
4. Click Save.
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10.2.11 Copying Data onto the Clipboard
You can copy data onto the clipboard from the active window as graphics, as
signal processor data or in ASCII format. Furthermore, you can copy the
window settings onto the clipboard. If you select the graphics, then the title
bar and the frame are not copied. The live video image is copied as graphics
without scan points.

)

Depending on the window selection or the view, you are offered a more or
less comprehensive dialog.

To copy onto the clipboard, proceed as follows:
1. Activate the required window or the required view. To do so, click it.
2. Click

or select Edit > Copy. The dialog Copy appears.

Figure 10.20:Dialog Copy

3. Select the data you want to copy onto the clipboard.

)

Please pay attention, if you are in profile view, that you do not have
selected profile lines. Otherwise these profile lines will be copied onto the
clipboard.

4. Click OK.
You can now paste the data from the clipboard into other applications.
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You can also purposefully click a certain part of the window with the right
mouse button and select Copy in the context menu. The dialog Copy appears.

Object view

Analyzer

Figure 10.21:Dialog Copy

Select the data you want to copy onto the clipboard and click OK.
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Index
Numerics
0 dB reference 3-18
1/3 octave bands 9-6
2D alignment
abort alignment 4-15
check alignment 4-15
check alignment points 4-13
define alignment points 4-12
define alignment points with Auto Align 4-15
delete alignment points 4-13
perform how and when 4-10
position laser beam 4-11
special features for PSV-3D 4-13
start 4-11
2D geometry, transform to 3D geometry
MSA with option MSAGeo 5-37
PSV/PSV-3D with geometry scan unit 5-35
3D alignment
alignment points with/without geometry scan
unit 4-55
appropriate alignment points with geometry
scan unit 4-56
appropriate alignment points without geometry
scan unit 4-57
appropriately position scanning heads
(PSV-3D) 4-55
edit alignment points 4-59
evaluate quality 4-58
for PSV with geometry scan unit 4-22
for PSV without geometry scan unit 4-17
for PSV-3D with geometry scan unit 4-34
for PSV-3D without geometry scan unit 4-28
further information 4-54
merge individual measurements (stitching) 4-60
merge individual measurements with mirror and
geometry scan unit 4-61
merge individual measurements, with
MSA 4-62
MSA, for the object system 4-48
MSA, for the scanning head system 4-45
optimal results with geometry scan unit 4-60
perform for different systems 4-16
perform how and when 4-16
position alignment points appropriately
(MSA) 4-62
position alignment points appropriately
(PSV/PSV-3D) 4-56
support with the PDA 4-42

3D alignment, start
MSA, for the object system 4-48
MSA, for the scanning head system 4-45
PSV with geometry scan unit 4-22
PSV without geometry scan unit 4-17
PSV-3D with geometry scan unit 4-34
PSV-3D without geometry scan unit 4-28
3D coordinates
delete (not APS) 5-31
delete, in point mode 5-22
interpolate (not APS) 5-30
interpolate, in point mode 5-22
of scan points, modify (not APS) 5-30
of scan points, modify in point mode 5-22
triangulate (not APS) 5-30
triangulate, in point mode 5-22
3D geometry
projection (3D view) 8-7
sight 8-7
view style 8-17
zero position, 3D view 8-5
3D view
display properties 8-5
view style of data 8-17
8 channels, acquire (as an option) 3-7

A
acquisition mode
display grid, in 3D view 8-3
mode in the software 2-3
set up 3D view 8-5
set up live video image 4-9
set up object 8-2
set up view style 4-8
set up view style of measurement data 8-3
activate, PSV-3D 3-3
active
channels 6-5
function generator 6-20
pan-tilt stage 3-10
Signal Enhancement 6-17
window 2-13
additional vibrometer controller, display in the
scanning head control 4-3
Agilent 33120 A and 33250 A, external function
generators 7-10
align
3D alignment for different systems 4-16
perform 2D alignment 4-10
perform 3D alignment 4-16
alignment points, check (2D alignment) 4-13

i

Index

alignment points, check (3D alignment)
MSA, for the object system 4-52
MSA, for the scanning head system 4-47
PSV with geometry scan unit 4-26
PSV without geometry scan unit 4-21
PSV-3D with geometry scan unit 4-40
PSV-3D without geometry scan unit 4-33
with the PDA (3D) 4-44
alignment points, define (2D alignment)
in the software or with the PDA 4-12
with Auto Align 4-15
alignment points, define (3D alignment)
appropriate, with geometry scan unit 4-56
appropriate, without geometry scan unit 4-57
MSA, for the object system 4-50
MSA, for the scanning head system 4-46
position appropriately (MSA) 4-62
position appropriately (PSV/PSV-3D) 4-56
PSV with geometry scan unit 4-24
PSV without geometry scan unit 4-18
PSV-3D with geometry scan unit 4-36
PSV-3D without geometry scan unit 4-30
with the PDA 4-44
alignment points, delete (2D alignment) 4-13
alignment points, delete (3D alignment)
MSA, for the object system 4-50
PSV with geometry scan unit 4-24
PSV without geometry scan unit 4-18
PSV-3D with geometry scan unit 4-36
PSV-3D without geometry scan unit 4-30
with the PDA 4-44
alignment points, edit (3D alignment) 4-59
alignment, abort (2D alignment) 4-15
alignment, abort (3D alignment)
MSA, for the object system 4-52
PSV with geometry scan unit 4-26
PSV without geometry scan unit 4-21
PSV-3D with geometry scan unit 4-40
PSV-3D without geometry scan unit 4-33
alignment, calculate (3D alignment)
MSA, for the object system 4-51
PSV with geometry scan unit 4-25
PSV without geometry scan unit 4-20
PSV-3D with geometry scan unit 4-37
PSV-3D without geometry scan unit 4-32
alignment, check (2D alignment) 4-15
alignment, complete for PSV-3D with the
geometry scan unit 4-39
alignment, end (3D alignment)
MSA, for the object system 4-53
MSA, for the scanning head system 4-48
PSV with geometry scan unit 4-27
PSV without geometry scan unit 4-22
PSV-3D with geometry scan unit 4-41
PSV-3D without geometry scan unit 4-34

ii

alignment, save 10-24
all start, animations
in measurement mode FFT, Zoom-FFT,
FastScan, MultiFrame 9-13
in measurement mode Time 9-17
all stop, animations
in measurement mode FFT, Zoom-FFT,
FastScan, MultiFrame 9-13
in measurement mode Time 9-17
analyzer
in the signal processor 2-13
open 2-7
print 2-16
properties 8-8
angle correction for oblique incidence 3-10
angular resolution of animations 9-14
animation
in measurement mode FFT, Zoom-FFT,
FastScan, MultiFrame 9-11
in measurement mode Time 9-16
of the vibration 9-11
save 10-23
scale deflection 9-14
start, in measurement mode FFT, Zoom-FFT,
FastScan, MultiFrame 9-13
start, in measurement mode Time 9-17
stop, in measurement mode FFT, Zoom-FFT,
FastScan, MultiFrame 9-13
stop, in measurement mode Time 9-17
areas, enclosed by scan points 5-23
arithmetic operations, in the signal processor 8-36
arrange, figures (APS) 5-25
ASCII, export 10-25
Assigned Best, laser focus status 7-6
Assigned Fast, laser focus status 7-6
Assigned Manually, laser focus status 7-6
assignment, clear (3D alignment)
PSV without geometry scan unit 4-22
PSV-3D without geometry scan unit 4-34
Auto Align
define alignment points 4-15
define scan points 5-21
automatically focus
laser beam 4-7
video camera 4-4
autoscale
in the analyzer 8-9
in the presentation window 8-4
Average Spectrum, view 8-16
averaging
frames 6-27
improve frequency spectra 6-3
with Signal Enhancement 6-17
avi, multimedia format 10-23

Index

B
background color
display properties 8-2
in the analyzer 8-14
in the video window 4-8
background, figure into (APS) 5-25
backwards, figure (APS) 5-25
band cursor 8-11
bands, save 10-12
bandwidth
measurement mode FastScan 6-24
measurement mode Zoom-FFT 6-23
measurement modes FFT and MultiFrame 6-11
black and white, live video image 4-9
brightness of the live video image 4-9

C
calculate
focus values, of scan points (not APS) 5-31
Calculated, laser focus status 7-6
calculation table, in the signal processor 2-13
carry out, Principal Component Analysis
(MIMO) 6-4
cascade, arrange windows 2-13
center frequency, measurement mode
Zoom-FFT 6-23
center of the screen, mark (MSA) 3-12
change
3D alignment points 4-59
distribute scan points 5-8
indices of scan points 5-28
of figures (APS) 5-23
scan points (APS) 5-22
scan points (not APS) 5-26
shape of a figure 5-7
channels
acquire, 8 channels (as an option) 3-7
allocate for PSV-3D 3-8
allocation, analog and digital 3-6
display (data set) 8-20
display in the scanning head control 4-4
parameters, for data acquisition 6-4
set up 3-5
circle, draw 5-6
close all, windows 2-13
close-up unit
calculate stand-off distance (ME’Scope
export) 10-22
calculate stand-off distance (UFF export) 10-18
set video image to black and white 4-9
color
data in the legend, analyzer properties 8-14
data in the legend, display properties 8-2
graphs in the analyzer 8-14
color saturation of the live video image 4-9

color-coding 8-17
combination of channels, display 8-20
combined file
display 8-29
general information 8-25
generate 8-26
sort individual measurements 8-31
take over frequency bands 8-31
commands, in the project browser 2-9
compatibility of Universal Files 10-17
complex averaging 6-3
complex numbers, enter in the signal
processor 8-41
component, define 5-31
connect, vibrometer 3-6
connections between scan points (APS)
define 5-14
delete 5-15
display 5-23
context-sensitive help 2-17
continuous measurement, make 7-1
contrast of the live video image 4-9
control
a second vibrometer, example
measurement 7-16
external function generator 7-10
internal function generator 7-11
pan-tilt stage 4-4
vibrometer 3-6
controller, connect 3-6
coordinate definition (3D alignment)
MSA, for the object system 4-53
PSV without geometry scan unit 4-27
PSV-3D without geometry scan unit 4-41
coordinate lines, delete (3D alignment)
PSV without geometry scan unit 4-19
PSV-3D without geometry scan unit 4-31
coordinates, assign (3D alignment)
PSV without geometry scan unit 4-19
PSV-3D without geometry scan unit 4-32
coordinates, modify (PSV-3D) 5-21
coordinates, set (3D alignment)
PSV without geometry scan unit 4-18
PSV-3D without geometry scan unit 4-30
coordinates, set/assign (3D alignment)
MSA, for the object system 4-50
PSV with geometry scan unit 4-24
PSV-3D with geometry scan unit 4-36
copy
figures (APS) 5-25
objects, in the project browser 2-10
coupling, input coupling 6-7
crosshair on display (MSA) 3-12
cursor mode 9-4
cursor properties 8-11

iii

Index

cursor values, copy 8-13
cursor, set
in the analyzer 8-10
in the presentation window 8-18

D
data
analyzer properties 8-13
display 8-1
display properties 8-3
data acquisition
8 channels, acquire (as an option) 3-7
options for 3-1
parameter description 6-2
set the parameters 6-1
data set, display in the analyzer 8-13
data transparency, set 8-4
data, read
in the analyzer 8-10
in the presentation window 8-18
dB reference
define 0, for data acquisition 3-18
define 0, for evaluation 8-22
set up 3-18
decrease speed
animation (measurement mode FFT,
Zoom-FFT, FastScan, MultiFrame) 9-13
animation (measurement mode Time) 9-17
default settings of the live video image 4-9
define
alignment points for 3D alignment (MSA) 4-62
alignment points for 3D alignment (PSV/PSV3D) 4-56
alignment points with/without geometry scan
unit 4-55
frequency bands 9-5
geometry components 5-31
scan points 5-1
delete
3D coordinates (not APS) 5-31
3D coordinates, in point mode 5-22
figures (APS) 5-25
focus values, of scan points (not APS) 5-31
frequency band 9-8
delete, settings 10-7
density of grid points (APS) 5-8
description, parameters for data acquisition 6-2
devices
initialize 2-3
set up 3-2
differential cursor 8-11
differential input 6-7
dim, laser beam (MSA/MSV) 4-3

iv

direction
of the reference, ME’Scope export 10-22
of the reference, UFF export 10-17
of the vibration, ME’Scope export 10-22
of the vibration, UFF export 10-17
disable
scan points (not APS) 5-29
scan points, in point mode 5-22
Disabled, scan status 7-4
display
combined file 8-29
data 8-1
file information 10-1
grid in acquisition mode (3D view) 8-3
grid in the presentation window 8-4
indices of scan points, in acquisition mode (3D
view) 8-3
indices of scan points, in the presentation
window 8-4
indices of scan points, in the video window 5-28
objects (elements), ME’Scope 10-21
objects (elements), UFF 10-16
of figures (APS) 5-23
page in the dialog preferences 9-14
vibrational directions (PSV-3D) 9-15
display properties
3D view 8-5
data 8-3
general 8-2
general, video window 4-8
set up live video image 4-7
video, video window 4-9
display type of the data set, select 8-21
distance between grid points (APS)
in point mode 5-16
in standard mode 5-9
distance measurement
MSA with option MSAGeo 5-36
PSV/PSV-3D with geometry scan unit 5-34
domain, display 8-20
dongle 2-1
draw, profile section 9-9
dropouts 7-9
duplicate, figures (APS) 5-25

E
edit, scan points (not APS) 5-27
ellipse, draw 5-6
enable
scan points (not APS) 5-29
scan points, in point mode 5-22
engine cycle, set frame boundaries 6-27
error message, when changing into acquisition
mode 3-3

Index

example measurement
control a second vibrometer 7-16
external function generator (as an option) 7-10
FastScan (as an option) 7-12
internal function generator (as an option) 7-11
MultiFrame measurement (as an option) 7-13
Signal Enhancement (SE) and Speckle
Tracking 7-9
example measurements 7-9
explanation of commands, help 2-17
export 10-11
ASCII 10-25
ME’Scope 10-18
Universal File 10-14
Wave Sound format 10-26
external function generator, control (example
measurement) 7-10

F
Failed
geometry status 7-5
laser focus status 7-6
FastScan
example measurement 7-12
measurement mode 6-24
parameters, for data acquisition 6-24
FFT lines
measurement mode Zoom-FFT 6-23
measurement modes FFT and MultiFrame 6-11
figures
change shape 5-7
distribute scan points 5-8
insert corner points 5-7
move corner points 5-7
rotate 5-7
figures (APS)
arrange 5-25
delete 5-25
display connections between scan points 5-23
duplicate 5-25
edit 5-23
group 5-25
move 5-24
present 5-23
scale 5-24
select 5-23
file information, display 10-1
file list 10-4
filter
geometry laser 4-3
geometry scan unit 5-35
parameters, for data acquisition 6-8
filter data, smooth the display of scans 9-3

focus
laser beam (MSA-500) 4-3
laser beam, second vibrometer 7-18
laser beam, with the PDA 4-6
laser beam, with the software 4-2
video camera 4-4
focus setting, check 5-39
focus sharpness 3-10
focus values
assign focus automatically 5-38
assign focus manually 5-37
calculate automatically 3-14
clear focus values 5-38
interpolate focus values 5-38
recalculate in modifying scan points (not
APS) 5-31
teach-in 5-37
focus values, clear in modifying scan points (not
APS) 5-31
focus values, interpolate in modifying scan points
(not APS) 5-31
focusing during scan
activate 5-39
deactivate 5-39
folder, add 2-9
foreground, figure into (APS) 5-25
formulae editor, in the signal processor 2-13
forwards, figure (APS) 5-25
frame cycle, set frame boundaries 6-27
frames
averaging 6-27
set boundaries 6-27
set number 6-27
frames per animation cycle, setting 9-14
frequency
parameters, for data acquisition 6-11
parameters, for data acquisition
(MultiFrame) 6-28
parameters, for data acquisition (ZoomFFT) 6-23
frequency band
define 9-5
display 8-23
take over, in combined file 8-31
frequency band definition
load 10-4
save 10-23
frequency resolution
measurement mode FFT 6-12
measurement mode Zoom-FFT 6-24

v

Index

function generator
control externally, example measurement 7-10
control internally, example measurement 7-11
multiple channel 6-20
parameters, for data acquisition 6-20
select waveform 6-21
switch off 6-20
function, display 8-20

G
gate signal 6-16
gauge for color-coding 2-11
general
analyzer properties, set up diagrams 8-14
display properties, presentation/acquisition
mode 8-2
display properties, video window 4-8
parameters, for data acquisition 6-2
generate, combined file 8-26
generator
multiple channel 6-20
parameters, for data acquisition 6-20
select waveform 6-21
signal output 7-11, 7-12
switch off 6-20
geometry
import 5-16
measure geometry that is too large, after
import 5-19
set up 3-13
geometry component, define 5-31
geometry laser, activate 5-34
geometry point
MSA with option MSAGeo 5-36
PSV/PSV-3D with geometry scan unit 5-34
geometry scan
abort 5-34
abort, MSA with option MSAGeo 5-36
abort, PSV/PSV-3D with geometry scan
unit 5-34
carry out 5-33
carry out (not APS) 5-31
start, MSA with option MSAGeo 5-36
start, PSV/PSV-3D with geometry scan
unit 5-34
geometry scan unit
adjust laser 3-10
define alignment points 4-55
filter 5-35
optimal results for 3D alignment 4-60
teach-in scan points 5-20
transform 2D geometry to 3D geometry 5-35
geometry scan unit, activate (3D alignment)
PSV with geometry scan unit 4-23
PSV-3D with geometry scan unit 4-35

vi

geometry status 7-5
GPIB/IEEE-488 address of external devices 2-2
grid (APS)
density of scan points 5-8
merge scan points 5-16
refine 5-16
rotate 5-9
select type 5-8
grid, display
in acquisition mode (3D view) 8-3
in the analyzer 8-14
in the presentation window 8-4
grid, set up for scan points 5-8
group, figures (APS) 5-25

H
hardlock 2-1
hardware, control 4-1
hardware, control with the PDA 2-18
harmonic cursor 8-12
head angle 3-11
help 2-17
hexagonal grid, select (APS) 5-8
hidden points, calculate 3-13
Hidden, scan status 7-5
hide
all scan points 5-23
scan points of a component 5-33
scanning head control 4-2
high pass filter, set in the controller 6-20
HP 33120 A, external function generator 7-10

I
icons for commands 2-5, 2-6
ICP 6-7
IEEE-488/GPIB address of external devices 2-2
illumination (MSA/MSV), brightness of the live
video image 4-9
import
geometry 5-16
ME’Scope 10-7
scan points 5-16
Universal File 10-7
Imported, geometry status 7-5
increase speed
animation (measurement mode FFT,
Zoom-FFT, FastScan, MultiFrame) 9-13
animation (measurement mode Time) 9-17
index offset
ME’Scope export 10-22
Universal File export 10-18
indicator position (MSA) 3-12
indicators on display (MSA) 3-12

Index

indices
of scan points, change 5-28
of scan points, in acquisition mode (3D
view) 8-3
of scan points, in the legend 4-5
of scan points, in the presentation window 8-4
of scan points, in the video window 5-28
individual measurements
merge, tips for 3D alignment 4-60
sort, in combined file 8-31
with mirror and geometry scan unit, tips for 3D
alignment 4-61
with MSA, tips for 3D alignment 4-62
info
about PSV 2-17
command in the browser 2-10
information, on 3D alignment 4-54
input coupling 6-7
input range of the data acquisition board 6-7
input, differential 6-7
insert, corner points of figures 5-7
internal function generator, control (example
measurement) 7-11
interpolate
3D coordinates (not APS) 5-30
3D coordinates, in point mode 5-22
focus values, of scan points (not APS) 5-31
Interpolated
geometry status 7-5
laser focus status 7-6
interpolation
in the analyzer 8-14
in the presentation window 9-2
Invalidated
allocate status 9-2
scan status 7-5
isolines
set up, in presentation mode 8-4
view style 8-17

J
junction box, allocation of channels 3-6

L
laser beam
dim (MSA/MSV) 4-3
focus (MSA-500) 4-3
focus with the software 4-2
focus, with the PDA 4-6
position, with the PDA 4-6
position, with the software 4-4
switch on/off, with the PDA 4-6
switch on/off, with the software 4-2
laser beam, position (2D alignment) 4-11

laser beam, position (3D alignment)
MSA, for the object system 4-49
PSV with geometry scan unit 4-23
PSV without geometry scan unit 4-17
PSV-3D with geometry scan unit 4-35
PSV-3D without geometry scan unit 4-29
with the PDA 4-44
laser focus status 7-6
laser position, reassign (3D alignment)
MSA, for the object system 4-52
PSV with geometry scan unit 4-26
PSV without geometry scan unit 4-21
PSV-3D with geometry scan unit 4-38
PSV-3D without geometry scan unit 4-33
leakage 6-12
legend
in the analyzer 2-8
in the presentation window 2-12
in the video window 2-6
lens calibration, set up (only MSA) 3-15
line properties (APS) 5-10
line, draw (APS) 5-5
list of open windows 2-13
live video image 2-6
load
frequency band definition 10-4
settings 10-4
log in 2-2
low pass filter, set in the controller 6-19

M
magnification, set for MSA/MSV 4-2
magnitude (dB(A)) 8-21
magnitude averaging 6-3
manual, set frame boundaries 6-27
marginal points, select on modifying scan points
(not APS) 5-31
maximum velocity
measurement mode FastScan 6-24
measurement mode FFT 6-12
measurement mode Time 6-26
measurement mode Zoom-FFT 6-24
ME’Scope
export 10-18
import 10-7
measured quantity, set 6-7
Measured, geometry status 7-5
measurement
continuous measurement 7-1
example measurements 7-9
messages 7-7
single shot 7-1
start 7-2
stop 7-7
too large geometries, after import 5-19

vii

Index

measurement channel, see channel
measurement data, recalculate
application examples 8-48
make a calculation 8-34
measurement data, set up view style 8-3
measurement mode
FastScan 6-24
MultiFrame 6-27
select 6-3
time 6-25
Zoom-FFT 6-23
measurement range, set in the controller
displacement 6-19
velocity 6-19
measurement window 2-7
merge, scan points in the grid (APS mode) 5-16
messages
on data acquisition 7-7
set up display 3-19
MIMO, carry out 6-4
mirror, use (3D alignment)
PSV with geometry scan unit 4-25
PSV without geometry scan unit 4-20
PSV-3D with geometry scan unit 4-37
PSV-3D without geometry scan unit 4-32
modes in the software 2-3
Modified, geometry status 7-5
modify
3D coordinates of scan points (not APS) 5-30
3D coordinates of scan points, in point
mode 5-22
scan points (not APS) 5-27
monochrome video image
in acquisition mode (3D view) 8-3
in the presentation window 8-4
monochrome, live video image 4-9
move
corner points, of figures 5-7
figures (APS) 5-24
objects, in the project browser 2-10
MSA
3D alignment for the object system 4-48
3D alignment for the scanning head
system 4-45
transform 2D geometry to 3D geometry 5-37
MSA monitor
position of indicators 3-12
show crosshair 3-12
show indicators on display 3-12
MSA, special features for scanning head 3-12
MSA/MSV, set magnification 4-2
MultiFrame
example measurement 7-13
measurement mode 6-27
parameters, for data acquisition 6-27

viii

multimedia format avi 10-23
multiple channel, generator 6-20

N
new window 2-13
No 3D Coordinates, geometry status 7-5
no averaging 6-3
No Laser Focus, laser focus status 7-6
NO TRIGGER, message 7-7
noise level with Signal Enhancement and Speckle
Tracking 7-9
Not Measured, scan status 7-4
Not Reachable, scan status 7-4
Nyquist 8-21

O
object
distance, ME’Scope 10-22
distance, UFF export 10-18
properties 5-4
object, set up view 8-2
Object, view 8-16
offset, add (3D alignment)
MSA, for the object system 4-53
PSV with geometry scan unit 4-27
PSV without geometry scan unit 4-22
PSV-3D with geometry scan unit 4-41
PSV-3D without geometry scan unit 4-34
OFV-056-C, close-up unit
calculate stand-off distance (ME’Scope
export) 10-22
calculate stand-off distance (UFF export) 10-18
set video image to black and white 4-9
online help 2-17
open, project browser 2-9
optical signal level 4-2
optics
control with the PDA 4-6
load settings 10-5
save settings 10-24
set up 3-9
optics, set 4-1
Optimal Measured, geometry status 7-5
Optimal, scan status 7-5
options
display software options 2-17
for data acquisition 3-1
overlap 6-12
OVERRANGE, message
input range, data acquisition board 7-7
measurement range for the velocity 7-7
Overrange, scan status 7-5

Index

P
page
in a dialog 6-1
print setup 2-16
pan
zoomed diagram section 8-9
zoomed image section 2-16
pan-tilt stage
activate 3-10
control 4-4
parameters of the controller, set 6-18
parameters, for data acquisition
channels 6-4
description 6-2
FastScan 6-24
filter 6-8
frequency 6-11, 6-23
frequency (MultiFrame) 6-28
general 6-2
generator 6-20
MultiFrame 6-27
set 6-1
Signal Enhancement (SE) 6-16
time 6-26
trigger 6-14
vibrometer 6-18
window 6-12
password 2-2
PDA
control optics 4-6
control the hardware 2-18
define single scan points 5-12
toggle scan points 5-13
Peak Hold, averaging 6-3
phases, measure 6-14
point mode
define scan points, with the PDA 5-12
define scan points, with the software 5-12
description 5-1
scan point definition 5-10
polar grid, select (APS) 5-8
polygon, draw 5-6
position
alignment points for 3D alignment (MSA) 4-62
alignment points for 3D alignment (PSV/PSV3D) 4-56
appropriate alignment points with geometry
scan unit 4-56
appropriate alignment points without geometry
scan unit 4-57
laser beam, with the PDA 4-6
laser beam, with the software 4-4
scanning heads for 3D alignment
(PSV-3D) 4-55
preferred scan direction 3-9

PREMA ARB 1000, external function
generator 7-10
presentation mode
display grid, in the presentation window 8-4
mode in the software 2-3
scan 9-1
sections of a spectrum 9-4
set up 3D view 8-5
set up object 8-2
set up the presentation of the isolines 8-4
set up view style of measurement data 8-3
presentation window, print 2-16
Principal Component Analysis, carry out
(MIMO) 6-4
print preview 2-16
print, active window 2-16
profile section, draw and edit 9-9
Profile, view 8-16
project browser
add project folder 2-9
commands 2-9
copy and move objects 2-10
description 2-8
open 2-9
project folder, add 2-9
projection, 3D geometry (3D view) 8-7
properties
of signals to be imported 10-8
of the analyzer 8-8
of the live video image 4-7
of user defined signals 8-45
PSV
3D alignment with geometry scan unit 4-22
3D alignment without geometry scan unit 4-17
PSV, about 2-17
PSV-3D
3D alignment with geometry scan unit 4-34
3D alignment without geometry scan unit 4-28
3D mode 3-3
activate 3-3
allocate channels 3-8
arrange scanning heads 3-11
as a pure PSV-1D 7-6
as PSV-1D 3-4
display vibrational directions 9-15
in 1D mode 3-4
in 1D mode for fault diagnosis 3-5
modify coordinates 5-21
scan points, teach-in 5-20
special features for 2D alignment 4-13
use with only one scanning head 7-6

ix
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PSV-A-410, close-up unit
calculate stand-off distance (ME’Scope
export) 10-22
calculate stand-off distance (UFF export) 10-18
set video image to black and white 4-9
pvd, proprietary binary format
open 10-3
save 10-12

Q
quality of the 3D alignment, evaluate 4-58
quality, specify (3D alignment)
MSA, for the object system 4-51
MSA, for the scanning head system 4-46
PSV with geometry scan unit 4-25
PSV without geometry scan unit 4-20
PSV-3D with geometry scan unit 4-37
PSV-3D without geometry scan unit 4-32
quantity, set measured quantity 6-7

R
range, input range of the data acquisition
board 6-7
ranges, dialog analyzer properties 8-10
recalculate, measurement data 8-32
rectangle, draw 5-5
redo
display profiles 9-10
edit figures (APS) 5-25
reference point
ME’Scope 10-22
UFF export 10-18
refine, grid in APS mode 5-16
remeasure
automatically 6-4
manually 7-4
resolution
measurement mode FFT 6-12
measurement mode Time 6-26
measurement mode Zoom-FFT 6-24
scan points on lines (APS) 5-10
right-angled grid, select (APS) 5-8
RMS signal, display 8-20
rotate
figure 5-7
grid (APS) 5-9
rotation
figure (APS) 5-7
grid (APS) 5-9
RS-232, controlling external devices 2-2

x

S
sample frequency
measurement mode FFT 6-12
measurement mode Time 6-26
sample time
measurement mode FFT 6-12
measurement mode MultiFrame 6-28
measurement mode Time 6-26
samples
measurement mode MultiFrame 6-28
measurement mode Time 6-26
saturation of the live video image 4-9
save
animation 10-23
camera settings and alignment 10-24
frequency band definition 10-23
frequency bands 10-12
scan point definition 10-24
settings 10-24
scale
deflection in the animation 9-14
figures (APS) 5-24
z-range, in presentation mode 8-4
scan
evaluate 9-1
follow in the video window 7-4
start 7-3
scan data, proprietary binary format
open 10-3
save 10-11
scan direction, preferred 3-9
scan point definition
load 10-5
save 10-24
scan point grid, refine 5-16

Index

scan points
assign, to components 5-32
carry out a geometry scan (not APS) 5-31
change indices 5-28
clear focus values (not APS) 5-31
connect (APS) 5-14
define 5-1
define single, with the PDA 5-12
define single, with the software 5-12
define, with Auto Align 5-21
delete 5-25
delete 3D coordinates (not APS) 5-31
delete 3D coordinates, in point mode 5-22
density of grid 5-8
disable (not APS) 5-29
disable, in point mode 5-22
display connections (APS) 5-23
display indices, in acquisition mode (3D
view) 8-3
display indices, in the presentation window 8-4
display indices, in the video window 5-28
edit (APS) 5-22
edit (not APS) 5-26
enable (not APS) 5-29
enable, in point mode 5-22
import 5-16
index display, in the legend 4-5
interpolate 3D coordinates (not APS) 5-30
interpolate 3D coordinates, in point mode 5-22
interpolate focus values (not APS) 5-31
modify (not APS) 5-27
modify 3D coordinates (not APS) 5-30
modify 3D coordinates, in point mode 5-22
properties of lines 5-10
recalculate focus values (not APS) 5-31
select marginal points (not APS) 5-31
select, according to properties 5-27
select, of a component 5-33
select, with the mouse 5-26
set up the grid 5-8
show/hide all 5-23
show/hide, of a component 5-33
showing (hiding) in the live video image 2-7
status display, in the legend 4-5
status display, in the video window 7-4
teach-in with geometry scan unit 5-20
toggle, with the PDA 5-13
triangulate 3D coordinates (not APS) 5-30
triangulate 3D coordinates, in point mode 5-22
view style 8-17
scan status 7-4

scanning head
arrangement for PSV-3D 3-11
pan and tilt 4-4
select 3-9
set up 3-9
scanning head control
additional vibrometer controller 4-3
show (hide) 4-2
scanning head, select (3D alignment)
PSV-3D with geometry scan unit 4-35
PSV-3D without geometry scan unit 4-29
with the PDA 4-43
scanning heads, position for 3D alignment
(PSV-3D) 4-55
screen center, mark (MSA) 3-12
scroll bar, in the analyzer 8-8
SE (Signal Enhancement)
example measurement 7-9
parameters, for data acquisition 6-16
select
figures (APS) 5-23
marginal points, of scan points (not APS) 5-31
scan points, of a component 5-33
scan points, with certain properties 5-27
scan points, with the mouse 5-26
set
data transparency 8-4
parameters, for data acquisition 6-1
set up
3D View, view style 8-5
isolines, in presentation mode 8-4
live video image 4-9
measurement data, view style 8-3
object, view 8-2
title and background, in acquisition mode 4-8
set, proprietary binary format
load settings 10-4
save settings 10-24
sets, enter in the signal processor 8-41
settings
data acquisition 6-1
delete 10-7
load 10-4
save 10-24
setup, preferences 3-1
shape of figures, change 5-7
show
all scan points 5-23
scan points of a component 5-33
scanning head control 4-2
sight, 3D geometry 8-7
signal description, in the signal processor 8-43
Signal Enhancement (SE)
example measurement 7-9
parameters, for data acquisition 6-16
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signal level, optical 4-2
signal output of the generator 7-11, 7-12
signal processor 8-32
analyzer 2-13
application examples 8-48
arithmetic operations 8-36
calculation table 2-13
description 2-12
display result 8-46
enter complex numbers 8-41
enter sets 8-41
formulae editor 2-13
print 2-16
save formulae 8-47
save user defined data set 8-44
toolbar 2-12
signal, display 8-20
signal-to-noise ratio, with averaging 6-3
single point data, proprietary binary format
open 10-3
save 10-12
single point measurement, start 7-2
Single Scan Point, view 8-16
single shots, make 7-1
software
display options 2-17
modes 2-3
software, set up
channels
dB reference 3-18
devices 3-2
geometry 3-13
lens calibration (only MSA) 3-15
messages 3-19
scanning head 3-9
sort, individual measurements in combined
file 8-31
sound format, export 10-26
Speckle Tracking
example measurement 7-9
parameters, for data acquisition 6-17
speckles 7-9
spectrum
display 8-20
evaluate 9-4
square, draw 5-5
standard mode
description 5-1
scan point definition 5-4
standard, default settings of the live video
image 4-9
start
scan 7-3
single point measurement 7-2

xii

status
of scan points, in the legend 4-5
of scan points, in the video window 7-4
status bar 2-5
Status Points, view style 8-17
step backward
animation (measurement mode FFT,
Zoom-FFT, FastScan, MultiFrame) 9-13
animation (measurement mode Time) 9-17
step forward
animation (measurement mode FFT,
Zoom-FFT, FastScan, MultiFrame) 9-13
animation (measurement mode Time) 9-17
stitching
3D alignment with mirror and geometry scan
unit, tips 4-61
3D alignment with MSA, tips 4-62
3D alignment, tips for individual
measurements 4-60
display combined file 8-29
general information 8-25
merge measurements 8-26
stop, measurement 7-7
Surface, view style 8-17
surfaces, treat 6-17
svd, proprietary binary format
open 10-3
save 10-11
switch off
function generator 6-20
laser beam, with the PDA 4-6
laser beam, with the software 4-2
switch on/off, laser beam
with the PDA 4-6
with the software 4-2

T
test mode 7-8
tile horizontally, arrange windows 2-13
tile vertically, arrange windows 2-13
tilt angle 3-11
time
averaging 6-3
measurement mode 6-25
parameters, for data acquisition 6-26
time data animation 9-1
time for a measurement
with averaging 6-3
with overlap 6-12
time for a scan, estimation 5-3
time signal, display 8-20
title, display
above the object 8-2
in the analyzer 8-14
in the video window 4-8

Index

toggle
scan points with the PDA 5-13
Too little Light, geometry status 7-5
Too much Light, geometry status 7-5
toolbar
in the analyzer 2-8
in the application window 2-5
in the presentation window 2-11
in the signal processor 2-12
in the video window 2-6
tracking filter, set in the controller 6-19
transparency of data, set 8-4
transparency of graphics, in the live video
image 4-9
treat, surfaces 6-17
triangulate
3D coordinates (not APS) 5-30
3D coordinates, in point mode 5-22
Triangulation, geometry status 7-5
trigger, parameters for data acquisition 6-14
tripod, control 4-4

U
undo
display profiles 9-10
edit figures (APS) 5-25
unit, select (3D alignment)
MSA, for the object system 4-49
MSA, for the scanning head system 4-46
PSV with geometry scan unit 4-23
PSV without geometry scan unit 4-17
PSV-3D with geometry scan unit 4-35
PSV-3D without geometry scan unit 4-29
Universal File
export 10-14
import 10-7
UNIX 10-17
used, frequency range 6-11
user defined data set
properties 8-45
save 8-44

vibrometer controller 2 4-3
video
display properties, video window 4-9
flip 3-10
video camera, zoom and focus 4-4
video image
live in the video window 2-6
set up live video image 4-9
view, set up 3D view 8-5

W
Wave Sound format, export 10-26
waveform, of the generator 6-21
width of lines (APS) 5-10
window
copy data onto clipboard 10-28
parameters, for data acquisition 6-12
save as graphics 10-27
window function
measurement mode MultiFrame 7-15
measurement modes FFT and Zoom-FFT 6-13
window list 2-13
windowing of input signals 6-12
Wireframe, view style 8-17

Z
z-axis, move 4-3
zero position, 3D geometry (3D view) 8-5
zoom
in the analyzer 8-8
in windows 2-15
pan 2-16
pan diagram section 8-9
undo 2-16, 8-9
video camera 4-4
Zoom-FFT, measurement mode 6-23
z-range, scale in presentation mode 8-4

V
Valid
allocate status 9-2
scan status 7-5
values, round 8-10
version of the software, display 2-17
vibration, animate 9-11
vibrational directions, display (PSV-3D) 9-15
vibrometer
connect 3-6
control 3-6
control a second, example measurement 7-16
parameters, for data acquisition 6-18
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Schwarzschildstraße 1
12489 Berlin
Tel.:
(030) 6392-51 40
Fax:
(030) 6392-51 41
E-mail: polytecberlin@polytec.de
Internet: http://www.polytec.de

Great Britain (GB)
Lambda Photometrics Ltd.
Lambda House, Batford Mill
GB-Harpenden, Hertfordshire AL5 5BZ
Tel.:
+44 (0) 1582 764334
Fax:
+44 (0) 1582 712084
E-mail: info@lambdaphoto.co.uk
Internet: http://www.lambdaphoto.co.uk

International from outside Germany (D)
POLYTEC GmbH
Headquarters
Polytec-Platz 1-7
D-76337 Waldbronn
Tel.:
+49 7243 6 04-0
Fax:
+49 7243 6 99 44
E-mail: info@polytec.de
Internet: http://www.polytec.com

Japan (J)
Polytec Japan
Hakusan High Tech Park
1-18-2 Hakusan, Midori-ku
J-Yokohama-shi, 226-0006 Kanagawa-ken
Tel.:
+81 (0) 45 938-4960
Fax:
+81 (0) 45 938-4961
E-mail: info@polytec.co.jp
Internet: http://www.polytec.co.jp
USA West
Polytec, Inc., North American Headquarters
1342 Bell Avenue, Suite 3 -A
Tustin, CA 92780
Tel.:
+1 714 850 1835
Fax:
+1 714 850 1831
E-mail: info@polytec.com
Internet: http://www.polytec.com
USA Midwest
Polytec, Inc., Midwest Office
3915 Research Park Dr., Suite A-12
Ann Arbor, MI 48108
Tel.:
+1 734 662 4900
Fax:
+1 734 662 4451
E-mail: info@polytec.com
Internet: http://www.polytec.com
USA East
Polytec, Inc., East Coast Office
25 South Street, Suite A
Hopkinton, MA 01748
Tel.:
+1 508 544 1224
Fax:
+1 508 544 1225
E-mail: info@polytec.com
Internet: http://www.polytec.com

